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NASA STI Program . . . in Pro�le

Since its founding, NASA has been
dedicated to the advancement of
aeronautics and space science. The
NASA scienti�c and technical
information (STI) program plays a key
part in helping NASA maintain this
important role.

The NASA STI Program operates
under the auspices of the Agency Chief
Information O�cer. It collects,
organizes, provides for archiving, and
disseminates NASA's STI. The NASA
STI Program provides access to the
NASA Aeronautics and Space
Database and its public interface, the
NASA Technical Report Server, thus
providing one of the largest collection
of aeronautical and space science STI
in the world. Results are published in
both non-NASA channels and by
NASA in the NASA STI Report Series,
which includes the following report
types:

• TECHNICAL PUBLICATION.
Reports of completed research or a
major signi�cant phase of research
that present the results of NASA
programs and include extensive data
or theoretical analysis. Includes
compilations of signi�cant scienti�c
and technical data and information
deemed to be of continuing reference
value. NASA counterpart of
peer-reviewed formal professional
papers, but having less stringent
limitations on manuscript length and
extent of graphic presentations.

• TECHNICAL MEMORANDUM.
Scienti�c and technical �ndings that
are preliminary or of specialized
interest, e.g., quick release reports,
working papers, and bibliographies
that contain minimal annotation.
Does not contain extensive analysis.

• CONTRACTOR REPORT.
Scienti�c and technical �ndings by
NASA-sponsored contractors and
grantees.

• CONFERENCE PUBLICATION.
Collected papers from scienti�c and
technical conferences, symposia,
seminars, or other meetings
sponsored or co-sponsored by NASA.

• SPECIAL PUBLICATION.
Scienti�c, technical, or historical
information from NASA programs,
projects, and missions, often
concerned with subjects having
substantial public interest.

• TECHNICAL TRANSLATION.
English-language translations of
foreign scienti�c and technical
material pertinent to NASA's
mission.

Specialized services also include
creating custom thesauri, building
customized databases, and organizing
and publishing research results.

For more information about the NASA
STI Program, see the following:

• Access the NASA STI program home
page at
http://www.sti.nasa.gov

• E-mail your question to
help@sti.nasa.gov

• Phone the NASA STI Help Desk at
757-864-9658

• Write to:
NASA STI Information Desk
Mail Stop 148
NASA Langley Research Center
Hampton, VA 23681-2199
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Abstract

This manual describes the installation and use of NtGCM software.
NtGCM is software designed for monitoring the growth of nanotubes in
a high temperature and high pressure chamber using a laser*. NtGCM
software monitors a dozen di�erent parameters that are important to
understanding the growth of the nanomaterials including the laser input
power, the temperature at eight separate locations inside and outside
the growth chamber, as well as the pressure and �ow rate of the gaseous
media that control the environment in the chamber. The measurements
are all made in real time. The program features a robust user account
management layer and a rich data display manager that allows plotted
data, displayed units and other parameters to be changed on the �y for
the operator's convenience.

*For more details on nanotube growth using lasers see for example M. W. Smith,
K. C. Jordan, C. Park, J.-W. Kim, P. T. Lillehei, R. Crooks, J. S. Harrison, �Very long
single- and few-walled boron nitride nanotubes via the pressurized vapor/condenser
method� Nanotechnology 20 505604 (2009).
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1 About this document

This manual is intended primarily to help guide the user through installation
and running of the software described. In addition to helping an existing
user to be able to more e�ectively utilize the software, this manual
also provides an avenue for a potential new user to understand the
capabilities of the software. Finally, the software described is built in
a modular manner, with common tasks such as the graphing of data and
user management handled by dedicated modules that can be inserted
into a new project. This manual also provides program developers an
application example demonstrating the use of these modules for possible
integration into their work.

1.1 Disclaimer

While every e�ort has been made to ensure the smooth operation of
the software and accuracy of this manual, it must be noted that the
program is intended to be used for research purposes only. The authors,
developer, copyright holders and/or other parties provide the program
and this manual "AS IS" without warranty of any kind, either expressed
or implied, including, but not limited to, the implied warranties of �tness
for a particular purpose. The developer also o�er no warranty that the
data format of future versions of the program will be compatible with
that of this development version. The entire risk as to the quality and
performance of the program and the security of data rests with the user.
Any suggestions on improvements to the program or this manual may
be communicated to the developer for consideration. The modules that
carry out data management, user account management and other tasks
in this software are available from the developer upon request.
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2 Getting started

2.1 Terminology and notation

Back to the table of contents

Figure 1: A highly simpli�ed schematic of the high pressure high
temperature growth of boron nitride nanotubes using a laser. The
components labeled in the schematic are described in the text.

Figure 1 shows a highly simpli�ed schematic of the high temperature
high pressure laser growth of boron nitride nanotubes. The schematic is
aimed only at helping understand the terminology used in this manual.
For a fuller description of the growth process, the reader is referred to
Smith et al. 1 The elements of the growth system are:

1. High pressure chamber
2. A gaseous medium that includes nitrogen or nitrogen containing

compounds
3. A feedstock containing boron
4. The laser which heats up and vaporizes the feedstock
5. A plume in which elemental boron reacts with nitrogen
6. A condensation/collector mesh
7. Nanotubes accumulating on the collector mesh

In this manual, the terms measurement, monitoring and test will be
used interchangeably to refer to an instance when nanotubes are being
grown in the pressure chamber and is tracking and recording one or
more processing variables. Note also the use of timestamp/Timestamp
and Time Stamp when referring to time signatures that are included in
the measurement data. Whenever possible the single word timestamp
will be used in the text but Time Stamp may also be used when there

1M. W. Smith, K. C. Jordan, C. Park, J.-W. Kim, P. T. Lillehei, R. Crooks, J. S.
Harrison, �Very long single- and few-walled boron nitride nanotubes via the pressurized
vapor/condenser method� Nanotechnology 20 505604 (2009).
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is a need for consistency with the notation utilized in the program code.
Section, subsection and description headers will be in normal case except
for cases where the header refers to a named application window or
function. In that case, �rst letter capitalization may be used.

Note: While the information displayed in the screenshots

from running instances of the application is only meant as an

illustration to the user of the program features and is scaled to

�t the page layout, in the electronic version of this document,

it is possible to zoom in to that sample content for a closer

look.
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2.2 Requirements

Back to the table of contents
� Minimum (tested) hardware

Pentium III/Celeron 866 MHz or higher; 256 MB RAM; 700 MB
disk space

� Operating System

Microsoft Windows XP and above. Tested on MS Windows XP, 7
and 8.

� National Instruments (NI) LabVIEW Run-Time Engine

On computers that do not have a working installation of NI LabVIEW,
requires the installation of the NI Run-Time environment. Use

Run-Time engine 2013 or newer. The 32 and 64 bit Windows
Run-Time engines for LabVIEW 2014 may be obtained from National
Instruments
http://www.ni.com/download/labview-run-time-engine-2014/

4887/en/ and
http://www.ni.com/download/labview-run-time-engine-2014/

4889/en/.
� Measurement Computing (MC) DAQ Drivers & InstaCal

requires the installation of Measurement Computing drivers
for the USB-TC thermocouple DAQ. The selection of the thermocouple
to be used can only be done in Measurement Computing InstaCal
software. The thermocouple selection in is only to ensure that
the correct description is included in the measurement data �les.

DOES NOT CONFIGURE THE THERMOCOUPLE.

Measurement Computing software may be obtained from www.

mccdaq.com.
� Instrument settings �le

Instrument settings are read from NtGCM_Instrument_Settings.cfg

which must be in the installation folder.
� Notepad

In order to be able access the read-only views of the Logbook,
(program) Error Log, Measurement Log and Messages Log, a text
editor such as MS Notepad must be installed on the computer
running .

� Adobe Reader

To access (*.pdf) help �les, Adobe Reader should be installed.
Adobe Reader can be obtained from www.adobe.com.

� Image viewer

To view the screen shots generated by a photo browser that
displays *.png image �les must be installed.

While every e�ort has been made to test functionality of 3rd party tools,
the �nal responsibility for compatibility of third party software settings
and rests with the user.
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3 NtGCM overview

3.1 Start up

Back to the table of contents
On starting up, loads a number of settings from con�guration

�les located in the installation directory and the application directory
(Fig. 2). The location of these �les, on a particular host system, is
determined at installation time by the software. The settings in the �les
include information that the application will need to communicate with
instruments as well as details on the currently registered users. If no
�le with user settings is found, it will be assumed that this is the �rst
running of the software on a particular host and therefore a new one will
be created.

Figure 2: NtGCM loads settings from con�guration �les located in the
installation directory as well as the application directory. These settings
include instrument con�gurations and information on the registered
users.
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(a) Start up screen when no users registered (LOGIN button disabled)

(b) One or more users registered (LOGIN button enabled)

Figure 3: The windows that display when NtGCM launches

Figures 3 and 4 show some screenshots. Figure 3 shows the
startup screen before (3(a)) and after (3(b)) the �rst user has been
registered (user administration will be discussed in more detail in Section 5).
Figure 4 shows thePrimary MeasurementWindow which is described
in detail in Section 4.3.1.
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(a) Before measurement

(b) Measurement running

(c) Measurement stopped

Figure 4: The Primary Measurement Window (a) before, (b) during
and (c) after a measurement
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Features of the program include:

1. The big picture
(a) is intended to make the user experience in setting up

and running of the measurement the same irrespective of the
instruments in use. The user only deals with one interface
and the program handles instrument speci�c settings.

(b) monitors/can monitor and record (depending on the physical
hardware present and user settings) the variables listed below
with their (typically SI) units:
i. Time [s] (From the start of the measurement to when the
data point is captured)

ii. Timestamp (Recorded internally as the time in seconds
since 01/01/1904 00:00:00.00 UTC)

iii. Laser power [W]
iv. (Boron feedstock) Feeder position [m]
v. (Chamber gas) Pressure [Pa]
vi. (Gas) Flow rate [m3/s]
vii. 8 Temperatures:

A. Room
B. Chamber neck
C. Chamber wall
D. Interior of chamber location 1
E. Interior of chamber location 2
F. Interior of chamber location 3
G. A temperature at a location that is speci�ed by the

user in the test notes
H. Another temperature at a location that is speci�ed

by the user in the test notes
viii. (Boron source) Feed rate (Change in feeder position divided

by elapsed time) [m/s]
ix. Proportional Indicators [%]:

These record certain values in proportion to some prede�ned
maxima (typically device/safety limits). The values recorded
are...
A. Laser power
B. Feeder position
C. (Chamber) pressure
D. (Gas) �ow rate

2. User management
(a) features aUser Manager to control access to experiment

settings
(b) The User Manager allows di�erent measurement settings

and preferences to be saved for each authorized user. These
settings are loaded whenever the associated user logs in.

(c) User account types are:

12



Standard user Can carry out measurements but not add or
remove users

Advanced user Can carry out measurements, and add but
not remove users

Administrator Can carry out measurements and add or
remove users

(d) The User Manager features a logbook that registers various
events including user login/logout and the start of measurements.
User comments can also be entered into the logbook. All
users are able to open a read-only snapshot of the logbook.
Snapshots of the logbook are compressed and archived periodically
(automatically or at the user's request).

3. Instruments
(a) o�ers of a choice of suitable instruments for each measurement.

The user must ensure that the instruments chosen to run the
measurement are correctly connected and con�gured. The
program then handles communicating with the instruments
and using them during testing.

(b) Instrument settings are read from the �le
NtGCM_Instrument_Settings.cfg which must always be available
in the parent directory.

4. Measurement �les

(a) All �lenames are speci�ed before the start of a test, allowing
the program to save each data point immediately upon measurement.
This prevents the loss of data should anything interrupt the
system during a measurement.

(b) The program can automatically generate unique �lenames
that are timestamped. This is convenient when the user
needs to set up a measurement quickly. It is however highly
recommended that �les be given more descriptive names or
easy future reference.

5. Setting up and running a measurement

(a) will not start a test until various critical settings have
been con�gured. A test status display guides the user in
identifying any outstanding issues.

(b) The program also selectively enables and disables access to
menu items to guide the user in setting up measurements or
otherwise using the application. Only those menu functions
that are compatible with the current settings or are appropriate
for the current stage in the set up process are enabled.

(c) A test pro�le feature allows the user to preview and verify the
parameters of a test before it is run. A clock counts from the
start of a test, allowing the user to keep track of its progress.

(d) Various warnings and alarms may be set up to alert the user of
special conditions during a measurement. Alarms and warnings

13



can be set for the following variables:
i. Laser power
ii. Feeder position
iii. Pressure
iv. Flow rate
v. All temperatures except room temperature
vi. Feed rate
Conditions that can trigger an alarm/warning include:
� Value rises above a set limit
� Value drops below a set limit
� Value drops a by a certain (user entered) (%)
� The value of a continuously monitored variable drops a
user de�ned (%) below the maximum measured value.
This is achieved by continuously recalculating the maximum
as data is monitored.

Additional settings are available but will most likely not be
very relevant in the usage of .

6. Graph and front panel controls

(a) The user may change any graph or front panel controls even
when a measurement is running

(b) The user can display the data in any appropriate units that
they are comfortable with

(c) The analysis graphs allow for the overlay of multiple measurements
(d) The graphs allow the user to place the legend information in

an unobtrusive location
(e) Menu and mouse access to various features
(f) At any time, a user may take a snapshot of a graph window

or the front panel controls. The *.png image �le generated is
automatically named (including date and time) and stored in
the user's working directory.

7. Help
(a) Multiple help �les including instrument manuals and this manual

are available within the program in *.pdf format and accessible
through the menu or front panel controls.

The above and other features will be described in more detail in the
remainder of this manual.
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3.2 Accessing help

Back to the table of contents
features a number of help tools that can be accessed though the

front panel controls or from the main menu. Included in the help section
is information about the program, this manual as well as the manuals of
the instruments that can control (Fig. 5).

Figure 5: A list of the all the help �les accessible through NtGCM.
These �les can be opened by the system's *.pdf reader.

3.3 NtGCM �les

Back to the table of contents
During measurements, data is written to three �les. The Measurement

Data File (*.res) contains all information about the measurement. This
data is structured for read-back by the program but is in a format that is
human readable. A select set of data is written to the Measurement Log
(*.log) which contains tabular text. Messages generated by the program
during the measurement are written, in plain text, to the measurement
Messages Log (*.msg). Note that the program starts to write to the
messages log as soon as a new �lename is entered and not at the start
of the measurement. This allows for messages that may come up during
measurement set up or between measurements to also be recorded. These
messages could be useful in troubleshooting.
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4 The user interface

4.1 Front panel controls

Back to the table of contents

Figure 6: Controls and indicators in the Primary Measurement

Window

Below is a description of the controls and indicators in the Primary
Measurement Window. Note that in notation
Primary Measurement Window actually refers to the graph (11) in
Fig. 6. In this manual, Primary Measurement Window will be used
to refer both to the graph as well as to the full front panel featuring the
graph and the additional controls depending on the context.

1. Main menu: This is where most user actions and measurement
setup will occur. Some but not all of the menu actions are mirrored
with controls on the front panel. The menu will be discussed in
detail in Section 4.2.

2. Clocks: The clocks are the pulse of the system. The session
timer shows how much time has passed since the currently running
instance of the program was started. Any internal error state that
may freeze the operation of the program's measurement engine is
often �rst seen by a stopping of this timer. The test timer starts
counting once a measurement begins. This clock will continue to
update periodically until the measurement is completed.

3. LOGIN / LOGOUT : User login and logout button.
4. Logged in user name: Name of the currently logged in user.
5. Test Readiness Indicator : This indicator shows whether or not

the minimum setup to start a measurement has been met. If not,

16



it indicates, sequentially, the settings that need to be addressed
before the start of a measurement. Additional states of the
Test Readiness Indicator are shown in Fig. 7.

6. Laser power: Laser power indicator.
7. Feeder position: Feedstock position indicator.
8. Pressure and �ow rate: Chamber pressure and gas �ow rate

indicators.
9. Temperature: Temperature indicators for various zones inside

and outside of the pressure chamber.
10. Proportional indicators: This shows a selection of the variables

compared to some preset maxima. The maximum values of the
variables are set in the instrument con�guration �le
NtGCM_Instrument_Settings.cfg

11. Primary Measurement Window (Graph): This is one of three
graph windows generated by . Data from the running measurement
is shown in this window. The plotted quantities and their units can
be changed at any time during or after the measurement. The other
two graph windows are the Auxiliary Measurement Window

and Analysis (2D) Window which are full screen windows.
12. Clock: This shows the current date and time as reported by

the Operating System (OS). The clock's timestamp will be added
to the measurement data recorded by to help synchronize
with measurements from other instruments that are not being
read through . This assumes that these measurements are
on the same computer or one whose time has been synced with
that running . If the timestamp is incorrect, this can be �xed
by adjusting the system time using the OS's clock tools.

13. About and ?: Quick access to the help items.
14. EXIT / STOP MONITORING button: This provides another

option for stopping a measurement or exiting the program. When
a measurement is running, this button transforms to a
STOP MONITORING button. The measurement must be in the
stopped state before exiting the program. During a measurement,
the Test Readiness indicator becomes the Emergency Stop! button.
This provides yet another way to quickly stop the measurement
while ensuring that measurement �les are properly terminated and
communications with instruments safely closed.

17



(a) No users registered

(b) No user logged in

(c) Primary DAQ not selected

(d) Temperature monitor no selected

(e) Invalid test description

(f) Invalid test environment

(g) Measurement �lenames not set

(h) Measurement ready to start

(i) Measurement running

(j) Measurement stopped by user

(k) Post measurement (waiting for setup of the next measurement)

Figure 7: NtGCM guides the user through the steps of setting up and
running a measurement through the Test Readiness Indicator
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4.2 The main menu

Back to the table of contents
Fig. 8 shows the menu.

(a) File (b) Primary DAQ (c) Temperature monitor

(d) Measurement (e) Window (f) Graph

(g) Alarm (h) User-Logbook (i) User-Advanced user

(j) Administrator (k) Help (l) Help submenus

Figure 8: The NtGCM menu
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A full listing of the menu items is shown below:

1. File
� Set Filenames
� Open Measurement Result (Ctrl+O)
� Import Measurement Data
� Read Measurement Log
� Read Measurement Messages
� Measurement Descriptions
� Update Measurement Data
� Save Measurement Result As (Ctrl+Shift+S)
� Con�gure ASCII Export
� Export ASCII
� Quit Program (Ctrl+Q)

2. Instruments
� Primary DAQ

� Select
� DAQ Con�guration

� Temperature Monitor
� Select
� Con�gure Probes

� Read Settings File
3. Monitoring

� Sample/Test Description
� Test Environment
� Review Test Range
� Start (Ctrl+R)
� Stop (Ctrl+X)
� Preview Settings
� Save Measurement Method
� Select Measurement Method
� Advanced Settings

� Set Sampling Frequency
4. Window

� Primary Measurement
� Auxiliary Measurement
� Messages
� Analysis (2D)
� Analysis (3D) (Disabled)
� Misc F/P Control
� Additional Functions

� Con�gure F/P Controls
� Capture Screen Image
� Toggle Measurement Status Window

5. Graph
� Select Curves
� Con�gure Axes
� Legend

� Show/Hide
� Move
� Format

* LV Native
* Floating
* Embedded

� Labels
� Additional Settings

6. Alarm
� O�
� Test

7. User
� Login
� List All Users
� Logout
� Logged In User Info
� Save Program Settings
� Logbook

� Read
� Archive Now
� Write Comment
� Read Error Log

� Advanced User
� Create New User Account
� Update Account Information

� Administrator
� Delete User Account

8. Help
� About
� NtGCM Users Manual
� Instrument Manuals

� Primary DAQ
* NI-USB-6009

� USB Temperature DAQs
* MC-USB-TC

� All Literature

20



4.3 Graph and Messages windows

Back to the table of contents
A variety of plotting options, for the data collected, are available

through the window and graph menus. At any point during or after
a measurement, the plotted quantities, for the currently running or
loaded measurements, may be changed by selecting Graph→Con�gure
Axes from the menu. The interface for doing so will be covered after the
descriptions for each of the available plotting windows.

4.3.1 Primary Measurement Window (Graph)

In the Primary Measurement Window (Fig. 9) consists of a
graph also known as the Primary Measurement Window as well
as some additional numerical indicators. The most recently collected
measurement data in the current session will be displayed in thePrimary
MeasurementWindow graph and those indicators. During a measurement,
this graph and the indicators will update as data points are collected.

Figure 9: ThePrimary Measurement Window when a measurement
is running
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4.3.2 Con�guring the front panel indicators

The display units and range of the front panel controls can be changed by
double-clicking on any one of these controls. The dialog shown in Fig. 10
is brought up. Note that while the range of each of the temperature
controls can be set in any units that the user is comfortable with in the
setup dialog, all the temperatures will be displayed to the units selected
for the �rst (RT) indicator. The units being used are included as part
of the control caption as shown in Fig. 11. All the other ranges will be
automatically converted to the units of the �rst control.

(a) Front panel control units (b) Options are available for the units

Figure 10: Setting the units and display ranges of the front panel controls

Figure 11: Note that all the temperature controls will display values to
the units selected for the �rst control (Room temperature). Individual
ranges can be set for the di�erent indicators.
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4.3.3 Messages window

Clicking Window→Messages in the menu heading will cause the screen
in Fig. 12 to appear.

ThisMeasurement Messages Window displays certain measurement
related messages. These include the time at which a measurement starts
or ends, information on the measurement settings and the status of
communications with the instruments. When troubleshooting any measurement
anomaly, this should be the �rst place to look. The information displayed
in the Measurement Messages Window is written to the Messages
Log �le. Note that writing to a Messages Log starts (and ends) when
a new �lename is entered and so the messages recorded will include
information generated at set up time before a measurement or after one
has �nished.

Figure 12: TheMeasurement Messages Window showing a snapshot
of typical messages displayed during a run. These messages will
change depending on the communications between the program and the
instruments. Note: In the electronic version of this manual, it

is possible to zoom in and read the messages displayed in this

test instance.
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4.3.4 Auxiliary Measurement Window

The measurement data can also be plotted on a full screen graph in the
Auxiliary Measurement Window (Fig. 13). As with the Primary
Measurement Window, the data will be plotted in real-time as it is
acquired. By default, theAuxiliary MeasurementWindow automatically
loads the �rst measurement in the session. If there are additional measurements,
those will need to be selected for plotting in theAuxiliary Measurement

Window. If the currently running measurement is one of those selected
for display then the data is updated automatically. The Auxiliary

Measurement Window supports plotting multiple curves and so the
currently running measurement as well as any loaded measurement results
can be plotted together. Information on the plots is provided through
legends that can be displayed in various formats.

(a) Single curve (�embedded� legend)

(b) Multiple curves (��oating� legend)

Figure 13: Data plotted in the Auxiliary Measurement Window. If
the current measurement is one of the selected plots in the Auxiliary
Measurement Window then the data is updated as the measurement
runs. The Auxiliary Measurement Window allows stacking of
multiple plots (b) so measured results from di�erent runs can be
compared. Various legend formats are supported.
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4.3.5 2D analysis graph window

In this window, users may plot results from multiple measurements for
comparison and any additional analysis (Fig. 14). The user must have
collected, opened or imported at least one set of data during the current
session. Procedures for opening and importing data are covered in
Section 8. Once there is data available to the Analysis (2D) Window,
the user may use Graph→Select Curves to select which curves to display
from the available data (Section 4.3.8).

Figure 14: The Analysis (2D) Window showing multiple plots
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4.3.6 Con�guring graph axes

In order to con�gure the graph axes select Graph→Con�gure Axes from
the menu which will bring up the dialog shown in Fig. 15. The dialog
will come up for the currently displayed graph window. The dialog can
also be brought up by double-clicking with the mouse on the graph axes.
To set what quantity is being displayed on either Y-axis, simply click on
the desired quantity from the list of available options. The units may be
changed by either clicking on the up and down arrows next to the units
box or by clicking the units box and then selecting the desired units from
the list that appears.

For each axis, there are a number of selectable options for managing
the display of data. The are as follows:

� AutoScale: This option is checked by default. If it is not desirable
for the axis scale to automatically adjust as new data is collected,
then this item should be unchecked and a minimum and maximum
value for the scale should be provided in the appropriate input
controls.

� Show From..., Show Last..., Show Up To: These allow setting
a rolling scale that shows part of the range (X-axis Time and Time
Stamp only). These special ranges are set using the dialogs shown
in Fig. 16.

� Logarithm: Checking this will cause the scale to be put into a
logarithmic format.

� Negative: When this option is selected, the data displayed will
be multiplied by negative one (−1).

� Invert: This option will display the inverse of the data (1/x).
� Reverse: This option will �ip the scale of the axis to go from a
high value to a lower one.

� Show Grid: Choosing this option will cause grid lines to be drawn
along the axis for which the option is selected. Horizontal lines will
appear on the chart for a Y-axis and vertical lines for an X-axis.

� Join Points: Selecting this will draw straight line segments between
the data points.

� Hide Points: This option toggles the visibility of data points. If
Join Points is checked, then the lines will still appear on the chart.

The quantity plotted on the X-axis can also be changed in one of
two ways. Firstly, the user can select the variable to be plotted from
the drop-down menu. In some cases, it is desirable to plot data that
would typically be on a Y-axis as the X value. This is done by using
Set Right Y as X option and will automatically set the X-axis to be
whatever quantity was being plotted on the right Y-axis. In this mode,
the right Y-axis will then no longer be displayed. As with the other
settings, the user can readily go back to the conventional display of the
axes by de-selecting Set Right Y as X.
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(a) Con�guring plots displayed in the Primary Measurement Window

(b) Setting up a �special range� for data in the Auxiliary Measurement
Window

Figure 15: Con�guring the axes and plot of a 2D graph in the (a)
Primary Measurement Window and (b) Auxiliary Measurement

Window). For �special� variables such as the Time Stamp additional
tools are available when setting the range manually.
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(a) Show Last...

(b) Show From...

(c) Special range for the Time Stamp

Figure 16: X-Axis Time and Time Stamp have additional ranges that
are available for manual selection

28



Figure 17: Some additional graph settings

There are some additional plot attributes that can also be set for
each of the graphs through the dialog shown in Fig. 17. The dialog may
be obtained from the menu selection Graph→Additional Settings. The
settings accessible include:

� Highlight Negative Logs Whenever the Logarithm option is
selected, in the graph format in Fig. 15, plots the log of
the absolute value of the number to protect against numerical
errors (Logs of negative numbers are not de�ned in the real plane).
In some cases, the data whose value is being plotted is actually
negative, it is possible for to show this.

� Plot Multiple Colors Because has to deal with di�erent
graph content possibly on both the left and right axes and with
the possibility of having to highlight negative logs, it has been left
to the user to determine, for the presentation of a particular data
set, whether or not to try and use multiple colors.

� Plot Multiple Line Styles and Plot Multiple Symbol Styles

As with the line colors, the options are provided to use multiple line
and symbol styles. The user is encouraged to try out combinations
of these settings to see what works best for their particular data.

� Match Legend Text and Plot Colors will either have all
the legend text in one color or can match the text color to the plot
color. Again the user is encouraged to use the settings that best
�t their requirements.

� Line Thickness and Symbol Size can vary the thickness of
the graph lines as well as the sign of the symbols used.
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4.3.7 Graph legends

gives a number of options for the information that can be displayed
in the legend Fig. 18.

(a) Selecting legend labels

(b) Options for labeling the plots

Figure 18: Selecting information to display in the graph legend

The plotting windows in can display legends in various forms.
The following legend con�guration options are available from the menu:

� Show/Hide Legend (in the Auxiliary Measurement Window

andAnalysis (2D)Window this is also achieved by double-clicking
anywhere in the plot, away from the axes. Clicking in the region
of the axes brings up the axes settings dialogs.)

� Change the format of the legend
� Change the information that is displayed in the legend
� Change the location of the legend

The LV Native and Embedded legends are drawn on the graph canvas
while the Floating legends are displayed in specialized ��oating �windows.
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(a) �Embedded� legend positioned in the top left corner

(b) �Embedded� legend positioned in the bottom right corner

Figure 19: Embedded legends showing di�erent placement options

The position of the LV Native and Embedded legends on the canvas
can be changed by double-clicking somewhere in the graph window (not
on the axes labels) or through the Graph→Legend→Move menu item.
The positions available range from top-left to bottom-right (Figs. 19(a)
and 19(b)). It is up to the user to pick a location for the legend that
does not (substantially) interfere with the reading of the plotted data.
The Floating legends o�er a more �exible option that can be moved to
any place on the screen. Two options for the test descriptions are shown
in are shown in use in Figs. 20(a) and 20(b), the test name and test
date respectively. Note that for user settable test descriptors, the data
for a speci�c option may not be available if the user did not enter that
information when the test was carried out.
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(a) �Floating� legend (plots labeled by test/sample name)

(b) �Floating� legend (plots labeled by test date)

Figure 20: Floating legends showing information display options
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4.3.8 Selecting curves

The option Graph→Select Curves is available only for the Auxiliary
MeasurementWindow andAnalysis (2D)Window which are capable
of plotting multiple curves. This allows the user to choose what data to
have displayed in these graphs to make them more readable or to compare
di�erent measurements. Figure 21 shows the dialogs for selecting curves
for the Auxiliary Measurement Window (21(a)) and the Analysis
(2D) Window (21(b)). The di�erence in the two is that the Analysis
(2D) Window allows for the independent selection of data sets for the
left and right axes while in the case of the Auxiliary Measurement

Window, the same data sets are used for both axes. With each data
set, di�erent columns can be selected for plotting (Section 4.3.6).

(a) Selecting curves to plot in Auxiliary Measurement Window

(b) Selecting left and right y-axis data for the Analysis (2D) Window

Figure 21: Selecting the curves to display in the (a) Auxiliary

Measurement Window and (b) Analysis (2D) Window
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To select a curve for plotting in theAuxiliary MeasurementWindow,
click on it in the Available Curves column and then the Add button.
This will add the data associated with the selected curve to the plot. For
the Analysis (2D) Window, the curve highlighted in the Available
Curves column can be added to either the Y1 (Left Y) or Y2 (Right

Y) axis independently. This is done by using the Add button pointing
to the desired axis column. To remove data from an axis, click on the
curve listing in the appropriate column and then click the single Remove
button in the case of the Auxiliary Measurement Window or the
button under the column for theAnalysis (2D) Window. The buttons

Add All and Remove All can also be used to add or remove all the
available plots.
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4.3.9 Measurement Status Window

A �oating window to show the status of the measurement can be displayed
(or hidden) using the menu selectionWindow→Additional Settings→Toggle
Measurement Messages or by double-clicking with the mouse in the
center of the graph in the Primary Measurement Window. Selecting
to display the messages brings up a text dialog similar to those shown
in Fig. 22. The dialog can be closed by double-clicking anywhere in the
main window or through the close button.

(a) Measurement status dialog when test is idle

(b) Measurement status dialog when a test is running

(c) Measurement status dialog after a test is completed

Figure 22: TheMeasurement Status Window showing messages that
are typically displayed at various stages of a measurement
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5 User account management

runs a user account management system that controls user access
to functions as well as allowing each user to have their own preferred
settings. The settings include measurement parameters and the con�gurations
of the various graphs and controls, such as the units, �le paths etc. On
logging into the application, the program looks to see if there is a valid
user settings �le, which it reads in, otherwise default settings are loaded.
NOTE!Only users that are registered and logged in can run measurements
while all others are able to recall measurements and browse the settings.

allows for three types of user accounts:
1. Standard User Can run measurements but cannot create or delete

user accounts
2. Advanced User Can create user accounts but cannot delete an

existing account
3. Administrator Can create and delete user accounts

When there is no user logged in it is still possible to open and plot saved
measurement results as well as read the logbook but not to set up or run
a measurement.

5.1 First-time user/creating new accounts

Back to the table of contents
The �rst time any user wishes to make a measurement, an account

must be created for them. The �rst account created on the computer will
be an Administrator account Fig. 23(a). In order to create an account, go
to the User→Advanced User→Create New User Account option from the
menu. Note that creating an account requires Administrator or Advanced
User authentication credentials (Fig. 23(b)). The dialog box in Fig. 23(c)
will appear for creating an account. There are several options for the
level of access that the new user should have, the administrator/account
creator may select any one of these that is available.
NOTE!Only anAdministrator can create an account with administrator
privileges.

Once an account is created, it is possible to modify the account
information. A Standard User or Advanced User can only update his/her
own account information. An Administrator can update the information
of any user, including resetting user account passwords for the other
users. To modify an existing user account, the dialogs in Fig. 24 should
be invoked through the menu selection User→Advanced User→Update
Account Information.
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(a) Creating the �rst user account (b) Administrator authentication

(c) User account types

Figure 23: NtGCM o�ers a number of user account types. (a)The �rst
user registered is automatically assigned an Administrator account. (b)
The subsequent addition of users requires Administrator (or Advanced
User) authentication. (c) These added users can have Standard User,
Advanced User or Administrator level credentials. An Advanced User
can add additional Standard or Advanced but not Administrators
privileges.

37



(a) Authentication (b) Standard User information update

(c) Administrators can update other users' accounts

Figure 24: Some user account information can be updated after
the account has been created. (a) In order to update information,
authentication is required. (b) A Standard User can only update
their own information, while (c) an administrator can also modify the
information of other users.
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5.2 Logging in

Back to the table of contents
There are three ways to access the user login dialog (Fig. 25(a)). The

�rst is the LOGIN button at the top right hand of the front panel (3)
in Fig. 6. The menu selection User→Login will also bring up the login
dialog. For the two options above, once the login dialog is displayed, the
user must enter the correct login name and password. The third option
is through the menu selection User→List All Users. This will cause a
dialog to appear with all registered users listed Fig. 25(b). From there,
if there is no user currently logged in, they can select the user account to
be logged in to and click the LOGIN button. This will bring the up the
login dialog in Fig. 25(a) with the user name �eld pre-populated. The
user must then enter the correct password to login. A password hint is
also available if one was set up during the account creation process.

(a) The user login dialog

(b) List of all registered users

Figure 25: User logging in can be achieved by (a) directly calling the
login dialog from the main menu or front panel login button and then
entering the user (login) name and password. Alternatively, (a) a list
of all registered users can be brought up and used to pre-populate the
name �eld in the login dialog.
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After the user has successfully logged in, user speci�c settings are
loaded as shown in Fig. 26(a). User login requirements are strictly
enforced and incorrect information leads to login failure Fig. 26(b).

(a) Login success (b) Login failure

Figure 26: Login success and failure

If a user is already logged in, then the selection and login functions
of the List All Users dialog are disabled (Fig. 27).

Figure 27: List All Users dialog when there is a user already logged in.
New user selection and login functions are disabled
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At anytime, it is possible to request some information about the
currently logged in user, Fig. 28. The information provided includes
the contact information of the user, if that was included in the account
settings, when they logged in as well as when they last ran a measurement.

(a) Logged in user Information with partial contact details

(b) User information including full contact details and timing
of the latest measurements in the current session

Figure 28: Accessing information about the currently logged in user,
including contact details if they are available, as well as information on
when they last ran a measurement
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5.3 Logging out/saving settings

Back to the table of contents
Making the User→Logout menu selection, using the LOGOUT button

on the Front Panel or the EXIT button (14 in Fig. 6) will bring up the
logout dialogs Fig. 29. The program will ask the user if they would like to
save their settings as they logout Fig. 29. Saved settings are available to
the user upon logging in again and make setting up and getting ready to
run a measurement quicker. The settings that are saved by include
all of the following:

� Test description (except for the test/sample name)
� Selected instruments
� Front panel control units and ranges
� Graph axes con�gurations
� ASCII data export settings

Note! Settings can also be saved while logged in by selecting User→Save
Program Settings in the menu. This action is recommended after a
major change to the settings which the user wishes to preserve, such as
con�guring a number of instruments. It helps protect the new settings
should the session not terminate cleanly.

(a) User logout dialog

(b) Quit program (user logged in) (c) Quit program (no user logged in)

Figure 29: Dialogs that appear on (a) user logout and (b) & (c) quitting
the program
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5.4 Deleting user accounts (Administrator ONLY)

Back to the table of contents
By selecting User→Administrator→Delete User Account in the menu,

an administrator may remove a user account. Administrator authentication
is through the dialog in Fig. 30(a).

Note! Account deletion is NOT reversible. A warning is issued
before the deletion of the user account Fig. 30(b). The accounts of a
user that is currently logged in or the administrator that is attempting
to delete the account (unless they are the last remaining user) cannot
be deleted Fig. 30(c). Deleting a user account in will erase settings
but not any measurement data.

(a) Administrator authentication

(b) Delete con�rmation

(c) Some accounts may be non-deletable with
current settings

Figure 30: (a) Deleting a user account requires Administrator
credentials. (b) NtGCM will give a series of warnings before deleting a
user account. (c) Note that it is not possible to delete the account of a
user that is currently logged in or the administrator that is attempting
to delete the account unless they are the last registered user.
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5.5 Logbook

Back to the table of contents
maintains a logbook that contains various information on program

execution events. The logbook can be accessed by the User→Logbook→Read
menu selection. The logbook displays any information regarding when
users have logged on or o� and when any measurements have been run
(Fig. 31(b)). Additionally, it will display any comments written by
previous users. A user may write a comment by clicking
User→Logbook→Write Comment in the user menu to get the dialog in
Fig. 31(a). Simply entering the desired commentary into the resulting
dialog box is su�cient, as the logbook will automatically add a time and
date to the comment.

The program also maintains an error log. The error log (Fig. 32) can
also be accessed from the user menu. As its name implies, this log is a
running record of any errors that have occurred while the program was
running. These notes are mainly aimed for developer/maintainer user
and may be requested during program troubleshooting.

(a) Writing a user comment

(b) Read-only view of the logbook

Figure 31: A logged in user may write a brief comment into the logbook.
Any user can access a read-only view of the logbook
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Figure 32: NtGCM also maintains an error log. Again the user is
able to access a read-only view of the log. The errors logged may be
communicated to the developer for possible �xes in later releases of the
software.

IMPORTANT! Note that the logbook and error log are only
intended for tracking program performance. It is up to the user to
maintain proper records and notes of their experiments.
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6 Setting up a measurement

The software will not allow a measurement to be started until various
settings have been correctly con�gured. These are described in this
section. Incomplete or non-compliant settings will be highlighted in the
Test Readiness Indicator .

6.1 Selecting instruments

Back to the table of contents
The �Primary� DAQ, which reads all the test variables except for the

temperatures, can be selected through Instruments→Primary DAQ→Select.
The dialog box in Fig. 33 will be brought up. The device to be used can
then be selected from the pull-down menu. A device number allows the
instrument to be identi�ed on the host system's USB bus.

(a) Primary DAQ selection window

(b) The DAQs available for selection

Figure 33: Selecting the primary DAQ. The device to be used
can be chosen in the pull-down menu listing all the devices that
NtGCM supports. A device number is used by the system to address
the speci�c hardware being used.
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The con�guration of the primary DAQ that is currently selected can
be accessed by going to Instruments→Primary DAQ→Con�gure in the
menu to get one of the dialogs in Fig. 34. These settings, which cannot
be altered from within , are shown for information only.

(a) No DAQ selected

(b) Simulation DAQ settings (c) NI USB 6009 DAQ settings

Figure 34: Primary DAQ con�guration settings. These are read in from
a �le which is located in the NtGCM installation directory

47



uses a separate (from the �Primary�) DAQ to read the temperature
probes. This DAQ can be selected by navigating to Instruments→Temperature
Monitor→Select in the menu. The dialog box in Fig. 35 will appear. The
user must select both the DAQ device and the (temperature reading)
probe type. A device number must also be set and is used by the system
to address the hardware.

(a) The temperature reading DAQ selection dialog

(b) Available DAQs (c) Selected DAQ and probe type

Figure 35: Dialogs for selecting the temperature probe reading DAQ.
The user must select both the DAQ device and probe type that is being
used.
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The probe selection dialog allows for a large number of options.
(Fig. 36). Not all of these will be in use for a particular instance
in which is being used, nor would all the temperature ranges be
compatible with the experiments managed by the software. Do note
that the selection in must match the hardware that is being used
for the information saved in the measurement �les to be useful in setting
up future experiments.

REMINDER! The temperature probe selection in is only for
reference purposes and ensuring that the correct information is added to
the measurement results �les. Con�guring of the probe that will actually
be used by the software is done external to (Section B.2)

Figure 36: Selecting the temperature probe. Note that in NtGCM,
the probe selection is only for reference purposes and inclusion in the
measurement �le description �elds. The actual probe used will be
determined by the settings in InstaCal. It is highly recommended
though that the NtGCM settings match the InstaCal settings so that
the data in the measurement �les will include the correct details on the
experiment.
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The temperature probe locations can seen by going to
Instruments→Temperature Monitor→Con�gure Probes which brings up
the dialog shown in Fig. 37. These settings cannot be changed by the
user and again are shown for information only. However, there are
two �Auxiliary� temperature probes that the user can locate at their
discretion. Information on the location of these probes may be added to
the test notes (Section 6.2).

Figure 37: Temperature probe locations. Note that these settings cannot
be changed by the user. However, there are two �Auxiliary � temperature
probe channels that the user can assign as they �nd necessary. Notes on
the location of these probes may be added to the test settings notes or
otherwise recorded by the user.
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The complete �Primary�and temperature reading DAQs con�guration
information is read in from the �le NtGCM_Instrument_Settings.cfg.
The contents of this �le can be shown to the user following the menu
selection Instruments→Read Settings File. A dialog such as that shown
in Fig. 38 will be displayed. These developer level settings cannot be
modi�ed by the user are are only shown for information purposes.

Figure 38: Snapshot of the contents of the settings �le that
NtGCM uses and which is located in the installation directory. It is
possible to view but not to change these settings in the application.
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6.2 Setting the test description and test environment

Back to the table of contents
The dialogs in Fig. 39 are used to specify settings of the test. A

description of the test, including a sample/test identi�er, the material
under test and any additional notes that the user may wish to add
are entered using the dialog shown in Fig. 39(a). The Sample/Test
Name is a required �eld that must be �lled in before a measurement
can begin. As the test/sample description may be used in legend labels
it is recommended to keep it short and concise. Additional information
on the test can always be added in the notes. A valid test environment
must also be entered using the dialog in Fig. 39(c). There are a number
of prede�ned templates for setting the test environment Fig. 39(b) as
well as the ability to enter settings for a fully user de�ned environment.

(a) Test/sample description

(b) Picking templates for setting the test
environment

(c) Details of a test environment

Figure 39: Setting the test/sample description as well as the test
environment
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6.3 Reviewing the test range and setting alarms

Back to the table of contents
The Review Test Range dialog (Fig. 40) allows the user to set alarms

and other actions for those variables that allow it. The dialog is accessed
by the menu selection Monitoring→Review Test Range. A summary of
some key test variables is presented, as well as, warning and alarms that
the user may have set.

Figure 40: Before the test, the user can review the range of values that
various variables are expected to lie in and set actions to be carried
out if the values reach some critical points during a run. Note that
because NtGCM is a monitoring (and not a measurement controlling)
application, the operator signature is not a strict requirement to start a
measurement.
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allows alarms and other actions to be set for a number of the
measurement variables. Entering of the set-points for alarms and other

actions is initiated by clicking the Check/Set Critical Points button on

the test range review dialog. This brings up the additional dialogs in
Figs. 41 and 42. Figure 41(a) shows a summary of the settings while
Figs. 41(b), 42(a) and 42(b) show some of the variables that allow for
setting of critical points, the status of the variables that can trigger
critical point actions 42(a) and the actions that can be triggered 42(b).

(a) Settings to de�ne the critical points and actions to be triggered

(b) The variables for which critical point actions can be set

Figure 41: Various actions can be set to be triggered should some
variables exceed preset bounds during a measurement
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(a) Variable status that trigger critical points

(b) Actions to be taken on reaching a critical point

Figure 42: (a)Measurement variable status that trigger critical point
actions and (b) the actions that are triggered
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6.4 Previewing test settings

Back to the table of contents
At any moment before or during a measurement, the user can see a

summary of the current test settings. Monitoring→Preview Settings will
bring up the dialog in Fig. 43.

(a) Previewing test settings

(b) Preview test settings (continued)

Figure 43: At any time before or during a measurement, it is possible to
view a summary of the current test settings
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6.5 Advanced measurement settings: Sampling frequency

Back to the table of contents
The user can set a data capture rate using the dialog shown in Fig. 44.

This dialog is invoked though the menu selection Monitoring→Advanced
Settings→Set Sampling Frequency. It is important to make sure that this
data capture rate is supported by the hardware being used Fig. 44(a). A
warning is issued to the user before setting this value to make them aware
of the importance of ensuring that the settings chosen are compatible
with the hardware in use Fig. 44(b).

(a) Setting the sampling frequency

(b) Sample frequency warning

Figure 44: NtGCM allows the user to set a (maximum)
sampling/instrument reading rate to be used in the measurement. It
should be noted that the actual frequency at which data is gathered will
depend on the hardware response.
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6.6 Setting �lenames

Back to the table of contents

Before beginning a measurement, the �les to which the data should
be written must be speci�ed through the dialogs in Fig. 45. writes to
three �les during the measurement (Fig. 45(a)). These are the Measurement
Data (*.res), Measurement Log (*.log) and Messages Log (*.msg) �les.
Each of the three �les is required and if not set correctly will be
highlighted Fig. 45(b). The Use the Same Base Name For All Files option

(a) The dialog for setting up measurement �lenames

(b) Highlighting of a missing required �le

(c) Auto-generated �lenames (also using the same base name)

Figure 45: Setting the measurement �lenames. NtGCM writes
measurement data to three �les. The names of the �les can be
independent, have the same base, be auto-generated or derive from the
sample/test name. The user must enter the full path for the �les. In the
case of the auto-generated and test/sample name derived �lenames, the
path points to the current working directory.
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may be selected to ensure all �les are saved in the same folder with
the same base name and di�erent extensions. This eliminates the need
to type each name individually and keeps the data and logs �lenames
consistent. If using the same base name is enabled, then the user need
only enter a value in the Measurement Result input.

Pressing the Autogenerate Filenames button allows all the �lename
inputs to be populated with automatically generated names. The format
for the automatically generated �lenames which includes the current
name of the program and the date and time of the measurement is shown
in Fig. 45(c). Filenames are generated pointing to the current working
directory which is usually the user's assigned directory. Filenames may
also be derived from the sample/test names. Note that in this case
it is up to the user to make sure that the appropriate test name has
been set before using the Set to Test Name button. will read the
current settings and propose a �lename which is displayed to the user.
The name will not be automatically updated if a user were to go and
change the measurement settings and not come back to the �lename
set up dialog. This protects the �lename settings from characters in
a test/sample description that may not be compatible with the host
system's �le naming rules.

6.7 Saving and loading measurement methods

Back to the table of contents
measurement settings are typically saved and loaded as part of

the user login/logout process. In this case, there is one set of settings
for the user. There may be cases where the user might want to be able
to save and quickly access more than one experiment con�guration or
when the same settings need to accessed by multiple users. Save/load
measurement method provides this functionality. The measurement method
includes instrument selections and data export settings. Saving a measurement
method is through the menu selection Monitoring→Save Measurement
Method. A method can be loaded by selecting Monitoring→Load Measurement
Method. The loaded method will override any settings that the user may
have con�gured in the currently running session.
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7 Running the measurement

Data acquisition is started through the main menu selection Monitoring→Start.
This brings up the user prompt dialog in Fig. 46(a). Once data acquisition
has begun, the measurements will run until stopped by the user. The
Test Readiness Indicator button on the the front panel highlights that

the measurement is running and the EXIT button at the bottom of the

Front Panel changes to STOP MONITORING state.
To stop monitoring, either the button on the front panel (14) in Fig. 6

can be used or the menu selection selection Monitoring→Stop made.
Once data acquisition is completed, a dialog box will appear listing

the locations to which the measurement results as well as measurement
and messages logs were saved (Fig. 46(b)).

(a) Measurement startup prompt

(b) Measurement completion message

Figure 46: Measurement start and completed messages. The
measurement completion message includes a listing of the full paths of
the measurement �les.
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After the measurement is completed, the test name is reset while
other settings are maintained to make it easier to set up the next measurement.
As experiments are typically run with di�erent settings, will prompt
the user to con�rm some variables before the start of the next test even
if they are to remain the same.

(a) Measurement interrupt by the user

(b) Post measurement view of front panel controls

Figure 47: Primary Measurement Window when a measurement is
stopped and afterwards. Note that after a test is completed, the user
must con�rm a number of parameters such as the Test Description even
if it is intended to use the same settings as before.
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8 Working with measurement results �les

provides a variety of tools to work with measurement data. This
section gives an overview of the di�erent functions that can be used to
manipulate data �les in the program. All of these functions may be
found under the File menu.

8.1 Opening a measurement result

Back to the table of contents
allows the user to not only load results from previous measurement

for display and analysis in the Auxiliary Measurement Window and
Analysis (2D) Window, but also to easily access and reuse the settings
of those measurements. When a measurement result is opened, it will
bring the data as well as all the measurement settings associated with
that data into the program's workspace, automatically overwriting any
previous measurement settings the user may have entered. All this is
done through a dialog box which prompts the user to enter or browse
for the desired data �le (Fig. 48).

Figure 48: The dialog to open a measurement result �le

8.2 Importing measurement data

Back to the table of contents
Importing di�ers from opening a measurement result �le in that the

settings from the loaded measurement �le are not used to reset the
current measurement environment. This makes importing ideal when
the data is desired purely for display/analysis purposes. Opening a
measurement result is more suited when it is intended to display data
from the previous measurement as well as setting up a new test using
settings similar to the one that has been opened.

8.3 Accessing measurement descriptions

Back to the table of contents
When saves test data, there is additional information describing

the measurement that is also saved. The data, which is available for
the measurements conducted in or loaded into the session, can be
accessed through the File→Measurement Descriptions menu selection.
This brings up the dialog in Fig. 49(a) allowing the user to browse and

62



select from the available measurements. Once a measurement is selected,
information such as that shown in Fig. 49(b) is displayed.

(a) Selecting a measurement whose description to display

(b) Description of the measurement

Figure 49: NtGCM can display the description of the current
measurement or other measurements loaded into the current session. (a)
The user can select the measurement whose description they wish to see
and (b) get the information that is available on that measurement.
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8.4 Saving measurement result as new �le

Back to the table of contents
Although the program will automatically save data acquired during

a run to the �lenames speci�ed at measurement set up, it is sometimes
necessary to save data under a new �lename. This is particularly the
case for example if the user wants to replace an automatically generated
�lename with something that is easier to remember. The menu selection
File→Save Measurement Result As will open a dialog that allows the
user to set a new �le path to which the data will be saved. The function
creates a copy of the data and does not erase the previous �le. If the user
wishes to erase that �le, they may use the host system's �le management
tools. This should only be done after making certain of the location and
validity of the replacement �le.

Figure 50: The dialog to save a measurement result under a new �lename

8.5 Modifying and (re)saving measurement data

will allow certain aspects of already measured data to be modi�ed
and the measurement saved, preferably under a new name. This feature
allows the user to, for example, �x an incorrect sample description.
Note that none of these changes have any e�ect on the experimentally
measured data. A note on the changes is added to a new measurement
messages �le which is created when the modi�ed data is saved. Only the
most recently completed or opened (not imported) measurement can be
modi�ed. Modi�cation of the measurement data is achieved by going
to the appropriate measurement con�guration dialog (Section 6). The
user must explicitly request for the change to the data to be completed
(File→Update Measurement Data) upon which a dialog warning about
what the action is issued (Fig. 51). Should the user continue with the
changes, the data is then modi�ed. Measurement data can be saved
under the existing �lename or a new �lename (preferred) by calling the
Save Measurement Result As... dialog (Fig. 50).
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Figure 51: Warning about what is and (more importantly) is not possible
when updating measurement data
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8.6 Exporting measurement data

Back to the table of contents
Any measurement results collected can be exported in ASCII format.

The �rst step in doing so is to select File→Con�gure ASCII Export in
the menu, which will cause the dialog in Fig. 52 to appear. To add
a data column to the exported �le, click on the desired quantity in
the Functions Available list and then the Add button. There is
no limit to the number of columns that are exported beyond the number
of measured values but each available column may only be exported
once. The ordering of the exported columns may be changed by selecting
one from the Export Data Column(s) list using the Move Up and

Move Down buttons.
The units used for a given column can also be changed by selecting it

in the Export Data Column(s) list and then selection the desired unit

from the Units column. Set SI Units for All will a�ect all exported
data columns and change their units to SI.

Figure 52: Con�guring data export involves picking which columns from
all the available data to export, the ordering of those columns as well the
the units to use. Additional header information may also be included in
the export �le.

The user may also opt to include column names, comments made in
the sample description dialog and/or the sample description itself in the
exported data �le. Note that if comments and/or a sample description
are included in the export, this additional information may a�ect the
way some spreadsheet programs will load/import the exported data.

Additional control of the formating of the numeric data that is exported
is possible and invoked using the Advanced Settings button. This
brings up the dialog in Fig. 53. Some formatting choices may make
the data easier to display or import into other software.
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Figure 53: Detailed control of the formatting of the exported data is also
supported

After the export is con�gured, the user must use the menu selection
File→Export ASCII in order to actually export data. This will bring up
a dialog with a list of all datasets collected or opened during the current
session (Fig. 54). Highlighting a dataset to be exported and choosing the

SELECT button will bring up the dialog in Fig. 55(a). If it is desired

to export all the available datasets, then the SELECT ALL option can
be used. When exporting multiple datasets at once, there are a number
of options o�ered for setting the export �lenames (Figs. 55(b), 55(c)) or
saving all the exported datasets to a single �le (Fig. 55(d)).

Figure 54: Selecting the data to export. It is possible to select a single
or multiple datasets and to save that data in one or multiple �les.
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(a) Exporting a single dataset

(b) Using data name to generate �lenames when exporting for multiple datasets

(c) Filenames for multiple datasets can be generated from a user input base name

(d) Data from multiple measurements can also be exported to a single �le

Figure 55: Dialogs for exporting data for (a) a single dataset, as well
as (b), (c) options for naming �les that NtGCM o�ers when exporting
multiple datasets. (d) Multiple datasets may also be exported to a single
�le. In that case, the data columns will be concatenated.
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8.7 Reading measurement and messages logs

Back to the table of contents
can open saved measurement and messages logs in read-only

mode using the host system's text editor. This function can be accessed
from the menu through File→Read Measurement Log and File→Read
Messages Log.
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9 Getting help

features a help interface that includes access to this manual as
well as instrument manuals. The manuals and other documentation
are in *.pdf format and therefore reading them requires a working
installation of a suitable reader to be available on the host computer.
Information about the program, including the version number be be
accessed through the menu selection Help→About. This brings up the
dialog shown in Fig. 56.

(a) Information about the program

(b) Information about the program (cont)

Figure 56: Information about NtGCM
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This manual can be accessed through the menu selection Help→NtGCM
Users Manual. Individual instrument manuals are accessed through the
menu selection Help→(..the instrument..). It is also possible to access all
the literature in the program data store through the option Help→All
Literature.This brings up the dialog shown in Fig. 57.

Figure 57: A listing of all the available resource �les
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Appendix A

Supported hardware

This software supports the use of any of the hardware described in
this appendix for data acquisition.

A.1 USB DAQs (�Primary� DAQs)

Back to the table of contents
supports the DAQs below as the �Primary� device for reading

most of the test data with the exception of the temperature probes which
are read through a dedicated DAQ.

� National Instruments NI USB 6009 This is a multifunction
DAQ device with eight (8) analog in (AI) (14-bit, 48 kS/s), two (2)
analog out (AO) (150 Hz) and thirteen (13) digital I/O channels.

A.2 Temperature DAQs

Back to the table of contents
uses a dedicated temperature reading DAQ that supports multiple

probes.

1. Measurement Computing USB-TC (MC USB-TC) The MC
USB-TC will support up to eight (8) thermocouples.

A.3 Temperature probes

Back to the table of contents
1. The MC-USB-TC supports type J, K, R, S, T, N, E, and B thermocouples.

IMPORTANT! For con�guring the MC USB-TC, the temperature
probes (thermocouples) to be used have to be speci�ed in the Measurement
Computing provided and separately installed InstaCal software. The
corresponding setting in is only used for reference purposes and
DOES NOT a�ect the actual hardware used. It is up to the user to
make sure that the correct temperature probe is being used and that the
readings are being interpreted correctly.
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Appendix B

Setting up the USB DAQs

Back to the table of contents
Note that the following information includes settings in 3rd

party software. The Developers and maintainers of make

no claims as to the accuracy of the information which is only

intended to help the user get started. For more up to date and

accurate information, the user is strongly advised to consult

the documentation for the 3rd party tools.

B.1 Setting up the NI-USB-6009 in NI MAX and NtGCM

1. Make sure that the device is connected to the computer and that
the status indicator LED is ON.

2. Open National Instruments Measurement and Automation Explorer
(NI MAX). NtGCM was compiled with the Version of MAX
shown in Fig. B58(a).

3. In NI MAX, under Devices and Interfaces �nd your device
(NI-USB-6009). Information about the device will be displayed
under Settings. Key are the Name and Status (Fig. B58(b)).
The device name must correspond to the setting in NtGCM and
the device status must be Present for it to be accessed by .

4. To rename a device, in the left hand panel, right-click on the
selected device and select Rename then enter the new name (Fig. B58(c))

5. For USB devices, using the naming convention
Device_NtGCM-Number is used. Device and Number should be
as shown in the select device dialog (Fig. B59).

6. A restart of and or the computer may be required to make the
settings take e�ect.
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(a) NI MAX Version used in NtGCM compilation

(b) Key settings for the NI USB-6009 DAQ

(c) Renaming the device

Figure B58: Con�guring the USB DAQ in NI MAX
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Figure B59: The convention for naming a USB DAQ in NtGCM. The
corresponding name must be entered in NI MAX in order forNtGCM to
be able to communicate with the device.
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B.2 Setting up the USB-TC in InstaCal

The version of InstaCal used to test is show in Fig. B60. To use
InstaCal...

1. Make sure that the device is connected to the computer and that
the status indicator LED is ON.

2. Open Measurement Computing InstaCal. Information about the
devices (Boards in InstaCalnotation) that are available should
then be displayed as shown in Fig. B61(a). If there are more than
one device attached, you may need to use InstaCal's blink feature
to identify the board you intend to use with .

3. If necessary, you can change the number of a board as shown in
Figs. B61(b) and B61(b) to match what you intend to use in .
In order for NtGCM to be able to communicate with the

Device, the Board number must match the Device number

in the select temperature DAQ dialog.

4. Select the type of thermocouple that you intend to use as shown
in Fig. B62(a). Note: This is the ONLY place you have

to select the thermocouple that will be used. As stated

elsewhere, the selection in is only used for reference

purposes

5. Save the con�guration as shown in Fig. B62(b).The naming convention
for the con�guration isDevice_NtGCM-Number . Device and Number
should be as shown in the select device dialog (Fig. B63).

6. Make sure that the con�guration that you intend to use has been
sent to the device. A dialog to that e�ect appears when you save
a con�guration di�erent from the current one.

7. A restart of the computer is recommended to make the settings
take e�ect.

8. You may also need to plug and unplug the device if you have
communicated with it using InstaCal, before can take proper
control of it.
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(a) The InstaCal banner

(b) The InstaCal version used to test NtGCM

Figure B60: The version of InstaCal used to test NtGCM
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(a) The Boards available

(b) Changing the Board Number

(c) Selecting the Board Number

Figure B61: Selecting a device and setting the Board Number in
InstaCal. The Board Number is equivalent to the Device Number in
NtGCM.
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(a) Selecting a thermocouple in InstaCal

(b) Saving the con�guration

Figure B62: Selecting the thermocouple and saving the con�guration
in InstaCal. Note that while it may be possible to assign di�erent
thermocouple types to the di�erent channels, NtGCM assumes a
single type of thermocouple is being used for all the channels. Note
that this limitation in NtGCM only a�ects the information written
about the measurement and the user could use multiple thermocouple
types as allowed by InstaCal and add appropriate comments to the
measurement notes.
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Figure B63: The convention for naming a temperature DAQ in
NtGCM. The device number used in NtGCM must match the board
number in InstaCal in order for NtGCM to be able to communicate
with the device.
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Appendix C

Troubleshooting the USB devices

Back to the table of contents
In the event of communications trouble with the USB devices, the

user may try self-test and reset procedures using NI MAX for the NI
USB-6009 and InstaCal for the MC USB-TC. To access the interactive
control of these devices follow the steps in Sections B.1 and B.2 to get
the dialogs in �gures B58, B60, B61, and B62. Additional information
about these may be found in the appropriate instrument manuals.

C.1 Wiring diagrams

Figures C64 and C65 are the recommended wiring diagrams for the NI
USB-6009 and MC USB-TC. Note that the actual wiring used may di�er
from the recommendation if necessary but the user must make sure to
make the appropriate changes in the instrument settings �le for the
NI USB-6009 or including them in the measurement notes for the MC
USB-TC.
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Figure C64: Recommended wiring for the NI USB-6009
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Figure C65: Recommended wiring for the MC USB-TC
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