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SWEPP Assay System 
Software Test Plan and Report 

1. INTRODUCTION 

The Idaho National Engineering Laboratory (INEL) Stored Waste Examination 
Pilot Plant (SWEPP) operations staff use nondestructive analysis methods to characterize 
the radiological contents of contact-handled waste containers. Containers of waste from 
Rocky Flats Environmental Technology Site and other DOE sites are currently stored at 
SWEPP. Before these containers can be shipped to the Waste Isolation Pilot Plant 
(WIPP), SWEPP must veri@ compliance with storage, shipping, and disposal 
requirements. This program has been in operation since 1985 at the INEL Radioactive 
Waste Management Complex (RWMC). 

One part of the SWEPP program measures neutron emissions from the containers 
and estimates the mass of plutonium and other transuranic (TRU) isotopes present. A 
Passive/Active Neutron (PAN) assay system developed at the Los Alamos National 
Laboratory [1]1 is used to perform these measurements. A computer program named 
NEUT2 was originally used to perform the data acquisition and reduction finctions for the 
neutron measurements. This program was originally developed at Los AIamos and was 
extensively modified by a commercial vendor of PAN systems and by personnel at the 
INEL. NEUT2 uses the analysis methodology outlined in [l], but no formal 
documentation exists on the software itself. The SWEPP Assay System (SAS) computer 
program replaced the NEUT2 software in early 1994. The SAS software was developed 
using an "object model'' approach and is documented in accordance with ANSI/IEEE 
standards. The new software incorporates the basic analysis algorithms found in NEWT2. 
Additional finctionality and improvements include a much improved user interface, the 
ability to change analysis parameters without having to mod% the code, and other 
features designed for flexibility and maintainability. 

This document supersedes the original SAS Software Test Plan and report (STP) 
[SI. This document contains the testing requirements and results for the SAS computer 
program (Version 2.0). Companion documents include a software requirements 
specification [2], a software design description [3], a software verification and validation 
plan [4], and a software configuration management plan [6] .  Following the release of the 
SAS Version 2.0, subsequent work is anticipated in order to continue developing this 
assay technology. 

Version 1.0 of the SAS was developed by staff from the INEL Scientific 
Computing unit under the technical direction of the Nuclear and Radiation Physics unit. 
Version 2.0 is under development by staff from the INEL Nuclear Physics and Radiation 

References cited in this document are listed in Section 1.4. 

1 
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Chemistry Department, with documentation and testing assistance provided by personnel 
from the Software and Electronics and the Engineering Analysis departments. Funding for 
this work has been provided through the INEL Transuranic (TRU) Waste Programs 
department. 

1.1 Purpose 

The primary purpose of this test plan and report is to document the test process 
and to verify that the requirements for the SAS are implemented correctly. It is guided by 
the format and content guideline suggested by the ANSI/IEEE software engineering 
standards [8]. This test plan and report satisfies the testing requirements of ASME NQA- 
1-1994 Supplement 11s-2 [lo] for a Quality Level 2 application. 

validation analysts for the SAS. 
The intended audiences for this test plan are the developers and verification and 

1.2 Scope 

This document specifies the software tests to be performed by the SAS at the 
INEL. 

1.3 Definitions, Acronyms, and Abbreviations 

Reference [12] provides, in general, definitions, acronyms, and abbreviations 
typical to the life cycle approach to software development. The following are specific to 
this document: 

CAMAC 
DMS 
GPIB 
INEL 
RWMC 
SAS 
SGRS 
SWEPP 
WIPP 

computer aided measurement and control 
data management system 
general purpose interface bus 
Idaho National Engineering Laboratory 
Radioactive Waste Management Complex 
SWEPP Assay System, the name of the computer program 
SWEPP Gamma-Ray Spectrometer [13] 
Stored Waste Examination Pilot Plant 
Waste Isolation Pilot Plant 

1.4 Overview 

Section 2 provides the list of references. Section 3 identifies the items required to 
conduct the testing. Section 4 lists the features to be tested, and section 5 lists the 
individual tests to be conducted. Section 6 lists the features that are not to be tested. 
Section 7 describes the approach to testing. Section 8 specifies the suspension criteria and 
the resumption requirements for the testing. Section 9 describes the environmental needs. 
Section 10 provides a detailed description for each test. Section 11 provides the 
requirements traceability matrix. Regarding the execution of the test plan, Section 12 

2 
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describes the results, Section 13 discusses the anomalous events, Section 14 provides a 
summary, and Section 15 gives an evaluation. 

r31 

P I  

r51 

r61 
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[ 141 

[ 151 

3. TESTITEMS 

This test will address SAS Version 2.0. The SAS executable code must reside on 
the hard disk of the platform connected to the CARlAC crate. The software requirements 
specification document 121 must be available prior to testing. Specific environmental 
needs are described in Section 9. 

3 
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4. FEATURES TO BE TESTED 

This test plan will address the following: 
Ensure that no problems were introduced in moving from Version 1 .O to 
Version 2.0. 
Determine that the concerns outlined in the System Change Request (SCR) 
[14] covering the Version 2.0 revisions were properly addressed. 

Version 2.0 of the SAS includes the following additional fbnctionality which must 
be tested: 

0 

0 

0 

0 

0 

0 

0 

Reporting of individual plutonium isotopic masses. 
Implementation of u5U corrections 'to active assay results using SGRS and 
reporting 235U mass based on SGRS results. 
Use SGRS results, if available, to determine 241Am mass. 
Ability to reanalyze saved data using new calibration, matrix or SGRS data. 
Calculation of TRU activity, total activity, plutonium equivalent Curies and 
fissile gram equivalent (FGE). 
Assay results and other information needed during data reviews added to data 
files. 
Additional "data integrity" checks added to minimize the possibility of 
performing assays when the system hardware is not fbnctioning properly. 

5. TEST IDENTIFICATION I 

The following outline lists the major test categories. Subsections are provided for 
both valid and invalid test cases. The individual test cases are listed here for reference. 
Specific details for each test are provided in Section 10. 

User Access 
VALID 

Operator login 
Operator logout 
Physicist login 
Physicist logout 
Administrator login 
Administrator logout 
Close chamber window and log out 

Invalid user ID 
Valid user ID, invalid password 

INVALID 

Administrator Functions 

UA. 1 
UA.2 
UA.3 
UA.4 
UA.5 
UA.6 
UA.7 

UA.8 
UA.9 

4 
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VALID 
Log file manipulation 
Add operator 
Add physicist , 

Add administrator 
Change operator's user ID 
Change operator's user password 
Change operator's access level 
Change physicist's user ID 

Change physicist's access level 
Change current administrator's user ID 
Change administrator's user ID 
Change current administrator's password 
Change administrator's password 
Change administrator's level 
Delete operator 
Delete physicist 
Delete administrator 

Adding duplicate operator ID 
Adding duplicate physicist ID 
Adding duplicate administrator ID 
Changing current administrator's access level 
Debating current administrator's user ID 

- Change physicist's user password 

INVALID 

Container List 
VALlD 

Adding container 
Changing container 
Deleting container 

Adding duplicate container 
Adding container, volume = 0 
Adding container, volume 0 
Adding container, volume > 10,000 
Adding container, then canceling 
Changing container, volume = 0 
Changing container, volume < 0 

INVALID 

AF. 1 
AF.2 
AF.3 
AF.4 
AF.5 
AF.6 
AF.7 
AF.8 
AF.9 

AF.10 
AF.ll 
AF.12 
AF.13 
AF. 14 
AF. 15 
AF.16 
AF. 17 
AF.18 

AF. 19 
AF.20 
AF.21 
AF.22 
AF.23 

CL. 1 
c1.2 
c1.3 

c1.4 
c1.5 
c1.6 
c1.7 
c1.8 
c1.9 

c1.10 

5 I 
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Changing container, volume > 10,000 
Changing container, then canceling 

Matrix List 
VALID 

Adding matrix, not sludge 
Adding matrix, sludge, not Americium sludge 
Adding matrix, Americium sludge 
Deleting matrix 
Setting matrix attributes 

Adding duplicate matrix 
Setting invalid matrix attributes 

.INVALID 

Chamber Calibration 
VALID 

Chamber calibration parameters 
Mass fractions 

Chamber calibration parameters 1 

Mass fractions, negative value 

INVALID 

Mass fractions, sum different from 1 .O 
Waste Attributes 

VALID 
File name (alpha) 
File name (numeric) 
File name (special characters) 
Valid matrix codes 
Valid container net weight 
Run/New Assay 
Switch between windows 

File name (invalid special characters) 
Invalid net weight 

INVALID 

Toggle. Switches 
VALID 

Auto Summary Report on, Auto Data Save on 
Auto Summary Report off 
Auto Summary Report on, Background Correction on 
Auto Summary Report off 
Auto Summary Report on, Background Correction off 

c1.11 
c1.12 

ML. 1 
m1.2 
m1.3 
m1.4 
m1.5 

. ML.6 
ML.7 - 9 

cc. 1 
cc .2  

cc .3  
cc .4  
cc .5  

WA. 1 
WA.2 
WA.3 

'WA.4 - 7 
WA.4 - 7 

WA.8 
WA.9 

WA.10 - 14 
WA.15 - 19 

TS. 1 
t5.2 
t5.3 
t5.4 
t5.5 

6 
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INVALID 
, none 

Processing Options 
VALID 

Background Count Time = 10 sec 
Background Count Time = 200 sec 
Background Count Time = 300 sec 
Active Pulse Verification = 100 counts 
Passive Count Time Verification = 10 sec 
Active Pulse Verification = 2,000 counts . 
Passive Count Time Verification = 200 sec 
Active Pulse Production = 100 counts 
Passive Count Time Production = 10 sec 
Active Pulse Production = 5,000 counts 
Passive Count Time Production = 300 sec 

No options file present 
INVALID 

Invalid background count time 
Invalid active pulse verification 
Invalid active pulse production 
Invalid passive count time verification 
Invalid passive count time production 

CAMAC Interface 
VALID 

INVALID 
CAMAC operational 

No CAMAC power 
No active CAMAC configuration 
No passive CAMAC configuration 
No controller 

Time and Date of Data Acquisition 

Time and date of passive assay 
Time and date of active assay 

VALID 

INVALID 
none 

Passive Signals 
VALID 

Passive data acquisition 

7 

CP. 1 
CP.2 
CP.3 
CP.4 
CP.4 
CP.5 
CP.5 
CP.6 
CP.6 
CP.7 
CP.7 

CP.8 
CP.9 - 11 

CP.12 - 14 
CP.15 - 17 
CP.18 - 20 
CP.21 -23 

CI. 1 

c1.2 
c1.3 
c1.4 
C1.5 

TDDA. 1 
TDDA.2 

PS. 1 



INVALID 

Active Signals 
VALID 

INVALID 

Invalid passive counts 

Active data acquisition 

Invalid active counts 
Data Reduction 

VALID 
Measurement computation 

'INVALID 
none 

Chi-square . 
VALID 

INVALID 

DMS Interface 
VALID 

N o d  chi-square 

Chi-square parameter file not available 

Receive request from DMS to perform new assay 
Acknowledge DMS data 
Send results to DMS 
Receive acknowledgment from DMS 
Receive request from DMS to perform recalculation 
Receive request fiom DMS to perform recalculation 
Verification of current data during remote recalculation 

INVALID 
none 

VALID 
Version 2.0 Modifications 

Corrupted data file 
Background data with passive assay 
Missing passive background data 
Window placement and color information 
Reanalyzhig saved data 
Background data integrity 
Closing windows after aborting assay 
"Keyboard accelerators'' 

INVALID 
none 

INEL-96/0058 

PS.2 - 4 

AS. 1 

AS.2 - 3 

DR.1-2 

CS.1 

cs .2  

DMS. 1 
DMS.l 
DMS.l 
DMS.1 
DMS.2 
DMS.3 

DMS.37 

vM. 1 
vM.2 
vM.3 
vM.4 
vM.5 
vM.6 
vM.7 
VM.8 

8 
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6. FEATURES NOT TO BE TESTED 

This test plan will not address the following items: 
0 

0 

0 

0 

0 

0 

DMS. DMS is a separate software system that transmits requests to, and 
receives responses from SAS and, thus, will not be tested. Only the 
interface will be tested. 
SGRS. SGRS is a separate software system that transmits requests to, 
and receives responses from SAS and, thus, will not be tested. Only the 
interface will be tested. 
CAMAC crate. The test will address the CAMAC crate only insofar as it 
interfaces with SAS. No additional testing will be performed: 
DOS 6.0, Windows 3.1, or the Microsoft Visual C++ 1.51 development 
environment. SAS testing will not directly address the operating system 
or compiler environment. 
Equation validity. Testing will not address whether the equations are 
valid for the application. The methodology used is as described in 
reference [ 11. 
Portability to other IBM compatible platforms. Because present plans call 
for the SAS to be installed on an IBM compatible 486 platform, all testing 
will be for the target environment. Because there is no present need for 
portability, testing will not address portability. 

7. APPROACH 

The SAS testing will address the functions formally provided by NEUT2, as well 
as improvements from SAS Version 1.0. The following paragraphs describethe testing 
approach for each of these functional areas. 

7.1 Data Acquisition and Data Reduction 

The SAS acquires passive and active assay data through the CAMAC crate 
system. For the passive assay, neutron detectors on all six sides of the assay chamber 
count the neutrons emitted from the waste container. A neutron generator injects 
neutrons into the container for the active assay, and the detectors count neutrons from 
induced fissions. The detectors are connected to a CAMAC crate. The SAS controls the 
CAMAC crate during the acquisition process and requests the counts needed to perform 
the assay at the completion of the data acquisition. The CAMAC crate interface with SAS 
shall be tested by (a) not having any power to the CAMAC crate and (b) not having 
controller access to SAS. The corresponding data reduction of the counts will be tested 
by a combination of valid and invalid count data. 

7.2 Calculated Quantities 

The SAS estimates the masses of both plutonium (Pu) and americium (247) 
contained in a waste drum, and computes the thermal power, thermal power error, thermal 
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power density, thermal power density error, total alpha activity, total alpha activity error, 
activity concentration error, total Pu mass and error, individual plutonium isotopic masses 
(238,239,240 and 241), the mass of u5U when its presence is indicated by gamma ray 
measurement results, TRU activity, TRU activity concentration, total activity, plutonium 
equivalent curies, and fissile grkn equivalent. These tests will also test the assay 
recalculation from existing signal data and the production of the measurement summary. 
The test cases will address combinations of validinvalid content matrixes. 

7.3 Remote and ]Local Modes of Operation 

The test cases will address both remote and local modes of operation of SAS. 

7.4 DMS Interface 

The SAS receives assay requests from the DMS. To test the DMS interface, all 
the acknowledgments and transmissions between the SAS and DMS will be tested. 

7.5 SGRS Interface 

The SWEPP Gamma-Ray Spectroscopy System (SGRS) will be tested separately, 
and the results will be stored in files which will be utilized by the SAS system during 
testing. 

7.6 Administrative ControVModification of Parameters 

All administrative fbnctions in the SAS must be tested: Both the list of available 
container types and the list of available matrix types must be tested to ensure that they can 
be modified successfully. 

8. SUSPENSION CRITERIA AND RESUMPTION REQUIREMENTS 

If SAS failure occurs as a result of a test, all testing should be suspended until the 
defect is corrected or evaluated. Iftesting reveals an error in the SAS, but the SAS 
continues to respond, testing can continue until completion. Any anomalies should be 
recorded in the Test Execution Log, Appendix A. 

I fa  CAMAC crate error is encountered, all testing should be suspended until the 
CAMAC crate error can be eliminated. 

9. ENVIRONMENTAL NEEDS 

The SAS must execute on an IBM compatible PC using at least an INTEL 386 
CPU. A mouse, VGA color monitor, HP LaserJet III compatible printer, at least DOS 
5.0, and Windows 3.1 are also required. At least 8 megabytes of memory, a floppy disk 

10 



(either a 5.25-inch or 3.5-inch) and a hard disk (120 megabytes capacity, minimum) are 
needed. 

The SAS program accesses signal data from a CAMAC crate. The required crate, 
modules, and controller are specified in Table 1. 

Table 1. CAMAC crate module configuration. 

Station Module type Module name 
01-02 2323 LeCroy 2323A Gate Generator 
03-04 2323 LeCroy 2323A Gate Generator 
05 255 1 LeCroy 2551 Scaler 
06 255 1 LeCroy 2551 Scaler 
07-08 2323 LeCroy 2323A Gate Generator 
09-10 2323 LeCroy 2323A Gate Generator . 

11 2551 LeCroy 2551 Scaler 
12 255 1 LeCroy 2551 Scaler 
13 450 DSP 450 Gated Quad Scaler 
14-15 2323 LeCroy 2323A Gate Generator 
16-17 2323 LeCroy 2323A Gate Generator 
18 2551 LeCroy 2551 Scaler 
19 255 1 LeCroy 2551 Scaler 
20 450 DSP 450 Gated Quad Scaler 
21 217 Jorway 217 Gated Clock Generator 
22 202 Jorway 202 Dataway Display 
23 255 1 LeCroy 2551 Scaler 
24-25 8901 LeCroy 8901A GPlB Interface 
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10. TEST PROCEDURE 

The test analyst should have a working knowledge of a windows environment, 
including push buttons, radio buttons, and scrolling lists. Familiarity with Microsoft 
Windows is desirable, as is facility in using a mouse. All procedure steps are described in 
terms of the mouse input device, although it is possible to operate the SAS program 
without using a mouse. All tests shall be documented in the Test Execution Log, 
Appendix A, identified by test category and test case number. 

The.SAS supports the drum assay chamber. For clarity in most screen images, the 
windows for the drum assay chamber are not shown. 

The SAS root directory is defined in the file AS.INI. This file is located in the 
working directory for the program. The working directory can be located using the 
Properties function in Windows. 

12 
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10.1 User Access 

10.1.1 Introduction and Description 

These tests address operator, physicist, and administrator login and logout capability of 
SAS. 

10.1.2 Special Requirements 

Windows shall be operating. The SWEPP Assay System icon or main window must be 
visible. 

10.1.3 Procedure Steps 

1) Double click on the SWEPP Assay System icon with the left mouse button. 

SWEPP Assay 
System, 

Version 2 0  

2) The login dialog is displayed. 

3) After logging in, inspect the menu items to confirm that all menu choices 
shown in the following figures are displayed. For each item in the menu bar, 
pull down the menu by clicking the mouse button. These menus will be used 
throughout the remainder of the tests. 
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10.1.4 Valid Test Cases 

Purpose . 
UA.1 

This test addresses operator ,agin requirements, 3. 
Input Description 

,2.2 M.l and 3.1.2.2 M.2. 

1) In the login dialog, enter valid operator ID and password. 
2) ClickonOK. 
3) Confirm the archive disk reminder window by clicking the OK button. 
4) h l l  down the File, Run, Options, Window, and Help menus. 

Expected Results 
The archive disk reminder window is displayed. (The actual archive drive is specified in 
the file AS.IM.) 

. The Operator window and menu items are displayed. 

14 
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The Operator's File menu is displayed as shown. 

The Operator's Run menu is displayed as shown. 

Verification 
C hi-S q u a re 

Remote 
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The Operator's Options menu is displayed as shown. 

The Operator's Window menu is displayed as shown. 
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I The Operator's Help menu is duplayed as shown. 
F -  

PassfFail Criteria 
Test passes if the operator menus are displayed as indicated. 
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UA.2 
Purpose 

Input Description 
This test addresses the operator logout requirement, 3.1.2.2 M.3. 

1) If not logged in, log in to the SAS as an operator. 
2) pull down the File menu. 
3) Select Log Out. 

Expected ResuUs 
The initial SAS window is displayed. This window provides functions to log in & another 
user and to exit the SAS program. 

PasslFail Critenh 
Test passes if the initial SAS window is displayed. 
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UA3 
Purpose 

Input Descrip f h n  
This test addresses physicist login requirements, 3.1.2.2 .M.1 and 3.1.2.2 M.2. 

1) In the login dialog, enter valid physicist ID and password. 
2) ClickonOK. 
3) Confirm the archive disk reminder window by clicking the OK button. 
4) pull down the File, Run, Options, Window, and Help menus. 

Expected Results 
The archive disk reminder window is displayed. 

The Physicist window and menu items are displayed. 
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The Physicist's File menu is displayed as shown. 

n s  . Window HelD 

Print... 

Exit Ctrl+E 
Log out t 

The Physicist's Run menu is displayed as shown. 

Yerification 
C hi-S q u a re 
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The Physicist's Options menu is displayed as shown. 

J Background Correction 

- Color ... 
Assay l i m e s  ... 
Cali bration.. . 
- Matrix List ... 
Container List ... 

1 

The Physicist's Window menu is displayed as shown. 
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The Physicist's Help menu is displayed as shown. 

PasslFail Criteriu 
The test passes if the physicist menu is displayed. 

22 
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UA.4 
Purpose 

Input Descriptian 
This test addresses the physicist logout requirement, 3.1.2.2 M.3. 

1) If not logged in, log in to the SAS as a physicist. 
2) Pull down the File menu. 
3) Select Log Out. 

Expected Results 
The initial SAS window is displayed. This window provides functions to log in as another 
user and to exit the SAS program. 

11 Exit Loa In ... HelD I 

PasslFail Criteria 
Test passes if the initial SAS window is displayed. 
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UA.5 
Purpose 

Input Descnpfion 
This test addresses administrator login requirements, 3.1.2.2 M.l and 3.1.2.2 M.2. 

1) In the login dialog, enter valid administrator ID and password. 
2) ClickonOK. 
3) Pull down the File and Help menus. 

Expected Results 
The Administrator window and menu items are displayed. 

24 



sz 



INEL-96/0058 

UA.6 
Purpose 

This test addresses the administrator logout requirement, 3.1.2.2 M.3. 
Input Description 

1) If not logged in, log in to the SAS as an administrator. 
2) Pull down the File menu. 
3) Select Log Out. 

Expected Results 
The initial SAS window is displayed. This window provides functions to log in as another 
user and to .exit the SAS program. 

PasslFail Criteria 
Test passes if the initial SAS window is displayed. 

UA.7 
Purpose 

This test addresses the logout requirement, SCR User Interface Problems; Item 6 [14], to 
ensure that the "Chamber Window" can not be closed without first performing a user 
logout operation. 

Input Description 
Log in to the SAS as an operator. 
Close the "Chamber Window." 
Click on Yes. 
Log in to the SAS as a physicist. 
Close the "Chamber Window." 
Click on Yes. 
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Expected ResuUs 
"DO you really want to ..." dialog is displayed each time the user attempts to close the 
chamber window. 

The initial SAS window is displayed. This window provides functions to log in as another 
user and to exit the SAS program. 

PasslFail Criteria 
Test passes if the confirmation dialog and the initial SAS window are displayed. 
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10.1.5 Invalid Test Cases 

UA.8 
Purpose 

This test addresses the requirement to permit only users with a valid user ID to access 
SAS, requirement 3.1.2.2 M.l. This test enters an invalid user ID. 

Input Description 
1) In the login dialog, enter an invalid operator ID and valid operator password. 
2) ClickonOK. 

Expected Results 
"Invalid ID or Password" dialog is displayed. 

PasslFail Criteria 
The test passes if the error dialog is displayed. 
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UA.9 
Purpose 

This test addresses the requirement to permit only authorized users to access the system, 
requirement 3.1.2.2 M.l. This test enters a valid user ID, but invalid user password. 

Input Description 
1) In the login dialog, enter an valid operator ID and invalid operator password. 
2) ClickonOK. 

Expected ResuUs 
"Invalid ID or Password" dialog is dsplayed. 

PasslFail Criteria 
The test passes if the error dialog is displayed. 

I 
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10.2 Administrator Functions 

10.2.1 Introduction and Description 

These tests address mowing  the list of users who have access to.the system, as well as 
manipulating the log file. 

10.2.2 Special Requirements 

The user list dialog will be visible for the test cases dealing with the user list. The dialog 
inputs are described for each test. Optionally, following each test, the fde USERUT in 
the assay system root directory may be printed to verify that the user list is stored with 
appropriate data. 

10.23 Procedure Steps 

1) Log in as an administrator. 
2) Pull down the File menu. 

3) Select User List. 
4) The user list dialog is displayed. 

For user list es t  cases: 
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10.2.4 Valid Test Cases 

AF.1 
Purpose 

Input Description 
This test addresses manipulation of the log file, requirement 3.1.2.2 M.2. . 

1) PulldowntheFilemenu. . 
2) Select Print Log Files. 
3) After the file prints, p d  down the File menu. 
4) Select New Log Files. 

Expected Results 
The log file should print. 

PasslFail Criteria 
Test passes if the log file prints successfully. 

AF.2 
Purpose 

Input Description 
This test addresses adding an operator, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Enter valid user ID { [A-Z I a-z I 0-9]}6 
Enter user name { [A-Z I a-z I 0-9]}32 
Enter password { [A-Z I a-z I 0-9]}6 
Select Operator access level. 

2) Click on Add. 
3) ClickonOK. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, operator access level is 
indicated, and the password is hidden. 

Test passes if the operator is added to the list, and the attributes previously entered are 
displayed when the ID is selected. 

PassLFail Criteria 

AF.3 
Purpose 

Input Description 
This test addresses adding a physicist, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Enter valid user ID { [A-Z I a-z I 0-91 } 6 
Enter user name { [A-Z I a-z I 0-91 } 32 
Enter password { [A-Z I a-z I 0-9]}6 
Select Physicist access level. 
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2) ClickonAdd. 
3) ClickonOK. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears h the list of 
users. When that user ID is selected, the user name is displayed, physicist access level is 
indicated, and the password is hidden. 

Test passes if the physicist is added to the list, and the attributes previously entered are 
displayed when the ID is selected. 

PasslFail Criteria 
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AF.4 
Purpose 

Input Description 
This test addresses adding an administrator, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Enter valid user ID { [A-Z I a-z I 0-91 }6 
Enter user name { [A-Z I a-z I 0-91 }32 
Enter password { [A-Z I a-z I 0-9]}6 
Select Administrator access level. 

2) Click on Add. 
3) ClickonOK. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, administrator access level 
is indicated, and the password is hidden. 

Test passes if the administrator is added to the list, and the attributes previously entered 
are displayed when the ID is selected. 

PasslFail Criteria 

AF5 
Purpose 

Input Description 
This test addresses changing an operator's user ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 

2) Change the user ID. 
3) Click on Change. 
4) ClickonOK. 

Select an existing user ID from the pull down menu. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, operator access level is 
indicated, and the password is hidden. 

Test passes if the operator's user ID is changed. 
PasslFail Criteria 

AF.6 
Purpose 

Input Description 
This test addresses changing an operator's user password, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 

2) Change the password. 
3) Click on Change. 
4) ClickonOK. 

Select an existing user ID from the pull down menu. 
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Expected Results 
When the user list dialog is displayed again, and that user ID is selected; the user name is 
displayed, operator access level is indicated, and the password is hidden. 

Test passes if the operator's user password is changed; the operator must login with the 
new password. 

PasslFail Criteria 

AF.7 
Purpose 

This test addresses changing an operator's access level, requirement 3.1.2.2 M.4. 
Input Descripfwn 

1) In,the user list dialog, 
Select an existing operator user ID from the pull down menu. 
Select Physicist access level radio button. 

2) Click on Change. 
3) ClickonOK. 
4) In the user list dialog, 

Select an existing operator user ID from the pull down menu. 
Select Administrator access level radio button. 

5 )  Click on Change. 
6 )  ClickonOK. 
7) Retum the access level to its original status when the test is complete. 

Expected Results 
When the user list dialog is displayed again, and that user ID is selected, the user name is 
displayed, the appropriate access level is indicated, and the password is hidden. 

Test passes if the access level is changed. 
PasslFail CnYenh 

AF.8 
Purpose 

Input Descnpth  , 

Select an existing physicist's user ID from the pull down menu. 

This test addresses changing aphysicist's user ID, requ3ement 3.1.2.2 M.4. 

1) In the user list dialog, 

2) Change the user ID. 
3) Click on Change. 
4) ClickonOK. 

' 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, physicist access level is 
indicated, and the password is hidden. 

Test passes if the physicist's user ID is changed. 
PasslFail Criteria 
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AF.9 
Purpose 

Input Description 
This test addresses changing a physicist's user password, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 

2) Change the password. 
3) Click on Change. 
4) ClickonOK. 

Select an existing physicist's user ID from the pull down menu. 

Expected Results 
When the user list dialog is displayed again, and that user ID is selected, the user name is 
displayed, physicist access level is indicated, and the password is hidden. 

Test passes if the physicist's user password is changed; the physicist must login with the 
new password. 

PasslFail Criteria 

AF.10 
Purpose 

Input Description 
This test addresses changing a physicist's access level, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Select an existing physicist user ID from the pull down menu. 
Select Operator access level radio button. 

2) Click on Change. 
3) ClickonOK. 
4) In the user list dialog, 

Select an existing physicist user ID from the pull down menu. 
Select Administrator access level radio button. 

5 )  Click on Change. 
6) ClickonOK. 
7) Return the access level to its original status when the test is complete. 

When the user list dialog is displayed again, and that user ID is selected, the user name is 
displayed, the appropriate access level is indicated, and the password is hidden. 

Test passes if the access level is changed. 

Expected Resulfs 

PasslFail CnYeria 
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This test addresses changing the current administrator's user ID, requirement 3.1.2.2 M.4. 
Purpose 

Input Description 
1) In the user list dialog, 

2) Change the user ID. 
3) Click on Change. 
4) ClickonOK. 

Select the current administrator's user ID €?om the pull down menu. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, administrator access level 
is indicated, and the password is hidden. 

Test passes if the administrator's user ID is changed. 
PasslFail Criteria 

AFJ2 
Purpose 

Input Description 
This test addresses changing an administrator's user ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Select an existing administrator's user ID from the pull down menu (other 
than the current administrator's). 

2) Change the user ID. 
3) Clickonchange. 
4) ClickonOK. 

Expected Results 
When the user list dialog is displayed again, the entered user ID appears in the list of 
users. When that user ID is selected, the user name is displayed, administrator access level 
is indicated, and the password is hidden. 

Test passes if the administrator's user ID is changed; the administrator must login with the 
new password. 

PasslFail Criteria 

AFJ3 
Purpose 

This test addresses changing the current administrator's user password, requirement 
3.1.2.2 M.4. 

Input Description 
1) In the user list dialog, 

2) Change the password. 
3) Clickonchange. 
4) ClickonOK. 

Select an existing administrator's user ID €?om the pull down menu. 
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5) Return the access level to its original status when the test is complete. 

When the user list dialog is dqlayed again, and that user ID is selected, the user name is 
displayed, administrator access level is indicated, and the password is hidden. 

Test passes if the administrator's user password is changed. 

Expected Results 

PasslFail Criteria I 

AF.14 
Purpose 

Input Description 
This test addresses chan,@ng an administrator's user password, requirement 3.1.2.2 M.4. 

1) In the user list dialog, 
Select an existing administrator's user ID from the pull down menu (other 
than the current administrator's). 

2) Change the password. 
3) Click on Change. 
4) ClickonOK. 
5) Return the access level to its original status when the test is complete. 

When the user list dialog is displayed again, and that user ID is selected, the user name is 
displayed, administrator access level is indicated, and the password is hidden. 

Test passes if the administrator's user password is changed. 

Expected Results 

PasslFail Criteria 

AFJ5 
Purpose 

Input Description 
This test addresses changing an administrator's access level, requirement 3.1.2.2 M.4. 

In the user list dialog, 
Select an existing administrator user ID from the pull down menu. 
Select Operator access level radio button. 

Click on Change. 
.In the user list dialog, 

Select an existing administrator user ID from the pull down menu. 
Select Physicist access level radio button. 

Click on Change. 
Click on OK. 
Return the access level to its original status when the test is complete. 

Expected Results 
When the user list dialog is displayed again, and that user ID is selected, the user name is 
dqlayed, the appropriate access level is indicated, and the password is hidden. 

Test passes if the administrator's access level is changed. 
PasslFail Criteria 
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AFJ6 
Purpose 

Input Description 
This test addresses deleting an operator user ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, select a user ID with operator access. 
2) Click on Delete. 
3) ClickonOK. 

Expected Results 

PasslFail Criteria 
When the user list dialog is displayed again, the deleted user ID does not appear in the list. 

Test passesif deleted user ID does not appear in the list. 

AF.17 
Purpose 

Input Description 
This test addresses deleting a physicist user ID, requirement 3.1 2.2 M.4. 

1) In the user list dialog, select a user ID with physicist access. 
2) Click on Delete. 
3) ClickonOK. 

Expected Resuh 

PasslFail Criteria 
When the user list dialog is displayed again, the deleted user ID does not appear in the list. 

Test passes if deleted user ID does not appear in the list. 

AFJ8 
Purpose 

Input Description 
This test addresses deleting a administrator user ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, select a user ID with administrator access. The 
administrator selected must be different from that of the administrator who is 
performing this test. 

2) Click on Delete. 
3) ClickonOK. 

Expected Results 

PasslFail Criteria 
When the user list dialog is displayed again, the deleted user ID does not appear in the list. 

Test passes if deleted user ID does not appear in the list. 
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10.2.5 Invalid Test Cases 

AFJ9 
Purpose 

Input Description 
This test addresses adding a duplicate operator ID, requiement 1.2. 4. 

1) In the user list dialog, select an operator user ID already in the list. 
2) Click on Add. 

Expected Results 
"Duplicate ID not allowed!" dialog is chsplayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 

AF.20 
Purpose 

Input Description 
This test addresses adding a duplicate physicist ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, select a physicist user ID already in the list. 
2) Click on Add. 

Expected Results 
"Duplicate ID not allowed!" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 
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AF.21 
Purpose 

Input Description 
This test addresses adding a duplicate administrator ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, select an administrator user ID already in the list. 
2) Click on Add. 

Expected Results 
"Duplicate ID not allowed!" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 

AF.22 
Purpose 

This test addresses changing the current administrator's access level, requirement 3.1.2.2 
M.4. 

Input Description 
1) In the user list dialog, 

Select the current administrator's user ID from the pull down menu. 
Select Operator access level radio button. 

2) Click on Change. 
3) In the user list dialog, 

Select the current administrator's user ID from the pull down menu. 
Select Physicist access level radio button. 

4) Click on Change. 
5) Return the access level to its original status when the test is complete. 

Expected ResuZts 
"You cannot change your own level" dialog is displayed. 
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PasslFail Criteria 
Test passes if dialog is displayed. 

AF.23 
Purpose 

Input Description 
This test addresses deleting the current administrator's user ID, requirement 3.1.2.2 M.4. 

1) In the user list dialog, select the user ID of the administrator perfonning this 

2) Click on Delete. 
test. 

Expected ResuIts 
"You cannot delete yourself!" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 
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10.3 Container List 

103.1 Introduction and Description 

These tests address modifying the list of containers that the assay system can process by 
adding containers to and deleting containers fkom the container list. 

103.2 Special Requirements 

The container list dialog will be visible. The dialog inputs are described for each test. 
Optionally, following each test, the file CONTAIN.LST in the assay system root directory 
may be printed to veri@ that the container list is stored with appropriate data. The file 
CONTAIN.LST must be Write-enabled in order to perform the following tests. 

103.3 Procedure Steps 

1) Log in as a physicist. 
2) Pull down the Options menu. 
3) Select Container List. 
4) If the file CONTAIN.LST allows Write access, the container list dialog is 

displayed as shown: 
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If the file CONTAIN.LST does not allow write access, the container list dialog 
is displayed as shown (addresses S C R  User Interface Problems, Item 11): 

c 
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103.4 Valid Test Cases 

CL.I 
Purpose 

This test addresses adding a container to the list; requirements 3.1.4.2 M.l, 3.1.4.2 M.5, 
and SCR User Interface Problems, Item 11. 

Input Description 
1) In the container list dialog, 

Enter a container description. 
. Enter a volume in the range > 0.00 and < 1000.00. 

2) ClickonAdd. 
3) ClickonOK. 

Expected Results 
When the conther list dialog is displayed again, the entered container description appears 
in the list of containers and the volume agrees with the volume entered to two digits after 
the decimal. 

PasslFail Criteria 
Test passes if the entered container appears in the list. 

CL3 

This test addresses changing a container in the list, requirements 3.1.4.2 M.l, 3.1.4.2 M.5, 
and S C R  User Interface Problems, Item 11. 

Purpose 

Input Description 
1) In the container dialog, select the container description entered in the previous 

test. 
2) Modify the container volume to a different volume in the range > 0.00 and < 

1000.00. 
3) Click on Change. 
4) ClickonOK. 

Expected Results 
M e n  the container list dialog is dsplayed again, the modified container description 
appears in the list. 

Test passes if the modified container is in the list. 
PasslFail Criteria 
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CL.3 
Purpose 

This test addresses deleting a container from the list, repirements 3.1.4.2 M.1,3.1.4.2 
M.5, and SCR User Interface Problems, Item 11. 

Input Description 
1) In the container dialog, select the container description modified in the 

previous test. 
2) Click on Delete. 
3) ClickonOK. 

Expected ResuUs 
When the container list dialog is displayed again, the deleted container description does 
not appear in the list. . 

PassIFail Criteriu 
Test passes if the deleted container is not in the list. 



103.5 Invalid Test Cases 

CL.4 
Purpose 

This test addresses adding a container to the list, requirements 3.1.4.2 M.l, 3.1.4.2 M.5, 
and SCR User Interface Problems, Item 11. 

.Input Description 
1) In the contaher list dialog, select a container description from the contaher 

2) ClickonAdd. 
list. 

Expected Results 
"Duplicate description" dialog is displayed. - 

PasslFail Criteria 
Test passes if dialog is displayed. 

CL.5 
Purpose 

This test addresses adding a container to the list, requirements 3.1.4.2 M.l, 3.1.4.2M.5, 
and SCR User Interface Problems, Item 11. 

Input Description 
1) In the container list dialog, 

Enter a container description 
Enter a volume of 0.0. 

Expected Results 
2) ClickonAdd. 

"Volume must be > 0" dialog is displayed. 
\ 



Pasflail Criteria 
Test passes if dialog is displayed. 

Purpose 
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CL. 6 

This test addresses adding a contsllier to the list, requliements 3.1.4.2 M. 1,3.1.4.2 M.5, 
and SCR User Interface Problems, Item 1 1. 

Input Description 
1) In the container list dialog, 

Enter a container description 
6 Enter a volume of -10.0. 

2) , Click on Add. 
Expected Results 

Pasflail Criteria 
"Volume must be > 0" dialog is displayed. 

Test passes if dialog is displayed. 

CL. 7 
Purpose 

This test addresses adding a container to the list, requirements 3.1.4.2 M. 1 , 3.1.4.2 M.5, 
and SCR User Interface Problems, Item 1 1. 

Input Descripfion 
1) In the container list dialog, 

Enter a container description 
Enter a volume of 999999.99. 

2) Click on Add. 
3) Click on Yes to add container. 

Expected Results 
"Volume seems excessive" dialog is displayed. 

Pasflail Criteria 
Test passes if dialog is displayed. 



CL.8 
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Purpose 
This test addresses adding a container to the list, requirements 3.1i4.2 M.l, 3.1.4.2 M.5, 
and S C R  User Interface Problems, Item 11. 

Input Description 
1) In the container list dialog, 

0 Enter a container description 
0 Enter a volume of 999999.99. 

2) ClickonAdd. 
3)  Click on No to cancel container addition. 

Expected Results 
"Volume seems excessive" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 

CL.9 

This test addresses changing a container in the list, requirements 3.1.4.2 M.l, 3.1.4.2 M.5, 
and SCR User Interface Problems, Item 11. 

Purpose 

Input Descripth 
1) In the container list dialog, 

Select any container 
0 Enter a volume of 0.0. 

Expected Results 
2) Click on Change. 

"Volume must be > 0" dialog is displayed. 
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PasslFail Criteria 
Test passes if dialog is mlayed. 

CL.10 

This test addresses changing a container in the list, requh-ements 3.1.4.2 M.l, 3.1.4.2 M.5, 
Purpose 

and SCR User Interface Problems, Item 11. 
Input Description 

Expected Results 

PasslFail Criteria 

1) In the container list dialog, 

2) Click on Change. 
Enter a volume of -10.0. 

"Volume must be > 0" dialog is displayed. 

Test passes if dialog is displayed. 

CL.11 
Purpose 

This test addresses changing a container in the list, requirements 3.1.4.2 M.l, 
and SCR User Interface Problems, Item 11. 

Input Description 
1) In the container list dialog, 

Enter a volume of 999999.99. 
2) Click on Change. 
3) Click on Yes to change container. 

Expected Results 
"Volume seems excessive" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. 

-1.4.2 h 5, 
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CL.12 
Purpose 

This test addresses changing a container in the list, requirements 3.1.4.2 M.l, 3.1.4.2 M.5, 
and SCR User Interface Problems, Item 11. 

Input Descnpfion 
1) In the container list dialog, 

2) Click on Change. 
3) Click on No to cancel container modification. 

Enter a volume of 999999.99. 

Expected Results 
"Volume seems excessive" dialog is displayed. 

PasslFail Criteria 
Test passes if dialog is displayed. . 
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10.4 Matrix List 

10.4.1 Introduction and Description 

These tests address modifving the list of matrixes that the assay system can process by 
adding matrixes to and deleting matrixes from the matrix list. 

10.4.2 Special Requirements 

The matrix .list dialog will be visible. The dialog inputs are described for each test. 
Optionally, following each test, the file MATRIX.LST in the assay system root directory 
may be printed to verify that the matrix list is stored with appropriate data. The file 
MATRIX.LST must be write-enabled in order to perform the following tests. 

10.4.3 Procedure Steps 

1) Login as a physicist. 
2) Pull down the Options menu. 
3) Select Matrix List. 
4) E the file MATRIX.LST allows write access, the matrix list dialog is displayed 

as shown: 

E the file MATlUX.LST does not allow write access, the matrix list dialog is 
displayed as shown: 
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10.4.4 Valid Test Cases 

Purpose 

Input Description 

Enter a new code in [0,999] 
Enter matrix description. 

This test addresses adding a matrix to the matrix list, requirements 3.1.4.3 M.3 and M.4. 

1) In the matrix list dialog, 

2) Click on Add. 
3) In the matrix parameters dialog, click on OK to accept the default values. . 
4) In the matrix list dialog, click on OK. 

Expected Results 
When the matrix list dialog is displayed again, the entered code and matrix description 
appear in the list of matrixes. When that item is selected, the code and description are 
displayed, and the word Non-Sludge appears as the matrix type. 

Test passes if the entered matrix appears in the list. 
PasslFail CnYerh 
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ML.2 
Purpose 

Input Description 

Enter a code in [0,999] 

This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M.4. 

1) In the matrix list dialog, 

. Enter matrix description. 
2) ClickonAdd. 
3)  In the matrix parameters dialog, select the Sludge radio button, then click on 

OK to accept the default values. 
4) In the matrix list dialog, click on OK. 

Expected Results 
When the matrix list dialog is displayed again, the entered code and matrix description 
appear in the list of matrixes. When that item is selected, the code and description are 
displayed, and the word Sludge appears as the matrix type. 

Test passes if the entered matrix appears in the list. 
PasslFail Criteria 

ML.3 
Purpose 

Input Description 

Enter a code in [0,999] 
Enter matrix description. 

This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M.4. 

1) In the matrix list dialog, 

2) ClickonAdd. 
3) In the matrix parameters dialog, select the Am Sludge radio button, then click 

4) In the matrix list dialog, click on OK. 
on OK to accept the default values. 

Expected Results 
When the matrix list dialog is displayed again, the entered code and matrix description 
appear in the list of matrixes. When that item is selected, the code and description are 
displayed, and both Sludge and Am Sludge appear as the matrix types. 

Test passes if the entered matrix appears in the list. 
PasslFail Criteria 
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ML.4 
Purpose 

This test addresses deleting a matrix from the matrix list, requirement 3.1.4.3 M.3 and 
M.4. 

Input Description 
1) In the matrix list dialog, select one of the matrix codes added in the previous 

2) Click on Delete. The matrix code will be removed from the list. 
3) Click on OK. 

tests. 

fipected Results 
When the matrix list dialog is displayed again, the deleted code and matrix description do 
not appear in the list of matrixes 

Test passes if the deleted matrix code no longer appears in the list. 
Pasflail Crireria 

ML.5 

This test addresses setting the matrix attributes for a matrix in the list, requirement 3.1.4.3 
M.3 and M.4. Note that the coefficients for the active sellrabsorption correction factor 
correlation do not have range restriction, and thus are not tested. 

For each input field and data value listed in, 

Purpose 

Input Description 

1) In the matrix list dialog, select one of the matrix codes added in the previous 

2) Click on Change. 
3) In the matrix parameters dialog, enter the value specified in Table 2 for the 

4) Click on OK. 

tests. 

field. 

Table 2. Valid Matrix Parameter Values. 

Field Value 
Mass selection 

(select only one) 
Active 
Passive 
Default 

Moderator index 0.5 
Active correction factor 1.0 
Passive shielded correction factor 5.0 

........................................................................ .......................................................... .... 

............................................................ I ......................... .. ....................................... - ..... - ...... 

.................................................................. - .......................................................... ...- ............ 
Passive system correction factor 10.0 ..................... ................................................................................................... I.._ .... - ...... 
Matrix Type 

(select only one) 
Non-Sludge 

Sludge 
Am Sludge 
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Expected Results 
The system returns to the matrix list dialog in each case. The input value or selection is 
retained when the matrix parameter dialog is reentered by clicking on Change again. 

Test passes if each changed value or selection is retained in the matrix parameter dialog on 
the next entry into the dialog. 

PassfFail Criteria 

10.4.5 Invalid Test Cases 

ML.6 
Purpose ' 

Input Description 

Select a code and description from the list 
Enter a different matrix description. 

Expected Results 

This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M.4. 

1) In the matrix list dialog, 

2) ClickonAdd. 

"Duplicate Content Code" dialog is displayed. 

PassfFail Criteria 
Test passes if dialog is displayed. 

ML.7 
Purpose 

Input Description 
This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M.4. 

1) In the matrix list dialog, 
Enteracodeof-10 , 

Enter a matrix description. 
2) ClickonAdd. 

Expected Results 
"Content Code must be in the range 0 to 999" dialog is displayed. 
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PasslFait Criteria 
Test passes if dialog is displayed. 

MZ.8 
Purpose 

This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M.4. 
Input Description 

In the matrix list didog, attempt to enter more that three digits in the code field. 
Expected Resulfs 

PassfFail Criteria 
No more than three digits may be entered. 

Test passes if no more than three digits can be entered. 

MZ.9 
Purpose 

This test addresses setting the matrix attributes for a matrix in the list, requirement 3.1.4.3 
M.3 andM.4. 

For each input field and data value listed in Table 3, 
Input Description 

1) In the matrix list dialog, select one of the matrix codes added in the previous 

2) Click on Change. 
3) In the matrix parameters dialog, enter the value for the data field from Table 3. 
4) ClickonOK. 

tests. 
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Table 3. Invalid Mark Parameter Values. 

Field Value Expected Result 
Moderator index -0.5 moderator index must be in [0.0,1.0] 
Moderator index 2.0 moderator index must be in [0.0,1.0] 
Moderator index 
Active correction factor 
Active correction factor 
Active correction factor 
Passive shielded correction factor 

0.0 
-1.0 

1.0 * -1.0 
0.0 
-1.0 

(resets value, continue to next test) 
correction factors must be 2 0.0 
uncertainty must be positive 
(resets value, continue to next test) 
correction factors must be 2 0.0 

Passive shielded correction factor 
Passive shielded correction factor 
Passive system correction factor 
Passive system correction factor 
Passive system correction factor 

1.0 f -1.0 
0.0 
-1.0 

1.0 f -1.0 
0.0 f 0.0 

uncertainty must be positive 
(resets value, continue to next test) 
correction factors must be 2 0.0 
uncertainty must be positive 
(resets value, continue to next test) 
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10.5 Chamber Calibration 

10.5.1 Introduction and Description 

These tests address the modification of the chamber calibration parameters. 

10.5.2 Special Requirements 

The chamber calibration dialog will be visible. The dialog inputs are described for each 
test. Optionally, following each test, the file ..WACC4LJl3.DAC from the assay system 
root directory may be printed to.verify that the chamber calibration data are stored 
appropriately. The file CALIB.DAC must be write-enabled in order to perform the 
following tests. 

10.53 Procedure Steps 

1) Log in as aphysicist. 
2) Pull down Options menu. 
3) Select Calibration. 
4) If the file CALIB-DAC allows write access, the chamber calibration dialog will 

be displayed as shown: 

If the file CALIB.DAC does not allow write access, the chamber calibration 
dialog will be displayed as shown, but no changes can be made (addresses S C R  
User Interface Problems, Item 11): 
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10.5.4 Valid Test Cases 

cc.1 
Purpose 

Input Description 
This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3. 

For each input field and data value listed in Table 4, 
1) In the chamber calibration dialog, enter the data value in the field. 
2) ClickonOK. 

. . Table 4. Valid chamber calibration patameter values. 

Field Value 
Shielded detector efficiency 0.055 
System detector efficiency 0.178 
Active zero matrix calibration factor 
Shielded coincidence zero matrix calibration factor 
System coincidence zero matrix calibration factor 

15.4 
95.0 
3.67 

Expected Results 
The system returns to the main window in each case. The value is retained when the 
calibration dialog is reentered. 

Test passes if each value G retained in the calibration dialog. 
PasslFail Criteria 

cc.2 
Purpose 

Input Description 

Enter Pu 238 mass fraction 0.01 
e Enter Pu 239 mass fraction 0.92 

Enter Pu 240 mass fraction 0.05 
Enter Pu 241 mass fraction 0.015 
Enter Pu 242 mass fraction 0.005. 

Expected Results 
The system returns to the main window. The values are retained when the calibration 
dialog is reentered. 

PasslFail Criteria 
Test passes if each value is retained in the calibration dialog on the next entry into the 

This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3. 

1) In the chamber calibration dialog, 

2) ClickonOK. 

dialog. 
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10.5.5 Invalid Test Cases 

cc.3 
Purpose 

Input Description 
This test addresses setting the chamber calibration parameters requirement 3.1.3.3 M.3. 

For each test case in Table 5, 
1) In the chamber calibration dialog, enter the value for the field €tom the fable. 
2) ClickonOK. 

Table 5. Invalid chamber calibration parameter values. 

Field Value Expected Result 
Shielded detector efficiency 
Shielded detector efficiency 

* shi&x~ detector efficiency 
Shielded detector efficiency 
System detector efficiency 
System detector efficiency 
System detector efficiency 
System detector efficiency 
Active zero matrix calibration factor 
Active zero matrix calibration factor 
Active zero matrix calibration factor 
Shielded coincidence zero matrix calibration factor 
Shielded coincidence zero matrix calibration factor 
Shielded coincidence zero matrix calibration factor 
System coincidence zero matrix calibration factor 
System coincidence zero matrix calibration factor 

-0.5 
2.0 

0.5 k -1.0 
0.029 k 0 

-0.5 
2.0 

0.5 f -1.0 
0.1265 k 0 

-1.0 
0.5 k -1.0 
4.35 f 0 

-1.0 
0.5 k -1.0 
28.1 f 0 

-1.0 
0.5 f -1.0 

detector efficiency must be in [O.O,l.O] 
detector efficiency must be in [O.O,l.O] 
uncertainty must be positive 
(resets value, continue to next test) 
detector efficiency must be in [0.0,1.0] 
detector efficiency must be in [0.0,1.0] 
uncertainty must be positive 
(resets value, continue to next test) 
calibration factor must be 2 0.0 
uncertainty must be positive 
(resets value, continue to next test) 
calibration factor must be 2 0.0 
uncertainty must be positive 
(resets value, continue to next test) 
calibration factor must be 2 0.0 
uncertainty must be positive 

System coincidence zero matrix calibration factor 1.28 k 0 (resets value, continue to next test) 

Expected Results 
As indicated in Table 5,  either the "Detector efficiencies ...I' dialog is displayed, 
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or the "Calibration factors ...'I dialog is displayed. 

PasslFail Criteria 
Test passes if each value entered produces the appropriate error dialog. 

cc.4 
Purpose 

Input Description 

Enter Pu 238 mass fraction 0.01 
Enter Pu 239 mass fraction 0.92 

* Enter Pu 240 mass fraction -0.05 
* Enter Pu 241 mass fraction 0.015 

Enter Pu 242 mass fraction 0.005. 

Expected Resulfs 

This test addresses seking the chamber calibration parameters, requirement 33.3.3 M.3. 

1) In the chamber calibration dialog, 

2) ClickonOK. 

"Fraction must be in the range 0 to 1." dialog is displayed. 

PassiFail Criteria 
Test passes if errordialog is displayed. 
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CC.5 
Purpose 

This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3. 
Input Description 

0 Enter Pu 238 mass fraction 0.1 
Enter Pu 239 mass fraction 0.92 

0 Enter Pu 240 mass fraction 0.05 
0 Enter Pu 241 mass fraction 0.015 
0 Enter Pu 242 mass fraction 0.005. 

Expected Results 

1) In the chamber calibration dialog, 

2) ClickonOK. 

"Sum of fractions greater than..." dialog is displayed. 

PasslFail Criteria 
Test passes if error dialog is displayed. 



10.6 Waste Attributes 

10.6.1 Introduction and Description 

These tests address choosing a file name, setting container identification, selecting the container 
type, selecting the matrix type, and entering the container's the net weight. These elements 
constitute the waste attributes. 

10.6.2 Special Requirements 

The new file dialog,will be visible. 

10.63 Procedure Steps 

1) Log in as an operator. 
2) pull down File menu. 
3) SelectNew. 
4) The new file dialog is displayed. 

5 )  When valid file names are entered for specific tests, clicking on OK will display the 
, waste attributes dialog. 
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10.6.4 Valid Test Cases 

WA.1 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3 and 3.1.4.3 M.1 and 
M.3. This test is particularly aimed at testing valid file names. 

Input Description 
1) In the new file dialog, enter file name WA-1. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Select matrix type 152 
Enter net weight 6.0. 

Select 55 gallon dnun for the container type 

4) Click on Assay (do not select an Assay type). 
5) Click on Close. 

Expected ResuUs 
File name is accepted and becomes the identification in the waste attributes dialog; waste 
attributes appear in the dialog box. 

Test passes if the waste attributes dialog contains the attributes that were input. 
PasslFail Criteria 

WA3 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3 and 3.1.4.3 M.1 and 
M.3. This test is particularly aimed at testing valid file names. 

Input Description 
1) In the new file dialog, enter file name 999999. 
2) ClickonOK. 
3) In the waste attributes dialog, 
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0 

0 Select matrix type 152 
Enter net weight 6.0. 

Select 55 gallon drum for the container type 

4) Click on Assay (do not select an Assay type). 
5 )  Click on Close. 

Expected Results 
File name is accepted and becomes the identification in the waste attributes dialog; waste 
attributes appear in the dialog box. 

Test passes if the waste attributes dialog contains the attributes that were input. 
PasslFail Criteria 

WA3 
Purpose 

This test addresses setting the waste attributes, which’include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and M.3 and 3.1.4.3 M.l and 
M.3. This test is particularly aimed at testing valid file names. 

Input Description 
1) In the new file dialog, enter file name $&$###. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Select matrix type 152 
Enter net weight 6.0. 

Select 55 gallon drum for the container type 

4) Click on Assay (do not select an Assay type). 
5) Click on Close. 

Expected Results 
File name is accepted and becomes the identification in the waste attributes dialog; waste 
attributes appear in the dialog box. 

Test passes if the waste attributes dialog contains the attributes that were input. 
PasslFail Criteria 

WA.4-WA.7 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M. 1 and M.3,3.1.4.3 M. 1 and M.3, 
and SCR User Interface Problems, Item 3. These tests are particularly aimed at testing valid 
matrixtypes. 

Input Description 
For each test case in Table 6, 

1) In the new We dialog, enter the file name using the identification name from the table. 
2) ClickonOK. 
3) In the waste attributes dialog, using the values from the table, 

Select container type 
Select matrix type 

0 Enter net weight. 

i 
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4) Click on Assay (do not select an Assay type). 
5 )  Click on Close. 

Expected ResuUs 
File name is accepted and becomes the identification in the waste attributes dialog; waste 
attributes appear in the dialog box. The matrix type displayed initially should be the same matrix 
type as was used in each previous test. 

Test passes if the waste attributes dialog contains the attributes that were input, and if the matrix 
type displayed initially is the same matrix type as was used in each previous test. 

PasslFail Criteria 

Table 6. Waste attribute hmt. valid test cases. 

Identification Container type Matrix code Net weight 
WA-4 55 gallon drum 0 10 
WA-5 55 gallon drum 152 70 
WA-6 55 gallon drum 292 80 
WA-7 55 gallon drum 320 110 
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WA.8 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and M.3, and 3.1.4.3 M.l and 
M.3; it also addresses SCR User Interface Problems, Item 1. This test is particularly aimed at 
testing starting a new assay from the Run menu rather than the File menu. 

Input Description 
Log in as an operator. 
Pull down Run menu. 
Select New Assay. 
The new file dialog is displayed. 

When valid file names are entered for specific tests, clicking on OK will display the 
waste attributes dialog. 



Expected Results 
File name is accepted and becomes the identification in the waste attributes dialog; waste 
attributes appear in the dialog box.. 

This test passes if files can be opened successfully. 
PasslFail Criteria 

' 

WA.9 

This test addresses switching between "Waste," "Active," "Passive" and "Results" windows, SCR 
User Interface Problems, Item 1. The PAN system must be functioning for this test. 

Purpose3 

Input Description 
1) In the new file dialog, enter file name WA-9. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Select matrix type 152 
Enter net weight 6.0. 

Select 55 gallon drum for the container type 

4) Click on Assay. 
5) SelectFull. 
6 )  If a warning about no current background appears, select Yes to continue. 
7) Wait for the assay to complete (this may take several minutes). 
8) Switch between the "Waste," "Active," "Passive" and "Results" windows by clicking 

9) Click on Close (in the "Results" windo*). 
the mouse within any visible part of the target window. 

Expected Results 

PasslFail Criteria 
Any window can be viewed by clicking the mouse within any visible part of the window. 

Test passes if all windows can be viewed by clicking the mouse within any visible part of the 
window. 
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10.6.5 Invalid Test Cases 

WA.10 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.1. This test is 
particularly aimed at testing invalid file names. 

In the new fde dialog, click on OK without selecting (or entering) a file name. 

The new file dialog remains displayed. 

Test passes if the new file dialog remains displayed. 

Input Description 

Expected Results 

PasslFail Criteria 

WA.11 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.l. This test is 
particularly aimed at testing invalid file names. 

In the new file dialog, enter file name *.001. 

The new file dialog remains displayed; the file list is updated to show only files with the suffix 
".001," if any exist. If no files match this criteria, then the list will be empty. 

Test passes if the new file dialog remains cllsplayed as described. 

Input Description 

Expected Results 

PasslFail Criteria 

WA.12 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.l. This test is 
particularly aimed at testing invalid file names. 

In the new file dialog, enter file name ?.001. 

The new file dialog remains displayed; the file list is updated to show only files with a single 
character prefix and the suffix ".001," if any exist. If no files match this criteria, then the list will 
be empty. 

Test passes if the new file dialog remains displayed as described. 

Input Description 

Expected Results 

PasslFail Criteria 
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WA.13 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.1. This test is 
particularly aimed at testing invalid file names. 

In the new file dialog, enter file name (blanks). 

The new file dialog remains displayed. 

Test passes if the new file dialog remains displayed. 

- 

Input Description 

Expected Results 

PasslFail Criteria 

WA.14 
Purpose 

This test addresses setting.the waste’adbutes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.1. This test is 
particularly aimed at testing invalid file names. 

In the new file dialog, enter a file name consisting of more than eight characters. 

“An invalid file name was specified” dialog is displayed. 

Input Description 

Expected Results 

PasslFail Criteria 
Test passes if the error dialog is displayed. 
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WA.15 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.l. This test is 
particularly aimed at testing when there is no net weight value entered. 

1) In the new file dialog, enter the file name WA-15. 
2) ClickonOK. 
3) In the waste attributes dialog, click on Assay. 

Input Description . 

Expected Results 
"Weight must be > 0" dialog is displayed. 

PasslFail Criteria 
Test passes if error dialog is displayed. 

WA.16 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M. 1 and 3.1.4.3 M. 1. This test is 
particularly aimed at testing net weights that are too small. 

1) In the new file dialog, enter file name WA-16. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Input Description 

* Select 55 gallon drum for the container type 
Select matrix type 152 for the matrix type 
Enter net weight 0. 

4) Click on Assay. 
Expected Results 

"Weight must be > 0" dialog is displayed. 
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PasslFail Criteria 
Test passes if error dialog is displayed. 

WA.17 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.l. This test is 
particularly k e d  at testingnegative net weights. 

Input Description 
1) In the new file dialog, enter file name WA-17. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Enter net weight -10. 

Select 55 gallon drum for the container type 
Select matrix type 152 for the matrix type 

4) Click on Assay. 
Expected Results 

"Weight must be > 0" dialog is displayed. 

PasslFail Criteria 
Test passes if error dialog is displayed. 
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WA.18 
Purpose 

This test addresses setting the waste attributes, which include file name, container identification, 
matrix type, and container net weight, requirements 3.1.4.2 M.l and 3.1.4.3 M.l. This test is 
particularly aimed at testhg non-numeric data in the net weight field. 

input Description 
1) In the new file dialog, enter file name WA-18. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Enter net weight $$$.$$. 

Select 55 gallon drum for the container type 
Select matrix type 152 for the matrix type 

4) Click on Assay. 
Expected Results 

"Weight must be > 0" dialog is displayed 

PasslFail Criteria 
Test passes if error dialog is displayed. 
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WA.19 
Purpose 

This test addresses the requirement to input the container information, requirements 3.1.4.2 M.l 
and 3.1.4.3 M.l. This test is particularly aimed at testing net weight values that are too large. 

Input Description 
1) In the new file dialog, enter file name WA-19. 
2) ClickonOK. 
3) In the waste attributes dialog, 

Select 55 gallon drum for the container type 
Select matrix type 152 for the matrix type 
Enter net weight 999999.99. 

4) Click on Continue. 
Expected Results 

"Weight seem excessive" dialog is displayed. 

PasstFail Criteria 
Test passes if warming dialog is displayed. 
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10.7 Toggle Switches 

10.7.1 Introduction and Description 

.. 
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These tests address the options Auto Summary Report, Auto Data Save, and Background 
Correction. 

10.7.2 Special Requirements 

The open file dialog will be visible. The file for this test is located in the .WAC subdirectory of 
the assay system root directory. 

10.73 Procedure Steps 

1) Log in as an operator or physicist, as specified in the test case. 
2) Pull down File menu. 
3) Select Open. 
4) The open file dialog is displayed. 
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10.7.4 Valid Test Cases 

TS.1 
Purpose 

This test addresses the Auto Summary Report and Auto Data Save options, requirements 3.1.3.3 
M.l and M.2. 

Input Description 
1) Log in as an operator. 
2) In the open file dialog, change to the DAC subdirectory and select the file 000496. 
3) Click on OK. 
4) Pull down the Options menu and verifl that Auto Summary Report and Auto Data 

5) In the Waste Attributes dialog, click on Continue. 
6) Active and passive data dialogs will be displayed. Warning messages regarding the 

Save are checked. 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

7) In the results dialog, click on Close. 
Expected Results 

A summary report should be printed automatically. The report identifies date and time of the 
background data acquisition. 

The test passes if the above summary report is printed as described. 
Pasflail Criteria 

TS.2 
Purpose 

Input Description 
This test addresses Auto Summary Report toggling, requirements 3.1.3.3 M. 1 and M.2. 

1) Log in as an operator. 
2) Pull down the Options menu and ensure that Auto Summary Report is toggled off. 
3) In the open file dialog, change to the DAC subdirectory and select the file 000496. 

5) In the Waste Attributes dialog, click on Continue. 
6) Active and passive data dialogs will be displayed. Warning messages regarding the 

I 4) ClickonOK. 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

7) In the results dialog, click on Close. 
Expected Results 

Pasflail Criteria 
No hardcopy summary report should appear. 

Test passes if the summary report is not printed. 
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TS.3 

This test addresses the Auto Summary Report and Background Correction options, requirements 
3.1.3.3 M.l and M.2. 

Purpose 

Input Description 
1) Log in as a physicist. 
2) In the open file dialog, change to the DAC subdirectory and select the file 000496. 
3) ClickonOK. 
4) Pull down the Options menu and verifjl that both Auto Summary Report and 

5 )  In the Waste Attributes dialog, click on Continue. 
6) Active and passive data dialogs will be displayed. Warning messages regarding the 

Background Correction are toggled on. 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

7) In the results dialog, click on Close. 
Ehpeded Results 

A summary report should be printed automatically. The report identifies date and time of the 
background data acquisition. 

The test passes ifthe above summary report is printed as described. 
PasMail Criteria 

TS. 4 
Purpose 

Input Description 
This test addresses Auto Summary Report toggling, requirements 3.1.3.3 M.l and M.2. 

1) Log in as a physicist. 
2) Pull down the Options menu and ensure that Auto Summary Report is toggled OE 
3) In the open file dialog, change to the DAC subdirectory and select the file 000496. 
4) Click on OK. 
5 )  In the Waste Attributes dialog, click on Continue. 
6) Active and passive data dialogs will be displayed. Warning messages regarding the 

. 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

7) In the results dialog, click on Close. 
Ejcpeded Results 

Pasflail Criteria 
No hardcopy summary report should appear. 

Test passes ifthe summary report is not printed. 
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TS. 5 
Purpose 

Input Description 
This test addresses Background Correction toggling, requirements 3.1.3.3 M. 1 and M.2. 

1) Log in as a physicist. 
2) Pull down the Options menu and ensure that Auto Summary Report is toggled on and 

3) In the open file dialog, change to the DAC subdirectory and select the file 000496. 
4) Click on OK. 
5) In the Waste Attributes dialog, click on Continue. 
6)  Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

Background Correction is toggled off. 

7) In the results dialog, click on Close. 
Expected Results 

A summary report should be automatically printed. The report indicates that the background 
correction was not applied. 

The test passes if the summary report is printed as described. 
PasdFail Criteria 

10.7.5 Invalid Test Cases 

None. 
#- 



10.8 Chamber Operation Parameters 
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- 

10.8.1 Introduction and Description 

These tests address the capability to m o m  the active pulse count limits and passive count time 
limits. 

10.8.2 Special Requirements 

The CAMAC crate must be on-line. 

10.83 Procedure Steps 

1) Log in as an operator. 
2) Pull down the Options menu. 
3) If not checked, select Auto Summary Report to toggle on. 
4) Pull down the Options menu and select Assay Times. 
5 )  The chamber operation parameters dialog is displayed. 
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10.8.4 Valid Test Cases 

CP.1 
Purpose 

This test addresses setting the background count time limit, requirements 3.1.3.3 M. 1 and M.2, 
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7. 

Input Description 
In the chamber operation parameters dialog, enter the background count time of 
10 sec. 
Click on OK. 
Pull down the Run menu and select Background. 
Wait until the acquisition is completed normally. 
Press Accept button in the passivebackground data dialog. 
Pull down the File menu and select Print. 
Select the file name BACKGRND from the DAC directoI);. 
Click on OK. 

Expected Results 
The background data file should be printed. The counts from the 10 ErHz clock (port 4, station 11 
for the drum assay chamber) should'be between 100,000 and 102,000 units. 

Test passes if the background data file is printed as described. 
Pasflail Criteria 

CP.2 
Purpose 

This test addresses setting the background count time limit, requirements 3.1.3.3 M. 1 and M.2, 
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7. 

Input Description 
1) In the chamber operation parameters dialog, enter the background count time of 300. 
2) Click on OK. 
3) Pull down the Run menu and select Background. 
4) After the acquisition has started, in the acquisition dialog, click on Cancel. 

Expected Results 

Pasflail Criteria 
The acquisition is canceled and the system returns to the operator menu bar. 

Test passes if the Run menu item is enabled in the menu bar. 

CP.3 
Purpose 

This test addresses setting the background count time limit, requirements 3.1.3.3 M. 1 and M.2, 
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7. 

Input Description 
1) In the chamber operation parameters dialog, enter the background count time of 200. 
2) Click on OK. 
3) Pull down the Run menu and select Background. 
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5) Press Accept button in passive background data dialog. 
6 )  Pull down the File menu and select Print. 
7) Select the file name BACKGRND from the DAC directoxy. 
8) ClickonOK. 

Expected Results 
The background data file should be prihted. The counts from the 10 kHz clock (port 4, station 11 
for the drum assay chamber) should be between 2,000,000 and 2,002,000. 

Test passes if the background data fie is printed as described. 
PusslFail Criteria 

CP.4 
Purpose 

This test addresses setting the active pulse count limit and passive count time limit for verification, 
requirements 3.1.3.3 M.1 and M.2. ~ It also covers acquiring active and passive data, requirements 
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7. 

Input Descriptian 

Enter passive count time for verification of 10 
Enter active pulse count for verification of 100 (this must also be manually entered 

1) In the chamber operation parameters dialog, 

in the neutron generator control panel). * .  

2) ClickonOK. 
3) Select Yes. 
4) ClickonOK. 
5) Pull down the Run menu and select Verification. 
6 )  Wait until both the active and the passive acquisitions are completed normally. 
7) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be dsplayed. Acknowledge any such messages. The results dialog 
will be displayed. 

automatically saved, otherwise, in the results dialog, click on Save. 
8) If the Auto Data Save box is selected in the Options menu the results wiU be 

9) Click on Close. 
10) Pull down the File menu and select Print. 
11) Select the file name 000496 from the DAC directory. 
12) Click on OK. 

Expected Results 
The verification data file should be printed. The counts from the 10 kT3z clock (port 4, station 11 
for the drum assay chamber) should be between 100,000 and 102,000. The counts for the active 
pulse (port 6, station 11 for the drum assay chamber) should be exactly 100. 

Test passes if the verification data file is printed as described. 
PusslFail Criteria 
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CP.5 
Purpose 

This test addresses setting the active pulse count limit and passive count time limit for verification, 
requirements 3.1.3.3 M. 1 and M.2. It also covers acquiring active and passive data, requirements 
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7. 

Input Description 

0 Enter passive count time for verification of 200 
0 Enter active pulse count for verification of 2,000. 

1) In the chamber operation parameters dialog, 

2) Click on OK. 
3) Pull down the Run menu and select Verification. 
4) Wak until both the active and the passive acquisitions are completed normally. 
5 )  Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

automatically saved; otherwise, in the results dialog, click on Save. 
6) Ifthe Auto Data Save box is selected in the Options menu the results will be 

7) Click on Close. 
8) Pull down the File menu and select Print. 
9) Select the file name 000496 fiom the DAC directory. 
10) Click on OK. 

Expected ResuIts 
The verification data file should be printed. The counts fiom the 10 lcHz clock (port 4, station 11 
for the drum assay chamber) should be between 2,000,000 and 2,002,000. The counts for the 
active pulse (port 6, station 11 for the drum assay chamber) should be exactly 2,000. 

Test passes if the verification data file is printed as described. 
PassPail Criteria 

CP. 6 

This test addresses setting the active puke count limit and passive count time limit for production, 
requirements 3.1.3.3 M. 1 and M.2. It also covers acquiring active and passive data, requirements 
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7. 

Purpose 

Input Descriprian 

Enter passive count time for production of 10 
Enter active pulse count for production of 100. 

1) In the chamber operation parameters dialog, 

2) Click on OK. 
3) Click on Yes. 
4) Click on OK. 
5) Pull down the File menu and select New. 
6) In the new file dialog, enter file name CP-6. 
7) Click on OK. 
8) In the waste attributes dialog, 

. 

0 Select 55-gallon drum for the container type 
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1 Select matrix type 152 
. Enter net weight 6.0. 

9) Click on Assay. 
10) Select Full. 
11) Wait until both the active and the passive acquisitions are completed normally. 
12) Active and passive data dialogs will be displayed. Waming messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

automatically saved; otherwise, click on Save. 
13) If the Auto Data Save box 

14) Click on Close. 
15) Pull down the File menu and select Print. 
16) Select file name CP-6.001. 
17) Click on OK. 

selected in the Options menu the results will be 

Expected Resulfs 
The summary report and the production data file should be printed. The counts from the 10 kHz 
clock (port 4, station 11 for the drum assay chamber) should be between 100,000 and 102,000. 
The counts for the active pulse (port 6, station 11 for the drum assay chamber) should be exactly 
100. 

Test passes if the production data file is printed as described. 
PasslFail Criteria 

86 



- 

CP. 7 
Purpose 

This test addresses setting the active pulse count limit and passive count time limit for production, 
requirements 3.1.3.3 M. 1 and M.2, It also covers acquiring active and passive data, requirements 
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7. 

INEL-96/0058 

Input Description 
1) In the chamber operation parameters dialog, 

Enter passive count time for production of 300 
Enter active pulse count for production of 5,000. 

2) Click on OK. 
3) Click on Yes. 
4) ClickonOK. 
5) Pull down the File menu and select New. 
6) In the new file dialog, enter file name CP-7. 
7) Click on OK. 
8) In the waste attributes dialog, 

Select matrix type 152 
Enter net weight 6.0. 

Select %-gallon drum for the container type 

9) Click on Assay. 
10) Select Full. 
11) Wait until both the active and the passive acquisitions are completed normally. 
12) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

automatically saved; otherwise, click on Save. 
13) If the Auto Data Save box is selected ih the Options menu the results will be 

14) Click on Close. 
15) Pull down the File menu and select Print. 
16) Select file name CP-7.001. 
17) Click on OK. 

Expected Results 
The production data file should be printed. The counts from the 10 kHz clock (port 4, station 11 
for the drum assay chamber) should be between 3,000,000 and 3,002,000. The counts for the 
active pulse (port 6, station 11 for the drum assay chamber) should be exactly 5,000. 

Test passes if the production data file is printed as described. 
Pasflail Criteria 
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CP.8 
Purpose 

This test addresses setting the chamber operation parameters . This test is against requirement 
3.1.3.3 M.l. 

Exit from the assay system. Rename the 0PTIONS.DAC file in the DAC subdirectory to 
0PTIONS.BAK. At the conclusion of the this test, rename the 0PTIONS.BAK file to 
0PTIONS.DAC. 

Log in to the assay system as either an operator or physicist. 

"File not found" dialog is displayed, 

Special Requirements 

Input Descnpfion 

Expected Res& 

the "Chamber configuration file(s) not found" dialog is displayed, 

and the "No chamber(s) specified ..." dialog is displayed. 
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PasslFail Criteria 
The test passes if the error dialog is displayed. 

CP.9 
Purpose 

This test addresses setting the background count time to invalid values. This test is against 
requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter background count time 0. 
2) ClickonOK. 

Expected Results 
"Values must be > 0" dialog is displayed. 

PasslFail Criteria 
The test passes if the error dialog is displayed. 

CP.10 
Purpose 

This test addresses setting the background count time to invalid values. This test is against 
requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter background count time -10. 
2) ClickonOK. 

Expected Results 
"Values must be > 0" dialog is displayed. 

PasslFail Criteria 
The test passes if the error dialog is displayed. 
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CP.11 
Purpose 

This test addresses setting the background count time to invalid values. This test is against 
requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter background count time 6,000. 
2) ClickonOK. 

Expected Results 
''Count time@) exceed one hour ...'I warning dialog is displayed. 

Pasflail Criteria . 
The test passes if the error dialog is displayed. 

CP.12 
Purpose 

This test addresses setting the active pulse count for verification to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter active pulse count for 

verification 0. 
2) Click on OK. 

Values must be > 0" dialog is 
Expeded Results 

displayed. 

Pasflail Criteria 
The test passes if the error dialog is displayed. 
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CP.13 
Purpose 

This test addresses setting the active pulse count for verification to invalid values. This test is 
against requirement 3.1.3.3 M.2. . 

Input Description 
1) In the chamber operation parameters dialog, enter active pulse count for 

2) ClickonOK. 
verification -10. 

Q e c t e d  Results 
"Values must be > 0" dialog is displayed. 

Pasflail Criteria 
The test passes if the error dialog is displayed. 

CP.14 
Purpose 

This test addresses setting the active pulse count for verification to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

In the chamber operation parameters dialog, attempt to enter more that six digits in the active 
pulse count for verification field. 

No more than six digits may be entered. 

Test passes if no more than six digits can be entered. 

Input Description 

Expected Results 

Pasflail Criteria 
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CP.15 
Purpose 

This test addresses setting the active pulse count for production to invalid values. This test is 
Input Description. 

Input Description 
1) In the chamber operation parameters dialog, enter active pulse count for production 0. 
2) ClickonOK. 

Expected Results 
"Values must be > 0" dialog is displayed. 

Pasflail Criteria 
The test passes ifthe error dialog is displayed. 

CP. 16 
Purpose 

This test addresses setting the active pulse count for production to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter active pulse count for 

2) Click on OK. 
production -10. 

Expected Results 
"Values must be > 0" dialog is displayed. 

Pasflail Criteria 
The test passes ifthe error dialog is displayed. 
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CP.17 

This test addresses setting the active pulse count for production to values that are too large. This 
test is against requirement 3.1.3.3 M.2. 

In the chamber operation parameters dialog, attempt to enter more that six digits in the active 
pulse count for production field. 

No more than six digits may be entered. 

Test passes if no more than six digits can be entered. 

Purpose 

Input Description 

c 

Zikpected Results 

PasdFail Crireria 

CP.18 
Purpose 

This test addresses setting the passive count time for verification to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter passive count time for 

verification 0. 
2) Click on OK. 

hkpected Results 
"Values must be > 0" dialog is displayed. 

PasdFail Criteria 
The test passes if the error dialog is displayed. 

CP. 19 
Purpose 

This test addresses setting the passive count time for verification to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter passive count time for 

2) Click on OK. 
verification -10. 

Expected Results 
"Values must be > 0" dialog is displayed. 
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Pasflail Criteria 
The test passes ifthe error dialog is displayed. 

CP-20 

This test addresses setting the passive count time for verification to values that are too large. This 
test is against requirement 3.1.3.3 M.2. 

Purpose 

Input Description 
1) In the chamber operation parameters dialog, enter passive count time for 

2) Click on OK. 
verification 9999. 

Expected Results 
''Count time@) exceed one hour . . ." dialog is displayed. 

Pasflail Criteria 
The test passes if the error dialog is displayed. 

CP.21 
Purpose 

This test addresses setting the passive count time for production to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chambei operation parameters dialog, enter passive count time for 

production 0. 
2) Click .on OK. 

Expected Results 
"Values must be > 0" dialog is displayed. 
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Pasflail Criteria 
The test passes if the error dialog is displayed. 

CP.22 
Purpose 

This test addresses setting the passive count time for production to invalid values. This test is 
against requirement 3.1.3.3 M.2. 

Input Description 
1) In the chamber operation parameters dialog, enter passive count time for 

2) Click on OK. 
production -10. 

Ekpected Results 
"Values must be > 0" dialog is displayed. - 

Pasflail Criteria 
The test passes if the error dialog is displayed. 
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10.9 CAMAC Interface 

10.9.1 Introduction and Description 

These tests address whether the CAMAC configuration files are available to SAS and whether the 
CAMAC system is operational. 

10.9.2 Special Requirements 

Auto Summary Report must be enabled. The default processing options, active pulse counts and 
passive count time, must be enabled. The CAMAC crate must be on-line. 

10.9.3 Procedure Steps 

Log in as an operator. 

10.9.4 Valid Test Cases 

CL I 
Purpose 

This test evaluates the SAS interface with the CAMAC system, requirement 3.1.3.4 M.l and SCR 
Requested Enhancements, problem 4. 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name CI-1. 
3) Click on OK. 
4) In the waste attributes dialog, - 

Select 55-gdon drum for the container type 
Select matrix type 152 
Enter net weight 6.0. 

5) Click on Assay. 
6 )  Select Full. 
7) Wait until both the active and the passive acquisitions are completed normally. 
8) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

automatically saved; otherwise, click on Save. 
9) If the Auto Data Save box is selected in the Options menu the results will be 

10) Click on Close. 
1 1) Pull down the File menu and select Print. 
12) In the print file dialog, enter file name CI-1.001. 
13) Click on OK. 
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Expected Results 
A summary report will be automatically printed. The saved file will be printed when the print file 
option is completed. 

The test passes ifa summary report is printed, and ifthe save file is printed and all sections are 
present in the printout. The sections which should be present are: 

Pasflail Criteria 

1) A header section listing file creation date, program ID and file ID. 
2) CHAMBER. 
3) CONTAINER. 

5) PUiMASS-FRACTIONS. 
6) An "Active" data. 
7) A "Passive Gross". 
8) A "Passive Background". 
9) A "Chamber Configuration Parameters". 
10) A "Net Active Count Rates''. 
11) A "Net Passive Count Rates''. 
12) A "Active/Passive Mass Values". 
13) A "Reported Mass Values". 
14) A "Derived Quantities". 
15) A "Calculated Matrix Corrections". 
16) A "Recalculated Mass Values". 

4) MATRIX. 
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10.9.5 Invalid Test Cases 

c1.2 
Purpose 

This test evaluates the SAS interface with CAMAC, when power to the CAMAC is not available, 
requirement 3.1.3.4 M. 1. 

Special Requirements 
Switch off the power to the CAMAC crate. At the conclusion of this test, switch on the power to 
the CAMAC crate. 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name CI-2. 
3) Click on OK. 
4) In the waste attributes dialog, 

Select 55-gdon drum for the container type 
Select matrix type 152 
Enter net weight 6.0. 

5 )  Click on Assay. 
6)  Select Full. 

Expected Resub 
"Check CAMAC crate power . . . I1 dialog is displayed. 

Pasflail Criferia 
The test passes if the error dialog is displayed. 

c1.3 
Purpose 

This test evaluates the SAS interface with the CAMAC system when the CAMAC crate 
configuration file is not available, requirement 3.1.3.4 M. 1. 

Log out from the system. Rename ACTCRATE.DAC in the DAC subdirectory to 
ACTCRATE.BAK. Log in to the system as either an operator or a physicist. At the conclusion 
of this test, log out from the system and rename ACTCRATE.BAK to ACTCRATE.DAC. 

Special Requirements 
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Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name CI-3. 
3) ClickonOK. 
4) In the waste attributes dialog, 

Select 55-gdon drum for the container type 
Select matrix type 152 ' 

Enter net weight 6.0. 
5 )  Click on Assay. 
6) Select Active. 

Expected Results 
"Active CAMAC, crate configuration file not found" dialog is displayed. 

.. .. ..... .h ........ 

PmdFail Criteria 
The test passes ifthe error dialog is displayed. 
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c14 
Purpose 

This test evaluates the SAS interface with the CAMAC system when the CAMAC crate 
configuration file is not available, requirement 3.1.3.4 M. 1. 

Special Requirements 
Log out from the system. Rename PASCRATE.DAC in the DAC subdirectory to 
PASCRATE.BAK. Log in to the system as either an operator or a physicist. At the conclusion 
of this test, log out from the system and rename PASCRATE.BAK to PASCRATE.DAC. 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name CI - 4. 
3) Click on OK. 
4) In the waste attributes dialog, 

Select %-gallon drum for the container type 
Select matrix type 152 

0 Enter net weight 6.0. 
5) Click on Assay. 
6 )  Select Passive. 

Expected Results 
"Passive CAMAC crate configuration file not found" dialog is displayed. 

Pasflail Criteria 
The test passes if the error dialog is displayed. 
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c1.5 
Purpose 

This test evaluates the SAS interface with the CAMAC system when the controller is not 
available, requirement 3.1.3.4 M. 1 

The CAMAC crate power must be on. The configuration files ACTCRATE.DAC and 
PASCRATE.DAC must be available. The GPIB controller cable connection fiom the PC to the 
CAMAC crate must be disconnected. 

Special Requirements 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name CI-5. 
3) Click'on OK. 
4) In the waste attributes dialog, 

Select 55-gdon drum for the container type 
Select matrix type 152 
Enter net weight 6.0. 

5) Click on Assay. 
6)  Select Full. 

Expected Results 
"Check CAMAC crate power ...'I dialog is displayed. 

Pasflail Criteria 
The test passes ifthe error dialog is displayed. 
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10.10 Time and Date of Data Acquisition - I  

10.10.1 Introduction and Description 

These tests address the time and date for the active and passive data acquisition. 

10.10.2 Special Requirements 

The CAMAC crate must be on-line. Auto Summary Report must be enabled. 

10.10.3 Procedure Steps 

Log in as an operator. 

10.10.4 Valid Test Cases 

TDDA.1 

This test addresses the acquisition of active data, time and date of the acquisition, and storing the 
active data on file, as specified by requirement 3.1.3.4 M.2,3.1.4.2 M.4, and 3.1.4.3 M.27. 

Purpose 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name TDDA-1. 
3) Click on OK. 
4) In the waste attributes dialog, 

Select 55-gallon drum for the container type 
Select matrix type 152 
Enter net weight 6.0. 

5) Click on Assay. 
6)  Select Active. 
7) Using the "clock" window in the lower right-hand corner of the screen, note time in 

8) Wait until the acquisition is completed normally. 
9) Select File menu, then click on Save. 
10) Click on Close. 
11) Pull down the File menu and select Print. 
12) In the print file dialog, enter file name TDDA-1.001. 
13) Click on OK. 

hours, minutes, and seconds when Active was selected. 

Expected Results 
The summary report for TDDA-1 will be printed. The time of active data acquisition on the 
report should be within 10 seconds of the noted computer clock time. The saved file will be 
printed when the print file option is completed. 
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Pasflail Criteria 
The test passes ifa summary report is printed, and ifthe save file is printed and all sections are 
present in the printout. 

lDDA.2 
Purpose 

This test addresses the acquisition of passive data, time and date of the acquisition, and storing 
the passive data on file, as specified by requirement 3.1.3.4 M.2, 3.1.4.2 M.4, and 3.1.4.3 M.27. 

Input Description 
1) Pull down the File menu and select New. 
2) In the new file dialog, enter file name TDDA-2. 
3) CliGkonOK. 
4) In the waste attributes dialog, 

Select 55 gallon drum for the container type 
Select matrix type 152 
Enter net weight 6.0. 

5) Click on Assay. 
6) Select Passive. 
7) Using the "clock" window in t le  lower right-hand corner of the screen, note time in 

hours, minutes, and seconds when Passive was selected. 
8) Wait until the acquisition is completed normally. 
9) Select File menu, then click on Save. 
10) Click on Close. 
11) Select File menu, select Print, then enter TDDA-2.001. 

Ekpeded Results 
The summary report for TDDA-2 will be printed. The time of passive data acquisition on the 
report should be within 10 seconds of the noted computer clock time. 

This test passes ifthe summary report appears as indicated. 
Pasflail Criteria 

10.10.5 Invalid Test Cases 

None. 
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10.11 Passive Signals 

10.11.1 Introduction and Description 

These tests address the calculation of the passive shielded total, system total, system coincidence, 
and shielded coincidence rates and errors. 

10.11.2 Special Requirements 

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located 
in the .U>AC\TEST subdirectory of the assay system root directory. 

10.11.3 Procedure Steps 

Log in as an operator or physicist, as specified. 

10.11.4 Valid Test Cases 

m. 1 

This test addresses passive data acquisition and reduction, requirements 3.1.3.4 M.8, and 3.1.3.6 
M. 1 through M.8, and SCR Technical Problems, Item 5.  

Purpose 

Input Description 
1) Login as an operator. 
2) Pull down the File menu and select Open. 
3) In the open file dialog, select the file name PS.001. 
4) Click on OK. 
5 )  In the waste attributes dialog, click on Continue. 
6) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

the values given below. 
7) In the results dialog, click on Close after evaluating ifthe responses are different from 

8) Pull down the File menu and select Print, then select the file name PS.001. 
Expected Results 

A warning about too large a variation in side detector counts will appear, and the offending data 
field in the "Passive Data" window will be highlighted. The values from hand calculations, using 
the formulas provided in the SRS [2], are shown below. These values must be independently 
verified. 

Shielded total net rate = 9.14 f 0.22 countshec 
System total net rate = 37.81 f 0.49 countshec 
Shielded coincidence net rate = 0.10 f 0.024 countshec 
System coincidence net rate = 2.01 f 0.11 countshec 
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.A<... . m; Passive Data .A. ..... 
.E.:l 

Pasflail Crireria 
The test passes ifthe expected results are attained. 

10.11.5 Invalid Test Cases 

PS.2 

This test addresses the handling of invalid passive assay data values, requirements 3.1.3.4 M. 8 and 
3.1.3.6 M.l throughM.8 

Purpose 

Input Description 
1) Login as an operator. 
2) Pull down the File menu and select Open. 
3) In the open file dialog, select the file name PS.002. 
4) Click on OK. 
5 )  In the Waste Attributes dialog, click on Continue. 
6) Pull down the File menu and select Close. 

Expected Results 
"Incomplete Data" dialog is displayed. 
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Pasflail Criteria 
This test passes if the informational dialog is displayed. 

PS.3 
Purpose 

This test addresses the handling of invalid passive data values, requirements 3.1.3.4 M.8 and 
3.1.3.6 M.l through M.8. 

Input Description 
1) Login as a physicist. 
2) Pull down the File menu and select Open. 
3) In the open file dialog, select the file name PS.003. 
4) Click on OK. 
5) In the Waste Attributes dialog, click on Edit. 
6) Select "Use current Chamber & Matrix data." 
7) Change the matrix type to 300. 
8) In the Waste Attributes dialog, click on Continue. 
9) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 

10) In the results dialog, click on Close after evaluating the response. Do not save data. 
hkpected Results 

"Assay results may be.. .'I dialog is displayed. 

Pasflail Criteria 
This test passes if the warning dialog is displayed. 
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m.4 
Purpose 

This test addresses the handling of invalid passive assay data values, requirements 3.1.3.4 M.8 and 
3.1.3.6 M.l throughM.8. 

Input Description 

7) 

Login as an operator. 
Pull down the File menu and select Open. 
In the open file dialog, select the file name PS.004. 
Click on OK. 
In the Waste Attributes dialog, click on Continue. 
Active and passive data dialogs will be displayed. Warning messages regarding the 
counts may also be displayed. Acknowledge any such messages. The results dialog will 
be displayed. 
In the results dialog, click on Close after evaluating the response. 

Expected Results 
"Rate < 0" dialog is displayed. 

Pasflail Criteria 
This test passes if the informational dialog is displayed. 
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10.12 Active Signals 

10.12.1 Introduction and Description 

These tests address the calculation of active flux monitor, barrel flux monitor, and shielded total 
rates and errors. 

10.12.2 Special Requirements 

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located 
in the .DAC\TEST subdirectory of the assay system root directory. 

10.12.3 Procedure Steps 

Login as an operator. 
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10.12.4 Valid Test Cases 

AS.1 
Purpose 

This test addresses active assay data acquisition and reduction, requirements 3.1.3.4 M.5 and 
3.1.3.5 M. 1 through M.6, and SCR Technical Problems, Item 5. 

Input Description 
Pull down the File menu and select Open. 
In the open file dialog, select the file name AS.OO1. 
Click on OK. 
In the. Waste Attributes dialog, click on Continue. 
Active and passive data dialogs will be displayed. Warning messages regarding the 
counts may also be displayed. Acknowledge any such messages. The results dialog Will 
be displayed. 
In the results dialog, click on Close after evaluating the response per active data box 
shown below. 

w e d e d  Results 
The values from hand calculations, using the formulas provided in the SRS [2], are shown below. 
These values must be independently verified. 

Shielded total net rate = 461.25 f 1 1 .OO counts/sec 
Flux monitor net rate = 5795.05 f 38.07 counts/sec 
Barrel flux monitor net rate = 5794.45 f 38.07counts/sec 

The active data dialog displays the rates. 

Pasflail Criteria 
The test passes if the expected results are attained, and the proper number of significant figures 
are displayed. 

110 



INEL-96/0058 

10.12.5 Invalid Test Cases 

AS.2 
Purpose 

This test addresses the handling of invalid active assay data values, requirements 3.1.3.4 M.5 and 
3.1.3.5 M.l throughM.6 

Input Description 
Puli down the File menu and select Open. 
In the open file dialog, select the file name AS.002. 
Click on OK. 
In the Waste Attributes dialog, click on Continue. 
Active and passive data dialogs will be displayed. Warning messages regarding the 
counts should also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 
In the results dialog, click on Close after evaluating the response. 

Expected Results 
"Very low counts ..." dialog is displayed. 

"Assay results may be invalid!" dialog is displayed. 

Pasflail Criteria 
This test passes if the warning dialogs are displayed. 
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AX3 

This test addresses the handling of invalid active assay data values, requirements 3.1.3.4 M.5 and 
3.1.3.5 M.1 throughM.6 

Purpose 

Input Description 
1) Pull down the File menu and select Open. 
2) In the Open File dialog, select the file name AS.003. 
3) ClickonOK. 
4) In the Waste Attributes dialog, click on Continue. 
5) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts should also be displayed. Acknowledge any such messages. The results dialog 
will be displayed. 

6) In the results dialog, click on Close after evaluating the response. 
Expected Results 

"Very low counts.. ." dialog is displayed. 

"Assay results may be invalid!" dialog is displayed. 

Pasflail Criteria 
This test passes if the warning dialogs are displayed. 
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10.13 Data Reduction 

10.13.1 Introduction and Description 

These tests address the computation of active Plutonium mass, active Plutonium mass error, 
passive Plutonium mass, passive Plutonium mass error, Americium mass, Americium mass error, 
thermal power, thermal power error, thermal power density, thermal power density error, total 
alpha activity, total alpha activity error, activity concentration error, selection of the total 
Plutonium mass and error, individual plutonium isotopic masses (238,239,240 and 241), the 
mass of ='U when its presence is indicated by gamma ray measurement results, TRU activity, 
TRU activity concentration, total activity, plutonium equivalent curies, and fissile gram 
equivalent. These tests will also test the assay recalculation fiom existing signal data and the 
production of the measurement summary. 

10.13.2 Special Requirements 

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located 
in the .\DAC\TEST subdirectory of the assay system root directory. Open the file AS.INI located 
in the root directory of the assay system root directory and v e m  that "NE~2-CONVERSION" 
is set to "OFF". 

10.13.3 Procedure Steps 

Login as an operator. 
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10.13.4 Valid Test Cases 

DRI 
Purpose 

This test addresses computation of Plutonium and Americium masses, thermal power, thermal 
power density, total alpha activity, activity concentration, and the associated errors. This test 
addresses the requirements 3.1.4.3 M.5 through M. 12 and M. 15 through M.26. 

Input Description 
1) Pull down the File menu and select Open. 
2) In the Open File dialog, select the file name DR.001. 
3) ClickonOK. 
4) In the Waste Attributes dialog, click on Continue. 
5) Active and passive data dialogs will be displayed. Warning messages regarding the 

counts may also be displayed. Acknowledge any such messages. The Results dialog 
will be displayed. 

6) In the Eesults dialog, click on Close after evaluating the response. 
Expected Results 

The values from hand calculations, using the formulas provided in the SRS [2], are shown below. 
These values must be independently verified. 

Total Plutonium mass: (0.341 1 f 0.0086) g 
Pu-238 mass: (4.093 f 0.103)E-5 g 
Pu-239 mass: (0.3201 f 0.0081) g 
Pu-240 mass: (0.01985 f 0.00050) g 
Pu-241 mass: (1.160 f 0.029)E-3 g 
Am-241 mass: (4.833 f 0.138)E-3 g 
Thermal power: (1.354 f 0.026)E-3 Watts 
Thermal power density: (1.842 k 0.035)E-4 Watts/ft3 
Total activity: (0.1628 f 0.0037) Ci 
Alpha activity: (0.04218 f 0.00080) Ci 
TRU activity:. (0.04218 f 0.00080) Ci 
TRU activity concentration: (4.218 f O.O8O)E+5 nCi/g 
Plutonium Equivalent Curies: (0.0421 1 f 0.00080) Ci 
Fissile Gram Equivalent: (0.3232 f 0.0082) g 

The summary report is printed and the results dialog displays the values. 
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PasdFail Criteria 
The test passes if the computed values agree with the hand calculations to two significant decimal 
digits. 

DR2 
Purpose 

This test addresses computation of Plutonium and Americium masses, thermal power, thermal 
power density, total alpha activity, activity concentration, and the associated errors. This test 
addresses the requirements 3.1.4.3 M.5 through M. 12 and M.15 through M.26. 

Input Description 
Login as a physicist. 
Pull down the File menu and select Open. 
In the Open File dialog, select the file name DR.002. 
Click on OK. 
In the Waste Attributes dialog, click on Edit. 
Select "Use Current Chamber & Matrix data." 
Select matrix type 300. 
Select Continue. 
Active and passive data dialogs will be displayed. Warning messages regarding the 
counts may also be displayed. Acknowledge any such messages. The Results Dialog 
will be displayed. 

10) In the Results Dialog, click on Close after evaluating the response. Do not save data. 

The values from hand calculations, using the formulas provided in the SRS [2], are shown below. 
These values must be independently verified. 

Ejpected Results 

0 
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Total Plutonium mass: (3 207 f 0.180) g 
Pu-238 mass: (4.8 f 2.6)E-4 g 
Pu-239 mass: (3.013 f 0.169) g 
Pu-240 mass: (0.1883 f 0.103) g 
Pu-241 mass: (4.49 f 1.94) E-3 g 
Am-241 mass: (4.49 f 1.94) E-3 g 
Thermal power: (8.03 f 0.50) E-3 Watts 
Thermal power density: (1.093 +_ 0.068)E-3 Watts/ft3 
Total activity: (0.72 f 0.20) Ci 
Alpha activity: (0.2567 f 0.0157) Ci 
TRU activity: (0.2567 f 0.0157) Ci 
TRU adivity concentration: (2.567 f 0.157)E+6 nCi/g 
Pu Equivalent Curies: (0.2559 f 0.0156) Ci 
Fissile Gram Equivalent: (3.027 f 0.170) g 

The summary report is printed and the results dialog displays the values. 

Pasflail Criteria 
The test passes ifthe computed values agree with the hand calculations to two sigruficant decimal 
digits. 

Important Note 
This test uses current matrix, calibration, and mass fiaction data rather than the values stored in 
the data file DR.002. The assay results may therefore not agree with the values shown above, but 
must agree with the hand calculated values. 
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10.14 Chi-square 

10.14.1 Introduction and Description 

These tests address the function to compute chi-square statistics, requirement 3.1.3.3 M.4. 

10.14.2 Special Requirements 

The CAMAC crate must be on-line. The Pink D m  must be in the drum assay chamber. 

10.143 Procedure Steps 

Log in as an operator. 

10.14.4 Valid Test Cases 

CS.1 
Purpose 

Input Description 
This test addresses the function to compute chi-square statistics, requirement 3.1.3.3 M.4. 

1) Pull down the Run menu. 
2) Select Chi-square. 
3) The following notice is displayed. 

4) ClickonOK. 
5 )  Wait until the specified number of passive acquisitions are completed normally. The 

following dialog will be duplayed. Click on OK. (The values shown in this dialog box 
are sample values only - numbers in actual tests may be different.) 
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Expected Results 
The "Chi-square Results",window will appear and the chi-square report will be printed 
automatically. 

PasslFail Crileria 
The test passes if the "Chi-square Results" window appears and the report is printed. 

10.14.5 Invalid Test Cases 

cs.2 
Purpose 

This test addresses the function to compute Chi-square statistics, requirement 3.1.3.3 M.4. 
Special Requirements 

Rename the file CHISQ.DAC in the DAC subdirectory to CHISQ.BAK. At the conclusion of the 
test, rename the file CHISQ.BAK to CHISQ-DAC. 

Input Description 
1) Pull down the Run menu. 
2) Select Chi-square. 

Expected Results 
"File not found'' dialog is displayed. 

and then the "Chi-square parameters not found!" dialog is displayed. 
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10.15 DMS Interface 

10.15.1 Introduction and Description 

These tests address the SAS interface with the DMS computer. Specifically, these tests address 
DMS requesting an assay or recalculation, SAS acknowledging receipt of DMS data, SAS 
performing the requested fbnction and transmitting measurement results to the DMS computer, 
and SAS receiving an acknowledgment fiom the DMS computer. 

10.15.2 Special Requirements 

The CAMAC must be on-line. One of the SWEPP operations personnel must login to the DMS 
system. 

10.15.3 Procedure Steps 

Login as an operator. 
Pull down the Run menu. 
Select Remote. 
The Remote Operation dialog is displayed. 
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DMS. 1 

This test addiesses the SAS receiving a request from the DMS to perform an assay, requirements 
3.1.5.2 M.1, M.2, M.3, and M.4. 

Ifthe network link between the SAS PC and SGRS Workstation is operating, check for the 
existence of a file named TESTO1.GAM on the Workstation logical device PAN$RATIOS. If. 
this file exists, rename or delete it (note that multiple versions of the same file can exist on the 
SGRS Workstation). Gamma ratios files are located on the SGRS logical device PAN$RATIOS. 

Purpose 

Special Requirements 

Input Description 

1) Have the SWEPP operator place a drum in the assay chamber. Any drum containing 

2) Ensure that the Remote Dialog window is displayed on the SAS computer screen (see 

3) Have the SWEPP operator request a new assay via the DMS system using the 

some fissile material including the “Pink Drum” can be used for this test. 

10.15.3). 

following: 
Container ID: TESTOl 
Content Code: 000 
Bar Code: TEST01 
Gross Weight: 100 

Expected Results 
SAS will display a status message in the Remote Dialog window indicating receipt of an assay 
request, acknowledgment of the request, and initiation of processing. The Waste Attributes 
window will be displayed showing the Container ID (TESTOl), Content Code (matrix type 000) 
and Net Weight2 received from the DMS, with the title bar showing TEST01 as the file name. 
Active and passive data acquisition and data analysis will be performed automatically. At the 
completion of data acquisition and analysis, the Results window will be displayed, a summary 
report printed and the assay results will be automatically transmitted to the DMS (the status line 
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data 
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS 
terminal will display selected assay quantities. The values displayed should agree with the 
corresponding quantities shown in the SAS Results window and on the SAS summary report. 

The test passes ifthe derived quantity values displayed on the operator’s DMS terminal agree with 
the derived values in the printed summary report to the minimum precision printed or displayed. 

Pasflail Criteria 

The net weight should be approximately 25kg less than the gross weight; check DMS screen for actual value. 
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DMS.2 
Purpose 

This test addresses the SAS receiving a request fiom DMS to perform a recalculation, 
requirements3.1.5.2M.l,M.2,M.3, andM.5. 

Special Requirements 
Ifthe network link between the SAS PC and SGRS Workstation is operating, check for the 
existence of a file named TESTO1.GAM on the Workstation logical device PAN$RATIOS. If 
this file exists, rename or delete it (note that multiple versions of the same file can exist on the 
SGRS Workstation). Gamma ratios files are located on the SGRS logical device PAN$RATIOS. 

Have the operator request a recalculation for drum TESTOl through the DMS system. 

SAS will display a status message in the Remote Dialog window indicating receipt of an assay 
request, acknowledgment of the request, and initiation of processing. The Waste Attributes 
window will be displayed showing the Container ID (TESTOl), Content Code (matrix type 000) 
and Net Weight received from the DMS, with the title bar showing TEST01 as the file name. 
Active and passive data acquisition and data analysis will be performed automatically. At the 
completion of data acquisition and analysis, the Results window will be displayed, a summary 
report printed and the assay results will be automatically transmitted to the DMS (the status line 
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data 
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS 
terminal will display selected assay quantities. The values displayed should agree with the 
corresponding quantities shown in the SAS Results window and on the SAS summary report. 

The test passes ifthe values shown in the SAS summary report and displayed-on the DMS 
terminal agree with the values obtained during the initial assay of drum TEST01 (test DMS.1) 
within the precision printed or displayed. 

Input Description 

Expected ResurtS 

Pasflail Criteria 

DMS.3 
Purpose 

This test addresses the SAS receiving a request fiom the DMS to perform a recalculation, 
requirement 3.1.5.2 M.l, M.2, M.3 and M.5. Further, this test verifies that the SAS will use 
current matrix, calibration and SGRS data during a remote recalculation (Process 4 under 3.1.5.2 
M.5), a new requirement added for SAS Version 2.0. 

The SGRS Workstation must be operating, the network link to the SAS PC must be fbnctional 
and the Pathworks network software must be running on the SAS PC. This test can be delayed 
until after test VM.5 has been performed, if desired. 

Special Requirements 

Input Description 

1) Have someone familiar with the SGRS Workstation make a copy of a gamma ratios 
file. The file to be copied must contain a non-zero value for the Am241/Pu239 ratio 
and preferably a non-zero value for the U235Du239 mass ratio. (The file created 
during test VM.5 can be copied for this test.) Name the copy TESTO1.GAM. 
Gamma ratios files are located on the SGRS logical device PAN$RATIOS. 
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2) Have the SWEPP operator (or someone with sufficient DMS privileges to change data 
values) make the following changes to drum TEST01 data values on the DMS system: 

Content Code: change fiom 000 to 007 
Gross Weight: change from 100 to 250 

3) Have the SWEPP operator request a recalculation for drum TESTOl via the DMS 
system. 

Expected Results 
SAS will display a status message in the Remote Dialog window indicating receipt of an assay 
request, acknowledgment of the request, and initiation of processing. The Waste Attributes 
window will be displayed showing the Container ID (TESTOl), Content Code (matrix type 007) 
and Net Weight received fiom the DMS, with the title bar showing TESTOl as the file name. 
Active and passive data acquisition and data analysis will be performed automatically. At the 
completion of data acquisition and analysis, the Results window will be displayed, a summary 
report printed and the assay results will be automatically transmitted .to the DMS (the status line 
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data 
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS 
terminal will display selected assay quantities. The values displayed should agree with the 
corresponding quantities shown in the SAS Results window and on the SAS summary report. 

1) The SAS summary report must list the Matrix Type as 007 and Net Weight as approximately 

2) The summary report must have a note indicating that the Am-241 mass was determined using 

3) Ifthe file TESTO1.GAM contains a non-zero value for the U235/Pu239 mass ratio, then the 

4) The values shown in the SAS summary report Ad displayed on the DMS terminal must agree 

Pasflail Criteria 

225 kg (actual value must agree with that shown on the DMS screen). 

either “Pu-239 Mass Ratio” or “U-235 Mass Ratio” information. 

SAS summary report must show a U-235 mass value. 

within the precision displayed or printed. 
final Note 

Aftertests DMS. 1 through DMS.3 have been completed successfully, have someone with 
“delete” privilege (SWPP Certification Specialist or DMS System Administrator) delete the data 
for drum TEST01 fiom the DMS system. 

10.15.5 Invalid Test Cases 

There are no invalid test cases. DMS performs its own time-out functions, e.g., ifthe RS-232 
cable is disconnected between the DMS and SAS. 

1 
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10.16 Version 2.0 Modifications 

10.16.1 Introduction and Description 

These tests address the operational performance of the modifications made in Version 2.0 of the 
SAS software. 

10.16.2 Special Requirements 

None. 

10.16.3 Procedure Steps 

Login as an operator or physicist, as indicated in the test case. 

10.16.4 Valid Test Cases 

Purpose 
This test addresses the performance of the SAS when a corrupted data file is read, addressing 
SCR Operational Problems, Item 3. 

Input Description 
1) Login as an operator. 
2) Pull down the File menu. 
3) Select Open. 
4) In the Open File Dialog, enter file name VM.001. 
5) Click on OK. 
6)  Click on Continue. 
7) Click on OK. 
8) Click on OK. 

Eypected Results 
"Incomplete Data" dialog is displayed. 
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Pasflail Criteria 
The test passes ifthe warning messages are displayed. 

m.2 
Purpose 

This test addresses the status of background data when a passive-only assay is performed, or if 
"Background Correction" is turned 0% addressing SCR Operational Problems, Item 4. 

Input Description 
1) Login as an operator. 
2) Pull down the File menu. 
3) Select New. 
4) In the New File Dialog, enter file name W-2. 
5) ClickonOK. 
6)  In the Waste Attributes dialog, 

Select matrix type 001 
Enter net weight 6.0. 

Select 55-gallon drum for the container type 

7) Click on Assay. 
8) Select Passive. 
9) After the assay is completed, pull down the File menu. 
10) Click on Save. 
1 1) Pull down the File menu. 
12) Select Print. 
13)In the print file dialog, enter file name W-2.001. 
14) Click on OK. 

Ejpeded Results 

Pasflail Criteria 
The program should save the passive background data in the file, and this file will be printed. 

The test passes if passive background data are present in the printed copy of the file in a section 
labeled "Passive Background. 'I 
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m.3 
Purpose 

This test addresses the notification of missing passive background data during a recalculation, 
addressing SCR Operational Problems, Item 5. 

Input Description 
Login as an operator. 
Pull down the File menu. 
Select Open. 
In the Open File Dialog, enter file name VM.003. 
Click on No in the message window. 
Click on Continue. 
Click on OK. 
Click on Close. 

hkpected Results 
"No background data.. .'I dialog is displayed. 

Pasflail Criteria 
The test passes if a warning message is displayed. 

m.4 
Purpose 

This test addresses the window size, placement and color information, addressing SCR User 
Interface.Problems, Item 9. 

Input Description 
1) Login as an operator. 
2) Pull down the Options menu. 
3) Select Color. 
4) Select the desired color. 
5) Click on OK. 
6)  Resize and reposition one or more windows. 
7) Logout and exit the program completely. 
8) Restart SAS, and log in as an operator. 

Expected Results 
The window sizes, positions, and background colors should be the same when the user logs back 
in. 
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Pasflail Criteria 
The test passes ifthe window sizes, positions, and background colors are the same after logging 
in the second time as when they were set initially. 

w.5 
Purpose 

This test addresses the ability of a Physicist to reanalyze saved data with new parameters, 
requirements 3.1.2.2 M.2,3.1.4.3 M.13 and M.14. 

Input Description 

' 9) 

Place a drum containing plutonium, 241Am, akd 235U in the assay chamber. 
Login as an operator. 
Pull down the File menu. 
Select New. 
The New File Dialog is displayed. 
Enter file name VM-5. 
Click on OK. 
In the Waste Attributes dialog, 

Select matrix type 001 
Enter net weight 1.0. 

Click on Assay. 

Select 55 gallon drum for the container type 

10) Select Full. 
1 1) After the assay has completed, click on Save (unless file was saved automatically). 
12) Click on Close. 
13) Log out. 

Make an SGRS measurement on the same drum using the same file name (VM-5).  
Log into SAS as a physicist. 
Pull down the File menu. 
Select Open. 
Enter file name VM-5. 
Click on OK. 
In the Waste Attributes Dialog, click on Edit. 
Select "Use current Chamber & Matrix data." 
Click on Continue. 

Make an SGRS measurement on the same drum using the same file name (VM-5). 
Login as a physicist. 
Pull down the File menu. 
Select Open. 
Enter file name VM-5. 
ClickonOK. . 
Click on Continue. 
Wait until the assay is complete, then click on Save. 
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Expected Results 
Part I: 
Expected results not included. Results/values were independently verified. 
Part 11: 
The assay report should now show a u5U mass and reflect the fact that mass ratio values were 
used for %lAm determination. Results/values were independently verified. 
Part 111: 
All values printed on the summary report must agree with the values on the summary report 
generated in Part II. 

The test passes if the results from Part II are verified by "independent calculation,," and ifthe 
summary repoh fiom Parts 11 and 111 agree. 

Pass/Fail Criteria 

W. 6 
Purpose 

Input Description 
This test addresses the integrity of the background data, SCR Technical Problems, Item 3. 

1) Place the "Pink Drum" in the assay chamber. 
2) Login as an operator. 
3) Pull down the Options menu. 
4) Select Assay Times. 
5) Set Background Count Time to 100. 
6)  Pull down the Run menu. 
7) Select Background. 
8) At the conclusion of the run, a warning message will be displayed and the "Passive 

Background Data" window will be shown with bad data rates highlighted. Click on 
OK. 

9) Select Reject in the "Passive Background Data" window. 
10) Click on OK. 

Expected Results 
The Passive Background Data dialog should display a warning message, with bad data rates 
highlighted. 
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Pasflail Criteria 
The test passes ifthe warning message is displayed and the "Passive Background Data" window 
will be shown with bad data rates highlighted. 

m. 7 
Purpose 

This test addresses closing the "Waste Description" window after an assay is aborted, SCR User 
Interface Problems, Item 7. 

Input Descripfion 
1) Login as a physicist. 
2) Pull down the File menu. 
3) Select New. 
4) In the new file dialog, enter file name VM-7. 
5) ClickonOK. 
6)  In the Waste Attributes dialog, 

Select matrix type 152 
Enter net weight 6.0. 

Select 55-gallon drum for the container type 

7) Click on Assay. 
8) When the assay starts, click on Cancel in the "Active Da.3 Acquisition" status window. 
9) Click on Yes in the "Confirmation Window." 
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10) Click on Close. 
Ejcpected Results 

The Close buttons in the Waste Attributes window and the File pull-down menu are active after 
the assay is aborted. 

The test passes if the Close buttons are active after the assay is aborted. 
Pasflail Criteria 

W. 8 
Purpose 

This test addresses the addition of "keyboard accelerators" for the most commonly, used menu 
options, SCR User Interface Problems, Item 5.  

Input Descridfion 
1) Loginas operator. 
2) Pull down the File menu. 
3) View the listed keyboard accelerator functions. 
4) Exit the window and press Ctrl+N, for "New Assay." 
5 )  Select Cancel. 
6) Press Ctrl+O for "Open." 
7) Select Cancel. 
8) Press Ctrl+E for "Exit." 
9) SelectNo. 
10) Pull down the Run menu. 
1 1) View the listed keyboard accelerator functions. 
12) Exit the window and press Ctrl+N, for "New Assay." 
13) Select Cancel. 
14) Press Ctrl+R, for "Remote." 
15) Select Exit Remote. 
16) Pull down the Help menu. 
17) View the listed keyboard accelerator function. 
18)Exit the window and press the F1 key, for "Abort." 
19) Select Acknowledge. 

hkpected Results 
Accelerator keys are shown on the described menus and produce the expected results when 
entered from the keyboard. 

Accelerator keys can be used to activate the described menu functions. 
Pasflail Criteria 

10.16.5 Invalid Test Cases 

There are no invalid test cases. 
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11. REQUIREMENTS TRACEABILITY 

The requirements traceability matrix in Table 7 identifies the requirement name and 
paragraph number fiom the Software Requirements Specification (SRS), Reference [2], the object 
where the requirement is designed and coded, and the test case that tests the requirement. The last 
column shows that each test passed the criteria specified in the test procedure, section 10. 

Table 7. Requirements traceability matrix. 

SRS or Requirement SDD / code Testcase Pass 
RWMC SCR Fail 

13623 
3.1.2.2 M.l 

3.1.2.2 M.2 

Login users 

Present user menu functions 

login-dlg, user, 
user-list, main-wnd 
main-wnd 

UA. 1,3,5,8,9 Pass 

UA.1,3,5, 
AF. 1, 
vM.5 
UA.2,4,6 
AF.2 - 22 

Pass 

3.1.2.2 M.3 
3.1.2;2 M.4 

Logout users 
Allow administrator to modify user list 

main-wnd 
users-dlg, user, 
user-list, main-wnd 
main-wnd, 
chamber-wnd 
chamber-wnd, . 

chamber-wnd, 
options-dlg 

options-dlg 

Pass 
Pass 

3.1.3.2 M.l Read default processing options for assay 
system 
Read default chamber processing options 

all Pass 

3.1.3.3 M.l TS.1- 5, 
CP.1- 8 
TS.1- 5, 
CP.l- 7,9 - 23 
cc.1- 5 

Pass 

3.1.3.3 M.2 Allow an operator or physicist to modify the 
processing options 

Pass 

3.1.3.3 M.3 Allow physicist to modify the chamber 
calibration 
Perform Chi-square test 
Read CAMAC crate contigumtion from file 
Get time and date of data acquisition 

calibration-dlg, 
chamber-wnd 
chamber-wnd 
camac-crate 
chamber-wnd, 
system-time, 
camac-crate 

Pass 

3.1.3.3 M.4 
3.1.3.4M.1 
3.1.3.4 M 2  

CS.1 - 2 
CI.1 - 5 
TDDA. 1,2 

Pass 
Pass 
Pass 

3.1.3.4 M.3 Acquire active data from assay chamber 

Store active data on file 

Read active data from file 

Acquire passive data from assay chamber 

Store passive data on file 

Read passive data from file 

Pass chamber, camac-crate, 
acquire-dlg 
chamber-wnd, 
camac-crate 
chamber-wnd, 
camac-crate 
chamber, camac-crate, 
acquire-dlg 
chamber-wnd, 
camac-crate 
chamber-wnd, 
camac-crate 

CP.4 - 7 

3.1.3.4 M.4 

3.1.3.4 M.5 

3.1.3.4 M.6 

3.1.3.4 M.7 

3.1.3.4 M.8 

CP.4 - 7 

AS.1- 3 

CP.1 - 7  

CP.1 - 7 

Pass 

Pass 

Pass 

Pass 

PS.1 - 4 Pass 
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Table 7. Requirements traceability matrix (cont'd). 

SRS Requirement SDD / code Test case Pass 
Fail 

-- - 

3.1.3.5 M.l 

3.1.3.5 M.2 

* 3.1.3.5M.3 

3.1.3.5 M.4 

3.1.3.5 M.5 

3.1.3.5 M.6 

3.1.3.6 M.l 
3.1.3.6 M.2 
3.1.3.6 M.3 
3.1.3.6 M.4 

3.1.3.6 M.5 
3.1.3.6 M.6 
3.1.3.6 M.7 
3.1.3.6 M.8 
3.1.4.2 M.l 

3.1.4.2 M.2 

3.1.4.2 M.3 

3.1.4.2 M.4 

3.1.4.2 M.5 

3.1.4.3 M.l 

3.1.4.3 M.2 
3.1.4.3 M.3 

3.1.4.3 M.4 

Compute flux monitor gross, background, 
and net rates 
Compute flux monitor gross, background, 
and net rate errors 
Compute barrel flux monitor gross, 
background, and net rates 
Compute barrel flux monitor gross, 
background, and net rate errors 
Compute shielded total gross, background, 
and net rates 
Compute shielded total gross, background, 
and net rate errors 
Compute shielded total rate 
Compute shielded total rate error 
Compute system total rate 
Compute gross, background, and net system 
total rate error 
Compute shielded coincidence rate 
Compute shielded coincidence rate error 
Compute system coincidence rate 
Compute system coincidence rate error 
Input container attributes 

Store container data on file 

Read container data from file 

Provide containe; summary report 

Allow physicist to modify the container list 

Input matrix attributes 

Store matrix data on file 
Read matrix data from file 

Allow physicist to modify the matrix list 

active-signals, detector AS.l- 3 

active-signals, detector AS.l- 3 

active-signals, detector AS.l- 3 

activeLsignals, detector AS.l- 3 

active-signals, detector AS.l- 3 

active-signals, detector AS.l- 3 

passive-signals, detector PS.l - 4 
passive-signals, detector PS.1 - 4 
passive-signals, detector PS.1 - 4 
passive-signals, detector PS.l- 4 

passive-signals, detector PS.1 - 4 
passive-signals, detector PS.l - 4 
passive-signals, detector PS.l- 4 
passive-signals, detector PS.l - 4 
waste-dlg, container, CL.1 - 12, 
chamber-wnd WA.l- 8, 

chamber-wnd, CI.1 
container 
chamber-wnd, WA.l- 8 
container 

10- 18 

container TDDA.l- 2, 
others 

container-dlg , CL.1- 12 
container, 
container-list, 
main-wnd 
waste-dlg, matrix, WA.l- 8, 
chamber-wnd 10 - 18 
chamber-wnd, matrix CI.l 
chamber-wnd, matrix WA.1- 8, 

m.1- 9 
matrix-dlg, matrix, m . l - 9  
matrix-list, main-wnd, 
matrix-parameter-dlg 

Pass 

Pass 

Pass 

Pass 

Pass 

Pass 

Pass 
Pass 
Pass 
Pass 

Pass 
Pass 
Pass 
Pass 
Pass 

Pass 

Pass 

Pass 

Pass 

Pass 

Pass 
Pass 

Pass 

133 



INEL-9 6/005 8 

Table 7. Requirements traceability matrix (cont'd). 

SRS Requirement SDD / code Test case Pass - 

3.1.4.3 M.5 
3.1.4.3 M.6 
3.1.4.3 M.7 
3.1.4.3 M.8 
3.1.4.3 M.9 
3.1.4.3 M.10 

3.1.4.3 M.ll 
3.1.4.3 M.12 
3.1.4.3 M.13 
3.1.4.3 M.14 
3.1.4.3 M.15 
3.1.4.3 M.16 
3.1.4.3 M.17 
3.1.4.3 M.18 
3.1.4.3 M.19 
3.1.4.3 M.20 
3.1.4.3 M.21 
3.1.4.3 M.22 
3.1.4.3 M.23 
3.1.4.3 M.24 

3.1.4.3 M.25 
3.1.4.3 M.26 
3.1.4.3 M.27 

3.1.5.2 M.l 
3.1.5.2 M.2 
3.1.5.2 M.3 
3.1.5.2 M.4 
3.1.5.2 M.5 

UI. 1 

uI.3 
uI.5 
UI.6 
UI.7 

Compute active Pu mass 
Calculate active Pu mass error 
Calculate passive Pu mass 
Calculate passive Pu mass error 
Select either the active or passive Pu mass 
Select either the active or passive Pu mass 
error 
calculate plutonium isotopic masses 
Calculate plutonium isotopic mass errors 
Calculate U-235 mass 
Calculate U-235 m&s error 
Calculate the Am-241 mass 
Calculate the Am mass error 
Calculate thermal power 
Calculate the thermal power error 
Calculate the thermal power denshy 
Calculate the thermal power density error 
Calculate activity values 
Calculate the activity errors 
Calculate the TRU activity concentration 
Calculate the TRU activity concentration 
error 
Calculate fissile gram equivalent 
Calculate fissile gram equivalent error 
Provide a measurement summary report for 
the container 
Send "handshake" message to DMS 
Send measurement results to DMS 
Receive "handshake" message from DMS 
Receive new assay request from DMS 
Receive recalculation request from DMS 

Switch between windows 

matrix 
matrix 
matrix 
matrix 
matrix 
matrix 

matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 
matrix 

matrix 
matrix 
chamber-wnd, 
container 
dms-dlg 
dms-dlg 
dms-dlg 
dms-dlg . 
dms-dlg 

chamber-wnd, 

DR.1- 2 
DR.l- 2 
DR.l- 2 
DR.l- 2 
DR.l- 2 
DR.l- 2 

DR.l- 2 
DR.1- 2 
vM.5 
vM.5 
DR.1- 2 
DR.l- 2 
DR.l- 2 
DR.l- 2 
DR.1- 2 
DR.l- 2 
DR.l- 2 
DR.l- 2 
DR.1- 2 
DR.l- 2 

DR.l- 2 
DR.l- 2 
TDDA.1- 2, 
others 
DMS. 1,2,3 
DMS. 1,2,3 
DMS.1,2,3 
DMS.l 
DMS.2,2 

WA.8,9 
waste-dlg, active-dlg, 
passive-dlg, results_dlg 

Default "Matrix Type" waste-dlg WA.4-7 
"Keyboard accelerators" assaysys.rc, main-wnd vM.8 
Close "Chamber Window" chamber-wnd UA.7 
Close "Waste Description" window waste-dlg vM.7 
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Table 7. Requirements traceability matrix (cont'd). 

SRS Requirement SDD / code Test case Pass 
Fail 

uI.9 

uI.10 
uI.11 

RE.4 
OP.3 
OP.4 
OP.5 

TP.3 
TP.5 

Window size, placement and color 
information 

View matrix parameters 
Attempts to update write-protected lists 

Store additional information 
Attempt to read corrupted data file 
Append background data to save file 
Notification of missing passive background 
data during a recalculation 
Background data integrity 
Significant figures displayed 

assay-system, VM.4 
mGn-wnd, 
chamber-wnd 
matrix-parameter-dlg ML.1- 9 
matrix-lag, cL.1- 12, 
matrix-parameter-dlg, ML.l- 9, 
container-dlg cc.1- 5 
chamber-wnd, matrix CL1 
chamber-wnd, itstream VM.1 
chamber-wnd VM.2 
chamber-wnd VM.3 

chamber-wnd, itstream VM.6 
chamber-wnd, matrix, PS.1, AS.l 
active-dlg, passive-dlg, 

Pass 

Pass 
Pass 

Pass 
Pass 
Pass 
. Pass 

Pass 
Pass 
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12. RESULTS 

The first set of tests were conducted on April 2,1996. The DMS interface tests 
were conducted on April 15,1996, when the DMS programmer's part of that system was 
ready. These tests were DMS.1 and DMS.2. Because the software programming for 
DMS was not complete the interface between this system and DMS was all that was 
checked. These tests were also conducted twice because they initially failed due to 
programming problems which were fixed later that same day. Additional tests to validate 
the DMS interface were conducted on April 29,1996; these tests, which were modified 
from the original test plan, tested the SAS receiving a request from the DMS to perform 
an assay, testing requirements 3.1.5.2 M.l, M.2, M.3, and M.4. These tests were 
completed successfully. 

Some of the tests that had failed on April 2,1996 were later re-conducted on April 
3,1996 after some programming modifications were made to the software. The problems 
occurred using the mass fractions from the Gamma assay on the recalculation. The test 
had to be re-done when the SGRS was available. The test VM.5 (parts I and II) was re- 
tested again on April 15, after additional programming fixes were made, and was 
successful. The addition of a Part III was also necessary to complete the entire test. 

The tests that needed to be re-run on April 3,1996 included WA.1, where 
modifications to the plan had to be made to reflect programming changes. Although 
WA.1 was completed successfully on the first test on April 2,1996, some anomalies in the 
test were eliminated by re-testing and validating so that the test, per the modifications 
made to the plan, could be run successfully. Test CP.4 was conducted twice on April 2, 
because the printer being out of paper caused a general error in the application. This error 
was a known software problem related to the fact that the print routines that were 
originally developed for the program were not configured to be Windows print routines. 
This problem wiU need to be fixed in the next software update. The clock also failed the 
first time, but was subsequently correct in the second test. The problem was that the 
count criteria were arbitrarily met the second time and not the f i t ,  but the count data was 
correct. This.problem existed because the test plan was too stringent, stating that the 
counts would be within 100 milliseconds, when in fact the computer interrogates the 
CAMAC crate every 100 to 150 milliseconds which can cause times of successive runs to 
vary by as much as 150 ms. This is not a problem since the actual CAMAC clock time is 
used in the assay calculations. The test plan has been changed to specify the time to be 
within 200 ms rather than 100 ms. Based on this information, the results of the CP.7 test 
were acceptable. 

In tests TDDA.1 and TDDA.2 the clock time was 15.04.05 when started and the 
start time was recorded as 15.08.58. There was a disparity in the set time and test time 
because of the clock time and assay time being read as unequal. It was probable that the 
wrong time was written down during the f i t  test. This test is an arbitrary test in that the 

. 
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computer clock is read by the program so there should be no disparity. These tests were 
re-run with successfbl results. 

Tests DR. 1 and DR.2 did not pass on April 2, 1996 because there was a possible 
problem with the Am-241 mass. A program fix was required, and when re-tested on April 
15, 1996, the problem was solved. The calculations from these tests, which were verified 
by an independent physicist, were validated as correct on April 29, 1996, when the 
independent physicist and the quality review met and evaluated the results. 

13. ANOMALOUS EVENTS 

Several corrections were made to the test plan during the testing conducted over 
the three day period. These changes included correcting editorial errors, indicating places 
where the proper screen capture in the example was not used, and adding additional steps 
or deleting steps that did not fit the test. Additional cases where changes had to be made 
were either the addition of new tests which fbrther evaluated what was tested, or that 
were needed to test enhancements to this version of the software that were not part of the 
original tests conducted on a previous version of this software. Hand calculations were 
completed to validate the tests. Where disparities existed that could not be verified, tests 
were either re-run or the software programming was adjusted to be correct. In some 
cases, additional steps to complete a test were added that were not part of the plan for an 
individual test. In cases where examples existed and did not appear to be obvious, a note 
was added to prevent any confbsion. 

An additional correction that had to be made to the plan consisted of changing the 
user ID in cases where the wrong one was used. The tester and the programmer also 
added steps to test if a test was successful, such as changing a password, which validated 
that the computer had actually accepted the change. These instances were added to 
validate the test, even though they were not initially part of the test plan. 

The problem with the clocks and the arbitrariness of the time between the clock 
and the assay system was not seen as a problem in test CP.4. This test, as noted above, 
was conducted twice on April 2, because the printer being out of paper caused a general 
error in the application. This error did not surprise the programmer, and was a known 
software problem which relates to the Windows print routines. This problem will need to 
be fixed in the next software update. It was suggested that operators be trained, or a note 
provided in the procedures, to indicate that operators need to check the paper level prior 
to system operation. The clock also failed the first time, but was subsequently correct in 
the second test. The problem was that the count criteria were arbitrarily met the second 
time and not the first, but the count data was correct. This problem existed because the 
test plan was too stringent, stating that the counts would be within 100 milliseconds, when 
in fact the computer interrogates the CAMAC crate every 100 to 150 milliseconds which 
can cause times of successive runs to vary by as much as 150 ms. This is not a problem 
since the actual CAMAC clock time is used in the assay calculations. The test plan has 
been changed to specifl the time to be within 200 ms rather than 100 ms. The software 
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uses actual time, therefore a slight overrun on the pre-set time is not a problem. The 
calculations use actual time so this is not a problem. Based on this information, the results 
of the CP.7 test were acceptable. 

During test CP.7, it was noted that the clock was 80 counts high. We determined 
that this condition was not a problem because the count is arbitrary and does not 
necessarily have to be exact. There would have been a concern if the counts were off two 
tenths of a second, this would have indicated that there was a problem. The degree of 
difference was an acceptable margin of error. 

During test UA. 1, it was noted that in one of the pull-down menus the available 
options to theuer  ID level were incorrect. The software was correct, it was the screen 
capture in the test plan that was not accurate. This problem was noted and the test plan 
updated to correct it. This problem occurred in the Wpt i~ns~~ section of the pull down 
menu under the Physicist ID. 

A problem was noted during test AF.3. Since testing had to conclude for a lunch 
break, and the system was shut down, the added password, which was to be deleted in test 
AF.16 - AF.18, was not saved. An additional problem was discovered in AF.5 - AF.15, 
where the plan stated that th; user should enter the valid user ID, and not select it from 
the pull down menu. This problem has been corrected as part of the plan updates. In tests 
AF-19 - AF.21, the test said to select a user ID but did not define which one. These 
elements, it was determined during testing, had to be defined in order for the test to-run 
correctly. These changes were also made. 

During the CP.7 test, it was noted that a potential problem could exist. The plan 
states that an operator needs to save the data, but if the auto save feature is selected, this 
is not required to be done, but just validated. A note was added to tell users that they 
either need to save or make sure that the auto save feature is on and that it works 
properly. 

Table 2 under test ML.5 was confusing to the tester in that certain sections of the 
table had numerous options, but it was not obvious that the user was to select only one for 
each group. A more logical grouping was suggested to improve readability and user 
clarity. Table 5 under test CC.3 also suffered from a similar problem. The order of the ’ 

text was not presented in such a way that the verification would be performed correctly by 
a confused user. Improvement was necessary to change textual order so that it reflected 
the way a user would read the table and validate the data. 

I 

During the WA.1, WA.2, and WA.3 tests the test plan required that the operator 
select full assay. It was determined during testing, and validated by the programmer, that 
it was not necessary to select N1. This correction to the test plan was subsequently made. 
In test WA.9, the test plan did not indicate that the window, after completing test step 5, 
would ask about running a background. It was noted that this needed to be added, and 
that the user needed to select yes in order to continue the test. In tests TS.1 and TS.3, in 
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1 step 2 of each test, an additional step needed to be added to instruct the user to change to 
the DAC subdirectory so that the files could be found. This was also added to the plan. 

In the test series of CP.1 through CP.3 an additional step "press accept button in 
passive background data" was required to be added because this step needed to be 
completed. This anomaly was determined during testing. This has been added to the plan. 
Test CP.4 also required an additional step which required an operator to select "yes" after 
step two, and then confirm. Step 6 required rewording to address the possibility that the 
automatic save option may be selected and so the saving step may just be a verification. 
The test plan was reworded to provide for this possibility. 

Tests DR.l and DR.2 could not be successfully evaluated on the April 2,1996, the 
original testing date, because the hand calculations to validate the data were not yet 
complete. The calculations were completed and validated on April 29,1996, and the tests 
were subsequently determined to be successful. 

Additional testing problems consisted of +or word changes which were 
corrected as needed. No additional corrections were required, or any subsequent testing 
on sequences that were previously tested and found to be successful. 

An additional test was added to the test plan because it was necessary to verify 
that the latest gamma results were the ones being used by the software and not results that 
were previously filed. This test was necessary because in previous tests it was determined 
that the latest gamma results were not being captured. Additional tests to validate the 
DMS interface were conducted on April 29,1996. These tests were not part of the 
original test plan, and tested the SAS receiving a request from the DMS to perform an 
assay, testing requirements 3.1.5.2 M.l, M.2, M.3, and M.4. These tests were completed 
successfully. 

14. SUMMARY 

At the completion of the fourth set. of tests, all tests were conducted successfully. 
Hand calculations, which were unavailable during the testing phase, were also completed 
and subsequently validated and signed off as successful completions of test results 
generated during the four testing days. The CAO QAPD [l5] has been satisfied by this 
test plan. This satisfies the Quality Level B testing-requirements. The tests described in 
Section 10, Test Procedure, have verified that all requirements specified in the SRS are 
correctly implemented. 

15. EVALUATION 

The additional test case that was tested on April 29,1996 was a good addition to 
the testing plan. This test validated that the gamma results being captured were the 
correct data and not data just stored in memory. This test also proved the interface would 
work between this software and DMS. An addition to operating procedures or training to 
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require operators to verify that the printer has enough paper before beginning to run tests 
would be a good addition. Since this was a problem during a test, a procedure step to 
validate that paper is in the priqter should be put in place. Although some problems 
existed at the start of testing, they were minor and subsequently corrected by the 
programmer to the satisfaction of the quality control person and the tester. 
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