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ABSTRACT 
 
The OPNET software was used to simulate the different scenarios of the networks which clearly 
explain the way the data is transmitted and received. We also find a lot about different topologies 
and how subnets can be used to effectively connect nodes in a network. The easy-to-use and 
drag-and-drop nature of OPNET helped a lot in simulating networks in star topology, creating 
different types of servers for each department of a campus network. The papers on wireless 
networks were very enlightening, awakening us to different standards presently in use, like, 
802.11, 802.16, etc. 
 
 
 The second half of the project included simulating ofdm in ADS. It is a case in point of 
the use of communication systems in present day technologies. We came to know of the use of 
ofdm in present wireless technologies. The advantages and disadvantages of ofdm also came to 
the fore. The ADS software’s user-friendly interface was very helpful in simulating the 
transmitter and receiver. 
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NETWORKING-A CONCEPT 

 
 Networking basically refers to the technology which strives to connect two or 
more computers into a cohesive network in which transfer of data can take place 
mutually. It is quintessential to a horde of technologies which are based on 
networking as the backbone. Some of the initial ideas in this topic deal with the 
issue of understanding the different kinds of topologies that can be implemented 
like: 

1.  Bus topology  
2. Ring topology 
3. Star topology 
4. Mesh topology 

 
 Each of these topologies is implemented in a unique way. In bus topology, a 
common cable connects all the nodes and provides for the backbone of a network 
essentially. In star topology, each node is connected to a central hub. In ring 
topology, data moves around in a single direction around the ring from one node to 
another. Each node acts as a repeater as well. In mesh topology, each node is 
connected to all other nodes. The Network operating system (NOS) monitors the 
exchange and flow of files and other information. There are two types of NOS: 
peer-to-peer or client-server NOS’s. 

 
 

• Server-based or centralized: A centralized server serves the clients 
• Peer-to-peer: Clients share the resources among themselves 

 
 
 A peer-to-peer network is economical and easy to setup. But on the flip side, 
it doesn’t provide enough security and there is no central backup system as well.  
 
 
 The International Standards Organization (ISO) formulated the OSI model 
for standardizing the network architectures and enabling easy interconnectivity. 
The OSI model defines seven layers of network services. Each layer wraps the 
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preceding layer's data and header with its own header. On the receiving end, each 
layer strips off the header that corresponds to its respective level. The different 
layers corresponding to the OSI model are: 
 
 

I. Physical Layer: This layer handles the electrical/light communication across 
the network media. This deals with the mechanical, electrical, functional, 
and procedural aspects. It also defines the    hardware characteristics such as 
voltage/current levels, signal strength, connector, and media. 

 
 
II. Data link Layer: It takes care of reliable delivery of data across a physical 

network by packaging, addressing and transmitting. It ensures that the 
information has been delivered. Ethernet, Token ring, PPP and SLIP are 
examples of protocols followed by this layer. 

 
 
III. Network Layer: It takes care of the routing of data (packets) to a system on 

the network and handles the addressing and delivery of data. 
 
IV. Transport Layer: It contains protocols and takes care of reliable transmission 

of data. Two major transport protocols are the TCP (Transmission Control 
Protocol) and the UDP (User Datagram Protocol). 

 
V. Session Layer: There are about 22 services provided by this layer. The main 

services are dialogue control and dialog separation. 
 
VI. Presentation Layer: This layer's main function is translation of the syntax 

and semantics of the data transmission. On the sending side, it converts 
computer's data representations into a standard network format. On the 
receiving side, it translates the network format into the receiving end 
computer's format. 

 
 

VII. Application Layer: This layer provides an entrance point for the application 
software to access network. Examples include File Transfer Protocol (FTP), 
Dynamic Host Configuration Protocol (DHCP), Telnet, and Simple Mail 
Transfer Protocol (SMTP). 
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The OPNET Software For Simulations 
 

The OPNET modeler is a sophisticated work-station based 
environment for the modeling and simulation of communication systems, 
protocols and networks. It has a hierarchical, object-based modeling 
structure. It also has a graphical interface which displays the characteristics 
of different individual parameters in comparison with the other parameters.  

 
This software is relatively easy to use; a prognosis of the network can 

be performed. But the time for simulation of big networks can be 
cumbersome.  

 
It has a drag-and-drop scheme for setting up networks. A network 

editor provides us with the workspace to work with. The network is 
subdivided into subnets. It consists of graphical representation of network 
topology. It also consists of global, node and link models. 

 
The time of simulation can be set during the run of the simulation. The 

following figures show the run window. 
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Wireless LAN- An Introduction 
 

  A local area network (LAN) is a computer network covering a small 
physical area, like a home, office, or small group of buildings, such as a school, or 
an airport. It has a lot of techniques through which networks can be implemented. 
For example: VLAN, Spanning Tree, LAN sizing. Wireless technology is one of 
its more illustrious and efficient counterparts. 
 
  Wireless computing is a rapidly emerging technology providing users 
with network connectivity without being tethered to  a wired network.  Wireless 
local area networks (WLANs), like their wired counterparts, are being developed 
to provide high bandwidth to users in a limited   geographical area. WLANs are 
being studied as an alternative to the high cost traditional additions, deletions, 
and changes experienced in wired LAN infrastructures. Physical and environmental 
necessity is another driving factor in favor of WLANs. Typically, new building 
architectures are being planned with network connectivity as one of the key features 
of the building. However, users in existing buildings may find it impractical to 
incorporate existing structures with wired network access. Examples of structures 
that are very difficult to wire include concrete buildings, trading floors, manufacturing 
facilities, warehouses, and   historical   monuments.   Lastly,   the   operational   
environment       may   not accommodate a wired network, or the network may be 
temporary and operational for a very short time, making t h e  installation of a wired 
network impractical. Examples where this is true include ad hoc networking needs 
such as conference registration  centers,  campus  classrooms,  emergency  relief  
centers,  and  tactical military environments. 
 
  It has ensured the setting up of a hassle-free network at minimal cost. 
With an enviable bandwidth and easy access this technology is here to stay. Due to 
the robust nature of this kind of networks, it is possible to reach out to the remotest 
parts of a place with consummate ease. 
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SIMULATION 1 
 
AIM: To simulate a network using a simple star topology 
Create a New Project  
  
In this first phase a project will be opened and named and the first simulation 
scenario named. The first simulation scenario will consist of 16 networked stations 
(PCs) and one hub. In this  
first phase the geographic size of the network is small.   
  
1. Start the OPNET IT Guru Academic Edition. Choose New from the File menu.  
2. Select Project and click OK.  Name the project. Name the scenario.   
3. In the Startup Wizard, initial Topology dialog box, make sure that Create Empty 
Scenario is selected and click next. Choose Office from the Network Scale List. 
Click Finish.   
4.  Close the Object Palette dialog box.   
 
Create the Network   
  
To create our switched LAN:   
  
1. Select Topology Rapid Configuration. From the drop-down menu choose Star 
and click OK.   
2. Click the Select Models button in the Rapid Configuration dialog box. From the 
Mod List drop-down menu choose Ethernet and click OK.   
3. In the Rapid Configuration dialog box, set the following six values: Center Node 
Mod= ethernet16_hub, Periphery Node Model = Ethernet station, Link Model = 
10BaseT, Number =16, Y=50, and Radius = 42 Click OK.   
  
The 10BaseT link represents an Ethernet connection operating at 10Mbps.   
  
4.Now that the network has been created, it should look like the network on Figure 
below.  
 
Choose Statistics  
  
To choose the statistics to be collected during the simulation:  
1. Right-click anywhere in the project workspace and select Choose Individual 
Statistics DES from the pop-up menu.   
2. In the Choose Results dialog box, choose the following 4 statistics:  
 
A. Ethernet Delay – this represents the end-to-end delay of all packets received 
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by all the stations.   
 
B. Traffic Received (in packets/sec) by the traffic sinks across all nodes  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

C. Traffic Sent (in packets/sec) by the traffic sources across all nodes  
D. Collision count is the total number of collisions encountered by the hub during 
packet transmissions.  
 
 
 
 
Configure the Simulation  
  
Here we need to configure the duration of the simulation:   
1. Click on the Configure / Run Simulation button.   
2. Set the duration to be 2.0 minutes. 
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SIMULATION 2 
 
AIM: To simulate different subnets for different departments of a campus and 
connect them together. 
 
The Description: 
 
1. Add to the project workspace the following objects from the palette: 

Application Config, Profile Config, and a subnet. Application Config is used to 
specify applications that will  

be used to configure users profiles. Profile Config describes the activity 
patterns of a user or group in terms of the applications used over a period of 
time. 
 

2. Right-click on the subnet node, edit attributes, change the name attribute to 
Engineering and click OK.   

3. Double-click on the Engineering node. You get an empty workspace, 
indicating that the subnet contains no objects.   

4. Open the Object Palette and make sure it is still set to internet toolbox. 
5. Add the following items to the subnet workspace: 10BaseT LAN, 

ethernet16Switch, and a 10BaseT link to connect the LAN with the Switch. 
Close the palette.   

6. Right-click on the 10BaseT LAN node. Edit attributes and   change the name 
of attribute to LAN and observe that the Number of Workstations attribute has 
a value of 10. 

7.  Click in the Value column for the Application: Supported Profiles attribute, 
and select Edit. You should get a table in which you should do the following:  

a. Set the number of rows to 1  
b. Set the Profile Name to Engineer. (Engineer is one of the “sample” 
profiles provided within the Profile Config object.) 

8. The object we just created is equivalent to a 10-workstation        
Star topology. The traffic generated from the users of this LAN resembles 
that generated by “engineers”. 
 

9. Make three copies of the Engineering subnet we just created. Click on the 
Engineering node. From the Edit menu, select Copy and then Paste three times, 
placing the subnet in the workspace after each, to create the new subnets.  

10. Configure the Servers:  
Now we need to implement a subnet that contains the servers. The servers have 
to support the applications defined in the profiles we deployed. You can 
double-check these applications by editing the attributes of our Profile node. 
Inspect each row under the Applications hierarchy, which in turn, is under the 
Profile Configuration hierarchy. You will see that we need servers that support 
the following applications: Web browsing, Email, Telnet, File Transfer, 
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Database, and File Print. 
    

 
 
 
 
 

FIG-1 
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FIG-2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The figure-1 shows the servers subnet inside which there are individual servers for 
different purposes and are interconnected. 
The figure-2 shows each of the different departments’ subnets. 
The figure-3 shows the overview of the entire network. 
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FIG-3 
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CHAPTER-1 
Introduction 
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Advanced Design System (ADS) 

 Advanced Design System (ADS) is an electronic design 
automation software system produced by Agilent EEs of EDA, a unit of Agilent 
Technologies. It provides an integrated design environment to designers 
of RF electronic products such as mobile phones, pagers, wireless 
networks, satellite communications, radar systems, and high-speed data links. 
Agilent ADS supports every step of the design process -- schematic 
capture, layout, frequency-domain and time-domain circuit simulation, and 
electromagnetic field simulation -- allowing the engineer to fully characterize and 
optimize an RF design without changing tools. 
Agilent EEs of EDA has donated copies of the ADS software to the electrical 
engineering departments at many universities and a large percentage of new 
graduates are experienced in its use. As a result, the system has found wide 
acceptance in industry. 
Use ADS and its highly integrated links and support as a basis for your design 
verification solution. ADS can be used for virtual prototyping, debugging, or as an 
aid in manufacturing test. To enhance engineering productivity and shorten time-
to-market, ADS software offers a high level of design automation and applications 
intelligence. This proven software environment is easily extensible: you can 
customize ADS by adding features focused on your particular application needs. 
ADS run on PCs and workstations, with complete file compatibility between 
platforms and across networks. 
With a complete set of simulation technologies ranging from frequency-, time-, 
numeric and physical domain simulation to electromagnetic field simulation, ADS 
lets designers fully characterize and optimize designs. The single, integrated design 
environment provides system, circuit, and electromagnetic simulators, along with 
schematic capture, layout, and verification capability -- eliminating the stops and 
starts associated with changing design tools in mid-cycle. 
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Orthogonal frequency-division multiplexing (OFDM)  
It is essentially identical to Coded OFDM (COFDM) and discrete multi-tone 
modulation (DMT). It is a frequency-division multiplexing (FDM) scheme utilized 
as a digital multi-carrier modulation method. A large number of closely-spaced 
orthogonal sub-carriers are used to carry data. The data is divided into several 
parallel data streams or channels, one for each sub-carrier. Each sub-carrier is 
modulated with a conventional modulation scheme (such as quadrature amplitude 
modulation or phase shift keying) at a low symbol rate, maintaining total data rates 
similar to conventional single-carrier modulation schemes in the same bandwidth. 
OFDM has developed into a popular scheme for wideband digital communication, 
whether wireless or over copper wires, used in applications such as digital 
television and audio broadcasting, wireless networking and broadband internet 
access. In an OFDM scheme, a large number of orthogonal, overlapping, narrow 
band sub-channels or subcarriers, transmitted in parallel, divide the available 
transmission bandwidth. The separation of the subcarriers is theoretically minimal 
such that there is a very compact spectral utilization. The attraction of OFDM is 
mainly due to how the system handles the multipath interference at the receiver. 
Multipath generates 
two effects: frequency selective fading and intersymbol interference (ISI). The 
"flatness" perceived by a narrow-band channel overcomes the former, and 
modulating at a very low symbol rate, which makes the symbols much longer than 
the channel impulse response, diminishes the latter. Using powerful error 
correcting codes together with time and frequency interleaving yields even more 
robustness against frequency selective fading, and the insertion of an extra guard 
interval 
between consecutive OFDM symbols can reduce the effects of ISI even more. 
Thus, an equalizer in the receiver is not necessary. 
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CHAPTER-2 
 

Getting Started with ADS 
(ADVANCED DESIGN SYSTEM) 
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Opening a Data Display Window 
 

To open a Data Display window: 

 • Choose Window > New Data Display or click the New Data Display 
Window button on the toolbar from the Main or Schematic window. 

To open additional windows from a Data Display window: 
   
 • Choose File > New or click the New button to open a window for a new 
dataset. 

 • Choose View > New Window to open a window for the same 
dataset.  

 
To open an existing data display: 
 

  • Choose Window > Open Data Display from the Main or Schematic 
window, select the dataset, and click OK. 

 
To close a data display: 
 

  • Choose File > Close Window in the window you want to close. This 
closes only the active window and does not affect the rest of the data display. If 
the contents of the display have been modified and it is the only window 
displaying data from that dataset, you are prompted to save any changes. 
 
 
The following form the basic elements of a data display window: 
   
 • The Menu bar displays the menus that are available in a Data Display 
window. 
 

  • The Dataset List displays the datasets that are available in a Data 
Display window. 

  • The Title bar displays the window type, filename, and a number for 
identifying which data display window it is. 
 • The Toolbar contains buttons for frequently used commands.  • The 
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Display Area is where you create your data presentations. 
 
Inserting Pages 

 
The Data Display allows the user to add multiple pages to the display area. 
Multiple pages provide the user with additional display area that can be used 
to display and organize large amounts of data. To insert a new page 
 
  1. Choose Insert > Page. 
  2. The New Page dialog box appears. Type a new name for the page. 
  3. Click the OK button to close the dialog box and insert the page 
 
Creating a Data Display 

 
The basic process of creating a data display consists of: 

 
•  Choosing a dataset (by name) to display 

 
•  Choosing a plot type for the display (Rectangular, Polar, etc.) 

 
•  Specifying the data variable to be displayed 

 
•  Choosing a trace type (Linear, Scatter, Histogram, etc.) 

 
 
The various plot and trace types enable you to display data in different 
formats. Equations enable you to perform complex mathematical 
operations on data for further analysis. 
Optionally, you can enhance your data display by adding: 

 
•  Markers identifying specific data points 

 
•  Text for clarification 

 
•  Graphical objects, such as lines and circles 

 
Choosing a Dataset 

 
When you open a Data Display window, all datasets defined for the current 
project are available for display. One dataset is selected as the default; it will 
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be used as the 
source of data unless a different dataset is chosen. If no datasets have been 
defined for the current project, the label on the drop-down menu reads 
dataset. 

 
 
 
 
 
 
 

Default Dataset 
 
 
You can also view datasets that are stored under other projects or are not part 
of a project, such as a dataset that contains measured instrument data. This 
can be useful for comparing simulated versus actual results or comparing 
results between projects. 

 
 
The data display does not store any data, it only retrieves and displays the data 
within a dataset. Thus, if the data in the dataset changes (for example, if you 
alter a design and resimulate), the data display will be updated to reflect the 
most current information in the dataset. 

 
To choose a dataset: 

 
1. Click the arrow to view the drop-down list of currently defined datasets. 
2. Choose the name of the desired dataset. The Datasets and Equations list 

box is updated to reflect the data variables contained in the selected 
dataset. 

 
 
 
Choosing a Plot Type 

 
A variety of plot types are available so that you can view data in different 
ways. The available plot types are shown in the following illustration. 
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Rectangular Plot—displays scalar data in a linear or logarithmic format 
Polar Plot—displays real and imaginary components of complex data 
on a polar plot  
Smith Chart—displays real and imaginary components of complex data 
on a Smith chart  
Stacked Plot—displays multiple rectangular plots 
List—displays data in tabular format 
 
Equation—displays equation created to generate data for display 

 
 
 
To specify a plot type: 

 
1. Choose Insert > Plot or click one of the plot type buttons on the palette. 

 
2. As you move the pointer into the display area, an outline of the shape and 

size of the current plot type appears. 
 

• If you are satisfied with the size, position the image as desired and 
click to place it. 

• If you want to change the size of the plot, position the image as desired 
(the upper-left corner is the reference point), press the left mouse 
button, and drag the pointer to the opposite corner. When the shape is 
the desired size, release the mouse button. 

 
3. Use the Plot Traces & Attributes dialog box to add the desired traces to the 

plot. 
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  Plot 
  Types 
 
 
  Data you 
  can plot 
 
 
 
 
 
 
 
4. Click OK. 

 
 
Selecting a Data Variable 
 
By default, selected data is plotted as the dependent variable, and the 
independent variable is a logical default, such as frequency or time. For a 
rectangular plot or a listing, you can also choose the independent variable. 
 
To select the variable whose data you wish to plot for analysis: 
 
1. Select a dataset from the Datasets and Equations list box. Variables in the 

dataset appear in the list below. 
2. Select a variable and click Add. The selected data is added to the Traces 

list box. 
3. Repeat as needed to display the desired data on the current plot. 
4. Click OK. 
 
To plot one variable against another: 
 
1. Double-click on the plot or select the plot and choose Edit > Item 

Options. 
2. The Plot Traces & Attributes dialog box appears. 
3. Select a variable from the Datasets and Equations list box. This variable 

will be plotted along the Y-axis. 
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4. Click the Add vs. button. From the dialog box that appears, select a 
second variable. (It can be from a different dataset or equation.) This one 
will be plotted along the x-axis and is considered the independent 
variable. 

5. Click OK to accept the variable. 
6. Click OK to display the trace on the plot. 
 
 
 
Selecting a Trace Type 
 
A trace type is assigned to the data during simulation to simplify viewing 
results. The trace type can be changed. A variety of trace types are available 
so that you can view data in different ways. 
 
To select a trace type: 
 
1. Double-click on the plot or select the plot and choose Edit > Menu Items. 
2.  Select at least one variable from the Traces list box. 
3.  Click Trace Options to display the Trace Options dialog box. 
4. Click the Trace Type tab and select the desired trace type. 
5.  Click OK. 
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Saving a Data Display 
 
There are two commands for saving a data display: Save and Save As. 
 
•  Choose File > Save to save changes to an existing file. A file suffix of .dds 
is automatically appended to a data display file. 
 
•  Choose File > Save As to save the Data Display window as a new file or to 
save a copy of the open file using a new name. 
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CHAPTER-3 
 

Orthogonal Frequency Division 
Multiplexing (OFDM) 

 
 
 
 
 
 
 
 
 
 
 
 



32 
 

 
 
 
 
 
 
 
OFDM  
  
 The primary advantage of OFDM over single-carrier schemes is its ability to 

cope with severe channel conditions — for example, attenuation of high 
frequencies in a long copper wire, narrowband interference and frequency-
selective fading due to multipath — without complex equalization filters. 
Channel equalization is simplified because OFDM may be viewed as using 
many slowly-modulated narrowband signals rather than one rapidly-
modulated wideband signal. The low symbol rate makes the use of a guard 
interval between symbols affordable, making it possible to handle time-
spreading and eliminate inter-symbol interference (ISI). This mechanism also 
facilitates the design of single-frequency networks, where several adjacent 
transmitters send the same signal simultaneously at the same frequency, as the 
signals from multiple distant transmitters may be combined constructively, 
rather than interfering as would typically occur in a traditional single-carrier 
system. 

  
 Advantages:- 

  Can easily adapt to severe channel conditions without complex  equalization 
  Robust against narrow-band co-channel interference 
  Robust against Inter-symbol interference (ISI) and fading caused  by 

multipath propagation 
  High spectral efficiency 
  Efficient implementation using FFT 
  Low sensitivity to time synchronization errors 
  Tuned sub-channel receiver filters are not required (unlike 

 conventional FDM). 
 Facilitates Single Frequency Networks, i.e. transmitter macro diversity. 

 Disadvantages:- 
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 Sensitive to Doppler shift. 
 Sensitive to frequency synchronization problems. 
 High peak-to-average-power ratio (PAPR), requiring linear transmitter 

circuitry, which suffers from poor power efficiency. 
 Loss of efficiency caused by Cyclic prefix/Guard interval. 

 
In OFDM, the sub-carrier frequencies are chosen so that the sub-carriers 
are orthogonal to each other, meaning that cross-talk between the sub-channels is 
eliminated and inter-carrier guard bands are not required. This greatly simplifies 
the design of both the transmitter and the receiver; unlike conventional FDM, a 
separate filter for each sub-channel is not required. 

The orthogonality requires that the sub-carrier spacing is  

   Δf = k/(TU) Hertz,  

where TU seconds is the useful symbol duration (the receiver side window size), 
and k is a positive integer, typically equal to 1. Therefore, with N sub-carriers, the 
total passband bandwidth will be  

   B ≈ N·Δf (Hz). 

The orthogonality also allows high spectral efficiency, with a total symbol rate 
near the Nyquist rate. Almost the whole available frequency band can be utilized. 
OFDM generally has a nearly 'white' spectrum, giving it benign electromagnetic 
interference properties with respect to other co-channel users. 

OFDM requires very accurate frequency synchronization between the receiver and 
the transmitter; with frequency deviation the sub-carriers will no longer be 
orthogonal, causing inter-carrier interference  (ICI), i.e. cross-talk between the 
sub-carriers. Frequency offsets are typically caused by mismatched transmitter and 
receiver oscillators, or by Doppler shift due to movement. While Doppler shift 
alone may be compensated for by the receiver, the situation is worsened when 
combined with multipath, as reflections will appear at various frequency offsets, 
which is much harder to correct. This effect typically worsens as speed increases, 
and is an important factor limiting the use of OFDM in high-speed vehicles. 
Several techniques for ICI suppression are suggested, but they may increase the 
receiver complexity. 
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Elimination of ISI (Inter-Symbol Interference):-  

 

One key principle of OFDM is that since low symbol rate modulation schemes 
(i.e. where the symbols are relatively long compared to the channel time 
characteristics) suffer less from inter-symbol interference caused by multipath 
propagation, it is advantageous to transmit a number of low-rate streams in parallel 
instead of a single high-rate stream. Since the duration of each symbol is long, it is 
feasible to insert a guard interval between the OFDM symbols, thus eliminating 
the inter-symbol interference. 

The guard interval also eliminates the need for a pulse-shaping filter, and it reduces 
the sensitivity to time synchronization problems. 
 
A simple example: If one sends a million symbols per second using conventional 
single-carrier modulation over a wireless channel, then the duration of each symbol 
would be one microsecond or less. This imposes severe constraints on 
synchronization and necessitates the removal of multipath interference. If the same 
million symbols per second are spread among one thousand sub-channels, the 
duration of each symbol can be longer by a factor of a thousand, i.e. one 
millisecond, for orthogonality with approximately the same bandwidth. Assume 
that a guard interval of 1/8 of the symbol length is inserted between each symbol. 
Inter-symbol interference can be avoided if the multipath time-spreading (the time 
between the reception of the first and the last echo) is shorter than the guard 
interval, i.e. 125 microseconds. This corresponds to a maximum difference of 37.5 
kilometers between the lengths of the paths. 

The cyclic prefix, which is transmitted during the guard interval, consists of the 
end of the OFDM symbol copied into the guard interval, and the guard interval is 
transmitted followed by the OFDM symbol. The reason that the guard interval 
consists of a copy of the end of the OFDM symbol is so that the receiver will 
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integrate over an integer number of sinusoid cycles for each of the multi-paths 
when it performs OFDM demodulation with the FFT. 

 
 
 
 
 
Inter Carrier Interference(ICI) in OFDM:- 
 
Multi Carrier systems like OFDM has the problem of Inter Carrier Interference 
(ICI), which results from the loss of Orthogonality between the sub carriers. This 
happens when the FFT is considered over duration where the subcarrier is non 
integer number of cycles, which would be the case when multipath is present and 
the guard time has amplitude is zero. This is reduced by use of cyclic prefix, where 
we transmit a copy the last part of the symbol followed by the symbol itself. This 
ensures Orthogonality over the FFT period in case of delayed multipath.  
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CHAPTER – 4 
 
 

OFDM Transmitter & Reciever 
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OFDM Transmitter :- 
 
 
An OFDM carrier signal is the sum of a number of orthogonal sub-carriers, 
with baseband data on each sub-carrier being independently modulated commonly 
using some type of quadrature amplitude modulation (QAM) or phase-shift 
keying (PSK). This composite baseband signal is typically used to modulate a 
main RF carrier. 
 

 
(The Transmitter) 

 

s[n] is a serial stream of binary digits. By inverse multiplexing, these are first 
demultiplexed into N parallel streams, and each one mapped to a (possibly 
complex) symbol stream using some modulation constellation (QAM, PSK, etc.). 
Note that the constellations may be different, so some streams may carry a higher 
bit-rate than others. 

An inverse FFT is computed on each set of symbols, giving a set of complex time-
domain samples. These samples are then quadrature-mixed to passband in the 
standard way. The real and imaginary components are first converted to the 
analogue domain using digital-to-analogue converters (DACs) ; the analogue 
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signals are then used to modulate cosine and sine waves at the carrier frequency, fc, 
respectively. These signals are then summed to give the transmission signal, s(t). 

 

 

 

 

OFDM Receiver:- 
 
 
The receiver picks up the signal r(t), which is then quadrature-mixed down to 
baseband using cosine and sine waves at the carrier frequency. This also creates 
signals centered on 2fc, so low-pass filters are used to reject these. The baseband 
signals are then sampled and digitized using analogue-to-digital 
converters (ADCs), and a forward FFT is used to convert back to the frequency 
domain. 

This returns N parallel streams, each of which is converted to a binary stream using 
an appropriate symbol detector. These streams are then re-combined into a serial 
stream, , which is an estimate of the original binary stream at the transmitter. 

 

 
 

(The Receiver) 
 
 

 
 



39 
 

 
 
 
 
 
 
 
 
 

 
 
 
 

CHAPTER – 5 
 

Simulations 
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Single Carrier OFDM 
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Two-Carrier OFDM 
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ICI in OFDM 
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CONCLUSION 

 
 The OPNET software was of great help during the simulations of different 
scenarios of the networks clearly explain the way the data is transmitted and 
received. We also learnt about different topologies and how subnets can be used to 
effectively connect nodes in a network. The easy-to-use and drag-and-drop nature 
of OPNET helped a lot in simulating networks in star topology, creating different 
types of servers for each department of a campus network. The papers on wireless 
networks were very enlightening, awakening us to different standards presently in 
use, like, 802.11, 802.16, etc. 
 
 
 The second half of the project included simulating ofdm in ADS. It was a 
great learning experience in communication systems. We came to know of the use 
of ofdm in present wireless technologies. The advantages and disadvantages of 
ofdm also came to the fore. The ADS software’s user-friendly interface was very 
helpful in simulating the transmitter and receiver. 
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