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Abstract

An open-access database has been set up to support the research project study-
ing the ‘Response of Humans to Abrupt Environmental Transitions’ (RESET). The
main methodology underlying this project was to use tephra layers to tie together
and synchronise the chronologies of stratigraphic records at archaeological and envi-
ronmental sites. The database has information on occurrences, and chemical compo-
sitions, of glass shards from tephra and cryptotephra deposits found across Europe.
The data includes both information from the RESET project itself and from the
published literature. With over 12,000 major element analyses and over 3000 trace
element analyses on glass shards, relevant to 80 late Quaternary eruptions, the
RESET project has generated an important archive of data. When added to the
published information, the database described here has a total of more than 22,000
major element analyses and nearly 4000 trace element analyses on glass from over
240 eruptions.

In addition to the database and its associated data, new methods of data analysis
for assessing correlations have been developed as part of the project. In particular an
approach using multi-dimensional kernel density estimates to evaluate the likelihood
of tephra compositions matching is described here and tested on data generated as
part of the RESET project.
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1 Introduction

The RESET project aimed to use a variety of different methods to achieve
the high resolution chronology needed to address questions relating to past
rapid climate change, and the human responses to it. The project covers Eu-
rope and N. Africa over the time range 10-60 ka BP. However, one of the key
elements underpinning the RESET approach has been the construction of a
tephrochronological framework, or lattice, which can be used to tie together
the chronologies of different types of record at archaeological and palaeoen-
vironmental (terrestrial and marine) sites. In order to develop this chronos-
tratigraphy, it has been necessary to acquire detailed information about these
tephra and cryptotephra deposits, both in terms of their composition and dis-
tribution. The RESET database has been an important tool for sharing this
information within the group and is now a major resource for other researchers
to use.

The database is relational in nature allowing very different types of informa-
tion to be accessed in a number of different ways. We have included both
information generated during the RESET project itself and also information
from publications, and gathered in previous data compilations. In addition to
the data itself, the database consists of an easily accessible user-interface and
a number of geographic, graphic and mathematical tools for data visualisation
and analysis. The emphasis here has been on making the data easy to use.
The reason for developing a database specifically for this project is that it has
enabled the organisational structure to be specifically designed for addressing
the project’s research aims. The database implementation has also allowed for
the integration of tools for data-analysis.

A summary of the data is given in Table 1, showing the scale of data available
both from the RESET project and from the published literature, including
major inputs from the the Natural Environment Research Council (NERC)
QUEST project, and from Felix Riede’s compilation of sites where the Laacher
See Tephra is found (Riede and Wheeler, 2009; Riede et al., 2011). The term
‘Site’ includes volcanoes, proximal volcanic sediments and distal locations such
as archaeological sites or palaeoenvironmental records. ‘Samples’ can either
be tephra deposits or sediments from archaeological and environmental sites
tested for the presence of volcanic glass particles. Where these samples, contain
glass shards, they have been analysed for major and trace elements. Usually
multiple measurements are made on glass shards from each sample to assess
the compositional range. Uncertainties (1σ) on the data presented within the
database can be estimated from repeat analyses of the secondary standards
analysed with the samples 3 . Sometimes the analyses enable to the glass to be

3 Using a compilation of secondary standard data run over numerous analytical
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RESET Other Total

Sites 185 952 1,152

Samples 5,679 1,817 7,496

Samples with major element analyses of glass 413 689 1,102

Samples with trace element analyses of glass 303 37 340

Major element analyses of glass 12,272 10,435 22,707

Trace element analyses of glass 3,572 421 3,993

Identified volcanic centres 31 26 44

Regional volcanic centres 5 6 6

Total volcanic centres 36 32 50

Eruptions 91 236 284

Eruptions with major element analyses 79 195 240

Eruptions with trace element analyses 67 21 85
Table 1
Summary of the main information in the database as of February 2014. The columns
refer to data directly from the RESET project, data from other published sources,
and the overall totals. In some instances sites and eruptions are associated with
data from both RESET and other published sources.

correlated to particular eruptions or, failing that, to volcanic centres. Some
eruptions are known from stratigraphic and compositional analyses of proxi-
mal deposits, but other eruptions are only known from distal tephra or cryp-
totephra deposits and the volcanic source of these may be identified only as a
region containing multiple volcanic centres.

Identification of tephra or cryptotephra deposits through major and trace el-
ement analyses of associated glass shards is normally done through the visual

sessions we estimated that the errors for each element are: ± 0.6 RSD% for typical
SiO2 concentrations (>50 wt%); ∼ ±1 RSD% for typical Al2O2 concentrations
(>10 wt%); ∼ ±10 RSD% for Na2O contents <1 wt% and fall to less than ±5
RSD% when Na2O contents are >4 wt%; <±2 RSD% at K2O contents >2 wt%;
±3 RSD% at CaO concentrations of 1.7 wt% and <1.5 RSD% at concentrations >5
wt%; ∼ ±4 RSD% at FeOt (all Fe expressed as FeO) concentrations of ∼3 wt% and
<±2 RSD% at >10 wt% FeO; ∼ ±15 RSD% at MgO contents of ∼0.5 wt% and
<±2 RSD% at >2 wt%; ∼ ±10 RSD% at TiO2 concentrations of ∼0.3 wt% and
<±2 RSD% at concentrations >2 wt%. Phosphorus, Cl and Mn are typically found
in low concentrations, <0.2 wt%, and the errors on these elements are significantly
larger. They are around ±40 RSD% for Cl at typical concentrations of ∼0.04 wt%,
and ∼ ±30 RSD% for MnO concentrations of ∼0.15 wt%. Errors in P2O5 are ∼ ±30
RSD% at 0.1 wt% and drop to <±7 RSD% at concentrations >0.25 wt%.
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comparison of analyses on unknown deposits to those on identified eruptions
together with stratigraphic, chronological, and mineralogical data that are
available.. This visual inspection can be supplemented by statistical analysis
using methods such as principle components analysis and discriminant anal-
ysis. Because the diagnostic features of the constituents of different tephra
or cryptotephra deposits are different for each case, this process tends to be
time-consuming and is, by its nature, not quantitative. Here we show that it
is possible to use multi-dimensional kernel density estimates to evaluate the
likelihood of tephra correlations. An on-line tool has been developed, that
enables large numbers of possible source eruptions to be tested rapidly, with
quantitative information on the possible identifications. Such statistical meth-
ods will not replace detailed consideration of the volcanic systems in question,
but they may provide a useful tool in narrowing down possible correlations
and help to give better criteria for positive matches.

2 Database structure

The database is divided into a number of related tables. The main tables in
the database are:

• sites/volcanoes : this table lists all sites within the database, whether they be
volcanic centres, or sites of archaeological and environmental interest; each
site has associated with it basic information on location (longitude, latitude,
altitude, country and region); in the case of volcanic centres the region
specified is the volcanic region, which is important in tephra identification
(see below); each site can have multiple references associated with it and can
also have metadata (text files, plans etc.) with further associated details.
• samples : samples within a site can have 3-D coordinate information associ-

ated with them; where the sample has tephra or cryptotephra present this
is identified as a proximal, mid-distal or distal deposit and the volcanic
material type is also specified; except in the case of proximal deposits, a
shard count (normally as g−1 dry weight but in some cases where comments
indicate as cm−3) is given.
• eruptions : for each volcanic centre, known eruptions are listed in this table;

the eruptions description gives the type of eruption (Plinian, Ultra-Plinian
etc.) and the best estimate of the date or age of the eruption with an
associated uncertainty and timescale; the reference for the date or age given
is also part of the eruption record.
• identifications : this is the table which links samples that contain tephra or

cryptotephra to individual eruptions, volcanic centres or volcanic regions; in
each case a certainty of association is given as a 1-5 scale; the identification
is if possible associated with the person who made the identification.
• instruments : this is a list of instruments used for analysis of tephra chem-
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istry; each instrument record specifies instrument type and location; where
the instrument is not known generic instrument types are still specified.
• batches : this table lists batches of analyses that have been performed to-

gether; this enables measurements on secondary standards (e.g., MPI-DING
reference glasses; Jochum et al., 2006) to be linked to the measurements
on unknown glass samples to assess analytical accuracy and precision; each
batch has information on instrument running parameters and any comments
made by the researcher running the analysis; for much published data this
information is not available and data are simply grouped by associated pub-
lication.
• majors : each individual major-element analysis of glass is listed in this table;

this is linked to a specific sample from the samples table and to a batch in
the batches table; the unnormalised data is stored in the database but this
can be displayed either as normalised or unnormalised; each measurement
can have multiple references associated with it where the data are published.
• trace: each individual trace-element analysis is listed in this table; this is

linked to a specific sample from the samples table and to a batch in the
batches table; each measurement can have multiple references associated
with it where the data are published.
• references : this table lists the full bibliographic details of all references; this

table is linked to sites (multiple references allowed), major/trace element
glass analyses (multiple references allowed) and the best-estimate dates or
ages for eruptions (one reference allowed).

3 Database implementation

The RESET database uses an open-source MySQL engine and a web interface
based on php. The database is available online at https://c14.arch.ox.

ac.uk/resetdb/db.php. The database is currently read-only for those not
involved with the RESET project, though in the future it may be possible for
users to add their own data for their own use, and request to have them made
publicly available through the database after publication.

3.1 Navigation of the database

Figure 4 shows the front page of the RESET database. There are links here
to many of the main aspects of the database, and the menu provides access
to the same pages even when the front page is not shown.

The navigation follows logically from the structure of the database laid out
above. The principal ways in which the data can be viewed are: by site, by
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sites :



site→



sitename

country

region

location

refs

samples :



sample→


sample ID

coordinates

shard count

material

sample . . .

sample . . .

. . .

site . . .

site . . .

. . .

Fig. 1. The main structure of data in the database relating to environmental and
archaeological sites. In this figure [ brackets denote arrays and { records within the
database; the term refs refers to a series of references.

volcano or eruption, and by reference. In addition, users can also look at
individual batches of analyses by instrument which enables them to find asso-
ciated measurements on reference standards. All data within the database are
hot-linked and so, for example, where a specific eruption is listed in a record,
clicking on the eruption name will call up the page that summarises all of the
information for that eruption.

Accessing information for individual sites can be done in a number of different
ways. If a site location is known, the country can be selected from the page
listing all countries for which there are data; the country page shows a list
of all sites located within that country, from which a selection can be made.
Alternatively, users can generate an alphabetical list of all sites that have
samples with information on the database. Finally, sites can also be linked
from maps (see below). Any of these means can be used to bring up a site
page which lists important information stored on that site in the database (see
Figure 5). In addition to a header with information about the sites location,
comments and metadata, the site page has four main data-tables: Samples
which shows samples listed by depth in the site; Identifications which are those
samples that have been associated with particular eruption events through
tephrostratigraphy; Samples with majors which lists all glass samples on which
chemical analyses have been undertaken (typically those with trace element
analyses also have major element analyses); References which lists references
specific to this site. From this site page users can use the menu item [View >
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volcanoes :



volcano→



volcanic ID

volcanic centre

country

volcanic region

location

refs

eruptions



eruption→



eruption ID

eruption type

date & uncertainty

timescale

ref

eruption . . .

eruption . . .

. . .

volcano . . .

volcano . . .

. . .

identifications :



identification→



sample ID

volcanic region

region certainty(1− 5)

volcanic ID

volcanic certainty(1− 5)

eruption ID

eruption certainty(1− 5)

assessor

identification . . .

identification . . .

. . .

Fig. 2. The main structure of data in the database relating to volcanic centres and
associated samples. In this figure [ brackets denote arrays and { records within the
database; the term ref refers to single reference link and refs refers to a series of
references.

Show on map] to plot the site on a map (see section 3.3) and [View > Plot
shard count] will plot the samples from the site by depth (see section 3.2). The
same can be done using the plot ( ) and map ( ) buttons to the right of the
menu bar. Pressing the / button returns to a list of all sites in the associated
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instruments :



instrument→



instrument name

location

instrument type

batches



batch→



date

analyser

comments

majors(see below)

trace(see below)

batch . . .

batch . . .

. . .

instrument . . .

instrument . . .

. . .

majors :



major analysis→


sample ID

SiO2, TiO2, Al2O3 . . .

refs

major analysis . . .

major analysis . . .

. . .

trace :



trace analysis→


sample ID

V, Ni, Rb . . .

refs

trace analysis . . .

trace analysis . . .

. . .

Fig. 3. The main structure of data in the database relating to environmental and
archaeological sites. In this figure [ brackets denote arrays and { records within the
database; the term refs refers to a series of references.

country.

A similar approach is taken with volcanic centres and eruptions. The volcanic
centre page shows a list of eruptions and all of the associated glass chemical
data, whereas the eruption page narrows this information down to the subset
of data identified to the specific eruption event. To get to an eruption page,
users can either navigate via the volcanic centre, or from the chronological list
of all eruptions.
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Fig. 4. Home screen of the RESET database.

Fig. 5. Site page for the archaeological site of Ahrenshöft, Germany.
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Fig. 6. Eruption page for the widespread Vedde Ash layer from Iceland.

3.2 Plotting data

The database has a built-in plotting facility (‘OxPlot’) which is able to present
the data from the database without exporting to other programs. The purpose
of this facility is to enable the rapid visualisation of data from the database,
and to simplify the preparation of reports for publication. There are essentially
three main type of plots generated by the database: profile plots for cores or
sediment sections, glass chemistry plots, and maps (see next section).

Once on a site page (such as Figure 5) within the database, where there are
data on samples at different depths, using the [View> Plot shard count] option
will produce a plot of the shard count against depth for that site (see Figure
7A). Where there is more than one section or core within the site, within the
plotter this detail can be explored by selecting the [View > Multiplot] option
(see Figure 7B). This multi plot function provides a useful way to look at the
distribution of tephra or cryptotephra at a site.

Probably the most important aspect of the database’s plotting functions, how-
ever, is the ability to plot glass-shard compositional data and to compare dif-
ferent glass compositions. Any page which contains major or trace element
data for glass can be entered into a plot. As a default the database will work
with major element data, but trace element plots can also be selected (see
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A B

Fig. 7. Shard count plot for the site of Ahrenshöft (Housley et al., 2012). Panel
A shows the simple plot against depth (m); panel B shows shard count divided
between the three different profiles at this particular site. In each case the blue
histogram shows the low resolution scan for glass, and the green histogram the
higher resolution scans. The shard counts are given in shards (g−1). The red markers
show where samples have been taken for major element analysis (position shown on
the y-axis and analysis count on the x-axis).

later in this section). For example, when on the database page for a specific
eruption, pressing the plot button at the top right of the page will present
the user with a plot of the total alkalis (Na2O and K2O) versus SiO2 (TAS;
Le Maitre, 2002, p. 36) for the glass analyses on deposits from that eruption
(see, for example, Figure 9). All data from that eruption will be shown. How-
ever, this information can also be subdivided: within the plotting routine if
[Edit > Import] is selected it is possible to split the data according to different
criteria - for example by material or by instrument used for the analysis. By
selecting [Edit > Data] (also within the plotting routine) it is possible to select
which datasets to put on the plot.

The plotting routine is cumulative and so, once the data for glass from one
eruption have been plotted, it is possible to select another eruption in the
database and plot the data from analyses of glass for its eruptives alongside.
Examples of this kind of plot are shown later in this paper (Figures 13 and 15).
In addition, it is possible to import data which is not in the database using
the [Edit > Import] function of the plotter (see section 5.1 for an example).
This function enables the users to look at their data against reference datasets
held in the database.

In addition to the TAS plots, if the user selects [View > Multiplot] from within
the plotting routine, a matrix of major element plots is displayed (examples
are given in Figures 14 and 16 below).

Finally, to examine the trace element data instead of the major element data,
it is necessary to set up an appropriate plot. To do this users can go to the
[Tools > Plots] page of the database and select which trace element they wish
to plot against (default is Nb). This will set up a blank plot. After navigating to
the relevant pages of the database it is then possible to add the data required
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to the plot, either using the plot button from the database or using the [Edit
> Import] option within the plotter (which allows the data to be split by
different criteria).

3.3 Geographical data

The plotting routine associated with the database is also set up to allow the
mapping of spatial geographical information. Wherever a page in the database
shows location information, this can be mapped either using the internal map-
ping routine of the database by selecting [View > Show on map] or can be
downloaded as KML 4 data by using [View > Download KML].

As an example, if the Laacher See Tephra (LST) is selected in the database,
which contains a large collection of occurrences of this tephra, largely from
Riede and Wheeler (2009) and Riede et al. (2011), this can be used to generate
the map shown in Figure 8. Each point in the map is hot-linked back to the
database so that further information can be found. This ability to switch
between map and stored information is why the integration of geographic
display within the database is so important.

The maps generated can use either the simple coastline underlay shown in
Figure 8, or any of the four main Google MapTM views (roadmap, satellite,
hybrid or terrain) available from the Google MapTM server. The map underlay
can be set from the [Format] menu of the plotting tool. The coastline outline
is a Scalable Vector Graphics (SVG), public domain map and is more suitable
for publications.

3.4 Technical details

The php code used for extraction of data from the database is fairly simple: its
function is primarily to allow secure access to the data and to perform the SQL
searches on the database. The data from the database are then sent to the user
as javascript arrays and objects. All of the presentation and numerical analysis
of the data takes place on the clients machine within the javascript engine of
the user’s browser. This approach has two main advantages: data only have
to be retrieved once because data comparison and presentation do not require
extra searches to be performed on the database, minimising the effect of low
connection speeds; furthermore the server itself does not have to prepare data
for presentation or do any numerical analysis, which improves performance of

4 Keyhole Markup Language (KML) is an XML format for geographic information
developed for Google EarthTM
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Fig. 8. Distribution of occurences of the LST with information stored in the
database. The grey outline shown is a 95% contour of a kernel density generated
from the mapped points. It shows the approximate main extent of find sites (which
not necessarily the same as the original tephra distribution).

the system with multiple users. However, there are also some disadvantages to
this approach: the quantity of data being analysed can be quite high and client
computers without much memory, or with low performance web-browsers, may
find that the system is slow to use, or cannot cope if they try to retrieve and
plot data on analyses of glass shards from a very large number of different
eruptions.

To see how the database methodology works in practice, users can navigate to
a site page such as that shown in Figure 5 and look at the page source. Here
they will see the raw data extracted from the database as a javascript data
object.

The statistical comparison tool is all written in javascript and is therefore
openly available. The main comparison routines are all given in one file https:
//c14.arch.ox.ac.uk/utils/kde.js
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The graphics generated by the database are also generated dynamically within
the web-browser of the user. This has the advantage that these processor in-
tensive tasks do not slow down the server. The graphics use the SVG standard,
compatible with most of the latest generation web-browsers. The plots gen-
erated can be saved in this format (editable with the open source Inkscape
package or various commercial alternatives such as AdobeTM Illustrator) or
can be converted to pdf or png format using ApacheTM Batik toolkit installed
on the server.

4 Statistical comparison tools

Comparing datasets from analyses of glass derived from tephra or cryptotephra
deposits raises issues common to many multivariate datasets. In this case there
are reference datasets (which are known to be associated with particular erup-
tions for example) and candidate datasets which are to be tested against the
references. The problem becomes two-fold: how the reference dataset be sum-
marised and how can matches be tested. The first of these problems is compli-
cated by the fact that distributions of chemical data from glass are often not
well approximated by a multivariate normal distribution and in particular can
be multi-modal. Two options are considered here: using multivariate normal
distributions and kernel density distributions. Both methods use unnormalised
data.

In each case the reference dataset X is assumed to comprise n measurements,
each with d parameters:

X =



x11 x12 . . . x1d

x21 x22 . . . x2d

...
...

. . .
...

xn1 xn2 . . . xnd


=



x1

x2

...

xn


(1)

A candidate distribution Y will be defined in the same way but with m mea-
surements, each with d parameters. In other words, it is assumed that for any
comparison the same parameters are measured on the reference and candidate
datasets (or that any measurements not made on both datasets are ignored).
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Fig. 9. Major element data for glass shards from the Laacher See Tephra plotted on
a TAS plot (normalised data displayed); the plot on the left shows the individual
data points and that on the left shows the multivariate normal distribution derived
from these.

4.1 Multivariate normal distribution

A multivariate (n dimensions) dataset can be summarised by its mean µ and
covariance Σ where:

µX = [µ1, µ2, . . . , µd] (2)

ΣX = [Σij], i = 1, 2, . . . , d; j = 1, 2, . . . , d (3)

On the assumption that the dataset is drawn from a multivariate normal
distribution, the estimate for the probability of any individual point within
this distribution will be given by:

pX(x) = pX (x1, . . . , xd) = Nd(µX ,ΣX) (4)

This can be illustrated using the example of tephra analyses for the Laacher
See Tephra (Turney et al., 2006; Finsinger et al., 2008; Riede et al., 2011;
Lane et al., 2011b, 2012b; Housley et al., 2013). Figure 9 shows the major
element data of glass from the LST plotted on a TAS plot (Le Maitre, 2002)
and the associated multivariate normal distribution (10 contours). This simple
example shows the limitations of using a multivariate normal model for this
type of data in that the peak of the distribution is actually in a composition
region which is relatively unlikely.

So if there is another glass shard with measurements y on the same set of
parameters, the probability that we would have got these measurements, had
the particle come from the same dataset as X, is given by:

pX(y) = pX (y1, . . . , yd) = Nd(µX ,ΣX) (5)
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For a full set of measurements Y , the average value for this probability is:

pX(Y ) =
1

m

m∑
i=1

pX(yi) (6)

Now the absolute value of this average will depend on the normalisation of
the chosen parameters. However, the higher this value is the more likely it is
that the dataset Y is actually just a subset of that for X. However, it is useful
to divide this average value by a similar average for the reference dataset to
get a ratio:

AY X =
pX(Y )

pX(X)
(7)

This value should be close to 1 if the distributions are very similar. It could
be greater than 1 if all the measurements in dataset Y cluster in the peak
of the distribution X. This ratio is a useful measure because it provides an
indication of the degree of overlap between the two distributions. Note that the
definition here is not symmetrical (that is AY X 6= AXY ) because the measure
is for Y being a subset of X. Now with multiple datasets it is possible to
form a matrix of such ratios which can be used to indicate possible matches of
unknown (uncorrelated) tephra or cryptotephra to known one. Before looking
at this in more detail, the Kernel-density approach will be considered.

4.2 Kernel-density distribution

Kernel density methods have been found useful in a range of applications asso-
ciated with chemical compositions and geographical distributions (Aitchison
and Lauder, 1985; Baxter et al., 1997; Santos et al., 2006; Weller et al., 2006).
With multiple dimensions, there is no well-defined method that can be used
to estimate the optimal kernel bandwidth. There are various methods which
require iterative or MCMS optimisation, sometimes within a Bayesian frame-
work (see, for example, Zhang et al., 2006, for a discussion) but these are by
their nature difficult to use in rapid comparison of data. An alternative is to
use a commonly applied approximation, which is shown to be approximately
optimal in cases which approach normality. To use this the data for any spe-
cific dataset, the data are first sphered (using the inverse of the covariance
matrix to perform the transformation x → x′) so that they have variance of
one in each dimension. The optimal bandwidth h for the multidimensional
spherically symmetric multivariate normal kernels within this space can then
be approximated (see Scott (1992) and Bowman and Azzalini (1997) as dis-
cussed in Zhang et al. (2006)) by:
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h =

{
4

(d+ 2)n

}1/(d+4)

(8)

where d is the number of dimensions (different variables) and n is the number
of samples. So within this transformed space each kernel takes the form of:

∼ Nd(x′i, h
2I) (9)

and the overall kernel density distribution is:

∼ 1

n

n∑
i=0

Nd(x′i, h
2I) (10)

Transforming the data back to their usual multivariate space means that the
kernel distributions are skewed in the direction of the covariance seen in the
particular dataset. This effect will be apparent through the practical examples
given later in this paper. The overall kernel density becomes:

qX(x) = qX (x1, . . . , xd) =
1

n

n∑
i=0

Nd(xi, h
2ΣX) (11)

Figure 10 shows the major element data for the LST plotted on a TAS plot
(compare to Figure 9), in this case just using two dimensions. The kernel
density approach gives a better representation of the underlying distribution.

The aim is to use these improved distributions to test for matches in much
the same way that the multivariate normal distributions were used above.
Here, however, there is a slight complication when normalising in that if we
calculate qX(X) we might expect to get an artificially high value since the
data points themselves define the peaks of the kernels. To overcome this we
miss out the kernel associated with the test point while performing the sum.
Using the modified distribution:

qX j̄(x) =
1

n− 1

n∑
i=0,i 6=j

Nd(xi, h
2ΣX) (12)

the appropriate data comparison matrix (where X 6= Y ) becomes:

BY X =
1
m

∑n
i=0 qX(yi)

1
n

∑n
j=0 qX j̄(xj)

(13)
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Fig. 10. Major element data for glass from the Laacher See Tephra plotted on a
TAS plot (normalised data displayed); the plot on the left shows the individual
data points and that on the left shows the kernel density estimate distribution
derived from these datapoints; this plot should be compared to Figure 9.

and BXX ≡ 1.

4.3 Significance of comparisons

Whenever comparing chemical datasets, it is impossible to prove that two
datasets are the same. Logically, it is only possible to show that two datasets
are unlikely to be the same. For this reason it is suggested that the matrix
elements AY X and BY X be used to indicate where it is unlikely that dataset
Y is a subset of dataset X. Any threshold that is chosen will be arbitrary but
anything lower than 0.05 indicates that the average probability for the points
measured is below 5% of the expected value, and this is a good working value.
The examples below will show how this works in practice.

4.4 Implementation of the statistical tools

The statistical tools used in this database are integrated into the plotting
package (’OxPlot’) linked to the database. There are three tools specifically
included which can be accessed from the [Tools] menu item of the plotter.

• PCA: This performs a principle components analysis (PCA) of the datasets
imported into the plotter. Users is prompted for which variables they wish
to include (e.g., SiO2, Al2O3, CaO). Running the analysis will generate the
PCA matrix and λ values for each component. This matrix can be exported
to a spreadsheet. In addition, running this analysis sets up a plot of the
data against the two principal components (PC1 and PC2).
• Ellipsoid matrix : This will calculate the matrix AY X based on multivari-

ate normal distributions as described above. The matrix generated can be
exported to a spreadsheet.
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• KDE matrix : This will calculates the matrix BY X based on kernel density
analysis as described above. The matrix can be exported to a spreadsheet.

In addition to the formal tools, the plotting routine also uses the same mathe-
matical formalism for another purpose. For each dataset plotted it is possible
to show either a multivariate normal distribution or a kernel density distri-
bution (based on normalised or unnormalised data, depending on the user’s
choice). In both cases the distribution can be represented either by a series
of contours (5, 10 or 20 levels) or as a single 95% probability contour (these
options are set under the [Format] menu. In the case of multivariate nor-
mal distributions the software puts an ellipse around the datasets, the kernel
density method puts a more free-form curve around the data. There is a con-
venient way to turn this form of display on and off for all datasets using [View
> Toggle ellipses] and [View > Toggle KDE]. Control of what is displayed for
each dataset is given under the [Edit > Data] option.

5 Example applications

In this section two different applications of the database will be examined
which are chosen to illustrate its utility. The first case study shows the way
in which the database can be used to help with the study of deposits at a
particular site. In this case the data are from cryptotephra and tephra deposits
found in the sediments of Soppensee (Lane et al., 2011b, 2012a). The second
case study will focus on the use of the database and the comparison tools
to summarise information about all of the tephras and cryptotephras in the
RESET tephra lattice.

5.1 Identification of tephra from Soppensee

The background to this study is presented in Lane et al. (2011b), with rele-
vant further discussion in Lane et al. (2012a). There are four deposits where
there are tephra-derived glass shards present: two are visible (Sop T4.74 and
Sop T5.95) and two are cryptotephra concentrations (Sop T5.19 and Sop T5.62).
The data for this case study are given in the supplementary online information,
organised into a table suitable for import into the plotting routine.

To use the database for an exercise like this, a blank TAS plot can be generated
from the database. Using the [Edit > Import] function of the plotter, the data
can then be pasted into the the plotter, and split by tephra/cryptotephra
deposit to give separate datasets for each deposit. From the database users can
then select glass-shard data from eruptives that are possible correlates with
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Fig. 11. Major element data for glass shards from tephra/cryptotephra deposits
from Soppensee plotted on a TAS plot with 95% KDE contours (See Le Maitre,
2002, for field key; data nomalised). This provides an immediate indication of the
most likely identifications for the different deposits. However, it can be seen that
Sop T5.62 could either be correlated with the Vedde or the Dimna Ash and it is not
immediately obvious which one is most likely. An aspect of the KDE implementation
is also visible here, shown by the Vedde ash data, which are highly bimodal; the
KDE contours are extended in the direction of the mixing line due to non-optimal
kernel choice (see section 4.2); this may not look ideal but in practice it means
that the KDE matrix will give higher values on a mixing line, even if no points are
present, than would be the case if the kernel choice was technically better.

the glass data for the unknown deposits. In this case the Vedde Ash (Birks
et al., 1996; Björck and Wasteg̊ard, 1999; Blockley et al., 2007; Davies et al.,
2001, 2005; Lane et al., 2012a,b; Lowe and Turney, 1997; Matthews et al.,
2011; Pilcher et al., 2005; Ranner et al., 2005; Schoning et al., 2001; Turney
et al., 1997, 2001, 2006; Wasteg̊ard et al., 1998, 2000), LST (Riede et al.,
2011; Turney et al., 2006; Finsinger et al., 2008; Lane et al., 2012b; Housley
et al., 2013), Dimna Ash (Lane et al., 2012a), and the Askja-S (Davies et al.,
2003; Turney et al., 2006; Pilcher et al., 2005; Lane et al., 2012b; Lind and
Wasteg̊ard, 2011) tephra deposits were chosen. These are added to the same
plot using the plot button from the database. This gives the data as shown in
Figure 11. It is possible to plot the data for all of the other major elements
by selecting [View > Multiplot].

Although such plots are useful for looking at the data, we would prefer to
quantify the possible matches. To do this we use the [Tools > Ellipsoid Matrix]
or [Tools > KDE Matrix] options. After choosing to use all the major element
data this gives us matrices that describe the possible matches available (Tables
2 and 3).

Either of these approaches give us a summary of what all of the different
major element glass-shard data tell us of possible matches. In practice the
two different methods give similar results, which in some ways in encouraging
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Datasets A B C D E F G H

A - Vedde Ash 1.000 0.002 0.077 0.000 0.000 0.000 0.006 0.000

B - LST 0.000 1.000 0.000 0.000 0.000 0.000 0.000 0.000

C - Dimna Ash 1.054 0.000 1.000 0.000 0.000 0.000 0.000 0.000

D - Askja-S 0.000 0.000 0.000 1.000 0.000 0.000 0.000 0.000

E - Sop T4.74 0.000 0.000 0.000 0.000 1.000 0.000 0.000 0.000

F - Sop T5.19 0.000 0.000 0.000 0.787 0.000 1.000 0.000 0.000

G - Sop T5.62 1.156 0.000 0.047 0.000 0.000 0.000 1.000 0.000

H - Sop T5.95 0.000 0.046 0.000 0.000 0.000 0.000 0.000 1.000

Table 2
Matrix AY X based on multivatiate normal probability distributions (SiO2, TiO2,
Al2O3, FeOt, MnO, MgO, CaO, Na2O, K2O) for glass from the tephra and cryp-
toephra deposits found in Soppensee, and for glass from tephras which might be
possible matches

Datasets A B C D E F G H

A - Vedde Ash 1.000 0.002 0.104 0.000 0.000 0.000 0.030 0.000

B - LST 0.000 1.000 0.000 0.000 0.000 0.000 0.000 0.000

C - Dimna Ash 1.301 0.000 1.000 0.000 0.000 0.000 0.000 0.000

D - Askja-S 0.000 0.000 0.000 1.000 0.000 0.000 0.000 0.000

E - Sop T4.74 0.000 0.000 0.000 0.000 1.000 0.000 0.000 0.000

F - Sop T5.19 0.000 0.000 0.000 0.592 0.000 1.000 0.000 0.000

G - Sop T5.62 1.239 0.000 0.100 0.000 0.000 0.000 1.000 0.000

H - Sop T5.95 0.000 0.028 0.000 0.000 0.000 0.000 0.000 1.000

Table 3
Matrix BY X based on KDE probability distributions (SiO2, TiO2, Al2O3, FeOt,
MnO, MgO, CaO, Na2O, K2O)

as it implies that the matrix method is not too dependent on the method used
to generate the distribution. In both cases there is no match for Sop T4.74.
In fact this visible tephra is thought to be the Vasset Killian tephra from the
Massif Central (for which there were no data in the database). Sop T5.19, also
manifest as a visible tephra layer, can clearly be correlated with the Askja 10-
ka tephra. Sop T5.62 (a cryptotephra) matches better with the Vedde than
with the Dimna Ash (by a factor of 25 by the multivariate normal method and
by a factor of 12 by the more robust KDE method) which is a useful finding.
In these three cases the tools provided do seem to do what was intended. The
numbers show that the method is asymmetrical and show, for example, that
Sop T5.19 is very likely to be a subset of Askja S but the Askja-S tephra
would not be likely to be a subset of a tephra fully represented by Sop T5.19.
This makes sense and shows that the approach can achieve something which
statistical distance methods could not.

However, where the method appears not to work so well is with the tephra
layer Sop T5.95, because both methods show a possible weak link to the LST
(slightly weaker with the KDE method). However, it is thought that this visible
tephra almost certainly is the LST. It is worth considering the reasons for this
weakness in KDE correlation in more detail. To do this the other tools within
the plotter can be used. Selecting out just the data for the LST and Sop T5.95,
a principal components analysis can be performed, and a plot of the data with
KDE contours generated (Figure 12). Here the reason for the poor match can
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Fig. 12. Principal components analysis of tephra from the LST with that from the
Sop T5.95 layer in Soppensee, which is thought to come from the same eruption. The
Sop T5.95 compositions fall in a low-point in the multimodal distribution from the
LST and therefore only provide a weak statistical match. However this is most likely
because the LST data in the database is not representative of the compositional
range of the entire eruption deposits.

be seen: the data from Sop T5.95 occupy a space not populated by the LST
dataset, even though they do lie within the overall envelope. Presumably this is
because the reference dataset is not yet fully representative of all compositions
from the eruption. In this case, although the tools have not done exactly what
was intended in finding a match, they have helped to explore the differences
between the datasets.

5.2 Glass from the RESET tephra lattice

The second application of the comparison tools is to use them to look at a
large dataset of glass-shard compositional data found in the database. The
tephras chosen are the late Quaternary layers discussed in Bronk Ramsey
et al. (2014b). Because glass compositions of tephras or cryptotephras from
the Northern and Western European volcanic centres (Iceland, France and
Germany) will be easily distinguished from those of Southern Europe, the
tephras are split into two groups; this will just have the effect of making the
matrices generated easier to display. In practice, the mathematical operations
are sufficiently fast that analsyes of glass shards from large number of different
tephras can be investigated at the same time.

The selected tephra layers generated from Northern and Western European
centres (including Iceland), with major element data, are: Saksunarvatn (Wasteg̊ard
et al., 2001; Dugmore and Newton, 1997; Andrews et al., 2002; Pyne-O’Donnell,
2007; Birks et al., 1996; Lind and Wasteg̊ard, 2011; Bramham-Law et al.,
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Datasets A B C D E F G

A - Saksunarvatn 1.000 0.000 0.000 0.000 0.000 0.000 0.000

B - Askja-S 0.000 1.000 0.000 0.000 0.000 0.000 0.000

C - AF555 0.000 0.000 1.000 0.607 0.000 0.000 0.000

D - Vedde Ash 0.000 0.000 0.000 1.000 0.002 0.000 0.000

E - LST 0.000 0.000 0.000 0.000 1.000 0.000 0.000

F - Penifiler Tephra 0.000 0.000 0.000 0.000 0.000 1.000 0.602

G - Borrobol 0.000 0.000 0.000 0.000 0.000 0.673 1.000

Table 4
Matrix AY X based on multivatiate normal probability distributions (SiO2, TiO2,
Al2O3, FeOt, MnO, MgO, CaO, Na2O, K2O) for tephra from Northern and Western
Europe which are important in the RESET tephra lattice

Datasets A B C D E F G

A - Saksunarvatn 1.000 0.000 0.000 0.001 0.000 0.000 0.000

B - Askja-S 0.000 1.000 0.000 0.000 0.000 0.000 0.000

C - AF555 0.000 0.000 1.000 0.498 0.000 0.000 0.000

D - Vedde Ash 0.000 0.000 0.000 1.000 0.002 0.000 0.000

E - LST 0.000 0.000 0.000 0.000 1.000 0.000 0.000

F - Penifiler Tephra 0.000 0.000 0.000 0.000 0.000 1.000 0.650

G - Borrobol 0.000 0.000 0.000 0.000 0.000 0.601 1.000

Table 5
Matrix BY X based on KDE probability distributions (SiO2, TiO2, Al2O3, FeOt,
MnO, MgO, CaO, Na2O, K2O) for tephra from Northern and Western Europe which
are important in the RESET tephra lattice

2013), Askja-S (Davies et al., 2003; Lane et al., 2011b, 2012b; Lind and
Wasteg̊ard, 2011; Pilcher et al., 2005; Turney et al., 2006), Abernethy AF555
(Matthews et al., 2011), Vedde Ash (Birks et al., 1996; Björck and Wasteg̊ard,
1999; Blockley et al., 2007; Davies et al., 2001, 2005; Lane et al., 2011a,c,b,
2012a,b; Lowe and Turney, 1997; Matthews et al., 2011; Pilcher et al., 2005;
Ranner et al., 2005; Schoning et al., 2001; Turney et al., 1997, 2001, 2006;
Wasteg̊ard et al., 1998, 2000), LST (Riede et al., 2011; Lane et al., 2011b,
2012b; Turney et al., 2006; Finsinger et al., 2008; Housley et al., 2013), Penifiler
(Matthews et al. (2011); Pyne-O’Donnell (2007); Pyne-O’Donnell et al. (2008),
and originally identified as the Borrobol in Davies et al. (2003)) and Borrobol
(Matthews et al., 2011; Pyne-O’Donnell, 2007; Ranner et al., 2005; Turney
et al., 1997, 2001). A combined TAS plot for glass-shard analyses from these
tephras is shown in Figure 13, with details of the major element compositions
shown in Figure 14. Although such plots can be somewhat confusing, with
the danger of glass data from different eruptives plotting over one another,
because they can be quickly generated from the database, they do provide a
way to visualise the spread of glass compositions for a whole region.

As with the case of the single site study for Soppensee, the multivariate nor-
mal and KDE matrices can be used to see which glass analyses overlap in the
multidimensional space defined by the major element compositions. As with
the single site example it turns out that the two different approaches (matri-
ces A shown in Table 4 and B in Table 5) yield very similar conclusions. As
an example, AF555 might be mistaken for the Vedde Ash (or indeed for sev-
eral other minor related tephra from that period that probably all share the
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tephra/cryptotephra deposits from Northern and Western Europe (c.f. Figure 13).
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same source), but it is very unlikely that the Vedde Ash would be mistaken
for AF555, from the numerical analysis given here. Of course this conclusion
needs to be treated with some caution: this could, for example, be partly be-
cause only have a small subset of the original AF555 tephra is present in the
distal samples. Chemical data must clearly alway only be considered alongside
stratigraphic information.

The next task is to look at the much larger number of tephras layers in this se-
lection from sources in the Mediterranean region. Here we have major element
data for glass shards from Pomici Principali (Lane et al., 2011a; Lowe et al.,
2007; Magny et al., 2006; Smith et al., 2011; Tomlinson et al., 2012a; Wulf
et al., 2004, 2007), Soccavo 1(Smith et al., 2011; Albert et al., 2012), Neapoli-
tan Yellow Tuff (NYT; Bourne et al., 2010; Lane et al., 2011a; Magny et al.,
2006; Tomlinson et al., 2012a; Wulf et al., 2004, 2007), Biancavilla-Montalto
Ignimbrite (Y1; Douka et al., 2014), TM11 (Wulf et al., 2004, 2007), Verdoline
(Wulf et al., 2004, 2007; Bourne et al., 2010; Tomlinson et al., 2014a), Cape
Riva (Y2; Wulf et al., 2002; Margari et al., 2007; Kwiecien et al., 2008), Pomici
di Base (Wulf et al., 2004, 2007), Y3 (Wulf et al., 2004, 2007; Bourne et al.,
2010; Vogel et al., 2009; Tomlinson et al., 2012a), Codola (Bourne et al., 2010;
Wulf et al., 2004, 2007; Vogel et al., 2009; Tomlinson et al., 2014a), Campanian
Ignimbrite (Y5, C13; Bourne et al., 2010; Douka et al., 2014; Margari et al.,
2007; Morley and Woodward, 2011; Pyle et al., 2006; Seymour and Christa-
nis, 1995; Tomlinson et al., 2012a; Vogel et al., 2009; Wulf et al., 2004, 2007),
Green Tuff (Y6; Vogel et al., 2009), Nisyros Upper Pumice (Margari et al.,
2007; Tomlinson et al., 2012b), and Mount Epomeo Green Tuff (MEGT, Y7;
Wulf et al., 2004, 2007; Bourne et al., 2010; Tomlinson et al., 2014b).

Figures 15 and 16 show the TAS plot and detailed major element plots for these
data, again providing a broad overview of the range of compositions present.
Table 6 shows the matrix A based on multivariate normal statistics and Ta-
ble 7 the matrix B based on KDE distributions. As with the other example
applications, the conclusions are broadly similar using the two approaches.
The consequences of these analyses are discussed from the point-of-view of
the tephra lattice in Bronk Ramsey et al. (2014b).

Although there is little difference between the multivariate normal and KDE
matrices, it is apparent from Figure 10 that the kernel density distribution
does better represent the distribution of glass compositions. As both methods
are easily applied, it seems most appropriate to use the KDE matrix if only
one is used. However, by looking at both matrices it is possible to test how
robust the conclusions are under different assumptions.
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Fig. 15. TAS plot (normalised) for glass shard analyses for tephra/cryptotephra
deposits from the Mediterranean region which are components of the RESET tephra
lattice (Bronk Ramsey et al., 2014b).
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Fig. 16. Major element plots (normalised) for glass shard analyses for
tephra/cryptotephra deposits from the Mediterranean region (c.f. Figure 15).
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6 Conclusions

Data per se are only valuable if they can be used. As datasets become larger
and more complex, retaining usability becomes a larger challenge. Tephra
studies do generate large quantities of data, and the RESET database has
been designed to ensure that these datasets remain useful for researchers across
many different projects. The aim of this database is to make the data useful,
not only by making navigation of the database easy, but also by providing
tools for visualisation and statistical analysis of the data which are directly
linked with the database itself. These functions do not require the installation
of any special software and so allow anyone to explore the data freely.

There are more things that could be done to the database to develop it further:
in particular, as people use the database more, it is expected that new types
of database query might be added. However, the framework used to generate
the database is very flexible and so should be relatively easy to modify. The
other import aspect of a working will be the management of additions to the
database from new publications.

This database has also already spawned other tools. In particular, the IN-
TIMATE database and chronological integration tool (Bronk Ramsey et al.,
2014a) grew directly from the framework of the RESET database. Likewise
the mapping elements within OxCal (Bronk Ramsey and Lee, 2013) were a
byproduct of the RESET mapping functions. Together these provide a whole
group of tools that can help in Quaternary research.
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Y., Horz, K., Jacob, D. E., Kasemann, S. A., Kent, A. J. R., Ludwig, T.,
Zack, T., Mason, P. R. D., Meixner, A., Rosner, M., Misawa, K., Nash,
B. P., Pfänder, J., Premo, W. R., Sun, W. D., Tiepolo, M., Vannucci, R.,
Vennemann, T., Wayne, D., Woodhead, J. D., 2006. MPI-DING reference
glasses for in situ microanalysis: New reference values for element concen-
trations and isotope ratios. Geochemistry, Geophysics, Geosystems 7 (2).
URL http://dx.doi.org/10.1029/2005GC001060

Kwiecien, O., Arz, H. W., Lamy, F., Wulf, S., Bahr, A., Röhl, U., Haug,
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A Supplementary Information

A.1 Glass-shard major element data (non-normalised) for the Soppensee case
study

Layer SiO2 TiO2 Al2O3 FeOt* MnO MgO CaO Na2O K2O total

Sop T4.74 67.12 0.46 15.38 1.96 0.21 0.22 0.70 5.37 5.82 97.24

Sop T4.74 65.41 0.40 15.60 1.84 0.19 0.22 0.86 5.14 5.58 95.23

Sop T4.74 67.62 0.46 15.39 1.82 0.24 0.25 0.71 5.16 5.88 97.52

Sop T4.74 65.13 0.08 20.05 0.65 0.00 0.04 2.16 7.82 3.50 99.44

Sop T4.74 66.94 0.27 17.35 1.01 0.11 0.14 0.76 6.15 6.44 99.16

Sop T4.74 66.27 0.38 15.67 1.74 0.22 0.21 0.88 5.49 5.37 96.23

Sop T4.74 66.67 0.33 16.44 1.47 0.17 0.24 0.99 6.11 5.59 98.02

Sop T4.74 67.58 0.43 15.67 1.87 0.25 0.22 0.75 5.66 5.72 98.14

Sop T4.74 64.86 0.04 20.25 0.48 0.00 0.02 2.23 8.10 3.37 99.36

Sop T4.74 66.07 0.13 18.31 0.70 0.02 0.06 0.84 6.58 6.28 98.98

Sop T4.74 68.67 0.42 14.86 1.97 0.27 0.22 0.64 5.45 5.47 97.94

Sop T4.74 67.27 0.24 17.55 1.12 0.17 0.11 1.16 6.84 4.96 99.40

Sop T4.74 65.44 0.18 18.52 0.79 0.11 0.06 1.23 6.83 5.27 98.42

Sop T4.74 66.53 0.29 16.49 1.35 0.21 0.15 0.70 5.77 6.03 97.52

Sop T4.74 65.52 0.41 15.54 1.59 0.22 0.21 0.88 5.24 5.34 94.95

Sop T4.74 65.33 0.35 16.35 1.42 0.17 0.20 1.02 5.84 5.42 96.09

Sop T4.74 64.59 0.06 20.21 0.53 0.00 0.02 2.07 7.64 4.03 99.16

Sop T4.74 67.17 0.44 15.87 1.80 0.20 0.25 0.74 5.63 5.79 97.89

Sop T4.74 66.70 0.37 16.91 1.58 0.19 0.19 1.34 6.17 4.94 98.39

Sop T4.74 65.50 0.22 18.61 1.25 0.14 0.12 1.92 6.72 4.34 98.82

Sop T4.74 65.71 0.18 19.48 0.83 0.04 0.05 2.05 7.62 3.66 99.63

Sop T4.74 66.81 0.48 14.82 2.15 0.30 0.24 0.65 5.09 5.89 96.43

Sop T4.74 66.66 0.18 18.23 0.87 0.03 0.05 1.01 6.85 5.50 99.37

Sop T4.74 65.44 0.10 19.01 0.62 0.09 0.02 0.99 7.08 5.56 98.92

Sop T5.19 75.19 0.31 12.36 2.55 0.08 0.25 1.64 3.84 2.53 98.74

Sop T5.19 73.98 0.29 12.39 2.43 0.07 0.24 1.48 3.89 2.56 97.33

Sop T5.19 75.76 0.31 12.48 2.69 0.00 0.19 1.59 3.89 2.53 99.45

Sop T5.19 72.71 0.31 11.85 2.37 0.00 0.24 1.67 4.04 2.38 95.70

Sop T5.19 73.00 0.26 11.77 2.46 0.06 0.24 1.60 4.08 2.39 95.98

Sop T5.62 71.08 0.31 13.57 3.77 0.12 0.23 1.35 4.47 3.60 98.49

Sop T5.62 69.50 0.28 13.36 3.54 0.10 0.21 1.19 4.60 3.23 96.01

Sop T5.62 71.08 0.29 13.76 3.66 0.19 0.21 1.26 4.81 3.38 98.65

Sop T5.62 71.55 0.28 13.70 3.71 0.19 0.21 1.30 4.49 3.52 98.95

Sop T5.62 70.10 0.26 13.35 3.64 0.13 0.21 1.28 4.89 3.47 97.33

Sop T5.62 68.72 0.27 12.73 3.53 0.13 0.18 1.24 4.93 3.35 95.06

Sop T5.62 72.46 0.29 13.53 3.87 0.11 0.21 1.30 5.36 3.41 100.52

Sop T5.62 72.44 0.30 13.72 3.82 0.22 0.20 1.27 5.07 3.50 100.54

Sop T5.95 57.70 0.23 22.79 1.64 0.21 0.04 0.91 10.74 5.56 100.25

Sop T5.95 57.38 0.24 22.80 1.72 0.29 0.04 0.90 10.43 5.61 99.84

Sop T5.95 57.47 0.21 22.76 1.93 0.25 0.05 0.79 10.64 5.62 100.16

Sop T5.95 57.20 0.20 23.01 1.81 0.28 0.08 0.74 10.88 5.64 100.22

Sop T5.95 57.15 0.26 23.05 1.75 0.36 0.07 0.88 10.35 5.52 99.88

Sop T5.95 57.95 0.19 22.90 1.71 0.31 0.05 0.91 10.29 5.71 100.49

Sop T5.95 57.41 0.21 23.12 1.73 0.36 0.06 0.90 10.73 5.66 100.59

Sop T5.95 56.04 0.17 22.56 1.86 0.39 0.08 0.88 9.86 5.38 97.66

Sop T5.95 59.26 0.24 22.33 1.74 0.36 0.03 1.09 9.81 5.32 100.44

Sop T5.95 58.33 0.21 22.88 1.37 0.22 0.03 1.05 10.31 4.79 99.60

Sop T5.95 55.88 0.23 22.00 1.72 0.23 0.13 1.25 10.23 4.99 97.13

Sop T5.95 57.25 0.19 23.19 1.65 0.35 0.04 0.74 11.30 5.19 100.34

Sop T5.95 57.50 0.20 22.62 1.91 0.30 0.06 0.87 10.54 5.58 100.03

Sop T5.95 57.89 0.26 22.51 1.77 0.33 0.04 0.86 10.41 5.62 100.16
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Layer SiO2 TiO2 Al2O3 FeOt* MnO MgO CaO Na2O K2O total

Sop T5.95 57.51 0.22 22.84 1.75 0.33 0.10 0.87 10.81 5.65 100.51

Sop T5.95 56.79 0.22 23.41 1.70 0.28 0.05 0.74 10.74 5.22 99.64

Sop T5.95 57.55 0.21 23.01 1.68 0.23 0.07 0.85 10.71 5.54 100.27

Sop T5.95 55.09 0.18 22.54 1.69 0.26 0.03 0.95 9.95 5.41 96.61

Sop T5.95 57.59 0.21 22.75 1.95 0.25 0.07 0.89 10.81 5.69 100.62

Sop T5.95 57.38 0.19 22.40 1.79 0.24 0.05 0.82 11.10 5.34 99.74

Sop T5.95 57.87 0.18 23.13 1.71 0.32 0.10 0.88 10.56 5.56 100.77

Sop T5.95 58.23 0.22 23.07 1.89 0.22 0.03 0.99 10.43 5.39 100.92

Sop T5.95 59.54 0.08 22.62 1.17 0.25 0.03 1.05 9.94 4.99 99.96

Sop T5.95 57.74 0.21 22.96 1.64 0.29 0.07 0.92 10.31 5.53 100.23

Sop T5.95 57.92 0.20 22.71 1.77 0.32 0.05 0.86 10.34 5.68 100.26

Sop T5.95 57.70 0.27 23.60 1.79 0.31 0.06 0.87 10.34 5.51 100.92

Sop T5.95 57.66 0.18 22.85 1.71 0.28 0.04 1.04 10.17 5.66 100.01

Sop T5.95 57.51 0.16 23.34 1.92 0.24 0.06 0.72 11.03 5.40 100.78

Sop T5.95 55.82 0.19 22.00 1.68 0.29 0.08 0.86 10.14 5.56 97.07

Sop T5.95 57.58 0.18 22.81 1.42 0.28 0.08 0.70 10.32 5.28 99.20

Sop T5.95 57.89 0.24 22.65 1.80 0.18 0.05 0.79 10.26 5.59 99.87

Sop T5.95 59.85 0.10 21.76 1.00 0.18 0.05 1.02 8.77 6.21 99.22

Sop T5.95 57.72 0.24 22.96 1.82 0.28 0.06 0.89 9.84 5.50 99.80

Sop T5.95 57.27 0.23 22.80 1.71 0.24 0.03 0.87 10.42 5.48 99.55

Sop T5.95 57.80 0.18 22.52 1.80 0.32 0.06 0.84 10.25 5.54 99.73

* total iron oxides
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