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Introduction

Cedarville University’s geology program initiated the use of 3D printing in the spring of 2015 with the
hope of presenting a poster at the Geological Society of America Annual Meeting in Baltimore in early
November. With the acquisition of two DJI Phantom drones, the program began exploring applications
of drone usage, which led to the process of capturing geo-referenced images to use in 3D printing.
Through much trial and error, and the gracious help of the engineering department, the geology
program has printed several successful 3D models. These models include landscape models from
around the country, a Dilophosaurus skull, and a Dreadnoughtus front limb.

3D printers require an STL file (a STereolithography file) or OBJ file. However, there are numerous ways
to generate these, from a variety of sources, using an even wider range of software. Many open-source
programs exist that work fine; this guide will try to focus on those. However, some more-expensive (>
S0) software may yield better results and accomplish what it might take a couple other free programs
to. It pays to shop around, and you might discover a clearer / easier method than what’s described
here.

This is only an outline; as such, it won’t go too in-depth on any of the programs, but rather show you the
bare-bones procedures. Plenty of videos, web pages, and other resources are out there if you look.

And, considering how this field (along with that of UAV / drone usage) is exploding, much more is sure to
come!

Please check out the Appendices for some helpful resources and descriptions of file types and programs
referenced in this guide.

If you have any suggestions on adding to or editing this guide, please don’t hesitate to make them!
Some sections are very bare-bones, or incomplete and or unorganized, or all of the above. Our work
with drones and 3D printing will continue, and I'll update and edit this guide as we progress. If you'd like
new versions as they come, or just have some questions or comments, please don’t hesitate to e-mail
me at dylanmckevitt@cedarville.edu.

Oh, and our research poster detailing some of the processes outlined in this guide was presented at the
GSA Annual Meeting in Baltimore on November 4™; Paper No. 289-5, Booth 61. A digital copy should be
available online soon.

So, grab a cup of coffee or seltzer water mixed with fruit juice, crank some of your favorite Spotify or
ITunes jams, and have some fun!

D.] . McKevitt, November 2015
Cedarville uniVerSity ‘15

November 6, 2016: Well, although I’'m busy with M.Sc. work at Laurentian University and haven’t really
touched 3D printing since writing Draft 4, thanks to Ben S. who emailed me a question and gave me
reason to revisit and update part of this manual (Section 7)... albeit with a coffee and hot chocolate mix
instead of seltzer water and fruit juice! dmckevitt@laurentian.ca
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Section I: Starting With a Sequence of Ovetlapping Images (Photos).

Using UAVs, it is possible to obtain a series of overlapping images that can be processed into a DEM.

Pix4D
For processing in Pix4D, the captured images should be geo-referenced. If using a DJI drone, the DJI app
can be used to create a pre-planned flight, allowing the user to set a specific number of way-points to
which the drone will fly. Images can be taken along route via an automatic image capturing feature or
manually.

Process the images (reference to Pix4D site in Appendix C). Output either a final 3D model (in OBJ
format) for use in Blender (Section 5), or a point cloud file (PLY, XYZ, LAS, or LAZ format) for processing
in a program like MeshLab (this section, MeshLab subsection).

VisualSEFM

See Appendix C for info about this free program. Follow the instructions provided on the website to
avoid headaches in setting up and running the program on your computer.

Once set up, it only takes four easy (but time-consuming) steps to generate a PLY pointcloud! (1) Load
your photos. (2) Match the images. (3) Sparse reconstruction. (4) Dense reconstruction.

|4 visualSFm - [Sparse Reconstruction] - [0] - [] - a X

3 .

File Sﬁl\c_ﬂ..\u’iew Tools  Help v, s, . ~
=’ heY ) . S ot . bldi | Failed to find two images for initizlization
1 : =B B o2e | b3+ M iﬁ" M BASE A (W A S Resuming 5 finished, 54 sec used
Yeans® ST AP ) L et cat
1 2 4 at

| 50 cams, 16843 pts (3+: 12887)
cat | 146227 projections (3+: 138738)

1
qu 1 model(s) reconstructed from 51 images;
cat | 50 modeled; 0 reused; 51 EXIF;
. 10MB(7) used to store feature location.
a

e —— - et ) cat

b
timirn

s [ile | Structure-From-Motion finished, 55 sec used
42,5(36.5) seconds on Bundle Adjustment {+)
i = 41,4(35.9) seconds on Bundle Adjustment {*)
cat

Run full 30 reconstruction, finished
| Totally 55.000 seconds used

!
Work thread terminated! v

Once you’ve output a PLY pointcloud, you can turn it into a mesh and export it as a 3D surface (STL, OBJ,
etc.) using Meshlab (subsection in this section).

Arc 3D

If you have a bunch of images but lack the processing power or resources to generate a point cloud, or if
you just want an “easy way out”, simply use Arc 3D’s free webservice (referenced in Appendix C) where
you just upload your images, let them do all the work, and receive a textured OBl file. True piece of
cake.

MeshLab
In MeshLab, navigate to File>Import Mesh, and select your point cloud. Once opened, you first need
to compute the normals for the points; Filters=>Normals, Curvatures and Orientation—> Compute
normals for point set, and apply. This may take a few moments.
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& MeshLab_64bit v1.3.3 - [Project_1] = [m] X
® File Edit Filters Render View Windows Tools Help &8 X

hNFwvceomEa T B3 0 QPMm cOH® -« /WS Th- X XX

Project_1 B X

' 0 Small.ply* (7] :: L e

Compute the normals of the vertices of a mesh without exploiting the triangle
connectivity, useful for dataset with no faces

Neighbour num l 10

Smooth Iteration l 0

[ Flip normals w.r.t. viewpoint
vewontpos, | o] o] o] cet [vewde
Default Help

Close Apply as 2

work on PointSet A
Hesh has no per vertex radius.
Computed and added using

default neighbourhood

Harching cubes HLS meshing

done.

Applied filter Marching Cubes
( in 140
Applied filter Di
Mesh: Small.ply Mesh in 188 msec
Vertices: 4249248
Faces: 0 v

ete Current

Wanna see a fuzzy blue Pomeranian? Render—>Show Normal/Curvature.

& MeshLab_64bit v1.3.3 - [Project_1] — m]
@ File Edit Filters Render View Windows Tools Help - &)X

NFwceomEes TEBA I AIQEN SONS - /Wi Th- X XX

Project_1 B x

< 0 smallply* (752 @ @

Use the points and normal to build a surface using
the Poisson Surface reconstruction approach.

i s

Surface offsetting |1 ]

Default

A
Applied f
Mesh in 1¢
Applied fil
Mesh: Small.ply
Vertices: 4249248
Faces: 0 v

Next, Filters—>Remeshing, Simplification, and Reconstruction—> Surface Reconstruction: Poisson.
Options here include setting the Octree Depth and Solver Divide; select the “Help” button for a brief
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description of both. | found setting the Octree Depth at 10 and Solver Divide at 8 worked pretty well.
Select Apply, and once it says “Not Responding” go grab a cup of coffee, or take your un-blue (but still
fuzzy) Pomeranian for a walk.

& MeshLab_64bit v1.3.3 - [Project 1] - o -

& File Edit Filters Render View Windows Tools Help - & X
hFevcomsEs D B@ V1020 SONS - & /Wi Ta- X XX

Project_1 5 X

50 Small.ply * @B m e
ﬂ' 2 Poisson mesh ™[] r: mm o

< >

Hormal -Curvature A
Disabled Decorate mode Show
Hormal-Curvature

Successfully created a mesh of
853613 wert and 1706669 faces
Successfully created a mesh of
853613 faces

Applied filter Surface
Reconstruction: Poisson in 1116814
nEsc

When you return, a strange shape may surround your point cloud. That’s just the result of the Poisson
meshing. You can change the viewing options in the Dialog box to the right to “hide” your point cloud.
Also, note the old Render->Lighting—> Double side lighting trick. To simplify the mesh for further work,
make sure your mesh is selected and simply navigate to Filters—> Cleaning and Repairing—> Select Faces
with edges longer than..., check the “Preview” box, and move the slide bar to select whatever part of
the mesh you want to delete. Apply. Finally, just click on the Delete Faces and Vertices button in the
upper right.
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& Meshlab_64bit v1.3.3 - [Project_1] - ] -

& File FEdit Filters Render View Windows Tools Help “'..‘5 x
. — § : . ) Dl A & .
NEBeesES TIO@ 0 10N cOHES & /W Th X XK}
Project_1 ‘ent @ x

o smalpy (720 @ @ 0

% 2 Poisson mesh * @ :: m m EI

< >

853613 wert and 1706669 faces ~
Successfully created a mesh of
853613 faces

Applied filter Surface
Reconstruction: Poisson in 111814

nEsc
Selected 134 face=s with and edge
longer than 30.624100

Applied filter Select Faces with
edges longer than. .. in 63 msec

Next, you should clean the mesh. Many options lie under Filters> Cleaning and Repairing; for details, |
refer you to Mister P.’s amazing YouTube Tutorials (referenced in Appendix A).

Simplifying the mesh is the logical next step; this is also helpful on large file-size meshes produced in
Blender that you want to downsize without losing too much (if any) resolution. Simply choose
Filters=>Remeshing, Simplification and Reconstruction->Quadric Edge Collapse Decimation. This filter
can be repeated multiple times. For details, | once again refer you to Mister P. Or if you're tired of
hearing his music for the moment, proceed by setting either the percentage reduction (as a decimal;
usually 0.5 works good for the first iteration), or Target number of faces (compared to the current
number, noted at the bottom right of the window—the value in parentheses refers to all the open point
clouds / meshes, while the other refers only to the selected object). Apply, export the mesh, and be
amazed at how much the file size dropped!




So, You Want to 3D Print a Landscape? An Outline of Some Methods

& Meshlab_64bit v1.3.3 - [Project_1]
& File Edit Filters Render View Windows Toels Help

NFwceEE = O 00

""stanmmmannnt?

[return to Contents]

- [m]

x

- 8 x

I QM cOM® - /B iTh- X XX

Simpdfy 2 mesh using 2 Quadric based Edge Colapse
Strategy; better than dustering but slower

853267
N

[ Preserve Boundary of the mesh

Boundary Preserving Weight

[] Preserve Mormal

Target number of faces

Quality threshold

[ Preserve Topology

Optimal position of simplified vertices
[ Planar Simplification

[ weighted Simplification
Post-simplification deaning

[ simplify only selected faces

Project_1

GIFECEE
ﬂ?‘ 2 Poisson mesh @ :: B m EI

|~ 0 Small.ply*

<

>

Successfully created a mesh of
853613 faces

Applied filter Surface
Reconstruction: Poilsson in
111814 msec

Selected 134 faces with and edge
longer than 30.624100

Applied filter Select Faces with
edges longer than in 63 ms=c
Applied filter Delete Selected
Faces and Vertices in 156 n=ec

-

The mesh can be saved and exported in a variety of formats simply by choosing File>Export Mesh As.
Proceed to giving the model “thickness” in Blender (one of three methods in Section 5) (or, if you

brought the model in from Blender for simplifying / cleaning you’re done!).
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Section 2: Starting With Video.

Some software (including Pix4D) allows the extraction of a sequence of overlapping images from video,
which can in turn be processed as outlined in Section 1. The author hasn’t tested this technique yet...

Section 3: Starting With Elevation Data in General.

A quick search of the internet will reveal a plethora of freely available elevation data for areas around
the world, from county-size scale and larger to country-wide scale. This free data can be imported into
ArcGIS and manipulated in ArcMap to generate a DEM (as a .jpg or .png image), which can then be
converted into a printable, STL file using other software (e.g. Blender). ArcMap features diverse tools in
ArcToolbox for converting between different data types. Or, a cheaper (and easier option) utilizes
3DEM and AccuTrans 3D — see Appendix C for general info concerning these programs and how to
acquire them.

Section 4: Starting with DEM, TIN, GeoTIFF, LAS... Data.

If you have a DEM or TIN, then you’re already halfway to printing a 3D model! ArcMap has tools in
ArcToolbox for converting between TINs and DEMs (referred to as ‘Raster’ in ArcMap). ArcMap can also
generate contour lines from TINs or DEMs... but for our projects, that’s going in the wrong direction. If
you have an “image” DEM (e.g. in PNG or JPG format), as is obtained from ArcMap, then proceed to
Section 5. However, if your DEM is in another format (e.g. GeoTIFF, ASCII DEM, LAS,...), as is commonly
obtained from many internet sources, you can bypass ArcGIS and quickly utilize some free (or nearly so)
programs to generate a 3D model—see the rest of this section.

For select locations, you can obtain DEM data from http://opentopography.org/ (see Appendix A). For
this example, | selected Wizard Island in Crater Lake National Park. Data files available from this site
include LAS and GeoTIFF DEMs. Here are workflows for either of these file types that consequently work
with many other DEM data types... experiment with these programs for yourself!

3DEM and AccuTrans 3D
See Appendix C for info about these programs and how to obtain them.

We’ll use 3DEM to convert our LAS digital elevation model file (just one of many accepted by 3DEM) to a
USGS ASCII DEM. Select File>Load Terrain Model, select your file, and open it.



http://opentopography.org/
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Select DEM File Type [=]
— File Tupe

" USGS DEM " GeaTiff DEM
[dem, tar.gz, taz, gz) [tif]

" SATM Data  Tenain Matriz
[hat. bil) [bir, t=t])

= GLOEE Tile  GTOPO30 Tile
[zelected from map) [zelected from map)

& LIDAR Paint Cloud  ¥Z Paint Cloud
[las] [bin, txt)

& Mars MOLA " Mars Polar MOLA
[megt.ima) [megt.ima)

ok | Cancel |

A window will pop-up allowing you to change the resolution of your LIDAR DEM. | just accepted the
defaults.

==’ 3DEM Terrain Visualization [a][@]=]
File Operation GPS ColorScale Geo Coordinates Help

East Elevation
877275 m = 61720 m

10
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Although this program has many other useful applications (explore them if you have time!), for this
example we’ll simply navigate to File=>Save USGS ASCII DEM.

Next, open AccuTrans 3D. Select File>Open DEM As>USGS 1-degree (ASCIl) (*.dem) [or whatever file
type you have].

@l AccuTrans 3D(x64) - Version 2015.0.0 - [ WizardlslandDEM_from3DEM.dem | - m] x
File Prefs Work Area Layers Viewer Camera Display Show Dem Help
= F @ P R P = a} ich [P Cos DEM | Change &
Open AKF Optien Reliad Batch hﬁi Test Model ga g 05.. Bu&n EEE St SlktaftHelp 9
Pl Edit  Apply [femove [rema Edit Select Main Step-> + 10 30.0
éad Batch Batch S&Z‘F{‘st.':'ﬂl'fj {Rﬂ Layers Layers P -
Edit DEM East 20,0
G G
North 0.0
N .
(e Height 30
== 50
Tl 4 o0
I-IE an
WIRE @@ 0
3 5.0
Y
20.0
| 250
30.0
o
0
gt
A
Region
Cols 6317 Rows (6315
11 12
X 20 Y 20
Width |12632.0 Depth |12623.0
! MinZ 61720 Max Z 12.620.0
I__y Region
shart gNorm 6315 2623.0
%5 West East
1 0 6317 12632.0
OGL| Edie Tight 1 (€2 €03 (19007556172 30.0 G, LRl e [oys [2>
| Bkgrd |?itehs Top E@( Battom g:olom g:olam %m : “fov ward Rotate Rotate Rotate South |1 0
Lamera  Ho render 34 >5 I (Cilut [-%- C- 2 <-c-> 5 [Center| (9[: ou
FReset Bkard sbi?itehs Iﬁ Front H@lt g}om g:olam Zaorﬁ‘Zoom‘ g:olom g}om 2% Center Cenfer Pin EP'"*" Civat] Fast|Halate
70l n i e
< >

Now, select (from the top) Dem->Convert to 3D (less water), and modify the vertex interval if you'd like
to reduce the number of vertices / triangles. Select OK.

11
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@ AccuTrans 3D(x64) - Version 2 - [ WizardlslandDEM_from3DEM.dem | — ] =

File Prefs WorkArea Layers Viewer Camera Display Show Clipboard Tools_1 Tools 2 Tools.3 Align Help
F & F F P R Adust T2 T4 i [ s Layers | Edit ~
Open AKF option Reboad Batch E!i Tent Model Add Save Mg Opten Bima Dbjest Hi—s 5 1 ST s\taftHew yers |

PPl Edit  Apply [remove remoy Edit Select Hodify hake Fres Merge Merge Merge Merge Blign . wister + WizardislandDEM_from3DEM
o1 Batch Batch ‘veta | polgs Qfl Layers Layers Quads Guads Guads Verts Al Select Same Mormls @ okt m‘ﬁ

read

=

Ly §T
Join bitrude
==L
Extrude Eetrude

L3D aé:ar

1 12
(Veen

Fotate Cofors

[ens I%
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—Align Surface Normals (Flip Polygons)—

v|

Some optional steps include next selecting Tools_1->Adjust Object, and scaling-down the model,
changing its position, and/or rotating it. All these can also be done in Blender later-on; they’re
described in Shapespeare’s first video tutorial listed in Appendix A.
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The final step: File>Save As, and select the STL file type. Now you’re ready to import the model into
Blender to give it thickness! Use one of the three methods in Section 5.

MicroDEM
Another option involves using MicroDEM (Appendix C) to export an OBJ file to be opened in Blender.
For this example, | used a GeoTIFF of Wizard Island. | had obtained this from
http://opentopography.org/, but you can also save a GeoTIFF directly out of 3DEM.

First, go to File>Open—>Open DEM, and select your TIN / GeoTiff file. The file will load. Then just
select File->Save DEM->Caveat emptor. This saves an object (OBJ) file which can be imported directly
into Blender and given ‘thickness’ to generate your final 3D model (using one of the three methods
outlined in Section 5).
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Section S: Starting With a DWG File of Contour Lines.
SITEOPS Topo Lite

First, obtain a DWG of contour lines! Let’s use Massies Creek Gorge area in Cedarville Ohio, with the

Indian Mound to the northwest.

Navigate to the SITEOPS Topo Lite website (https://app.blueridgeanalytics.com/Topo Lite/).

=

M Inbox (34) - dylanmc... > | = Spotify Web Player X + SITEOPS Topo Lite

€ ) & BLUERIDGE Analytics, Inc. (US) | https; il v € Search wa. 9o

= H Tech Gear recipes Grad School Scholarship Harmonica | | Research

Welcome to SITEOPS Topo Lite!

Find topography and aerial imagery for anywhere in the US with the
click of a button! FOR FREE!

SITEOPS: Revolutionizing Land Development
Instructions for Using SITEOPS Topo Lite:

To speed navigation, enter as much information as you know into the search bar
located in the upper-left corner!

1. Left mouse button pans, middle wheel zooms, double-click to recenter and
zo0m

2. Once you have zoomed in far encugh the Select Location button becomes active

Left Click the Select Location button to begin DWG creation

4. While your DWG is created please tell us where to send your DWG file
(remember it has topography and aerial of your project)

5. Once you are done, try again! (just click back to map)

Let me find my property!

For help using Google Maps, click here. Use of this site is subject to our Terms of Use

(X

A\

TR

Here it’s pretty straight-forward. Much like using Google Maps, you just navigate to the location of
interest. When you are zoomed-in far enough, you'll have the option (in the upper right) to ‘Select

Location’. [note the ‘map / satellite’ options also in the upper right]
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M Inbox (34) - dylanmckevitt.. X = & Spotify Web Player X -4 SITEOPS Topo Lite

€ ) @ BLUERIDGE Analytics, Inc. (US) | https://app.bl il ¥ €' || Q Se
Research | | Geo Work | | SocMed | | Job Seal

Search I Instructions

Grad School | Scholarship | ) Harmonica |

Tech | | Gear recipes |

¢

, s N
‘Coogle . : )
G( 3 S Map data ©2015 Google Imagery £2015 . DigitalGlobe, State of Ohio / OSIP. U.S. Geological Survey, USDA Farm Service Agency | Terms of Use | Repart a map error

Click on ‘Select Location’, enter some information, and you’ll promptly receive an e-mail with a link to
the DWG file for your site.

You can open this file in DraftSight if you want to view it. In DraftSight, you could ‘trim-down’ the DWG
and re-save it as another DWG. | won’t mess with that here.

DraftSight
See Appendix C for info about this free program for viewing DWG files. You could continue with ArcGIS
to convert these contour lines into a DEM, but that’s an expensive (and, in my opinion, more complex)
option. A better workflow involves opening your DWG in DraftSight. Then simply navigate to the Layers
drop-down and turn off the unnecessary layers by clicking on the “green circles”. | only kept the
Contour Existing Grade and Contour Existing Grade Index layers visible.
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W File Edit View Insert Format Dimension Draw Modify Toolbox Tools Window Help Try DraftSight Professional

“ DraftSight - [siteops.dwg®] -

EN

Ik R P R I

:..g | e = Glh_'l O Contour Existing Grade Index V| ‘1 | [=] Bylayer d |||ByLayer R |||—ByLayer ~

#Mr!m---........-------I"g-’ﬂ

% = (2 @
General -

= |Ccr1bour Existing Grade Index V|
@ | (o] BylLayer V|

1.0000

|ByLayer

|— BylLayer ~ |

“a" |ByLayer

TR SO0 0SS

PrintStyle

w |Nune i |
Wz |B‘,'COI0r |
)£ [None

-
S
48

(=) | 15967704681
o) 636830.1596

(=) |0.0000

T 37951564

[+ 59879223

COONINEE N

Misc
@ |\"es ~ |

Command window

DraftSight 2015 xB4 Snap | | Grid | | Ortho (1593780.1871,637824.0267,0.0000)

Next, simply go to File>Save As, and save it as a *.dxf file (| used the R2013 Drawing type).

AccuTrans 3D
Open your .dxf contour line drawing file with AccuTrans 3D by selecting File>Open As—> DXF.
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@l AccuTrans 3D(x64) - Version 2015.0.0 - [ ContoursMassiesCreekGorge.dxf | “ suEmgy . - O ®
File Prefs Work Area Layers Viewer Camera Display Show Cllphuan! Tools_1 Toas 2 Tools 3 Align Help

= A BEEE "ﬁ‘ Adust T2 b sk B
Object Hi— 51

Layers] Edit
Open AKF Reluad Batch muri Text bodel Add Save Az Option Bitmap Cloze = setuvs Stait

Help

Ply E dit Apply . % % Edit Select Modify Make [rec Herge Merge Merge Merge Ahgn . “ﬂaiﬁ' + Contour_Existing_Grade

Layers Layers Quads Buads Buads WYerts Al Select Same Marsals

read Batch Batch check

+ Contour_Existing_Grade_Index
Edit DEM
Color  Color
[E

\\ Create
Fens UV

[y
Jolﬂ [xmde
DK DM
Exlrude Exlrude

30 aﬁ:ar

W]
Fotate Colars

Piurs I,

Rotate wirgs

Grﬁires -&

Ratate Grevs
shart

ou
Hidden  Key —Align Surface Normals (Flip Polygons)—.
13555358669 | |3{m | B DOl Ly ey Doz

Edit Edt  No [Light Farallel [ iy} 1 2 (C)173 v|

Bkard Stage Stage OFF Top Bac Bottom g:olom %m g:olom Fov world Fotate Fotate fiotate || |
Lamera Mo Stage Stéga ’e""e' Quads >5 Al EIn S0 T [-%- C-2- eca 50 Center c
Frant H%t Zoom Zoom @l R e i g =

Reset Biord EEEH S o FF Left Zoom Zoom Zoom Center Ceafer Pan  Ceivet Civet Rotite dlign Preset Preset =2 Show Flip P
Stat Al Select  pewrs One Al Help w

[Read file (dicnlav dialnn bow with antinnel A1 [ [ T7anl900lara

<

PRGNDEE L]

\V[ise950 | E [134609 | T1o |

oo J120 __JPp__ |

Next, simply choose Tools_1->Convert Contour Lines to Landscape/Terrain. | just accepted the default
options in the pop-up dialog box and hit OK.

Width () 8.232.23 Depth (¥) |3.675.91

MinZ 928.0 Max Z [1.055.0

Enter X and Y Spacing
300 |
Press 'enter' to calculate

Cols 276 | Rows 124

Total Vertices 34.224

? C-5

sran Help

This bit of spectacular magic takes a few moments... and then, voila!
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@ AccuTrans 3D(xB4) - Version 2075.0.0 - [ ContoursMasslesCreekGorg@hﬂ ", - m] x
*
File Prefs Work Area Layers Viewer Camera Display Sh§w Dem H.ap

 m n e hD D [ LD M . - adist A itk §
A A A A A A 55 nﬁ:aﬁp e e 175 6 L :
& Cj Ot flet oo ke Fop e Mot Ne Wene i Tl [ =1 [300
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o e UDNSHE " el
ey )
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RNO00 @
@ - O NafaT -
3 4 s [
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7 8 .
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11 12
X [300 | ¥ [so0 |
(Veen
fotare Lalirs Width (82500  |Depth (36900 |
C'verts I% .
Fatate wires Min Z |9270 |Max zZ |l‘054 1759[I|
Cwires _521 .
Rotate Grews —Reg'LLI)F
o
fdin R West East
b | 276 |[2s00 |

OGL| Edie  Ecie Ho [Light] pas)e 51 €152 €03 13584 61944 C, Gl Cexs Cevys LeZ>
7 B o Sz 19441 | ‘3{}_(} o word Rotate Rotate Rotate D D
5 Center ‘e South

OM | Bkord #tage Stace | gidecl OFF Top Back Botto Zoom Zoom Zoom
Camera Mo Shage Stage render [ @ &) C}:4 )5 5 In @t MEC C-k- [-Z- %
both A :
Reset Bkord [H S0 SN OFF Lelt Fromt Right ;nnm g:nlnm @nln .n‘n g:nlnm (Enlnm ‘f% Center Center Pan Crivet Crivot | Fast| RotSte
I T [ [ [Raal236 (177 I I|W | E|S|N||CW CE|CSCN

£ >

Navigate to Dem—>Convert to 3D (less water). | accepted the defaults. Hit OK!

—Verex Interval—— —Output Statistics
MNorth Count 124 O Morth Count

2
4
Total Count 34,224 O] Verices

Minimum Height (927.0  Pick—>

Maximum Height [1054.175903

East Count East Count

Edges

Triangles

UTM X
—Control Face Creation
'* Keepallfaces

_ Drop faces at Sea Level only

_ Drop faces if elevation is at or below

UTMY
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@ AccuTrans 3D(x64) - Version 2015.0.0 - | ContoursMassiesCreekGorge.dxf | - ] >
File Prefs Work Area  Layers  Viewer Camera Display Show Clipboard Tools_1 Toels 2 Teols 3 Align  Help
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& Create
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Jor e
Sk =M
Eibrude Edtrude

#D a%:ar
3
5
7
9
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(egny
Rutate Colors

Pans I

Ratate wirzs
hires Eﬁ
Fotate Grews
shart
cut
Hidden  key

OGL) et Ede Mo (LS| Parall [ @ @1 €2 €3 13584 619441 | |3,00 | C, [0l Daxr Doys L3z | M
Bkgrd Stage Stage OFF Top Back Botom %}um %‘Um %m h . . eFo\:) world Rotate Rotate Rotate | || |

Camers Mo Stage Stage render (). @ %] >4 (€136 [[C1:6 (@ A @In @0ut D C-%- 0-7- < g5 Center [FC| Co
both v - " .
Resat Beod FEH &% Ak O°F Leht Front F\%l %m %m % % g:olom g:alom E% Center Cenfer Pan  Chivot Crivet |Fast Hotgjte Align Freset  Preset =% Staw Flip P
Start Al Select  pwms One Al Help v
I 1 [ Tar2[971 [33n
< r i

RGO EEE ]

‘V|34224 | E ol | T1[67650 |

‘Qlu | T2 67650 | P 67650 |

~Align Surface Normals (Flip Polygons)

Bam! Simply save it as an STL by choosing File=>Save As (I used the ASCII option). Now, use one of the
three Blender methods outlined in this section to give your model thickness.

ArcGIS

This option isn’t as good as the one previously described for working with a DWG of contours... but it’s
the first | used, and I'll include it for sentimental reasons.

Open a new map in ArcMap. Navigate to View = Data Frame Properties > Coordinate System.
Choose whichever you want to use [l will use NAD 1983 (2011) StatePlane Ohio South FIPS 3402 (US
Feet)]. Then add a base map if you'd like (File > Add Data = Add Basemap). Next, bring in your DWG
file by selecting Add Data, and then the DWG file. You may have to add a folder connection... Hit ‘OK’
when the ‘Unknown Spatial Reference’ dialog box pops up. The DWG should automatically ‘go to’ the
correct location; to check this, in ArcMap, under Table of Contents, right-click on the ‘SITEOPS.dwg
Group Layer’ and select ‘Zoom to Layer’. If there’s a base map, it should correctly overlay it. If it
doesn’t... that’s no big deal (at least for this exercise).
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Q) Untitled - ArcMap
File Edit
D d&
(CHCY @ (*)

Insert  Selection Geoprocessing Customize Windows Help
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View Bookmarks

B x
&

o
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=

K KA
AR k¥

Editor ~ 2 v 4
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Table Of Contents
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25

siteops.dwg Annotati
siteops.dwg Point
siteops.dwg Polyline
siteops.dwg Polygon
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=

Basemap
World_Imagery
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1599829.261 638499.461 Feet

RAS Geometry ~ RAS Mapping~ 3¢ 8¢ |1l & < < &2 ApUtilities~

~

[orereo &]

[=@]=]

¥

sainesy aleajg‘t?\'] \

The next step is to convert these contour lines to a DEM (digital elevation map). [You could also convert

them to a TIN—a triangulated network—by selecting Arc Toolbox = 3D Analyst Tools = Data

Management - TIN = Create TIN; however, what we need here is a DEM.] Select Arc Toolbox = 3D

Analyst Tools = Raster Interpolation = Topo to Raster.
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.siteops.dwg Group Layer \siteops.dwg Polyline Color Contour surface raster.
1 Each feature input can
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one of six types specified.
< >
« Feature layer—The
Output surface raster input feature
| C:\Wsers\dylanmckevitt\Documents\ArcGIS\Default. gdb{TopoToR,_dwg_1 | E;- dataset.
Output cell size (optional) + Field—The name of
14.5850012301153 + the field that stores
| | Bl v the attributes, where
itk avkant fantinnal - v
<
OK Cancel Enviranments... << Hide Help Tool Help L

In the ‘Input feature data’, select the polyline file. Under the ‘Field’ heading, change ‘Color’ to
‘Elevation’ by using the drop-down menu. Leave the ‘Type’ as ‘Contour’. Then select where you want
the ‘Output surface raster’ to be saved; be careful how you name the output file (sometimes just having
‘strange’ characters in the file name, such as a dash [-] or underscore [_], could cause error messages—
see image below). The rest of the options can be left as default.
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= @ Current Session

= @ Topo to Raster [000000_12301899]
[ Output surface raster: <empty>
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Be patient while ArcMap generates the DEM. When finished, it will automatically load as a Layer.
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File Edit
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Next, right-click on the DEM layer name in the Table of Contents = Properties = Symbology =
Classified. Set ‘Classes’ at 32 (the max) and the ‘Color Ramp’ to black-white, so the highest elevation is
white [if this is not an option, right-click on the Color Ramp = Properties, and change Color 1 to black
and Color 2 to white]. Hit ‘OK’.
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Next, go to View = Layout View. Here is where you ‘lay out’ your map. You can right-click on the
‘page’ and select ‘Page and Print Setup’ to set the dimensions of the map that you’ll export. Then resize
the Data Frame by right-clicking on the map = Properties - Size and Position. Set the X and Y
positions to ‘0" and the Width and Height to match the ‘page’ dimensions, so the map image will take up
the entire page. Double-click on the map image to activate the Data Frame; use the Zoom In/Out, Pan,
and Select Elements tools to position the DEM. Make sure the Basemap layer is invisible by unchecking
the box next to its name in the Table of Contents (this will remove that ‘source’ information at the
lower-right of your map).
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Finally, export the DEM as an image by selecting File = Export Map. You can set the resolution (400 dpi
works fine) and export it as a .jpg or .png image.

Blender

If you chose the ArcGIS route, or if you just have a grayscale DEM image (or, for that matter, any image
you want to make 3D), read on!

That’s it for ArcGIS. The next step is to generate a 3D image (STL or OBJ) file from your .jpg or .png
image. We'll utilize Blender, but other programs also work. Essentially, we’ll be stretching the black-
and-white image (with shade corresponding to elevation) so the lightest-colored parts are ‘raised’ the
highest. Then we’ll give the image some ‘thickness’ before saving it as an STL.

Open a new file in Blender. For first-time users, select File > User Preferences 2> Add-ons. Here you'll
find a group of ‘Import-Export’ Add-ons. Make sure you check (to enable) the ‘Import Images as Planes’
and the ‘STL format’ ones (enabling all the others is okay too).
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Next, delete that cube; make sure it’s selected, then under ‘Edit’ on the left select ‘Delete’. [Also helpful
is to know the ‘Undo’ / ‘Redo’ buttons are under the ‘History’ section—below ‘Edit’.] Next, File >
Import 2 Images as Planes. Select the DEM you saved from ArcMap, and import it. It will appear as a
blank, grey plane.
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4% Blender — O *

Blender Render

Set Origin

(1) MassiesCreel 4 3D-printing

® OhjectMode 5 @ 5| % 5[ ? Global *+ @

[125) MassiesCreek e 4 3D-printing

r Object Mode : . : 'D :l—,r - Global

You can view and change the dimensions of the image (and its location) by selecting the “+” in the upper
right of the window; this will open some tools.
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4 Blender e m] X

All Scenes

Add Modifier

Object Data

(1) M esCreekGorge_4_3D-printing

@ ObjectMode + @ 7 %

To the right, select the ‘Add Modifiers’ tool [the wrench icon], and then add the ‘Subdivision Surface’
(under ‘Generate’) and the ‘Displace’ (under ‘Deform’) modifiers.

42 Blender - ] X

g i
A ]

B pefaut | 9R[E3 gl Scene | on[28 Blender Render

Set Origin

Simple

" Subdivide UVs

‘¥ Displace

Normal

Global % g

R

With the ‘Subdivision Surface’ modifier, select ‘Simple’ instead of ‘Catmull-Clark’, and change ‘View’ to
8 or 9 (later, you can play with this... the higher you go, the ‘better resolution’ you get, but it’s also more
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difficult to rotate / process the image... and the resulting STL will be a larger file). With the ‘Displace’
modifier, make sure your image is selected (under ‘Texture’), the ‘Texture Coordinates’ are set to ‘UV’,
and ‘Direction’ is ‘Normal’. Reduce the ‘Strength’ to something like 0.1 or 0.2 [this is essentially your
vertical exaggeration; see Appendix C on how to calculate the actual vertical exaggeration of your
finished model].

4% Blender — [m| *

L) Default  [SR|SS R Scene |an|3d

Blender Render

User Persp

Add Modifier

ge_4_30-printing

e 7 @:|% &

Hit ‘Apply’ for both modifiers. Order matters; apply the Subdivide modifier first.

Generating a solid model from a 2D surface: Method I—DBoolean
This method involves cutting the 3D model from a 3D object (cube, box, cylinder... whatever) using the
2D surface you just created as a guide. Or maybe you have a 2D STL surface from another method (like
that using DraftSight and AccuTrans 3D described earlier in this section); in that case, import your STL
and use either this method, Method 2, or Method 3.
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4% Blender
o[ 28 Blender Render ¥

Add Modifier

Set Origin

(1) Cube

® ChiectMode + @ 3 % 2§58 L 7

Gl & i3] <l () o)

Hit “7” to get an overhead view of the 2D plane, and then “5” to take off perspective (so you see square
edges). Then Add=> Mesh->Cube. Like you could have done with the image plane, you should now
adjust the cube’s dimensions (in the X and Y directions) to match the 2D surface, or to lie slightly within
the 2D surface’s edges. Either you can manually adjust the dimensions and location by expanding the
toolbar (as noted previously), or select the cube and the “Scale” Transformation Manipulator near the
bottom of the screen and then dragging the ends of the X/Y/Z handlebars in the viewer window. The
thickness of the cube below the bottom of the 2D plane will be the thickness of your model’s base.
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Finally, add a ‘Boolean’ Modifier. Make sure the cube is selected, choose ‘Intersect’ for the Operation,
and then select the 2D plane for the Object. It will take a moment or two to Boolean. Apply it.
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Those orange glowworms crawling all over your 3D model can now be annihilated by altering the
visibility in the layout tree so only the “cube” is visible.

%) Blender — [m| X
I

User Ortho

XYZ Euler

Object Data

Fy

(1) Cube

B33 <] [ | 5

Generating a solid model from a 2D surface: Method 2—Extruding
This method works well if the 2D surface you generate isn’t a “nice” shape (like a rectangle), or has
uneven edges, and you want to keep the entire surface (not just “trim out” an area of interest using the
Boolean method).

So, for this example, we’ll use data available from OpenTopo (see Data under Appendix A). The location:
Wizard Island, Crater Lake National Park. | already generated an object file using MicroDEM (see Section
4), but any OBJ or STL file can be used.

Import the Object file into Blender. Initially, it may not look just right; that’s because the object is larger
than the view constraints; under View, change Clip End to a really large number. Also, the object may
come in so the “up” direction is oriented along the Y-axis. To change it to the Z-axis direction, select the
object, type “r” for rotate, “x” to constrain the rotation to the X-axis, and then “-90” and “Enter” to
rotate it.
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49 Blender — O X

User Persp

(1) Wizardlsland

@ ObjectMode 5 @ 7

Now, to turn this 2D surface into a 3D object. This process is most useful on surfaces with a very uneven
boundary edge; however, even though this one has nice square edges, it’ll still work to illustrate the
process.

Select the object. Enter Edit Mode. Hit “1” on the number pad to get a straight-on view. With
everything selected, hit “e” for extrude, “z” and “z” again to lock the extrusion along the Z-axis, and then
move the cursor down however far you’d like the base to be.

” u

The bottom now is a negative of the top surface. To flatten it, type “s”,
base to a flat surface. If you zoom in on the bottom, it may display many little triangles; these are all of
the points from the top surface that have been extruded downwards. Such a large number of points
makes for an unnecessarily large file; you can sometimes reduce them by choosing “Face Select”,
selecting the bottom, and then Delete—> Dissolve Faces.

2", “0”, and “Enter” to scale the

Generating a solid model from a 2D surface: Method 3—Extrude and Boolean

Another option involves extruding the surface in blender, and then inserting a plane to be Booleaned
with the extrusion; details at https://www.youtube.com/watch?v=Ag-cP-tiO1k.

Save the STL
Finally, to save it as an STL. Go to File = Export > Stl.

Now you can import the STL into a 3D printing program to print it! However, if you want to view the
model first, MeshLab works pretty well. Just import the STL and play with the viewing options.
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MeshLab
For Meshlab, navigate to File > Import Mesh. Select the STL. Initially it will appear black; to make it
visible, go to Render = Lighting = Double Side Lighting.

& MeshLab_64bit v1.3.4BETA - [Project_1] — [m} X

® File Edit Filters Render View Windows Tools Help X

NFevceomsae T D@y 3PN 20N> X~

Mesh: Massies Cr Gorge 3D printing-1.stl
Vertices: 526338
Faces: 1052672

Note; the ‘ledges’ on the model are essentially contour lines—they correspond to the different shades
of the original DEM that was created in ArcMap. To see how much elevation change each ledge
represents, just check what elevation interval each shade of gray corresponded to in ArcMap (if you
made this model from a grayscale .png or .jpg produced in ArcMap).

The End. Of this section.
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Section 6: Starting With LiDAR Data (or an LAS File).

LiDAR (LAS files) is available for many locations, for free! Once again, we’ll use the Massies Creek Gorge
area in Cedarville, OH as an example in going from LAS data to a 3D model.

First, obtain LiDAR data for your site, in the form of LAS files (see Appendix A). For this example, | got it
from
http://ogrip.oit.ohio.gov/ServicesData/GEOhioSpatiallnformationPortal/OhioSpatialDatalnfrastructureD
ownloads.aspx.

Free LiDAR data is also available for select locations from http://opentopography.org/ (see Appendix A).

3DEM and AccuTrans3D

See Section 4 for a simple and effective workflow! (Note: these programs are free, or nearly so, easy to
use, and probably a better workflow than using ArcGIS... yeah, I’'m pretty sure of that. | include the
following ArcGlIS section out of nostalgia... if you’re an ArcMap junkie, help yourself. Otherwise, please
go to Section 4. That’s S-e-c-t-i-o-n-4. Please!)

ArcGIS
Open ArcMap (I'll be using the Massies Creek Gorge dataset used in Section 5). Select ArcToolbox 2>
Data Management Tools = LAS Dataset = Create LAS Dataset. Browse to the appropriate folder and
select the .las files. Choose the Output LAS Dataset file name and location. Leave the other options at
Default (but feel free to experiment if you choose!), and hit OK. [Once again, be careful that you don’t
include any ‘strange’ characters in the file name, or else it may not work!]
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Next, select ArcToolbox = Conversion Tools = To Raster = LAS Dataset to Raster. Browse to your

Input LAS Dataset, choose the file location and name of the Output Raster, and leave the other options

at default. Hit OK.
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The resulting raster dataset (DEM) should appear automatically as a layer. Next, adjust the map in
Layout View (as described in Section 5), and Export the map as a JPEG or PNG (I used 600 dpi

resolution).

37




So, You Want to 3D Print a Landscape? An Outline of Some Methods

[return to Contents]

° Massies Cr Gorge 4 3D Printing.mixd - ArcMap E‘@
File Edit View Bookmarks Insert Selection Geoprocessing Customize Windows Help
DEES8 OB xS EBE@ D by soona-[O[E][] 7
QM@ e K- T[N @ LM R L RASGeometry~ RASMapping~ 5 8 I F = o &
P Editor~ | » M| St Ll E N Nach A/ 9 | E B E g
Table Of Contents ax ~
o e =
8¢8 | :
= =7 lLayers E s
O siteops.dwg Polyline E
O siteops.dwg Group Layer = =
[0 MassiesCrGorgelAS i
=] LASdataToRas 1
Value =
High: 1121.38 =3
Low: 929.747 E
gk
O 2DEM
= [0 Basemap ]
World_Imagery =
g
)
| v
Bal&n< >
8.73 2.78 Inches

Finally, open the image in Blender and follow the procedure outlined in Section 5 to generate a 3D

model.

Voila! End of this section.
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Section 7: Want to Print a Country? Start With GeoTIFF (or other) Data.

As you’ve likely noticed form other parts of this manual, obtaining a variety of topographic / elevation

data for locations in the U.S.A. is no problem! However, what if you want to print a small-scale

elevation map of somewhere like... the Republic of Yemen? Freely-available data varies depending on

the country... but here’s a process | think will work for most locations.

First, check out the USGS Earth Explorer website (Appendix A). Create a free account, and then navigate
to your region / country of interest. Either type in an Address/Place or, like | did below, draw a polygon

around your area of interest.

science for a
EarthExplorer

Home

USGS Home

Contact USGS
Search USGS

Page Expires In1 6 C

Login Register [EYES Feedback Help

Search Criteria Data Sets
1. Enter Search Criteria

name, enter coordinates or click the map to define your
search area (for advanced map tools, view the help
documentation), and/or choose a date range.

Address/Place Feature

I covoon |

‘ Type: [WRS2 v | Path: Row: I
[ show | clear

(000N Predefined Area

| Decimal 71

1. Lat: 16° 11' 12" N, Lon: 053° 35' 31"E /R

2. Lat: 19° 27' 22" N, Lon: 052° 19' 00" E V2

3. Lat: 17° 28' 35" N, Lon: 041° 59' 23" E /R

Next, scroll down on the left to select Data Sets >>.
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1. Lat: 16° 11' 12" N, Lon: 053° 35' 31"E 2
2. Lat: 19° 27' 22" N, Lon: 052° 19' 00" E 7R
3. Lat: 17° 28' 35" N, Lon: 041° 59' 23" E 7R
4. Lat: 14° 50' 19" N, Lon: 042° 13' 53" E /R
5. Lat: 12° 07' 30" N, Lon: 043° 35' 37" E 2
6. Lat: 13° 11' 49" N, Lon: 047° 43' 28" E 7R
7. Lat: 14° 20' 58" N, Lon: 050° 24' 18" E 2

Add Coordinate | Clear Coordinates
DEICEETN B Result Options

Search from: [nm/ddlyyyy | to: [nm/ddiyyyy  |&
Search months: (all) T
|
Data Sets » | Addtional Crteria» | Results » |

Accessibility FOIA Privacy Policies and Notices Google Maps API Disclaimer

This will open the next tab, where you select the data type(s) you're seeking. If you want more info
about the data source, select the blue “Identity” circles next to the check boxes. As shown below, |
selected GMTED2010 Digital Elevation data.

| ) Use Data Set Prefilter (what's This?) I

l Data Set Search: ] ’

[#-Aerial Imagery A
[#-AVHRR
[#-CEOS Legacy
#-Commercial Satellites
[#-Declassified Data

[=-Digital Elevation [J

|| @ [E] ASTER GLOBAL DEM
[ @ [£] CoNED TBDEM

) @& EDNA

v @ [E] GMTED2010

) @& cToPO30

"/ @ [E] GTOPO30 HYDRO 1K
[ @ =] IFSAR Alaska

0 @ E LIDAR

&-SRTM

#-Digital Line Graphs

#-Digital Maps L]

£-E0-1

¥ Global Fiducials

-Global Land Survey

£ HCMM

#1SERV -

Clear All Selected | Additional Criteria » m

Next, select Results >> and view what data sets are available for download. Selecting the “footprint”
symbol (and the symbol to the right of it) will display the dataset on the map, as shown below.

e e e e ]
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Next, simply select the download button! You may have a few options; for this example, | selected the
30 ARC SEC option shown below. It was downloaded as a .zip file... don’t forget to unzip it!

7.5 ARC SEC (609.8 MB)
LU LU 15 ARC SEC (194.2 MB)

T 30 ARC SEC (43.8 MB)

Unzipping the download left me with a few .tif files to choose from (technically, these are GeoTIFF files
because they contain lat/long and elevation data).

*Note: As you’ll see, the borders of these files may not be political/country boundaries. Thus, if you seek
to only generate a 3D model of the country (and none of the surrounding area), you can open the .tif file
in a program like ArcGIS and clip the .tif with a political boundary, and then export the clipped .tif image
(export at a GeoTIFF to retain geographic data).
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Now, open 3DEM (Appendix C) and select the GeoTiff DEM File Type option, and then your .tif file. For
this example, | chose the “_max300.tif” file.

Select DEM File Type *
— File Type
 USGS DEM & GeaTiff DEM
[dem, tar.gz. tgz. gz] [tif]
) ) E.] 10n030e_20101 117 _gmted_dsc300.tif
" SATM Data  Temain Matrix
[hat. bil) (kin, =) =] 10n030e_20101117_grted_max300.tif
" GLOBE Tile  GTOPO30 Tike E.]) 10n030e_20101117_gmted_rnea300.tif
[zelected from map) [zelected from map) IEI 11]”1]31]!2_21]11]1 1 1'.-"_grr1ted_m d300.tif
" LIDAR Point Cloud " %vZ Paint Cloud
T i 5] 10n030e_20101117_gmted_min300.if
™ Marz MOLA ™ Marz Polar MOLA IEI 1‘]”‘]3‘]&_2‘]1 011 1?_9 mted_std 300.tif
[meqt.img] [meat.ima) -
Cancel |
The file should open in 3DEM, as shown below.
:;;c_)\@q.w Vigy - 1000306 20101117_gmted_max300.if - ] X

.
&le Operation GPS Color Scale Geo Coordinates Help

Elevation

Now, if you want to select a smaller area (for this example, I'm only interested in the area around
Yemen) select Operation = Select Smaller Area (or hit the F8 key) and drag a bounding rectangle
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around the area of interest, and hit Enter (select OK in the pop-up box). This will zoom to your
selection.

%' Overhead View - 10n030e_20101117_gmted_max300.tif = m} X
File Operation GPS ColorScale Geo Coordinates Help

Latitude = Longitude = Elevation
19.7713 | 42.9729 0.0 m

Select File > SAVE USGS ASCIlI DEM, and save a .dem file.

Next, open AccuTrans3D and select File > Open DEM As - USGS 1-degree (ASCII-1) (*.dem), and open
your file.

43




So, You Want to 3D Print a Landscape? An Outline of Some Methods

[return to Contents]

@ AccuTrans 3D(x64) - Version 2015.0.0 - [ Yemen_max300.dem | — [m] X
File Prefs WorkArea Layers Viewer Camera Display Show Dem Help
[ -l T = = Adust & a T n st R C-8 DEM | Change &
O ARE oo e Bt 1, o Add SEE BEE = - | £0209
apply Edit Apply [Femove remor 1 Edit Select Modify Make F Merge Merge Merge Merge Align water i W - o1
‘.”233 Batch Batch @ q\‘d Layers Lapers cuads Bunds Cuads Verts Al Select Same Nl ol - 4 v l_ :
£ oy Bt [ ][ 2[n9
s North ] 0
o [ ] :
:\\ Create E -
Eop
j;%. Extrude 'BA.-’I’ E “L' &I— 5
SK SM
ot
5B s 2% 2 Ko7
oS ] ) [T 800
B a3
@ 2 = NSNS oo
2 s s s
L (M UD, NS HE ke
5 & Uj‘;’}/ F Y El
sl ad Y
78 ¥y ¥ K
z Region
9 10 sc Bin T ==
Cols [1453 |Rows [881 |
1 12
o 1 X [9000 | Y [esase7 |
:f‘ﬂ'e i Width [1306800.0 |Depth [791970.96 |
| verts
Rotate wires MinZ lo IMax z |3.654A0 I
a
s 2 _Region
N
shot orth 791970.96
i ey West East
] | [1453 ] [13068000]
OGL| Edt Edi  No (DR Faralel 51 €2 @3 C, COL C<x> Ceys 02>
ON | Bkgrd Stage Stage @ OFF T?é Bacl Bn@m g:olom %om golom AR (-fm? world Rotate Rotate Rotate South I:I D
tamers No Stage Stage render (uadc B 54 >5| > l A| @ @t D C-%- L-2- <> &P Center Ec ‘% 0
Reset Bkgd E L BN OFF Iﬁ Front H% golom S}m an ok %om %om E% Center Cenfor Pan Crvot Coivt | Fast] Rotdte
W|E|S|N|CW|CE|CS CN
[ [T T Tesa]116[173
v

From here on, the procedure is similar to that outlined in Section 4 (skip the first part that uses 3DEM).
However, this example needs a few tweaks... so I'll continue and note them.

Select Dem - Convert to 3D (less water), modify the Vertex Interval if you want to adjust the Output
Statistics (and thus the output file size), select OK, and wait a few moments while AccuTrans3D thinks.

I -8 T T |

" Convert DEM to a 3D mesh

~VerexInterval—— —Qutput Statistics
MNorth Count 881 e ! North Count
East Count - i East Count
Total Count :

280, 8
Minimum Height ~ Pick->

Maximum Height

Vertices

Edges

Triangles

UTM X
—Control Face Creation

'+ Keep allfaces
' Drop faces at Sea Level only

 Drop faces if elevation is at or below

When your computer fan slows down, you may find a “black line” on the screen. That’s good enough.
Select File > Save As, and name your .stl file.
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Now for the final steps in Blender! Open Blender, delete that cube, then select File = Import - Stl.
(Make sure you’ve enabled Stl importing as noted in Section 5). It will likely take a few moments of

Blender (Not Responding).

When the file opens in Blender, you'll likely see... nothing!

48 Blender

= R

= k)

W/ Yemenz max3od U © Rk ®

Set Origin

If so, click on that “+” tab circled in the image above to open options where you should increase the
Clip: End value to a very large value, and Scale down the object (I used a scale of 0.001 initially).
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42 Blender - [m] X

User Persp

Go ahead and scroll in/out to view your model (if you have trouble navigating, check out the Blender
User Manual at https://www.blender.org/manual/contents.html, or Google it... or [my favorite] just play
around!).

Zoom in/out: Scroll with MMB (middle mouse button) or press MMB + CTRL.
Rotate: Press and hold MMB.

Pan: SHFT + press MMB, or SHFT + Scroll or CTRL + Scroll.
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42 Blender [C:\Users\dylanmckevitt\Desktop\GMTED2010N10E030_300\Yemen2 blend] - a x

3

The object may come in so the “up” direction is oriented along the Y-axis. To change it to the Z-axis
direction, select the object, type “r” for rotate, “x” to constrain the rotation to the X-axis, and then “90”
and “Enter” to rotate it.

42 Blender™ [C:\Users\dylanmckevitt\ Desktop\GMTED2010N1DE030_3004 Yernen2.blend] - a x

Ll Scere  [aR[E3 Blender Render

)

1)

® Object Mode & % BN Global

ou_n
z

With this example, the elevation (in the axis direction) across Yemen is small compared to the
horizontal distances (x- and y-axes). Thus, the model appears pretty flat. Add vertical exaggeration by
scaling the Y value (I chose 0.010... and since the other scale values are 0.001, this is essentially 10x
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vertical exaggeration). Note: do not scale the Z value — the scale axes apply to how the model was
originally opened in Blender (before rotating).

2 Blender* [C:\Users\dylanmckevitt\Desktop\GMTED2010N 10E030_300\ Vernen2. blend]

L

[
- = |
b -/
Lt =0 g

cy

(1) Yernen2 max300

Object Mode & % BN Global ¥ g
i P

3| RN I PR | no sync

Now, to add thickness and make it a 3D-printable model. See Section 5 (I used Method 1 — Boolean for
this example).

For this example, it might be nice to emboss or engrave some text in the “ocean”; see Section 9.

Also, you could print your country model as multiple pieces to retain detail and have a larger “country”
than what your 3D printer platform allows. This can be accomplished by “cutting” your country into
adjacent sections in Blender and then saving each section as a separate .stl file.
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Section 8: Cleaning and Simplifying Point Cloud and Mesh Data.
Cleaning Point Cloud Data

Once you have a point cloud (from processing with a program like Pix4D or VisualSFM), the next step
may be to clean it up a bit in MeshLab (this step isn’t necessary). First, navigate to File=>Import Mesh,

and select your point cloud (here, | utilize a PLY of Cedar Lake, Ohio obtained from 157 UAV images
processed in Pix4D).

& MeshLab_64bit v1.3.3 - [Project_1] - O X

® File Edit Filters Render View Windows Tools Help

NFevceomsa T 0@ 13PN c00H® » X~
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& MeshLab_64bit v1.3.3 - [Project_1] - O

@ File Edit Filters Render View Windows Tools Help - & X

SRR

o" ¥y

e [an ~ f e . e S - “,.’
DB @ Q@D :@.@F@”/.’:xfﬁiﬁs”:’?ﬁﬁx
Projectd® teus® & X

« 0 Smallply* (7] ::m @

< >

work on PointSet "

Hesh has no per vertex radius.

Computed and added using

default neighbourhood

Harching cubes MLS meshing

done.

Applied filter Marching Cubes

( in 3 Tt

ter Delete Current

FOV: 60 Mesh: Small.ply Mesh in 188 msec

FPS: 56 Vertices: 4249248
Faces: 0 fa

MeshLab features many Filters for processing both point clouds and meshes, but to begin with it might
be easiest to use the Select Vertex Clusters tool in conjunction with Delete Vertices.

For more info, see Mister P.’s Tutorials referenced in Appendix A.

Another cleaning option involves Blender; details at
https://www.youtube.com/watch?v=wM52RaM6sTo.

Cleaning Mesh Data

MeshLab usually works well; see Mister P.’s YouTube Tutorials referenced in Appendix A.

Blender is another viable option. Not only can you select and delete faces / vertices, but you can also
close holes. Check out some YouTube videos.

Simplifying Point Cloud Data
Discussed briefly in Section 1. More here in future versions of this guide...

Simplifying Mesh Data
Ditto for above. And, again, Mister P.’s amazing Tutorials.
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Section 9: Adding Text or Symbols to Your Model.

Want to add text or symbols (like north arrows or scale bars) to your 3D model? Piece of cake...

ArcGIS / ArcMap
One option is to overlay a symbol or text onto the ArcMap map using ‘Insert’ before exporting it. Re-
color them in grayscale, so wherever they lie on your map they are distinct from the colors below. If the
text / image is lighter than the underlying shades of the DEM, it will stand in relief (embossed) on the
finished model; if darker, it will be engraved. Of course, the sharper the contrast between the shades of
the underlying landscape and the text / image, the deeper it will be “engraved” or “embossed”.
Continue processing the DEM image in Blender as outlined in Section 5.

Blender

Blender can be used to write text, extrude it, and Boolean it to emboss or engrave onto a model. The
Boolean modifier can add or subtract any two overlapping meshes; see Section 5.

Autodesk Meshmixer

Autodesk Meshmixer is useful for unioning or subtracting meshes from each other; import your 3D
landscape along with a mesh of text or a symbol and combine them.
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Section 10: Embedding a 3D Model into a PDF.

Tetra4D Converter
A pricey option, but you can take a free trial for a test run. Pretty straight-forward; see Appendix C.

LaTeX and U3D
A free option (untested by the author as of this time...) involves using LaTeX (with the media9 package —
not the outdated moviel5 package) to embed a U3D file-type model. Details at
http://rainnic.altervista.org/content/embed-3ds-pdf-latex-u3d. Google will gladly help you with any
questions / concerns. Or, if | ever succeed, | could (and will) update this section.

Matlab
Apparently, Matlab can also output a U3D format model for embedding in a PDF (still using LaTeX).
However, maybe there’s a way to bypass LaTeX and use only Matlab... | haven’t tried this method yet,
but some Googling/research may be worthwhile for those familiar with Matlab! For a start, check out:

https://github.com/johnyf/fig2u3d

http://www.mathworks.com/matlabcentral/fileexchange/37640-export-figure-to-3d-interactive-pdf
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Section I1: Printing Your 3D Model

This section will outline some of the many available options in 3D printers and materials, along with
some printing tips.

3D Printers

Materials

Printing Tips
If you’re using an extrusion-type printer (like the MakerBot that lays-down a string of ABS plastic), your
final model will have a “contoured” appearance on the top surface if it’s printed with the top “land
surface” oriented in the “up” z-direction. This layered, contoured effect can be avoided by printing the
model so the “land surface” is oriented along the x- or y-direction, so the model is “sitting on its side.”
Another benefit of this method is a shorter printing time; although the model will be “taller”, it’ll also be
narrower so the extruder doesn’t need to move over such a laterally extensive range (i.e. less wasted
movement).
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Appendix A: Some Helpful Resources

Data
https://app.blueridgeanalytics.com/topolite/: Site engineering software by BLUERIDGE Analytics; a free
online service that e-mails you a DWG of contour lines (1 ft interval) for any area in the U.S.A. you select.

http://www.diva-gis.org/Data: A nice variety of geospatial information, including global elevation data.

http://gis5.0it.ohio.gov/geodatadownload/default.htm?data=0sip2: The Ohio Geographically
Referenced Information Program (OGRIP)—Ilots of good data (LiDAR, DEM, TIFF...).

http://opentopography.org/: Free, high-resolution LiDAR data (under the ‘Find Data’ button) for select
locations in the U.S. and a few other places around the world. An NSF-funded project with the San
Diego Supercomputer Center. The site can also generate DEM/TIN files (like a GeoTiff TIN that can be
opened in MicroDEM... see Section 4).

https://www.thingiverse.com/: 3D models of things. A diverse assortment. And you can post models
you make on there too!

http://earthexplorer.usgs.gov/: USGS Earth Explorer, featuring an interactive map to select your area of
interest (anywhere in the world!) and see what data (elevation and other) is available. To download
data you’ll need to set up a free account; it only takes a couple minutes.

Video Tutorials

https://www.youtube.com/watch?v=-fe2zxcKSic: Shows how to convert any photograph into a 3D-
printable model, using Blender. We follow a similar same process to make 3D landscape models, but
our landscape ‘photograph’ is a grayscale DEM. (However, we don’t use the rudimentary extrude-and-
scale technique to get a good flat base; we Boolean!)

https://www.youtube.com/watch?v=t4-ICkvyJv0 and
https://www.youtube.com/watch?v=DIDSRU2nTXA: Making 3D Prints from LiDAR Data Parts 1 & 2, by
Shapespeare. Some good, thorough videos concerning data gathering and manipulation, and some
other software and data sources. Also, links to a 3D-printing podcast called ‘3D Printing Today’ on
ITunes and Stitcher Radio.

https://www.youtube.com/user/MrPMeshLabTutorials: Mister P.’s MeshLab Tutorials; everything from
the basics to cleaning and simplifying meshes and projecting a colored raster image onto your model!

https://www.youtube.com/watch?v=KI87Gubt2Co, https://www.youtube.com/watch?v=wBKidrOe-XA,
https://www.youtube.com/watch?v=-S7HelvIKcs: Very helpful videos detailing a workflow from drone
footage through Visual SFM and then viewing in MeshLab.

Websites of Interest
http://muearthlab.org/2015/02/3d-printing-topographic-maps-from-dems/: Mansfield University of
Pennsylvania; a small public university with a big UAV / 3D-printing initiative. This particular web page
features a process for printing landscapes from DEM imagery, similar to what is outlined in this guide.
These guys are really getting into it!
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https://www.matterhackers.com/news/how-to-3d-print-a-map-of-anywhere-in-the-world: How to 3D
Print a Map of Anywhere in the World by utilizing Google Earth... good for very small-scale maps
because the DEMs don't have good resolution at larger scales.

http://www.shapeways.com/: Shapeways, the company for 3D model inventors; if you don’t have
access to a 3D printer, you can upload your model on their site, choose from one of over 50 materials,
get a price quote and (if you like the price) have them ship the printed model to your door.

http://www.makerbot.com/blog/2011/06/23/12-ways-to-fight-warping-and-curling: Having trouble
with warping / curling edges when you try to print your model? Here are 12 potential solutions.
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Appendix B: Some Common File Types Relating to 3D Printing

DEM: Standard geospatial file format developed by the United States Geological Survey for storing a
raster-based digital elevation model.

DWG: AutoCAD and Open Design Alliance applications, Autodesk Inventor Drawing file.

JPEG or PNG: Digital raster image formats. Joint Photographic Experts Group format supports lossy
compression; Portable Network Graphics supports lossless data compression.

LAS: LASer format developed for LiDAR data (Light Detection And Ranging is an optical remote-sensing
technique that uses laser light to densely sample the surface of the earth, producing highly accurate
X,Y,Z measurements).

OBJ: Wavefront Technologies’ format for representing 3D geometry; stores the position of each vertex,
the UV position of each texture coordinate vertex, vertex normals, and the faces that make each
polygon defined as a list of vertices, and texture vertices.

PLY: Polygon File Format / Stanford Triangle Format; stores a list of nominally flat polygons with possible
properties including color and transparency, surface normals, texture coordinates and data confidence
values.

STL: Stereo Lithographic data format used by various CAD systems and stereo lithographic printing
machines; describes only surface geometry.

TIN: Triangulated irregular network; vector-based GIS format used to represent a surface.
U3D: Format used for embedding models into PDF documents.

... and there are many others!
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Appendix C: Programs

3DEM Terrain Visualization—available for free from http://freegeographytools.com/2009/3dem-
website-is-gone-but-3dem-still-available-here. A very handy, easy-to-use program for visualizing
digital elevation model data as colored, shaded terrain. It accepts various DEM file types
(pointclouds like LAS or XYZ, DEM, GeoTIFF,...), and can output GeoTIFF and ASCII DEMs (among
others!). You can also easily create animations (rotations, flybys) and overlay maps (e.g. topo
maps) onto the DEM terrain.

AccuTrans 3D—from MicroMouse Productions. A very handy program for conversion of 3D geometry
between many file formats, among other features. Available for the very low price of $20
(Canadian), or a fully-functional 30-day trial for free. Find it at
http://www.micromouse.ca/index.html.

Arc 3D—free at http://homes.esat.kuleuven.be/~visit3d/webservice/v2/. This useful web service allows
you to upload your images, and then their tools do all the work to perform 3D reconstruction
yielding a textured OBIJ file, and shoot you an e-mail when finished.

ArcGIS / ArcMap—this is a little pricy, but you can get a free 60-day trial version from their website.
And once that trial is over, you can get another by just signing-up again with a different e-mail
address. Free trial here: http://www.esri.com/software/arcgis/arcgis-for-desktop/free-trial. Or,
you can buy it;

Autodesk Meshmixer—free from http://www.123dapp.com/meshmixer. If you already have 3D
model(s), this program lets you combine them, create overlay patterns, and mold / refine
surfaces. Not necessary for 3D printing; however, you can subtract or add some 3D text models
to your landscape model (if you don’t use the process noted above in ArcMap).

Blender—free from https://www.blender.org/download/. It can do a LOT, far beyond what we use here
for 3D printing.

DraftSight— by Dassault Systemes, the makers of SolidWorks; free download at
http://www.3ds.com/products-services/draftsight-cad-software/free-download/

LaTeX—a high quality type-setting system, free from https://latex-project.org/. See Section 9 for how it
can be used to embed 3D models into PDFs!

MeshLab—free software for the processing and editing of unstructured 3D triangular meshes, from
http://sourceforge.net/projects/meshlab/. This program is useful for viewing 3D models (STL
files), and facilitates editing, cleaning, healing, inspecting, rendering and converting of meshes.
Visual Computing Lab — ISTI — CNR, http://meshlab.sourceforge.net/.

MicroDEM—free from
http://www.usna.edu/Users/oceano/pguth/website/microdem/microdemdown.htm. Made by
a professor at the US Naval Academy. Swiss Army Knife.

Pix4D—free trial version of Pix4Dmapper Discovery from https://pix4d.com/download/. This version
has limited processing and output capabilities. A trial version of the Pro version is also available
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after downloading Discovery. Otherwise, the Pro version costs $350/month, $3500/yr, or
$8700/life. Requires quality RAM and graphics card for image processing.

Tetra4D Converter—software for embedding 3D models into PDFs where they can be rotated! Info at
http://www.tetradd.com/; free 28-day trial at http://www.tetra4d.com/tetra-4d-converter/.
Cost: about $500.

VisualSFM—free from http://ccwu.me/vsfm/ by Changchang Wu. Load a sequence of overlapping
images and generate a PLY surface via 3D reconstruction! Like Pix4D, the image processing
requires a lot of computer RAM and a good graphics card (my HP Envy15 laptop, with an Intel
Core i7 processor, 8 GB RAM, and the standard Intel HD Graphics got bogged-down processing
51 landscape images...). Used in conjunction with Yasutaka Furukawa's CMVS software. Follow
the installation guide appropriate for your system.
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Appendix D: Calculating vertical exaggeration of your 3D model.

Some of the workflows | outlined produce models with no vertical exaggeration; others (such as
manipulating a PNG or JPG image in Blender), may produce a model with unknown vertical
exaggeration. In that case, the following method may be helpful.

Once your 3D model is printed, measure the difference between the lowest point and the highest point
of elevation (Y’). Also measure the length along one side (X’). Next, utilizing a resource like Google
Earth or ArcMap, calculate the total actual elevation change of your site (Y) [measured from the same
points you used on your model to calculate Y’]. Also measure the ground distance along one side of
your site (X) [the same side you measured on your model].

Now, use the equation® below to solve for the vertical exaggeration (n).

Y’ Y

— =n—-—

X' X
*Units of measurements (S| or English or whatever) don’t matter, as long as the same units are used in
measuring the model, and the same units are used in measuring the actual elevation change and ground

length of the site. The units of Y’ and X’ must be the same, and the units of Y and X must be identical.
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