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1 Introducción 

La presente tesis de máster ha sido desarrollada en el contexto del Proyecto PATRAC, 

“Patrimonio Accesible: I+D+i para una Cultura sin Barreras”, financiado por el 

Ministerio de Ciencia e Innovación. 

La información de partida con la que se ha trabajado proviene de dos fuentes: en 

primer lugar los datos obtenidos mediante el escaneado del ámbito con un Escáner 

Laser Terrestre y en segundo lugar la cartografía disponible de manera pública 

elaborada por el Instituto Cartográfico de Cataluña (ICC). 

El objetivo principal ha sido desarrollar una metodología que permita evaluar la 

accesibilidad física en entornos urbanos. Para ello se ha utilizado como caso de 

estudio el casco antiguo de Tossa de Mar (La Selva) y se ha tenido en especial  

consideración que la metodología fuera fácilmente extrapolable a entornos más 

extensos. 

Como objetivo secundario, se ha desarrollado una metodología para utilizar la nube de 

puntos obtenida mediante un Escáner Láser Terrestre (en inglés Laser Terrestrial 

Scanner o LTS) para la obtención de la topografía y la identificación de los obstáculos 

del ámbito delimitado por la fortificación medieval, teniendo en cuenta que dicha 

metodología puede aplicarse también a datos obtenidos de vuelos ALSM (Airborne 

Laser Swath Mapping) mediante LIDAR (Light Detection and Ranging). 

También como objetivo secundario se ha evaluado la posibilidad de utilizar información 

actualmente disponible de manera pública para obtener resultados comparables. 

1.1 Evaluación de la accesibilidad en entornos urbanos 

La evaluación de la accesibilidad en entornos urbanos nos permite hacer un 

diagnóstico de la adecuación del espacio urbano a su uso por parte de los ciudadanos, 

independientemente de su discapacidad.  

A partir de la evaluación de la accesibilidad se pueden establecer las medidas 

correctoras necesarias; en este sentido se están llevando a cabo en Cataluña diversos 

Planes de Accesibilidad Municipales, partiendo de unos planteamientos comunes 

(Departament de Benestar Social, 2002). 
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La disposición transitoria segunda de la Orden VIV/561/2010 establece que los 

espacios públicos urbanizados existentes deberán adaptarse, salvo excepciones, a las 

nuevas disposiciones antes del 1 de enero de 2019 (Ministerio de Vivienda, 2010). 

Para su aplicación es necesario disponer de las herramientas necesarias para poder 

evaluar de la manera más objetiva posible la accesibilidad del municipio, identificar las 

deficiencias subsanables, evaluar la eficacia de las medidas correctoras propuestas y 

finalmente realizar el seguimiento de las contingencias que puedan aparecer. 

La presente tesis intenta aportar una metodología para evaluar la accesibilidad en 

zonas urbanizadas basada en tecnologías de Sistemas de Información Geográfica (en 

adelante, SIG) con la aportación adicional de técnicas de remote sensing basadas en 

la información que proporcionan las nubes de puntos. 

1.1.1 Aproximación metodológica para la obtención datos del LTS 

En primer lugar, cabe destacar que la nube de puntos con la que se trabajó fue 

obtenida en una campaña para realizar el levantamiento de las fachadas en alzado, de 

manera que los puntos que representaban el suelo son un producto secundario de 

este trabajo y por lo tanto no tienen el detalle que les correspondería si se hubiera 

escaneado este elemento ex professo. Aún así, el detalle se ha mostrado suficiente 

para la aproximación metodológica que se propone. 

La información de la nube de puntos proporcionada por el LTS se ha utilizado para dos 

objetivos principales: 

 La obtención de la topografía de las calles sobre la que posteriormente evaluar 

las pendientes. 

 La detección de ciertos elementos como los escalones o las fachadas. 

Para llevar a cabo estos dos objetivos se ha trabajado la topografía en formato raster 

para poder realizar análisis en 2,5 dimensiones, asignando a cada pixel el valor de la 

altura que le corresponde. 

Mediante esta transformación ha sido posible realizar análisis de pendientes, de 

vecindad y de caracterización de superficies que no son posibles a partir de la nube de 

puntos. Otras ventajas añadidas son que las herramientas informáticas son capaces 

de procesar las imágenes raster a mucha mayor velocidad que las entidades tipo 
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punto al estar los pixels dispuestos en una malla regular y que los requerimientos de 

almacenamiento son mucho menores. 

1.1.2 Aproximación metodológica para el análisis de redes 

El estudio de la movilidad dentro de los espacios urbanizados se caracteriza por la 

multiplicidad de itinerarios que son posibles para visitar las distintas ubicaciones. El 

estudio de la accesibilidad, como caso específico, no es ajeno a esto puesto que 

puede ser posible acceder a un destino desde un punto de origen siguiendo distintos 

itinerarios con distintos grados de accesibilidad. 

El análisis de rutas óptimas se centra principalmente en la obtención del itinerario con 

el mínimo coste (tiempo, dinero, distancia) que permite visitar las ubicaciones 

deseadas en un orden preestablecido e incluso optimizar el orden de estas visitas. En 

estos análisis, los impedimentos para el análisis del movimiento en la red son dos 

tipos: 

 Impedimentos en función de una característica determinada, como por ejemplo 

el gálibo de un puente que impide el paso de un cierto tipo de camiones. 

Llamaremos a estos impedimentos intrínsecos. 

 Barreras o elementos de bloqueo temporal de la circulación en un tramo de la 

red, como por ejemplo la realización de obras, accidentes o retenciones. 

Llamaremos a estos impedimentos circunstanciales. 

Para aprovechar las herramientas disponibles para el análisis de redes de movilidad o 

de servicios y aplicarlas al análisis de accesibilidad en entornos urbanos se ha tenido 

que modelar la realidad existente desde el punto de vista de la accesibilidad 

acomodando estos dos tipos de impedimentos para tener en cuenta los distintos tipos 

de obstáculos, haciendo las siguientes simplificaciones: 

a) Se ha utilizado una red unimodal, de manera que no se considera como 

accesible un punto al que pueda llegarse mediante transporte público o 

privado. Se han considerado todas las calles peatonales. 

b) Se considera que los tramos que tienen algún impedimento no son 

transversables, sin distinguir su grado de accesibilidad, por lo que el cálculo 

elegirá siempre la ruta más corta que no tenga impedimentos. 

c) No se considera el sentido del movimiento dentro de la red. 
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d) Se han modelado sendas redes para cada tipo de usuario en función de su 

discapacidad. 

La primera simplificación se ha hecho por falta de datos de transporte público y de 

ubicación de plazas de aparcamiento adaptadas, aunque puesto que en el caso de 

estudio todos los itinerarios son peatonales no tiene ninguna incidencia. En caso de 

disponer de los datos, es trivial implementar una red multimodal. 

La segunda simplificación considera, para ciertos tipos de usuario, un escalón o una 

pendiente superior a un determinado valor como no transversables. No se considera 

que el usuario pueda viajar por una pendiente superior o subir un escalón si ello 

reduce la distancia del recorrido. Otras metodologías podrían tener en cuenta este 

aspecto. 

La tercera simplificación comporta que en la evaluación no se distinga entre 

pendientes ascendentes y descendentes. 

Finalmente, la cuarta simplificación es fruto de las limitaciones de funcionamiento de la 

herramienta informática utilizada que necesita definir una red distinta para evaluar 

cada tipo de discapacidad. 

1.2 Metodología seguida en los trabajos realizados 

Los trabajos realizados para obtener los resultados se detallan brevemente a 

continuación. 

Se ha utilizado una batería de técnicas basadas en Sistemas de Información 

Geográfica y se han elegido las soluciones que fueran más fácilmente extrapolables a 

ámbitos mucho mayores. También se ha evaluado en todos los casos la posibilidad de 

utilización de información de dominio público siempre que fuera factible. 

1.2.1 Metodología para la obtención de la topografía 

Inicialmente se ha contemplado la posibilidad de utilizar la información de los puntos 

altimétricos del ICC (aprtado 5.1) pero se ha comprobado que la información que 

proporciona no es utilizable, principalmente por la escasa densidad de los puntos y por 

el hecho que una parte de ellos corresponde a las cotas superiores de edificaciones. 
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El principal escollo para la obtención de la topografía es la presencia de elementos en 

la nube de puntos que no corresponden al suelo. Podemos encontrar dos tipos de 

elementos: 

a) Puntos dentro del perímetro de las fachadas y que por lo tanto se pueden 

descartar para la generación de la topografía de la calle. 

b) Puntos en las calles que corresponden a la detección de elementos (árboles, 

vehículos, personas, voladizos, mobiliario urbano, etc.) que no corresponden a 

su topografía. 

Los puntos del primer grupo son triviales de filtrar una vez reconocido el perímetro de 

las edificaciones; los segundos son mucho más difíciles de distinguir por métodos 

automáticos. 

Para identificar las zonas donde podemos encontrar puntos que representen la 

topografía con un alto grado de confianza se ha clasificado el raster según distintos 

criterios (apartado 5.2): desviación estándar (apartado 5.2.1), rango (apartado 5.2.2), 

pendiente (apartado 5.2.3) y curvatura tridimensional (apartado 5.2.4). También se han 

clasificado por métodos menos convencionales como la dimensión fractal (5.2.5). Esta 

operación es parecida a la teledetección orientada a objetos pero en este caso la red 

neural utilizada es la del operador que identifica los contornos. En futuras 

investigaciones se podría entrenar un módulo para realizar la operación 

automáticamente. 

Una vez identificadas las zonas consideradas válidas según los cuatro criterios, se han 

digitalizado una serie de puntos y se les ha asignado la coordenada Z del píxel 

correspondiente a su proyección en planta, como si se tomaran muestras con un 

“teodolito virtual” (apartado 5.3). 

A partir de estos puntos se ha podido generar un DTM (apartado 5.3.1) y un TIN 

(apartado 5.3.2). 

La topografía obtenida se ha comparado con la disponible en el ICC y se ha 

comprobado que en los puntos sin edificación concordaban con un error imperceptible 

mientras que en las zonas con edificación la topografía obtenida con esta metodología 

ofrecía mejores resultados. 
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Adicionalmente se ha desarrollado un módulo que limpia los errores de manera 

recursiva, pero se ha descartado su utilización porque sólo ha obtenido resultados 

correctos en un 90% de los casos aproximadamente y se ha descartado para la 

presente investigación. 

1.2.2 Metodología para la detección de obstáculos 

Para identificar los obstáculos desde el punto de vista de la accesibilidad (apartado 6) 

se ha utilizado una metodología distinta para cada tipo de elemento. 

Estos elementos se han comparado con la cartografía del ICC (para la obtención de la 

cual se realizó un trabajo de campo complementario en su momento) y los resultados 

han sido muy exactos, superando en algunos casos incluso a estos datos en cuanto a 

exactitud. 

Para la identificación de pendiente se ha utilizado la pendiente como medida para 

detectar cambios bruscos de altura (apartado 6.1), con lo que se pueden apreciar 

visualmente elementos rectilíneos en planta que corresponden a las fachadas, muros, 

torres y muralla, algunos de los cuales no aparecen en la cartografía del ICC. 

Para la identificación de las escaleras (apartado 6.2), la resolución del LTS ha 

permitido utilizar también la pendiente para visualizar la proyección en planta de las 

contrahuellas, utilizando unos valores más bajos que con las fachadas como umbral. 

En este caso la identificación ha sido también excelente utilizando como referencia la 

cartografía del ICC. 

La nube de puntos también se ha utilizado para detectar zonas con altura insuficiente 

mediante la exploración del modelo 3D (apartado 6.4). 

Por otra parte, las zonas de anchura insuficiente (apartado 6.3) e iluminación 

inadecuada (apartado 6.5) se han obtenido mediante la utilización de herramientas 

convencionales de SIG a partir de la geometría de las fachadas en el primer caso y de 

la ubicación de las farolas en el segundo caso. 

1.2.3 Metodología para la evaluación de red 

Para la construcción de la red se ha preparado la geometría del grafo que la 

representa para acoger la información necesaria (apartado 7). 
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Se han determinado en primer lugar los ejes de calle a partir de la cartografía del ICC, 

contrastada con la información obtenida del LTS (apartado 7.1). 

Para ajustar los ejes de calle a la topografía se han realizado dos operaciones: se han 

subdividido los tramos en segmentos cortos o subtramos (apartado 7.2) y se han 

convertido los tramos en entidades tridimensionales a partir de la topografía (apartado 

7.3). 

A partir de esta geometría se ha incorporado a cada subtramo la información de su 

pendiente (apartado 7.4) y de la presencia de obstáculos correspondientes a 

escaleras, pasos con altura insuficiente, pasos con anchura insuficiente y zonas de 

iluminación inadecuada (apartado 7.5). 

Una vez obtenida la geometría con la información necesaria para efectuar el análisis 

de redes, se han definido tres redes con distintos parámetros en función del tipo de 

discapacidad a evaluar (apartado 8): 

 Usuario estándar (apartados 8.1 y 9.2) 

 Usuario con movilidad reducida (apartados 8.2 y 9.3) 

 Usuario en silla de ruedas (aparatados 8.3 y 9.4) 

Para estudiar los itinerarios accesibles (apartado 9) se han determinado unos puntos 

de interés predeterminados (apartado 9.1) y se han obtenido tres tipos de resultados 

para cada caso evaluado: 

 En primer lugar, el cálculo de la ruta óptima entre múltiples puntos arbitrarios 

para los tres casos evaluados (apartados 9.2.1, 9.3.1 y 9.4.1 respectivamente), 

que permite generar un itinerario a medida y ubicar barreras presentes de 

manera circunstancial, como por ejemplo unas obras en la vía que impiden el 

paso temporalmente. 

 En segundo lugar, la obtención de la matriz origen-destino entre los puntos de 

interés predeterminados (apartados 9.2.2, 9.2.2 y 9.4.2 respectivamente), que 

permite identificar cuellos de botella y desconexiones en la red que facilita 

dirigir las posibles intervenciones hacia los aspectos que conllevan un mayor 

mejora de accesibilidad. 
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 Finalmente, en tercer lugar, la generación automática de las imágenes de los 

itinerarios entre los puntos predeterminados para su difusión mediante la 

inclusión en una página web (apartados 9.2.3, 9.3.3 y 9.4.3 respectivamente). 

Mediante esta metodología se consigue por una parte realizar una evaluación de la 

accesibilidad del entorno estudiado y también conseguir unos productos de salida que 

faciliten el conocimiento del entorno a los usuarios. 

La metodología utilizada es adaptable a entornos urbanos más extensos con algunas 

modificaciones por el hecho que todas las calles del caso de estudio se han 

considerado peatonales a efectos de este trabajo. 
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2 Estado del arte 

2.1 Accesibilidad y análisis de redes 

Para poder evaluar la accesibilidad con herramientas SIG, en primer lugar debemos 

crear un modelo que nos permita traducir las características de los espacios que 

queremos evaluar a un conjunto de entidades con atributos que pueda manejar el 

programa (Zeiler, 1999). 

En el análisis de redes en programas SIG se acostumbra utilizar la altura para modelar 

las intersecciones sin conectividad (por ejemplo el caso de puentes o túneles). En 

algunos ejemplos se modela la pendiente de las redes mediante datos obtenidos en 

trabajo de campo (Price, 2008) o se utiliza la información topográfica para obtener la 

pendiente a partir de los puntos extremos (Price, 2009). 

Por lo que hace referencia a la caracterización de la accesibilidad, la metodología 

POLIS (POLIS, 2008) utiliza el paradigma del Building Accessibility Model (BAM) para 

modelar la accesibilidad de los elementos de los edificios y de conjuntos de elementos 

hasta llegar a evaluar el edificio en conjunto. 

Siguiendo una metodología parecida, encontramos propuestas de evaluación de 

edificios patrimoniales (del Moral, 2006) siguiendo la normativa específica de 

aplicación en España (del Moral & Delgado, 2010). 

2.2 Topografía 

La utilización de tecnologías de detección y caracterización (entre ellas el escáner 

láser) ha aportado grandes avances en Medicina y en otras disciplinas como la 

Arqueología, dónde el uso del LIDAR está revolucionando la detección ruinas y 

alteraciones topográficas ocultas bajo la cobertura vegetal selvática (Figura 1), 

sustituyendo largas campañas de trabajo de campo (Weishampel, Patrick, Hightower, 

Chase, & Chase, 2010). 
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Figura 1: Detección de ruinas Maya bajo la cobertura vegetal (fuente: NY Times
1
) 

 

La caracterización de superficies topográficas a través su clasificación automática de 

manera paramétrica ha experimentado una gran evolución recientemente mediante el 

uso programas informáticos2. 

Se pueden clasificar los elementos en los siguientes tipos (Wood, 1996): 

 Fosas (pits) 

 Cauces (channels) 

 Desfiladeros (passes) 

 Crestas (ridges) 

 Cumbres (peaks) 

 Regiones llanas (planar regions) 

A partir de estos trabajos, se ha avanzado en la caracterización de superficies 

mediante redes, especialmente desde el punto de vista hidrológico (Pfaltz, 1976), con 

                                                 
1
 Véase http://www.nytimes.com/2010/05/11/science/11maya.html 

2
 Estas caracterizaciones pueden estudiarse con el programa de libre distribución LandSerf 

(véase http://www.soi.city.ac.uk/~jwo/landserf/) 
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la ayuda de herramientas informáticas (Wood, 2000), mediante las cuales se modelan 

las redes de cuencas y de desfiladeros y también su conectividad a partir de un DTM 

(Schneider, 2005). 

Otro enfoque más novedoso es el análisis multiescala de las superficies para averiguar 

sus dimensiones fractales y el empleo de lógica difusa para su caracterización (Fisher, 

2004). 

Para la depuración de nubes de puntos procedentes de LIDAR para obtener la 

topografía o las construcciones cabe destacar las técnicas de limpieza mediante en 

estudio de la pendiente (Vosselman, 2000) y depuradas mediante la incorporación de 

filtros (Sithole, 2001). 

Otras técnicas trabajan sobre entidades tipo malla triangular irregular (TIN), adaptando 

al TIN generado a partir de la nube obtenida una nueva malla (Axelsson, 2000) o 

mediante la reducción progresiva del número de nodos (Kersting & Kersting, 2005) 

Otros autores proponen trabajar directamente con la nube de puntos, filtrando los 

puntos que no correponden a la topografía (Błaszczak-Bąk, Janowski, Kamiński, & 

Rapińsk, 2010). 

Para distinguir entre topografía y objetos, se ha propuesto el uso de redes neurales 

artificiales combinado con análisis multiescala (Priestnall, Jaafar, & Duncan, 2000), el 

uso de wavelets (Bartels & Wei, 2006) y el desarrollo del algoritmo de segmentación 

llamado skewness balancing (Bartels, Wei, & Mason, 2006). Estas propuestas van 

encaminadas a la clasificación automática de información LIDAR que está empezando 

a generalizarse con su incorporación al paquete eCognition Developer 8 de Definiens. 
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2.3 Marco legislativo 

La sensibilidad con los aspectos relacionados con la accesibilidad aparece ya en el 

artículo 49 la Constitución Española de 1978: 

“Los poderes públicos realizarán una política de previsión, tratamiento, rehabilitación e 

integración de los disminuidos físicos, sensoriales y psíquicos, a los que prestarán la 

atención especializada que requieran y los ampararán especialmente para el disfrute 

de los derechos que este Título otorga a todos los ciudadanos.” 

La Ley 13/1982, de 7 de abril, de Integración Social de los Minusválidos (Jefatura del 

Estado, 1982) y posteriormente la Ley 51/2003, de 2 de diciembre, de igualdad de 

oportunidades, no discriminación y accesibilidad universal de las personas con 

discapacidad (Jefatura del Estado, 2003) cimentan la necesidad conseguir el mayor 

grado de accesibilidad para todas las personas. 

Recientemente, se ha aprobado una modificación del Código Técnico de la 

Edificación3 que lo modifica para regular la accesibilidad dentro de los edificios y en el 

acceso a los mismos (Ministerio de Vivienda, 2010). 

De manera casi simultánea a la regulación de la accesibilidad en las edificaciones, la 

accesibilidad de los espacios públicos ha sido regulada recientemente4 (Ministerio de 

Vivienda, 2010) complementando la reglamentación existente hasta la fecha5 

(Ministerio de la Presidencia, 2007). 

Estas regulaciones se añaden a las normas UNE 170001-1:2007 (AENOR, 2007) y 

UNE 170001-2:2007 (AENOR, 2007) que ya estaban vigentes.  

La mayoría de las autonomías han legislado también en materia de accesibilidad. En 

el caso de la Comunidad Autónoma de Cataluña es de obligado cumplimiento el Codi 

                                                 
3
 Real Decreto 173/2010, de 19 de febrero, por el que se modifica el Código Técnico de la 

Edificación, aprobado por el Real Decreto 314/2006, de 17 de marzo, en materia de 
accesibilidad y no discriminación de las personas con discapacidad. 
4
 Orden VIV/561/2010, de 1 de febrero, por la que se desarrolla el documento técnico de 

condiciones básicas de accesibilidad y no discriminación para el acceso y utilización de los 
espacios públicos urbanizados 
5
 Real Decreto 505/2007, de 20 de abril, por el que se aprueban las condiciones básicas de 

accesibilidad y no discriminación de las personas con discapacidad para el acceso y utilización 
de los espacios públicos urbanizados y edificaciones 
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d’accessibilitat6 (Departament de Benestar Social, 1995) que desarrolla la Llei de 

promoció de l'accessibilitat i de supressió de barreres arquitectòniques7 (Generalitat de 

Catalunya, 1991). 

Por otra parte, en Cataluña, el Decret d’Habitabilitat8 ha incorporado también muchos 

conceptos en relación con la accesibilidad (Departament de Benestar Social, 2009) de 

la misma forma como lo ha hecho el CTE demostrando la cada vez mayor importancia 

de conseguir unos espacios accesibles dentro y fuera de los edificios. 

   

                                                 
6
 Decret 135/1995, de 24 de març, de desplegament de la Llei 20/1991, de 25 de novembre, de 

promoció de l’accessibilitat i de supressió de barreres arquitectòniques, i d’aprovació del Codi 
d’accessibilitat 
7
 Llei 20/1991, de 25 de novembre, de promoció de l'accessibilitat i de supressió de barreres 

arquitectòniques 
8
 Decret 55/2009, de 7 d'abril, sobre les condicions d'habitabilitat dels habitatges i la cèdula 

d'habitabilitat 
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3 Incorporación de la información de partida al SIG 

Se ha incorporado la información procedente del LTS y también cartografía adicional 

de dominio público para poder contrastarla con los resultados obtenidos con el LTS y 

también para explorar la posibilidad de replicar el trabajo realizado únicamente con 

estas fuentes. 

3.1 Importación de la información de la nube de puntos 

La resolución de los detalles proporcionada por el LTS nos permite analizar las 

características del entorno con gran precisión utilizando métodos automáticos; sin 

embargo, debido al sistema de captura de datos del LTS, encontramos tres problemas 

principales que nos impiden generar una topografía correcta de manera directa: 

 Los puntos obtenidos no incorporan ningún tipo de referencia espacial, ni 

horizontal ni vertical, por lo que necesitan ser georeferenciados.  

 Hay zonas que no contienen la información de ningún punto y por lo tanto no 

disponemos de datos en algunas localizaciones. Esto se produce debido a la 

existencia de zonas de sombra porque objetos fijos o móviles ocluyen la 

trayectoria del laser del escáner. Debido a esto los datos deberán ser 

interpolados. 

 Finalmente, el escáner registra objetos (árboles, personas, automóviles, 

mobiliario urbano, voladizos…) pero es incapaz de distinguirlos del suelo para 

obtener una topografía correcta. Para solventar este problema será necesario 

filtrar la nube de puntos para descartar estos objetos. 

En el escáner de tiempo de vuelo utilizado, la resolución está limitada por la mínima 

fracción de tiempo que es capaz de distinguir, siendo como máximo el producto de la 

velocidad de la luz (constante) por la mitad del tiempo de vuelo (Ecuación 1): 

Ecuación 1: Resolución espacial y resolución temporal en un escáner laser de tiempo de vuelo 

        

La información procedente del LTS se ha incorporado a ArcGIS Versión 9.3.1. Para 

gestionar la información se han utilizado las extensiones Spatial Analyst, 3D Analyst y 

Network Analyst. 
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La información de la nube de puntos se ha obtenido en un archivo de texto ASCII 

exportado desde los programas GeoMagic y Pointools, con los que se ha trabajado la 

geometría mediante operaciones de mallado y filtro. 

El contenido de este archivo de texto es un listado con los 1.823.336 puntos del ámbito 

estudiado donde cada fila del archivo corresponde a la información de un único punto. 

En cada línea encontramos las tres coordenadas del punto en el espacio (x,y,z) 

separadas por comas y con el separador decimal en formato anglosajón: 

Figura 2: Archivo ASCII procedente del LTS 

[...] 

-180.000,-188.900,-15.100 

-180.000,-188.500,-15.157 

-180.000,-188.400,-15.157 

-180.000,-188.300,-15.252 

-180.000,-177.000,-13.786 

[...] 

 

Como se puede apreciar (Figura 2), la resolución espacial de esta retícula puntos es 

de 10 centímetros en proyección horizontal y de 1 milímetros en elevación. 

Como tratamiento previo para rectificar la elevación estos puntos, y debido que ArcGIS 

no es capaz de manejar el volumen de datos contenido en el archivo ASCII, el archivo 

se ha importado en una la base de datos Microsoft Access dónde se han modificado 

las coordenadas Z, de manera que a la coordenada menor (-15,511) se le ha asignado 

la cota ±0 (Ecuación 2): 

Ecuación 2: Asignación de coordenada 0 a la cota inferior 

                                          

Una vez modificada la coordenada Z se ha exportado el listado de puntos nuevamente 

a un fichero ASCII y se han importado en ArcGIS, como entidades tipo MultiPoint y 

como entidad tipo raster, para poder tratar la información topográfica con distintas 

metodologías. 
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3.2 Cartografía del Institut Cartogràfic de Catalunya (ICC) 

Los productos cartográficos disponibles en el Instituto Cartográfico de Cataluña que se 

han utilizado son los siguientes: 

Base topográfica 1:5.000 (hoja 307-110) 

 Formato: DXF 3D 

 Fecha del vuelo: Mayo de 2001 

Ortofoto 1:5.000 (hoja 307-110) 

 Formato: MrSID con compresión 10 

 Resolución de píxel de 0,50 metros (4638x6941) 

 Fecha del vuelo: Junio de 2008 

Cartografía 1:1.000 (Proyecto 08,09-2004 código 00119771600) 

 Formato: SHP 3D 

 Fecha del vuelo: Agosto de 2004 

 Fecha de revisión de campo: Diciembre de 2005 

La descripción del contenido de estos archivos se ha obtenido en formato PDF en la 

web del ICC9(ICC, 2009). 

La información está dividida en: 

 Puntos 

 Líneas 

 Áreas 

 División en hojas del ICC 

La información del archivo SHP obtenido de la web del ICC está estructurada de 

manera que las entidades disponen de un campo llamado “CAS” los prefijos del 

contenido del cual son los siguientes: 

 Orografía y relieve ORO_* 

 Modelo de elevaciones MED_* 

                                                 
9
 http://www.icc.cat/cat/Home-ICC/Inici/Cartografia/Documentacio/Especificacions-tecniques 



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 24 

 

 Hidrografía y obras hidráulicas HID_* 

 Vegetación y usos del suelo VEG_* 

 Comunicaciones y vialidad COM_* 

 Construcciones y poblaciones CON_* 

 Energía y telecomunicaciones ENE_* 

 Toponimia y anotaciones TOP_* 

 Registros REG_* 

Se ha cortado la cartografía para obtener únicamente las entidades que forman parte 

del ámbito de estudio y se han filtrado las siguientes entidades mediante el comando 

Selection > Select by Attributes para utilizarse como referencia para la 

georeferenciación de otra información (Figura 3): 

 Fachadas CON_01* 

 Porches CON_02* 

 Medianeras CON_03* 

 Vertientes CON_04* 

 Cubiertas CON_07* 

 Ruinas CON_10* 

 Muros CON_14* + CON_15* + CON_18 

 Desniveles y barandillas CON_20 

 Escalones CON_23 

 Cumbreras CON_29 

Figura 3: Información vectorial y raster del ICC importada, filtrada y recortada 
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También se ha importado la información de puntos altimétricos 3D y la ortofoto para 

poder trabajar con ella sin depender de la cartografía WMS del ICC (Figura 3). 

3.3 Cartografía del Ayuntamiento de Tossa de Mar 

Se han importado la posición de las farolas facilitada por el Ayuntamiento de Tossa de 

Mar. Sólo se ha utilizado la información de su localización de manera que los campos 

de información que contiene se han descartado (Figura 4). 

Figura 4: Ubicación del alumbrado proporcionada por el Ayuntamiento de Tossa de Mar 

 

También se ha incorporado la información de planeamiento obtenida de la web del 

Ayuntamiento (Ajuntament de Tossa de Mar, 2010) para poder disponer de los límites 

de propiedad entre espacio público y privado. Como la cartografía es una imagen 

ordinaria sin referencia espacial, se ha tenido que georeferenciar utilizando como 

referencia la cartografía del ICC (Figura 5). 
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Figura 5: Información de planeamiento importada y georeferenciada 

 

3.4 Otras fuentes de datos disponibles públicamente 

Adicionalmente se ha consultado la cartografía WMS del Catastro (Dirección General 

del Catastro, 2010) y de Goolzoom (Barrio, 2010). 
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4 Tratamiento de los datos del LTS 

4.1 Conversión a entidades de tipo punto 

Se ha realizado la importación a entidades tipo punto (Figura 6), a partir del archivo de 

texto ASCII mediante la orden 3D Analyst Tools > Conversion > From File > ASCII 3D 

to Feature Class indicando que el formato en el archivo de texto es XYZ y 

seleccionando MultiPoint como tipo de entidades a generar en contraposición a 

entidades tipo Point. 

Figura 6: Nube de puntos importada en ArcGIS a partir del archivo ASCII (2D y 3D) 

 

A diferencia de las entidades tipo Point, que consumen un registro para cada elemento 

con sus campos correspondientes, las entidades tipo MultiPoint son entidades también 

de tipo punto que se almacenan de manera conjunta en clusters de hasta 5.000 puntos 

en un solo registro para ahorrar espacio y tiempo de procesamiento. 

La ventaja de utilizar este tipo de entidades es que tendremos únicamente 414 

registros en comparación con los 1.823.336 registros que hubieran consumido las 

entidades tipo punto. 
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Como contrapartida, no podemos asignar campos de información a cada punto de 

manera individualizada. Sin embargo, para la metodología que estamos utilizando, 

esto no supone ningún inconveniente puesto que tan solo nos interesa la coordenada 

Z, que está implícita en la geometría del punto. 

Al carecer de georeferenciación, los puntos se importan el origen de coordenadas 

situado en la intersección del ecuador con el meridiano de Greenwich. Para poder 

ubicar la nube de puntos en sus coordenadas correctas, se puede utilizar la 

herramienta Spatial Adjustment (sin utilizar rectificación) mediante la cual se 

determinan las localizaciones algunos puntos origen (en la nube de puntos) y sus 

destinos correspondientes (utilizando como referencia la información del ICC). 

Alternativamente, se pueden convertir los puntos a una entidad de tipo raster y 

georeferenciar este raster con la herramienta Georeferencing; esta segunda opción ha 

sido la utilizada debido a su mayor facilidad para identificar elementos en el raster en 

comparación con la nube de puntos. Posteriormente se puede convertir el raster 

nuevamente a puntos mediante la orden Conversion Tools > From Raster > Raster to 

Point. 
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4.2 Conversión a entidad de tipo raster 

Trabajar con entidades tipo raster tiene algunas ventajas para el caso que nos ocupa: 

 La información de la nube de puntos procedente de GeoMagic ya esta 

ordenada en una estructura de retícula y por lo tanto no se introducen 

distorsiones de muestreo adicionales en la conversión. 

 Las herramientas de georeferenciación son mucho más potentes cuando 

trabajan con este tipo de entidades que con entidades vectoriales. 

El raster se obtiene de la nube de puntos anteriormente importada a MultiPoint 

mediante la instrucción Conversion Tools > To Raster > Point to Raster. Como campo 

para determinar el valor del raster elegimos el de shape, con lo cual se asignará la 

coordenada Z del punto al valor de cada pixel en función de la posición del punto 

correspondiente en planta. Para evitar distorsiones pediremos que la herramienta elija 

el valor más frecuente de la coordenada Z y que genere un raster de la misma 

resolución que la nube de puntos (0,1 metros). 

De la importación como raster se ha obtenido una imagen de 2001 x 2001 pixels 

(200,1 x 200,1 metros), dónde el valor del pixel corresponde con la coordenada Z de 

los puntos importados y las zonas donde no hay puntos son representadas como 

valores nulos (Figura 7). 
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Figura 7: Raster de elevaciones en falso color 

 

Para comprobar la correcta importación, se ha ejecutado de nuevo la instrucción 

Conversion Tools > To Raster > Point to Raster; en este caso se ha indicado que se 

genere un raster con idénticas características pero con la cuenta del número de puntos 

de los cuales adopta los valores cada píxel. El resultado debería ser un raster 

compuesto únicamente de 1.823.336 pixels de valor 1 y el resto valores nulos, que es 

el resultado que se ha obtenido (Figura 8). 
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Figura 8: Numero de puntos muestreados por píxel (rojo = 1 ; negro = sin datos) 

 

Una vez importado el raster se ha georeferenciado utilizando como referencia la 

cartografía del ICC. 

Dado que el escaneado se hizo a nivel de calle, no disponemos de lecturas de las 

cubiertas ni del interior de los edificios. La cobertura de la región analizada ha sido del 

45,54% (1.823.336 / 2.0012 x 100) y por lo tanto el 54,49% de los pixels tienen el valor 

nulo. 

Para interpolar los valores de los puntos dónde no hay datos (Longley, Goodchild, 

Maguire, & Rhind, 2010), se han ensayado distintos algoritmos que proporciona 

ArcGIS para estimar estos valores a partir de los valores conocidos de las entidades 

MultiPoint. Con estos ensayos se ha pretendido averiguar qué modelo se adapta mejor 

para predecir los valores de las zonas donde no hay datos. 
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Debido a que ArcGIS solamente puede realizar la interpolación a partir de entidades 

de tipo punto y no de tipo raster, ha sido necesario en convertir el raster previamente 

georeferenciado a una nube de puntos mediante la herramienta Conversion Tools > 

From Raster > Raster to Point de manera que obtenemos una nube de puntos 

georeferenciada con un campo llamado GRID_CODE correspondiente al valor del 

pixel y con posición coincidente la del centro del pixel. 

Se han evaluado cuatro métodos deterministas (IDW, Spline, Natural Neighbor y 

Trend) y un método geoestadístco (Kriging). También se ha evaluado un método 

enfocado a obtener superficies topográficamente correctas (Topo to Raster). 

Para evaluar la calidad de los resultados obtenidos se ha aplicado la herramienta 

Spatial Analyst Tools > Local > Cell Statistics y se han comparado los resultados de la 

interpolación con los del raster original mapificando la desviación estándar en cada 

punto. 

Finalmente, se ha optado por el algoritmo Natural Neighbor ya que produce unos 

resultados comparativamente más ajustados para el conjunto de datos con los que se 

ha trabajado. 
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4.2.1 Interpolación IDW (Inverse Distance Weighted) 

La interpolación IDW se basa en calcular el valor interpolado a partir sus valores 

vecinos asignándoles una ponderación en función inversa de la distancia elevada a un 

exponente (Watson & Philip, 1985). Es posible restringir el número de vecinos en 

función de un radio o de un número máximo de vecinos a considerar. 

Se han evaluado distintos valores y finalmente se ha utilizado un exponente de 2 y un 

radio variable que considera 12 vecinos. El resultado presenta artefactos en zonas con 

poca densidad de puntos y al mismo tiempo pierde precisión en las zonas donde la 

densidad es mayor (Figura 9). 

Figura 9: Interpolación IDW con los valores considerados óptimos y evaluación del error 
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4.2.2 Interpolación Spline 

El algoritmo de interpolación utilizando la Spline impone las dos siguientes condiciones 

(Franke, 1982): 

 La superficie interpolada debe pasar exactamente por los puntos de los que se 

tienen datos. 

 La superficie obtenida debe tener la mínima curvatura. 

El resultado obtenido es una superficie con cambios suaves en el caso que se utilice la 

opción regularized y con cambios más abruptos en el caso de la opción tension. 

Se han evaluado distintos opciones y finalmente se ha optado por la opción 

regularized puesto que se obtienen mejores resultados para el conjunto de datos 

estudiado. 

El algoritmo genera muchos artefactos en las mayores zonas sin datos en forma de 

patrón cruzado en diagonal y mayores errores que el IDW (Figura 10). 

Figura 10: Interpolación Spline con los valores considerados óptimos y evaluación del error 

  

  



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 35 

 

4.2.3 Interpolación Natural Neighbor 

El algoritmo Natural Neighbor es parecido al IDW en el sentido que pondera a los 

valores vecinos en función de su posición respecto al pixel evaluado. 

La metodología que utiliza consiste en primer lugar en generar un diagrama de 

Voronoi (Figura 11) de los puntos a interpolar (puntos negros) grafiado como los 

polígonos de color verde. En segundo lugar se genera un segundo diagrama de 

Voronoi (en naranja)  incluyendo el punto a interpolar (estrella roja) y asigna los pesos 

en función del área de superposición con el diagrama anterior(Sibson, 1981). 

Figura 11: Esquema de asignación de valores del algoritmo Natural Neighbors (fuente: ESRI) 

 

El resultado del algoritmo es un raster cuyos límites son el Convex Hull del conjunto de 

puntos de partida en proyección horizontal. 

El algoritmo obtiene relativamente buenos resultados tanto para zonas con pocos 

puntos como para zonas con mayor densidad sin introducir demasiados artefactos ni 

errores (Figura 12). 

Figura 12: Interpolación Natural Neighbor y evaluación del error 
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4.2.4 Interpolación Topo to Raster 

El algoritmo Topo to Raster interpola los valores de elevación y genera una estructura 

de drenaje conectada evitando la creación de puntos bajos que no se acostumbran a 

dar en las topografías naturales (en nuestro caso no se han considerado). El algoritmo 

está concebido principalmente para obtener superficies topográficas hidrológicamente 

correctas, en especial a partir de curvas de nivel pero no exclusivamente, por lo que 

también acepta entidades de tipo punto. La metodología está basada en el programa 

ANUDEM desarrollado en la Australian National University (Hutchinson, 1989). 

Los resultados son parecidos a los del algoritmo Natural Neighbor pero debido a las 

hipótesis de partida que utiliza el resultado es menos fiable puesto que los puntos 

iniciales no representan una topografía correcta sino con errores y se introducen 

algunas distorsiones (Figura 13). 

Figura 13: Interpolación Topo to Raster y evaluación del error 
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4.2.5 Interpolación Trend 

El algoritmo Trend consiste en encontrar el polinomio de grado n10 que más se 

aproxima a los puntos dados. Se trata de un interpolador inexacto, aunque como 

contrapardida nos da una medida del error RMS (Root Mean Square). 

Se ha utilizado el programa IDRISI para realizar este tipo de interpolación con un 

exponente de 9 (Figura 14). Al tratarse de un interpolador para valores que varían de 

manera continua, los errores presentes en la muestra introducen distorsiones que 

desaconsejan su uso. 

Figura 14: Interpolación Trend de exponente 9 en IDRISI y evaluación del error 
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 ArcGIS permite polinomios de hasta grado 12 y IDRISI polinomios de hasta grado 9 
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4.2.6 Interpolación Kriging 

El método de interpolación Kriging es, a diferencia de los anteriormente presentados, 

un método geoestadístico. El raster generado es la estimación de la superficie a partir 

de un conjunto disperso de puntos (Oliver, 1990). 

Es el método que ha requerido más tiempo de proceso de los interpoladores 

evaluados, necesitando 57 horas para ser calculado en un Intel Xeon 5150 operando a 

una velocidad de 2,66MHz. Alternativamente se puede utilizar el software IDRISI 

Taiga11 para calcular la interpolación mediante el algoritmo Kriging Local Linear Model 

Prediction en cuyo caso el cálculo se realiza en la misma máquina en menos de 6 

horas. 

El  hecho que el método asuma que la variación de los datos (en este caso las 

coordenadas Z) es estadísticamente homogénea en toda la superficie estudiada 

provoca que aparezcan problemas en la interpolación debido a que los errores del 

escáner laser introducen discontinuidades importantes en la cota de los puntos y por lo 

tanto esta información no está necesariamente correlada espacialmente. Este 

problema se manifiesta en la muestra en forma de tramado de líneas en las zonas sin 

datos (Figura 15) que es más aparente si representamos la varianza en cada píxel 

(Figura 16). 

Figura 15: Kriging y evaluación del error 
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 El motor geoestadístico de IDRISI está basado en el software libre gstat 
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Figura 16: Representación de la varianza de la interpolación Kriging 
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4.3 Conversión a entidad tipo TIN 

La información de los puntos del LTS también se ha estructurado en un TIN 

(Triangular Irregular Network). 

Los TIN son una forma de almacenar información topográfica de forma vectorial, a 

partir de la triangulación de los puntos que representan las cotas altimétricas. En un 

TIN, estos puntos se convierten en vértices de triángulos, los lados de los cuales 

coinciden con líneas que unen pares de puntos, creando una red. Para la formación de 

los triángulos se utiliza la triangulación de Delaunay, que maximiza los ángulos de los 

triángulos generados y por lo tanto evita en lo posible la generación de triángulos 

excesivamente alargados (Duckham & Worboys, 2004). 

El resultado una figura tridimensional que representa el terreno mediante triángulos, 

cuya proyección en planta es el convex hull de los puntos a partir de los cuales se ha 

generado el TIN. 

Para modelar el terreno en ArcGIS se ha optado por utilizar la entidad denominada 

Terrain que consiste en un conjunto de TINs donde la geometría aumenta o disminuye 

su grado de detalle (numero de triángulos) en función de la resolución a la que se está 

mostrando el terreno la entidad (Figura 17). 

Figura 17: TIN generado a partir de la nube de puntos del LTS 
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Se han creado TINs para las resoluciones 1:1000, 1:2000, 1:5000 y 1:10.000 para 

facilitar la visualización a distintas escalas. 

Se ha tenido que calcular la distancia media entre puntos, que es desconocida. Para 

averiguarla, se ha utilizado la herramienta 3D Analyst Tools > Conversion > From 

Feature Class > Feature Class Z to ASCII y se ha creado un fichero de de texto con la 

información de los puntos en formato ASCII (formato GENERATE). A partir de este 

archivo, con la orden 3D Analyst Tools > Conversion > From File > Point File 

Information se ha obtenido una entidad shape con la información de la distancia media 

entre puntos, que ha resultado de 0,16 metros entre un total de 1.681.613 puntos. 

Una vez generado el TIN, se han incorporado como hard erase los polígonos 

correspondientes a las manzanas debido a que los puntos capturados por el LTS que 

están dentro de su perímetro no nos dan ninguna información topográfica. El resultado 

(Figura 18) permite apreciar que la topografía obtenida contiene importantes errores y 

que por lo tanto no es apta para el cálculo de pendientes de las rutas. 

Figura 18: TIN modelando como vacíos las zonas correspondientes a las manzanas 

 

Con la visualización del TIN se hace patente que es necesario filtrar la información de 

la nube de puntos para excluir aquellos que no representan una muestra la topografía 

a estudiar (Kersting & Kersting, 2005). 
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Se han clasificado los triángulos según su altura (Figura 19), la dirección de su normal 

(Figura 20) y pendiente máxima (Figura 21) para detectar zonas donde existen errores 

de lectura que impiden evaluar la topografía sin introducir distorsiones. 

Figura 19: Triángulos del TIN clasificados según su altura (con sombreado) 

  

Figura 20: Triángulos del TIN clasificados según la dirección de su normal 
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Figura 21: Triángulos del TIN clasificados según su pendiente máxima 
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5 Obtención de la topografía 

5.1 Viabilidad de la utilización de la información del ICC 

Se ha contemplado la utilización de los puntos altimétricos del ICC para el cálculo de 

pendientes. 

Se ha seguido el mismo procedimiento descrito anteriormente para obtener la 

topografía del ámbito (Figura 22), utilizando la geometría de las manzanas (que 

previamente han tenido que convertirse a entidades 2D12) como hard erase. 

Para ello se ha tenido que calcular la distancia media entre puntos, que es 

desconocida. Para averiguarla, se ha utilizado la herramienta 3D Analyst Tools > 

Conversion > From Feature Class > Feature Class Z to ASCII y se ha creado un 

fichero de de texto con la información de los puntos en formato ASCII (formato 

GENERATE). A partir de este archivo, con la orden 3D Analyst Tools > Conversion > 

From File > Point File Information se ha obtenido una entidad shape con la información 

de la distancia media entre puntos, que ha resultado de 16,73 metros entre un total de 

15.578 puntos. 

Figura 22: TIN obtenido a partir de la información altimétrica del ICC 

 

Adicionalmente, se ha hecho una interpolación Kriging y mediante el estudio de la 

varianza del resultado (Figura 23) se ha constatado que estos puntos no aportan una 

información suficientemente detallada por estar los puntos demasiado separados y 

                                                 
12

 Véase http://resources.arcgis.com/content/kbase?fa=articleShow&d=30455 
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debido a que algunos de ellos representan cotas de elementos construidos, lo que 

impide su utilización para este estudio (Figura 24). 

Figura 23: Interpolación Kriging y Varianza de los puntos del ICC del ámbio 

  

Figura 24: Varianza representada sobre el MDT generado a partir de los puntos del ICC 

 

 



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 46 

 

5.2 Obtención de muestras representativas 

Para poder evaluar la pendiente del núcleo urbano es necesario disponer de una 

superficie topográfica que represente las calles por donde discurrirán los itinerarios 

evaluados. 

La metodología consiste en generar una nueva topografía a partir de unos puntos 

registrados por el LTS que, mediante técnicas de clasificación, se han identificado 

como representativos de la topografía con un alto grado de confianza. Estos píxeles 

serán llamados “candidatos”. 

Para la clasificación de los píxeles se ha desarrollado módulo en Model Builder de 

ArcGIS, el cual permite detectar posibles datos anómalos con cuatro criterios 

diferentes (Figura 25). 

Figura 25: Diagrama de bloques del módulo de identificación de candidatos
13

 

 

  

                                                 
13

 Véase código VisualBasic en apartado 12.1 (página 139) 
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5.2.1 Clasificación según la desviación estándar 

El primer método consiste en evaluar la desviación estándar de cada uno de los 

vecinos de cada píxel para, posteriormente, reclasificar los resultados en dos grupos 

(Figura 26): candidatos (en naranja) y descartados (en rojo). 

Figura 26: Clasificación de candidatos según la desviación estándar 

 

Se utiliza la herramienta Spatial Analyst Tools > Neighborhood > Focal Statistics y se 

calcula la desviación estándar (STD) en una ventana rectangular de 3x3 pixels. El 

resultado es clasificado con la herramienta Spatial Analyst Tools > Reclass > 

Reclassify de manera que los valores menores o iguales a 0,1 se les asigna el valor de 

1 (candidato) y los valores superiores a 0,1 se les asigna el valor de 2 (descartado). 

Para representar esta clasificación se hace un mapa temático con estos valores. 
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5.2.2 Clasificación según el rango 

El segundo método consiste en evaluar el rango (diferencia entre valor máximo y 

mínimo) de cada uno los vecinos de cada píxel para, posteriormente, reclasificar los 

resultados en dos grupos (Figura 27): candidatos (en naranja) y descartados (en rojo). 

Figura 27: Clasificación de candidatos según el rango 

 

Se utiliza la herramienta Spatial Analyst Tools > Neighborhood > Focal Statistics y se 

calcula el rango (RANGE) en una ventana rectangular de 3x3 píxeles. El resultado es 

clasificado con la herramienta Spatial Analyst Tools > Reclass > Reclassify de manera 

que los valores menores o iguales a 0,2 se les asigna el valor de 1 (candidato) y los 

valores superiores a 0,2 se les asigna el valor de 2 (descartado). Para representar esta 

clasificación se hace un mapa temático con estos valores. 
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Con esta operación que se obtienen los puntos que están 20 cm por encima de sus 

ocho vecinos, hecho que indica que se produce un cambio brusco de altura. Teniendo 

en cuenta que los píxeles vecinos están situados a 10 cm del pixel evaluado y que la 

diferencia es dos veces este valor, como consecuencia este rango representa una 

pendiente del 200% respecto los cuatro puntos situados ortogonalmente adyacentes y 

de alrededor del 140% para los cuatro puntos situados en las esquinas. 
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5.2.3 Clasificación según la pendiente 

El tercer método evaluado consiste en el cálculo de la pendiente14 (primera derivada) 

en cada pixel para, posteriormente, reclasificar los resultados en dos grupos (Figura 

28): candidatos (en naranja) y descartados (en rojo). 

Figura 28: Clasificación de candidatos según la pendiente 

 

Se utiliza la herramienta Spatial Analyst Tools > Surface > Slope y se calcula la 

pendiente (PERCENT_RISE). El resultado es clasificado con la herramienta Spatial 

Analyst Tools > Reclass > Reclassify de manera que los valores menores o iguales a 

50% se les asigna el valor de 1 (candidato) y los valores superiores a 50% se les 

asigna el valor de 2 (descartado). Para representar esta clasificación se hace un mapa 

temático con estos valores. 

                                                 
14

 Pendiente = Δ distancia vertical / Δ distancia horizontal x 100 
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5.2.4 Clasificación según la curvatura 

El cuarto método evaluado consiste en el cálculo de la curvatura o segunda derivada 

(Figura 30) en cada pixel para, posteriormente, reclasificar los resultados en dos 

grupos (Figura 29): candidatos (en naranja) y descartados (en rojo). 

Figura 29: Clasificación de candidatos según la curvatura (perfil) 

 

Se utiliza la herramienta Spatial Analyst Tools > Surface > Curvature para calcular la 

curvatura. Se generan tres rasters: curvature, profile curvature y plan curvature. El 

resultado de la profile curvature es clasificado con la herramienta Spatial Analyst Tools 

> Reclass > Reclassify de manera que los valores menores o iguales a -200 se les 

asigna el valor de 1 (candidato), los valores superiores o iguales a 200 se les asigna el 

valor de 1 (candidato) y los valores entre -200 y 200 se les asigna el valor 2 
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(descartado). Para representar esta clasificación se hace un mapa temático con estos 

valores. 

Figura 30: Curvatura de una superficie en planta y en perfil
15

 

 

 

  

                                                 
15

 Véase http://www.transportscotland.gov.uk/reports/road/j10107-07.htm 
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5.2.5 Metodologías adicionales para la identificación de candidatos 

Como metodología alternativa se ha ensayado el trabajo directo con la nube de puntos 

sin optimizar con GeoMagic. Para ello se ha exportado la nube de puntos desde 

Pointools a un archivo ASCII que se ha importado en ArcGIS. 

En primer lugar se ha utilizado la heramienta 3D Analyst Tools > Conversion > From 

File > Point File Information y se ha obtenido una entidad shape con la información de 

la distancia media entre puntos, que ha resultado de 0.019 metros entre un total de 

119.090.304 puntos. A continuación se ha convertido la información del archivo ASCII 

a una entidad MultiPoint con la orden 3D Analyst Tools > Conversion > From File > 

ASCII 3D to Feature Class. Para comprobar los resultados con los obtenidos a través 

de GeoMagic, se ha convertido la información de los puntos a un raster de la misma 

resolución (10 centímetros), muy inferior a la media de los puntos (2 centímetros). La 

relación entre resoluciones es que la de la nube de puntos es 25 veces superior a la 

del raster (Ecuación 3): 

Ecuación 3: Relación entre resoluciones raster y LTS 

                            
                      

                         
 

  

   
 

 

  
 

Mediante la instrucción Conversion Tools > To Raster > Point to Raster se ha 

convertido la entidad MultiPoint a raster. Como campo para determinar el valor del 

raster elegimos el de shape, con lo cual se asignará la coordenada Z del punto al valor 

de cada pixel en función de la posición del punto correspondiente en planta. Se han 

utilizado las siguientes opciones para elegir el valor del píxel a partir de los puntos que 

recaen en él: 

 La desviación estándar del conjunto de los valores (Standard Deviation) 

 El mayor de los valores que aparece (Maximum) 

 El menor de los valores que aparece (Minimum) 

 La diferencia de valores entre el valor mayor y el menor (Range) 

 La el número de lecturas de puntos en cada píxel (Count) 

En primer lugar se ha obtenido el número de lecturas por píxel, que equivale al número 

de lecturas por cada 10 centímetros cuadrados, con lo que se puede apreciar que las 

lecturas se acumulan en los planos verticales (Figura 31). 
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Figura 31: Densidad de lecturas por unidad de área 

 

La información del valor máximo y mínimo nos aportan distinta información. El valor 

mínimo nos permite identificar gran parte de los valores valores correspondientes a la 

topografía (Figura 32) pero no nos permite distinguirlos de manera categórica. 
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Figura 32: Valores mínimos para cada píxel del conjunto de la nube de puntos 

 

En el caso del valor máximo, nos proporciona una proyección horizontal casi 

arquitectónica (Figura 33) donde se aprecian, entre otros elementos, las cubiertas, las 

masas de los árboles, el tendido eléctrico y en algunos casos el mobiliario urbano. 
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Figura 33: Valores máximos para cada píxel del conjunto de la nube de puntos 

 

Para enfatizar este aspecto de representación arquitectónica, se ha realizado un mapa 

de pendientes que realza el detalle de la imagen identificando los bordes de la misma 

manera como se ha hecho tradicionalmente en la geometría descriptiva (Figura 34). 
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Figura 34: Plano de pendientes de los valores máximos del conjunto de la nube de puntos 

 

Finalmente, para profundizar en el análisis, se ha importado la información en el 

programa IDRISI de Clark Labs, especializado en el análisis raster. 

En primer lugar se ha exportado el raster a un archivo de texto mediante el comando 

Conversion Tools > From Raster > Raster to ASCII. La importación se ha realizado con 

el comando Import > Software Specific Formats > ESRI > ARCRASTER utilizando el 

formato ArcInfo Raster ASCII to IDRISI y seleccionando la referencia UTM 31N (que 

es la que corresponde a Tossa de Mar). 

Este análisis avanzado es prometedor para la caracterización y clasificación de las 

superficies topográficas. En este caso se ha analizado la dimensión fractal que nos da 

una medida de la rugosidad del terreno(Mark & Aronson, 1984) en una ventana de 
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3x316. La dimensión fractal varía entre 2.0 (amarillo) indicando una superficie suave 

invariante en un análisis multiescala y 3.0 (azul) indicando una superficie rugosa 

(Figura 35). 

Figura 35: Dimensión fractal representando la rugosidad del terreno 

 

No se han utilizado los que se detallan a continuación por las siguientes razones: 

 El valor que aparece en más ocasiones (Most Frequent) puesto que los valores 

son fraccionarios y hay mucha variabilidad 

 La suma de los valores de altura (Sum) puesto que obtendríamos la suma de 

las coordenadas Z. 
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 En una ventana de 9x9 si el análisis se realiza en Landserf 



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 59 

 

 La media de los valores de altura (Mean) puesto que no nos permite distinguir 

ningún rasgo distintivo al diluir los valores. 

La información a partir de la extracción del rango y de la desviación estándar (Figura 

36) es muy parecida, debido probablemente a la regularidad de la trama del raster. 

Figura 36: Rango (izquierda) y desviación estándar (derecha) del conjunto de la nube de puntos 
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5.3 Generación de una topografía representativa 

Con la información de los candidatos se han podido digitalizar una serie de puntos 2D 

en ubicaciones dentro de las calles considerados por las cuatro metodologías como 

correctos (Figura 37). 

Figura 37: Puntos evaluados para generar la topografía 

 

A estos puntos se les ha asignado la coordenada Z proveniente del MDT mediante la 

herramienta 3D Analyst Tools > Functional Suface > Interpolate Shape para asignar la 

coordenada Z a los puntos a partir del raster de elevaciones. 

También se han añadido cuatro puntos en las cuatro esquinas del ámbito. Como se 

puede apreciar en la imagen, las coordenadas de estos puntos son desconocidas a 

partir de la información del LTS. Para conocer su coordenada Z, se ha inferido su 
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altura a partir de la información de las curvas de nivel del ICC a través de su relación 

con los puntos conocidos. 

A partir de estos puntos en 3D obtenidos se ha generado una nueva topografía apta 

para la evaluación de las pendientes que evita los errores de la topografía original. Se 

han obtenido dos modelos del terreno: un modelo raster (MDT) y un TIN. 
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5.3.1 Generación de un Modelo Digital de Terreno 

A partir de la nube de puntos interpolada con el algoritmo Natural Neighbors, que ha 

sido evaluado como el más adecuado para el caso estudiado, se ha elaborado un 

Modelo Digital de Terreno (Figura 38). 

Figura 38: Modelo Digital de Terreno (interpolación Natural Neighbors) a partir de los puntos LTS 

 

La inspección del modelo tridimensional permite apreciar que el modelo no es válido 

para obtener una topografía adecuada: los edificios y otras construcciones aparecen 

como ruido dentro de las manzanas y se distinguen otras lecturas anómalas en las 

calles (Yuan, Zhang, Zhang, & Gao, 2009). 

Para la obtención del DTM con la topografía corregida se han utilizado los puntos 

anteriormente mencionados con la interpolación Natural Neighbors para obtener un 

nuevo DTM que representa mucho la topografía de las calles con mayor exactitud 

(Figura 39). 
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Figura 39: Modelo Digital de Terreno corregido a partir de los puntos seleccionados 
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5.3.2 Generación de un TIN 

Para la representación del terreno también se ha generado un TIN (mediante la 

creación de un Terrain) a partir de los puntos que se ha considerado representativos 

de la topografía (Figura 40). 

Figura 40: TIN generado a partir de los puntos seleccionados 

 

En primer lugar, se ha tenido que calcular la distancia media entre puntos, que es 

desconocida. Para averiguarla, se ha utilizado la herramienta 3D Analyst Tools > 

Conversion > From Feature Class > Feature Class Z to ASCII y se ha creado un 

fichero de de texto con la información de los puntos en formato ASCII (formato 

GENERATE). A partir de este archivo, con la orden 3D Analyst Tools > Conversion > 

From File > Point File Information se ha obtenido una entidad shape con la información 

de la distancia media entre puntos, que ha resultado de 8,73 metros entre un total de 

573 puntos. 

Para la construcción del Terrain se han utilizado: 

 Los puntos corregidos com o mass points (la coordenada z se obtiene de la 

geometría con lo opción shape) 

 La proyección en planta de las manzanas corregida como hard erase 
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 La proyección en planta de la muralla y las torres (previamente digitalizadas a 

partir de la cartografía del ICC) como hard erase 

 El límite rectangular del ámbito como hard clip 

 Las proyección en planta de las líneas de cuneta (previamente digitalizadas a 

partir de la imagen raster) como hard lines 

Se han creado TINs para las resoluciones 1:1000, 1:2000, 1:5000 y 1:10.000 para 

facilitar la visualización a distintas escalas. 

Adicionalmente, para facilitar la visualización, se han realizado las siguientes 

operaciones: 

 Extrusión las manzanas a partir de la topografía interpolada 

 Extrusión la muralla a partir de la topografía interpolada (con la altura de las 

torres almacenada en un campo) 

 Visualización de las líneas de cuneta 

 Creación de una base para disponer de una referencia en los extremos del 

modelo 
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6 Identificación de los obstáculos 

Debido a que el escaneado es horizontal, los puntos se acumulan en los planos 

verticales de manera que se aprecia una mayor densidad de puntos en la nube 

capturada cuando se ve en proyección horizontal (Figura 31). Sin embargo, es 

necesaria una metodología más precisa para poder identificar estos planos verticales y 

otros elementos sin depender de la densidad de la nube de puntos. 

6.1 Identificación de fachadas 

Con la información de la nube de puntos en ArcGIS se ha procedido a comprobar la 

información de las manzanas obtenidas del Instituto Cartográfico de Cataluña. 

Para identificar las fachadas se han ensayado dos metodologías, las cuales permiten 

reconocer variaciones muy bruscas de la coordenada Z de la nube de puntos. El 

primer algoritmo evalúa las pendientes en cada punto para identificar los saltos 

próximos a 90 grados y, el segundo, evalúa el rango de variación entre todos los 

puntos que se encuentran a 30 cm (3 pixels) de distancia del punto estudiado. 

Finalmente se ha optado por utilizar la primera metodología utilizando herramienta 

Spatial Analyst Tools > Surface > Slope y calculando la pendiente (PERCENT_RISE) 

para posteriormente tematizar los resultados (Figura 41). 

Mediante esta técnica ha sido posible corregir algunas manzanas que estaban mal 

delimitadas en el archivo de origen e incluso ha sido necesario realizar la digitalización 

de algunas, las cuales sorprendentemente no aparecían en la cartografía del ICC. 

Posteriormente la información de las fachadas se utilizó para digitalizar los ejes de 

calle entre las manzanas. 
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Figura 41: Detección de fachadas mediante la pendiente 
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6.2 Identificación de escaleras 

Para poder evaluar las escaleras como obstáculo, éstas necesitan ser identificadas 

como tales para poder digitalizar como polígono el área que ocupan en planta. 

A partir de la nube de puntos LTS es posible reconocer gran parte de los escalones 

debido a que el escáner barre los objetos horizontalmente y, por lo tanto, la densidad 

de las muestras aumenta considerablemente en los planos verticales (principalmente 

fachadas pero también en menor medida las contrahuellas de los escalones). Sin 

embargo, esta metodología no permite detectar la totalidad de los escalones, de forma 

que deben reconocerse de una forma distinta. 

Ello es posible porque según el teorema de Nyquist-Shannon (Ecuación 4), la 

resolución de los puntos (10cm) permite identificar los tramos horizontales de los 

escalones, habitualmente alrededor de 30cm. 

Ecuación 4: La frecuencia de muestreo permite detectar escalones 

                       
                     

 
 

Para ello se ha utilizado el algoritmo de pendiente sobre el raster importado 

anteriormente, con lo que se ha obtenido el valor absoluto de la primera derivada de la 

superficie que representan los puntos. Una vez obtenido este mapa de pendientes se 

ha clasificado el raster resultante para poder identificar las pendientes próximas a 90 

grados sexagesimales, con lo que se han podido identificar visualmente los cambios 

bruscos de pendiente que representan las contrahuellas. A partir de esta información 

se han digitalizado los polígonos correspondientes a la proyección en planta de las 

escaleras (Figura 42). 

Una vez obtenida la capa “Obstaculo_Escalera”, se ha creado un campo llamado 

“ESCALERA” y se ha asignado a las entidades que representan las escaleras la 

cadena de texto con el valor de “Escalera” como atributo. 
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Figura 42: Escaleras digitalizadas a partir de la información del LTS 
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6.3 Identificación de pasos con anchura insuficiente 

La anchura mínima libre de obstáculos de una calle supone un valor a tener en cuenta 

para ser transitable, tanto para personas discapacitadas, en mayor o menor medida, 

como para el resto de la población. 

Para que el análisis de redes pueda considerar como obstáculo la anchura 

insuficiente, ha sido necesario en primer lugar identificar los tramos que no que no 

cumplan con la anchura mínima. Para ello se ha utilizado la herramienta Analysis 

Tools > Proximity > Buffer para obtener unas entidades paralelas a las manzanas con 

una separación de la mitad de la anchura mínima17 y se han digitalizado los polígonos 

que corresponden a la superposición de estos polígonos con los de las manzanas 

adyacentes (Figura 43). 

Para asistir en la identificación de las intersecciones se ha creado una topología en 

ArcGIS con la condición Must not overlap de manera que las intersecciones se 

resalten en rojo. 

Una vez obtenida la capa “Obstaculo_Anchura”, se ha creado un campo llamado 

“ANCHURA” y se ha asignado a las entidades que representan los pasos estrechos la 

cadena de texto con el valor de “Anchura” como atributo. 

  

                                                 
17

 Se ha considerado como anchura mínima el valor de 1,50 m 
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Figura 43: Zona de anchura insuficiente 
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6.4 Identificación de pasos con altura insuficiente 

De la misma forma como con el caso de la anchura mínima, la altura mínima libre de 

obstáculos de una calle supone un valor a tener en cuenta para ser transitable, tanto 

para personas discapacitadas, en mayor o menor medida, como para el resto de la 

población. 

Para establecer los polígonos de altura mínima se ha examinado el modelo 3D con 

Pointools con ayuda de la cartografía del ICC (Figura 44) y se han digitalizado los 

polígonos correspondientes a las zonas con altura inferior a 2,10 metros en ArcGIS. 

Una vez obtenida la capa “Obstaculo_Altura”, se ha creado un campo llamado 

“ALTURA” y se ha asignado a las entidades que representan zonas de altura 

insuficiente la cadena de texto con el valor de “Altura” como atributo (Figura 45). 

Figura 44: Medición de alturas de la nube de puntos 
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Figura 45: Zonas de gálibo insuficiente 
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6.5 Identificación de zonas con iluminación inadecuada 

Para establecer las zonas insuficientemente iluminadas se han hecho las siguientes de 

simplificaciones:  

 Se ha supuesto que la radiación lumínica es de tipo esférico. 

 No se han considerado las reflexiones de los elementos construidos 

 No se ha tenido en cuenta la altura respecto al suelo 

 Se ha considerado que el flujo lumínico que radian las luminarias es el mismo 

para todas ellas 

Con estas simplificaciones se ha llegado a la conclusión que los puntos alejados en 

más de 12 metros de cualquier luminaria estaban insuficientemente iluminados. Se ha 

considerado evaluar distintos grados de iluminación (baja, media y alta), pero para el 

presente trabajo se ha optado por trabajar con este valor límite. 

Como alternativa se ha estudiado trabajar con la herramienta Spatial Analyst Tools > 

Density > Kernel density (Una vez obtenida la capa “Obstaculo_Iluminacion”, se ha 

creado un campo llamado “ILUMINACION” y se ha asignado a las entidades que 

representan las distancias menores de 12 la cadena de texto con el valor de 

“Iluminación Suficiente” como atributo. 
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Figura 46)  y Spatial Analyst Tools > Density > Point density (Figura 47) que nos 

permite identificar las zonas mejor iluminadas. 

Para conseguir representar gráficamente los puntos que estaban insuficientemente 

iluminados se ha partido de la información de la posición de estos, facilitada por el 

Ayuntamiento de Tossa de Mar, y se ha grafiado el lugar geométrico de los puntos que 

están a 12 m de ellos mediante la herramienta Analysis Tools > Proximity > Buffer. El 

resultado de esta operación es un polígono, los puntos interiores del cual 

consideraremos suficientemente iluminados y los exteriores iluminados de manera 

insuficiente (). Este polígono contiene un atributo con que se describe si la iluminación 

es o no suficiente. 

Una vez obtenida la capa “Obstaculo_Iluminacion”, se ha creado un campo llamado 

“ILUMINACION” y se ha asignado a las entidades que representan las distancias 

menores de 12 la cadena de texto con el valor de “Iluminación Suficiente” como 

atributo. 
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Figura 46: Densidad de farolas en un radio de 12 metros y 30 metros (Kernel Density) 

  

Figura 47: Densidad de farolas en un radio de 12 metros y 30 metros (Point Density) 
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Figura 48: Zonas suficientemente iluminadas 
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7 Preparación de la geometría para el análisis de redes 

Para poder efectuar el análisis de redes necesitamos partir de un grafo plano que 

servirá posteriormente para construir la topología de red. Sobre este grafo de partida 

se realizaran una serie de operaciones que en ningún caso alteraran el hecho que sea 

topológicamente correcto para el análisis de redes en ArcGIS. 

7.1 Obtención de los ejes de calles 

La cartografía del ICC dispone de los ejes de calle pero es incompleta a efectos del 

estudio que se pretende realizar. A partir de la cartografía de las manzanas rectificada, 

se han digitalizado manualmente los ejes de calle por los espacios vacíos entre las 

manzanas (Figura 49), para obtener un grafo sobre el que construir la red. 

Figura 49: Grafo de los ejes de calle del ámbito 
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7.2 División de los tramos en subtramos 

Los tramos obtenidos corresponden a los segmentos comprendidos entre 

intersecciones, de nodo a nodo. Ello conlleva dos problemas:  

 Para el estudio de pendientes, podría darse el caso que la diferencia de cotas 

entre dos intersecciones fuera pequeña en relación con su longitud y, por lo 

tanto, que el cálculo de pendiente diera un resultado pequeño, mientras que la 

realidad física fuera de algunas secciones con una pendiente muy fuerte y 

otras con una pendiente muy pequeña o inexistente. 

 El módulo de análisis de redes de ArcGIS considera la topología de red como 

un grafo plano entre nodos18, de manera que la presencia de obstáculos en un 

segmento invalida la totalidad del segmento entre los dos nodos, cosa que no 

nos permite evaluar correctamente las rutas. 

Por estas dos razones, se ha decidido dividir los tramos originales en subtramos de 

longitud igual o inferior a un metro (longitud aproximada de un paso) para poder 

representar con mayor fidelidad las variaciones de pendiente. Para ello, se ha optado 

por utilizar la herramienta Feature Conversion > Split Polylines > Equal Segments de la 

extensión XTools Pro 6.2.1 de la compañía Data East. 

Alternativamente, es posible realizar la división de manera manual mediante la 

selección de cada tramo y la herramienta Editor > Split. 

Otras alternativas evaluadas pero finalmente desechadas fueron: 

 Dividir los tramos en su intersección con las curvas de nivel 

 Dividir los tramos en su intersección con una retícula regular (fishnet) 

  

                                                 
18

 Esta funcionalidad será añadida en la próxima versión ArcGIS 10.0 
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7.3 Obtención de las rutas en 3D 

Para poder calcular la pendiente de los tramos ha sido necesario en primer lugar 

convertir las rutas de 2D a 3D. Para ello, se ha generado una superficie 3D a partir de 

la nube de puntos por interpolación mediante la herramienta 3D Analyst Tools > 

Functional Suface > Interpolate Shape y se ha drapeado la ruta 2D para que recogiera 

los valores de la coordenada Z de la superficie generada previamente en una polilínea 

3D (Figura 50).  

Figura 50: Rutas 3D adoptando la coordenada vertical de la superficie topográfica rectificada 

 

El resultado contrasta con la interpolación con la topografía obtenida directamente del 

LTS (Figura 51) y como resultado se han eliminado los errores en la topografía (Figura 

52). 
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Figura 51: Rutas 3D adoptando la coordenada vertical de la superficie topográfica original 

 

 

Figura 52: Rutas 3D antes (rojo) y después (verde) de la corrección 
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7.4 Incorporación de la información de la pendiente de cada subtramo 

Para poder calcular la pendiente en cada tramo ha sido necesario desarrollar una serie 

de rutinas utilizando los entornos de programación ModelBuilder de ArcGIS y Visual 

Basic de Microsoft (Figura 53). 

Figura 53: Diagrama de bloques del modelo de cálculo de pendientes
19

 

 

El módulo desarrollado crea seis campos para describir los puntos iniciales y finales de 

cada subtramo y utiliza unas rutinas desarrolladas en VisualBasic para extraer las 

coordenadas correspondientes de cada extremo de subtramo (inicio y final), las cuales 

son almacenadas para cada tramo en sus respectivos campos. 

Una vez calculadas las seis coordenadas, se crea un campo nuevo para alojar el valor 

de la pendiente, que es calculada mediante la fórmula siguiente (Ecuación 5): 

Ecuación 5: Fórmula utilizada para calcular la pendiente en cada tramo 

                      

 

 
     

        
 
        

 

 

  

Con esta fórmula se obtiene el valor absoluto de la pendiente en cada tramo. Una vez 

obtenidas las pendientes y asignadas como un atributo al campo correspondiente en 

cada tramo, se eliminan los campos auxiliares creados para su cálculo. A partir de 

                                                 
19

 Véase código VisualBasic en apartado 12.2 (página 141) 



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 83 

 

estos datos se ha realizado un mapa temático para verificar visualmente la variación 

de los valores de cada tramo (Figura 54), de manera que se grafían en rojo las 

pendientes superiores al 12% y con una rampa de colores las inferiores al 6%, al 8% y 

al 12% respectivamente. 

Figura 54: Mapa temático de pendientes de los subtramos 
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7.5 Incorporación de la información de los obstáculos 

A partir de las entidades (polígonos) que representan los tipos de obstáculos 

considerados (las escaleras, la altura, la anchura y la iluminación insuficiente) se ha 

procedido a asignar como atributo el tipo o tipos de obstáculo a cada tramo de ruta 

afectado. 

Para ello se ha desarrollado un módulo en Model Builder que interseca de manera 

secuencial cada una de las entidades que representan obstáculos con los tramos de 

ruta (Figura 55). 

Figura 55: Diagrama de bloques del módulo de cálculo de obstáculos
20

 

 

Con este proceso conseguimos preparar los subtramos para ser evaluados por el 

módulo de cálculo de rutas: 

 Se corta el tramo con la entidad obstáculo correspondiente, de manera que se 

obtienen fragmentos de subtramos dentro y fuera del polígono que se interseca 

 Se agregan cuatro campos nuevos en la información de los tramos: “ALTURA”, 

“ANCHURA”, “ESCALERA” e “ILUMINACION” 

 Se asigna el valor de tipo de obstáculo correspondiente a los fragmentos de 

subtramo obtenidos  a partir de la información que han heredado del polígono 

que representaba el obstáculo. 

Los resultados obtenidos pueden verse en un mapa temático para comprobar la 

correcta ejecución del módulo (Figura 56) e individualmente para los visualizar los 

tramos afectados por los cuatro tipos de obstáculos considerados: Altura insuficiente 

en verde, anchura insuficiente en azul, presencia de escaleras en rojo e iluminación 

insuficiente en naranja (Figura 57). 

                                                 
20

 Véase código VisualBasic en apartado 12.3 (página 144) 
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Figura 56: Mapa temático con el tipo de obstáculo en los tramos 
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Figura 57: Tramos de ruta afectados por altura, anchura, escaleras, iluminación insuficiente 

  

  

  

  



METODOLOGÍA PARA LA EVALUACIÓN DE RUTAS ÓPTIMAS EN ENTORNOS URBANOS A PARTIR DE DATOS DE LTS 

FRANCESC VALLS DALMAU, ARQUITECTO 

 

TESIS DE MÁSTER OFICIAL EN GESTIÓN Y VALORACIÓN URBANA (JULIO 2010) PÁGINA 87 

 

8 Definición de las redes para el análisis 

Una vez preparada la geometría es necesario construir la topología de red en ArcGIS21 

para poder efectuar los análisis con el modulo Network Analyst. 

Desde el punto de vista geométrico, el proceso para generar la red ha partido de una 

red inicial que siguiendo los ejes de calle, con nodos en sus intersecciones. La red de 

partida es una red topológicamente correcta a efectos de efectuar un análisis de redes 

(se trata de un grafo plano). 

Las operaciones que se han realizado sobre este grafo inicial han sido de dos tipos: 

 Fraccionamiento de las entidades en segmentos más pequeñas 

 Adición de campos y asignación de atributos 

Ninguna de estas operaciones ha alterado la red de manera que se impidiera realizar 

el análisis de redes puesto que continúa siendo apta para poder construir una red a 

partir de los puntos extremos de los subtramos generados. Asimismo, incorpora la 

información necesaria para especificar las restricciones y los valores necesarios para 

poder ser evaluada desde el punto de vista de la accesibilidad. 

Para evaluar las rutas óptimas se han construido tres redes unimodales en ArcGIS: la 

primera evalúa la ruta óptima con criterios para usuarios estándar, la segunda la 

evalúa para usuarios con movilidad reducida y la tercera para usuarios en silla de 

ruedas. 

 

  

                                                 
21

 Inicialmente se preveía utilizar el programa TransCAD pero finalmente se optó por el 
software ArcGIS y la extensión Network Analyst para poder trabajar en un único entorno. 
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8.1 Definición de la red para usuarios estándar 

Para crear la red para evaluar las rutas para los usuarios estándar, han seguido los 

siguientes pasos: 

 Crear un feature dataset que contendrá las feature classes, teniendo en cuenta 

que la referencia espacial debe ser la misma (con el nombre Red_STD) 

 Copiar la feature class obtenida en los pasos anteriores dividida en subtramos, 

con las pendientes calculadas y los atributos de los obstáculos asignados 

(Rutas_STD) 

 Crear un network dataset dentro de la feature dataset mediante el asistente en 

ArcCatalog. 

 Se especifica en el asistente que la conectividad se establece a partir de los 

puntos finales de los tramos, no se considera ni la elevación y no se modelan 

los cambios de dirección. 

 Como resultado, se generaran dos feature datasets: Rutas_STD_ND y 

Rutas_STD_ND_Junctions 

 El asistente crea Rutas_STD_ND que contiene la topología de red que el 

programa construye a partir de Red_ STD 

 El asistente crea Rutas_STD_ND_Junctions que contiene los puntos extremos 

de los tramos de la red generada 

Los criterios para evaluar las rutas para los usuarios estándar han sido: 

 Minimizar la distancia recorrida entre las paradas 

 Evitar los tramos con altura insuficiente 

A partir de estas premisas se han definido dos evaluadores: 

 Un evaluador de coste de distancia llamado EV_Distancia (Tabla 1) 

 Un evaluador de restricción para evitar los tramos con altura insuficiente 

llamado RE_Altura (Tabla 2) 
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Tabla 1: Evaluador de distancia de la red para usuario estándar 

Evaluador EV_Distancia (usuario estándar) 

Evaluado por defecto Si 

Parameters None 

Usage Cost 

Units Meters 

Data type Double 

Source Type Field 

Source Value Shape_Length 

Default Values Type Constant 

Default Value 0 

 

Tabla 2: Evaluador de restricción de altura de la red para usuario estándar 

Evaluador RE_Altura (usuario estándar) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ALTURA”) 

Pre-Logic VBscript 
if [OBST_ALTURA] = "ALTURA" 

then ALTURA = 1 

Default Values Type Constant 

Default Value Transversable 
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8.2 Definición de la red para usuarios con movilidad reducida 

Para crear la red para evaluar las rutas para los usuarios con movilidad reducida, se 

han seguido los siguientes pasos: 

 Crear un feature dataset que contendrá las feature classes, teniendo en cuenta 

que la referencia espacial debe ser la misma (con el nombre Red_MR) 

 Copiar la feature class obtenida en los pasos anteriores dividida en subtramos, 

con las pendientes calculadas y los atributos de los obstáculos asignados 

(Rutas_MR) 

 Crear un network dataset dentro de la feature dataset mediante el asistente en 

ArcCatalog. 

 Se especifica en el asistente que la conectividad se establece a partir de los 

puntos finales de los tramos, no se considera ni la elevación y no se modelan 

los cambios de dirección. 

 Como resultado, se generaran dos feature datasets: Rutas_MR_ND y 

Rutas_MR_ND_Junctions 

 El asistente crea Rutas_MR_ND que contiene la topología de red que el 

programa construye a partir de Red_ STD 

 El asistente crea Rutas_MR_ND_Junctions que contiene los puntos extremos 

de los tramos de la red generada 

Los criterios para evaluar las rutas para los usuarios estándar han sido: 

 Minimizar la distancia recorrida entre las paradas 

 Evitar transitar por escaleras 

 Evitar los tramos con altura insuficiente 

 Evitar los tramos con anchura insuficiente 

 Evitar los tramos con iluminación insuficiente 

A partir de estas premisas se han definido cinco evaluadores: 

 Un evaluador de coste de distancia llamado EV_Distancia (Tabla 3) 

 Un evaluador de restricción para evitar los tramos con altura insuficiente 

llamado RE_Altura (Tabla 4) 

 Un evaluador de restricción para evitar los tramos con anchura insuficiente 

llamado RE_Anchura (Tabla 5) 
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 Un evaluador de restricción para evitar los tramos con presencia de escaleras 

llamado RE_Escaleras (Tabla 6) 

 Un evaluador de restricción para evitar los tramos con iluminación inadecuada 

llamado RE_Iluminacion (Tabla 7) 

Tabla 3: Evaluador de distancia de la red para usuario con movilidad reducida 

Evaluador EV_Distancia (usuario con movilidad reducida) 

Evaluado por defecto Si 

Parameters None 

Usage Cost 

Units Meters 

Data type Double 

Source Type Field 

Source Value Shape_Length 

Default Values Type Constant 

Default Value 0 

 

Tabla 4: Evaluador de restricción de altura de la red para usuario con movilidad reducida 

Evaluador RE_Altura (usuario con movilidad reducida) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ALTURA”) 

Pre-Logic VBscript 
if [OBST_ALTURA] = "ALTURA" 

then ALTURA = 1 

Default Values Type Constant 

Default Value Transversable 
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Tabla 5: Evaluador de restricción de anchura de la red para usuario con movilidad reducida 

Evaluador RE_Anchura (usuario con movilidad reducida) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ANCHURA”) 

Pre-Logic VBscript 
if [OBST_ANCHURA] = "ANCHURA" 

then ANCHURA = 1 

Default Values Type Constant 

Default Value Transversable 

 

Tabla 6: Evaluador de restricción de escaleras de la red para usuario con movilidad reducida 

Evaluador RE_Escaleras (usuario con movilidad reducida) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ESCALERA”) 

Pre-Logic VBscript 
if [OBST_ESCALERA] = "ESCALERA" 

then ESCALERA = 1 

Default Values Type Constant 

Default Value Transversable 
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Tabla 7: Evaluador de restricción de iluminación de la red para usuario con movilidad reducida 

Evaluador RE_Iluminacion (usuario movilidad reducida) 

Evaluado por defecto No 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ILUMINACION”) 

Pre-Logic VBscript 
if [ILUMINACION] <> "ILUMINACION SUFICIENTE" 

then ILUMINACION = 1 

Default Values Type Constant 

Default Value Transversable 
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8.3 Definición de la red para usuarios en silla de ruedas 

Para crear la red para evaluar las rutas para los usuarios con movilidad reducida, se 

han seguido los siguientes pasos: 

 Crear un feature dataset que contendrá las feature classes, teniendo en cuenta 

que la referencia espacial debe ser la misma (con el nombre Red_SR) 

 Copiar la feature class obtenida en los pasos anteriores dividida en subtramos, 

con las pendientes calculadas y los atributos de los obstáculos asignados 

(Rutas_SR) 

 Crear un network dataset dentro de la feature dataset mediante el asistente en 

ArcCatalog. 

 Se especifica en el asistente que la conectividad se establece a partir de los 

puntos finales de los tramos, no se considera ni la elevación y no se modelan 

los cambios de dirección. 

 Como resultado, se generaran dos feature datasets: Rutas_SR_ND y 

Rutas_SR_ND_Junctions 

 El asistente crea Rutas_SR_ND que contiene la topología de red que el 

programa construye a partir de Red_ STD 

 El asistente crea Rutas_SR_ND_Junctions que contiene los puntos extremos 

de los tramos de la red generada 

Los criterios para evaluar las rutas para los usuarios estándar han sido: 

 Minimizar la distancia recorrida entre las paradas 

 Evitar transitar por escaleras 

 Evitar circular por tramos con altura insuficiente 

 Evitar circular por tramos con anchura insuficiente 

 Evitar los tramos con iluminación insuficiente 

 Evitar los tramos con pendiente superior al 12% 

A partir de estas premisas se han definido siete evaluadores: 

 Un evaluador de coste de distancia llamado EV_Distancia (Tabla 8) 

 Un evaluador de coste de pendiente llamado EV_Pendiente (Tabla 9) 

 Un evaluador de restricción para evitar los tramos con altura insuficiente 

llamado RE_Altura (Tabla 10) 
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 Un evaluador de restricción para evitar los tramos con anchura insuficiente 

llamado RE_Anchura (Tabla 11) 

 Un evaluador de restricción para evitar los tramos con presencia de escaleras 

llamado RE_Escaleras (Tabla 12) 

 Un evaluador de restricción para evitar los tramos con iluminación inadecuada 

llamado RE_Iluminacion (Tabla 13) 

 Un evaluador de restricción para evitar los tramos con pendiente superior al 

12% RE_Pendiente, utilizando un parámetro para establecer el valor máximo y 

evaluando el valor de EV_Pendiente (Tabla 14) 

Tabla 8: Evaluador de distancia de la red para usuario en silla de ruedas 

Evaluador EV_Distancia (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters None 

Usage Cost 

Units Meters 

Data type Double 

Source Type Field 

Source Value Shape_Length 

Default Values Type Constant 

Default Value 0 
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Tabla 9: Evaluador de pendiente de la red para usuario en silla de ruedas 

Evaluador EV_Pendiente (usuario en silla de ruedas) 

Evaluado por defecto No 

Parameters None 

Usage Cost 

Units Undefined 

Data type Double 

Source Type Field 

Source Value PENDIENTE 

Default Values Type Constant 

Default Value 0 

 

Tabla 10: Evaluador de restricción de altura de la red para usuario en silla de ruedas 

Evaluador RE_Altura (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ALTURA”) 

Pre-Logic VBscript 
if [OBST_ALTURA] = "ALTURA" 

then ALTURA = 1 

Default Values Type Constant 

Default Value Transversable 
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Tabla 11: Evaluador de restricción de anchura de la red para usuario en silla de ruedas 

Evaluador RE_Anchura (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ANCHURA”) 

Pre-Logic VBscript 
if [OBST_ANCHURA] = "ANCHURA" 

then ANCHURA = 1 

Default Values Type Constant 

Default Value Transversable 

 

Tabla 12: Evaluador de restricción de escaleras de la red para usuario en silla de ruedas 

Evaluador RE_Escaleras (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ESCALERA”) 

Pre-Logic VBscript 
if [OBST_ESCALERA] = "ESCALERA" 

then ESCALERA = 1 

Default Values Type Constant 

Default Value Transversable 
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Tabla 13: Evaluador de restricción de iluminación de la red para usuario en silla de ruedas 

Evaluador RE_Iluminacion (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters None 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Expression (se evalua el valor “ILUMINACION”) 

Pre-Logic VBscript 
if [ILUMINACION] <> "ILUMINACION SUFICIENTE" 

then ILUMINACION = 1 

Default Values Type Constant 

Default Value Transversable 

 

Tabla 14: Evaluador de restricción de pendiente de la red para usuario en silla de ruedas 

Evaluador RE_Pendiente (usuario en silla de ruedas) 

Evaluado por defecto Si 

Parameters PendienteMax (Double, Default Value = 12) 

Usage Restriction 

Units Undefined 

Data type Boolean 

Source Type Field 

Source Value Function 

Pre-Logic VBscript EV_Pendiente > PendienteMax 

Default Values Type Constant 

Default Value Transversable 
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9 Obtención de los itinerarios accesibles 

La extensión Network Analyst permite realizar cinco tipos de análisis: 

 Route 

 Service Area 

 Closest Facility 

 OD Cost Matrix 

 Vehicle Routing Problem 

Aunque existen muchos otros tipos de análisis en el estudio de redes (de Smith, 

Longley, & Goodchild, 2007) utilizaremos la funcionalidad de tres tipos de análisis: 

Análisis de rutas, generación de la matriz de costes origen-destino y centro más 

cercano. 

9.1 Definición de los puntos de interés 

Para evaluar las rutas se ha generado una capa de información con 20 puntos de 

interés (Figura 58), que corresponden a los puntos de origen y destino que se 

evaluarán en el análisis de redes para su salida en una página web. 

Se asignado un identificador en forma de campo alfanumérico para identificar los 

puntos de interés con una letra de la “A” a la “T”. 

Sin prejuicio de esto, el módulo es capaz de evaluar los itinerarios entre cualquier 

número de puntos arbitrarios, según cinco criterios: 

 Visitando las paradas en un orden establecido (Figura 59) 

 Visitando las paradas en el orden que permita recorrer la mínima distancia 

(Figura 59) 

 Visitando las paradas en el orden que permita recorrer la mínima distancia pero 

manteniendo los puntos de origen y final 

 Visitando las paradas en el orden que permita recorrer la mínima distancia pero 

manteniendo el punto de origen 

 Visitando las paradas en el orden que permita recorrer la mínima distancia pero 

manteniendo el punto final 
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Figura 58: Putos de interés evaluados en el análisis de redes 

 

 

Figura 59: Ruta con múltiples destinos, siguiendo un orden establecido y optimizando la distancia 
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9.2 Obtención de rutas para usuarios estándar 

El análisis de red se realiza sobre el network dataset creado anteriormente 

(Rutas_STD_ND), para el cual se han definido anteriormente todos los parámetros 

necesarios para poder efectuar la evaluación de rutas óptimas (detallado en el 

apartado 8.1, página 88). 

En primer lugar es necesario utilizar la herramienta Network Analyst Tools > Network 

Dataset > Build Network para construir la topología de red. 

Con esta acción la extensión Network Analyst genera una geometría a partir de los 

parámetros establecidos de manera que a cada segmento de red se le asignan valores 

en función de los evaluadores considerados: 

 EV_Distancia: Coste de atravesar el tramo (se ha considerado el mismo coste 

en los dos sentidos) medido en metros 

 RE_Altura: Consideración del tramo como transversable o no transversable (no 

se distinguen los dos sentidos) según su altura 
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9.2.1 Ruta entre múltiples puntos para usuarios estándar 

Cuando la geometría está generada y sus valores asignados, se ha procedido a cargar 

en ArcMap el network dataset Rutas_STD_ND. 

Con la herramienta Network Analyst Tools > Analysis > Make Route Layer se ha 

creado una capa de análisis de redes de tipo ruta óptima con los siguientes 

parámetros: 

 Nombramos a la capa de análisis “Ruta óptima (usuario estándar)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricción RE_Altura 

Con esta información se ha creado una capa de análisis que encontrará el recorrido 

con la mínima distancia entre puntos a visitar, evitando las zonas con altura 

insuficiente. Adicionalmente obtendremos la longitud total del recorrido óptimo. 

Para añadir paradas a la ruta, se ha utilizado la herramienta Create Network Location 

Tool de la barra de herramientas de Network Analyst para incorporar puntos de interés 

(entidades tipo stop). Estos puntos no deben ser necesariamente los puntos de interés 

prefijados descritos anteriormente. 

También se puede utilizar la misma herramienta para crear barreras (entidades tipo 

barrier) y así incorporar en la evaluación de la ruta información de elementos que 

impidan el paso de manera transitoria, como por ejemplo unas obras en la vía pública. 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

el itinerario óptimo correspondiente, pudiendo modificar los parámetros del análisis en 

la Layer Properties de la capa (por ejemplo el orden de las paradas). 
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9.2.2 Matriz origen-destino para usuarios estándar 

Para saber las distancias de las rutas óptimas entre puntos de interés, se ha creado 

una capa de análisis tipo OD Cost Matrix mediante la herramienta Network Analyst 

Tools > Analysis > Make OD Matrix Cost Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Matriz OD (usuario estándar)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricción RE_Altura 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario estándar)” como Input network analysis layer 

 Asignamos Origins como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario estándar)” como Input network analysis layer 

 Asignamos Destinations como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 
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Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la matriz origen-destino. El resultado es una capa con 400 entidades tipo línea que 

unen todos los puntos de interés posibles entre ellos (Figura 60). Para usuarios 

estándar, todos los puntos son accesibles. 

Figura 60: Pares de puntos donde el itinerario para usuario estándar es posible 
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 Los atributos de estas entidades tienen la estructura siguiente (Figura 61): 

 Figura 61: Listado de orígenes y destinos para usuario estándar (origen punto A) 

Name OriginID DestinationID DestinationRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 1 2 2 30,71874458 

A - C 1 3 3 44,63111445 

A - D 1 4 4 59,91164465 

A - E 1 5 5 59,96424825 

A - F 1 6 6 70,01825883 

A - G 1 7 7 75,08868066 

A - H 1 8 8 75,47930067 

A - I 1 9 9 86,98354013 

A - J 1 10 10 87,83095496 

A - K 1 11 11 88,24572631 

A - L 1 12 12 100,9299486 

A - M 1 13 13 110,2162764 

A - N 1 14 14 120,2805713 

A - O 1 15 15 120,9085702 

A - P 1 16 16 129,0520454 

A - Q 1 17 17 142,6015707 

A - R 1 18 18 173,774891 

A - S 1 19 19 197,8415113 

A - T 1 20 20 220,0989242 

… … … … … 

 

Esta información se puede representar en una matriz cuadrada de dimensiones n x n, 

simétrica y con ceros en la diagonal. Para obtenerla, en primer lugar se ha tenido que 

exportar la información a un archivo DBF mediante la herramienta Conversion Tools > 

To dBASE > Table to dBASE. 

Una vez importada la información en Access con la orden External data > Import > 

More > dBase File hemos obtenido una tabla llamada OD_STD en nuesta base de 

datos. 

Para obtener la matriz debemos crear una nueva consulta (Figura 62) con la orden 

Create > Other > Query Design que seleccionaremos que sea del tipo Crosstab a la 

que llamaremos OD_STD_Crosstab. 
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 El primer campo se le ha llamado “Origen_STD” y se le ha asignado la función 

Group By Row Heading y que adquiera el valor de la primera letra de los 

registros del campo “Name”: Left$([OD_STD]![Name];1) 

 El segundo campo se le ha llamado “Destino_STD” y se le ha asignado la 

función Group By Column Heading y que adquiera el valor de la ultima letra de 

los registros del campo “Name”: Right$([OD_STD]![Name];1) 

 El tercer campo es “Total_EV_Distancia” y se le ha asignado la función First 

Value de manera que obtiene el valor del campo “Total_EV_Distancia” (que es 

único) 

Figura 62: Consulta SQL para generar la matriz OD para usuario estándar 

TRANSFORM First(OD_STD.Total_EV_D) AS FirstOfTotal_EV_D 

SELECT Left$([OD_STD]![Name],1) AS Origen_STD 

FROM OD_STD 

GROUP BY Left$([OD_STD]![Name],1) 

PIVOT Right$([OD_STD]![Name],1); 

 

Con estas operaciones se ha obtenido la matriz de distancias origen-destino para el 

usuario estándar y se le ha dado formato en Excel (Figura 63). Para ello se ha utilizado 

la opción conditional formatting aplicado a los valores de la matriz: 

 Cells that contain a blank Gris claro 

 Cell value = 0 Gris oscuro 

 Todo el rango Gradación rojo-amarillo-azul 
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Figura 63: Matriz de distancias origen-destino para usuario estándar 

  A B C D E F G H I J K L M N O P Q R S T 

A 0 28,06 41,93 66,13 66,83 79,41 56,13 28,93 40,23 52,25 73,26 44,16 52,35 58,99 78,17 66,05 87,03 112,29 127,22 151,24 

B 28,06 0 13,91 38,83 39,02 51,46 28,27 28,08 26,53 33,32 49,06 53,19 48,96 51,43 61,99 67,46 83,58 103,93 103,28 147,33 

C 41,93 13,91 0 25,38 25,17 37,56 15,27 37,60 30,10 31,20 40,10 62,97 54,21 54,34 58,79 73,49 86,62 103,77 93,20 148,69 

D 66,13 38,83 25,38 0 5,07 15,24 18,74 62,04 51,57 47,05 41,78 86,98 74,93 72,71 68,57 94,15 103,45 115,53 85,55 161,68 

E 66,83 39,02 25,17 5,07 0 12,74 15,58 60,48 49,09 43,54 36,87 85,04 71,97 69,26 64,00 91,05 99,55 110,97 80,74 157,16 

F 79,41 51,46 37,56 15,24 12,74 0 25,54 71,23 58,57 50,89 38,01 95,03 80,10 76,20 66,69 98,68 104,75 113,09 73,43 159,31 

G 56,13 28,27 15,27 18,74 15,58 25,54 0 45,70 33,59 28,31 27,62 69,78 56,40 53,97 51,41 75,53 84,84 98,12 78,78 144,03 

H 28,93 28,08 37,60 62,04 60,48 71,23 45,70 0 15,52 28,45 52,17 25,43 24,10 30,09 50,43 40,60 59,48 83,62 103,52 123,99 

I 40,23 26,53 30,10 51,57 49,09 58,57 33,59 15,52 0 13,03 36,66 36,53 24,12 25,02 38,23 43,44 57,36 77,55 88,52 120,82 

J 52,25 33,32 31,20 47,05 43,54 50,89 28,31 28,45 13,03 0 23,90 46,78 29,29 25,72 28,69 47,82 56,73 72,58 75,60 117,62 

K 73,26 49,06 40,10 41,78 36,87 38,01 27,62 52,17 36,66 23,90 0 69,86 50,06 43,47 28,78 66,17 68,12 75,11 54,32 121,36 

L 44,16 53,19 62,97 86,98 85,04 95,03 69,78 25,43 36,53 46,78 69,86 0 22,21 31,42 57,35 24,40 47,27 75,36 115,06 109,32 

M 52,35 48,96 54,21 74,93 71,97 80,10 56,40 24,10 24,12 29,29 50,06 22,21 0 9,29 35,15 19,35 35,46 59,98 92,89 99,94 

N 58,99 51,43 54,34 72,71 69,26 76,20 53,97 30,09 25,02 25,72 43,47 31,42 9,29 0 25,95 22,84 32,39 53,77 83,85 95,94 

O 78,17 61,99 58,79 68,57 64,00 66,69 51,41 50,43 38,23 28,69 28,78 57,35 35,15 25,95 0 44,69 40,59 46,97 58,03 93,17 

P 66,05 67,46 73,49 94,15 91,05 98,68 75,53 40,60 43,44 47,82 66,17 24,40 19,35 22,84 44,69 0 22,95 51,41 101,83 85,47 

Q 87,03 83,58 86,62 103,45 99,55 104,75 84,84 59,48 57,36 56,73 68,12 47,27 35,46 32,39 40,59 22,95 0 28,74 91,04 64,50 

R 112,29 103,93 103,77 115,53 110,97 113,09 98,12 83,62 77,55 72,58 75,11 75,36 59,98 53,77 46,97 51,41 28,74 0 78,71 46,26 

S 127,22 103,28 93,20 85,55 80,74 73,43 78,78 103,52 88,52 75,60 54,32 115,06 92,89 83,85 58,03 101,83 91,04 78,71 0 116,91 

T 151,24 147,33 148,69 161,68 157,16 159,31 144,03 123,99 120,82 117,62 121,36 109,32 99,94 95,94 93,17 85,47 64,50 46,26 116,91 0 

 

Con la información de esta matriz se pueden descartar las distancias excesivas si se 

creyera necesario. 
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9.2.3 Rutas posibles para usuarios estándar 

Desafortunadamente, las entidades generadas son líneas rectas entre los puntos y no 

itinerarios reales, por lo que es necesario un paso adicional para poder obtener 

gráficamente todas las rutas posibles para su utilización en la web. 

Para conseguirlo, debemos utilizar una capa de análisis tipo closest facility de una 

manera distinta a como está diseñada para aprovechar que el análisis closest facility 

genera los itinerarios con su geometría real a diferencia del OD Cost Matrix. 

Como conocemos el número de puntos de interés (en este caso 20) se han podido 

obtener las rutas creando en primer lugar una capa de análisis tipo Closest Facility 

mediante la herramienta Network Analyst Tools > Analysis > Make Closest Faclity 

Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Centro más cercano (usuario estándar)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como facilities to find introducimos 20 (el número total) 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricción RE_Altura 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario estándar)” como Input network analysis 

layer 

 Asignamos Facilities como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 
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Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario estándar)” como Input network analysis 

layer 

 Asignamos Incidents como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la totalidad de las rutas posibles. El resultado es una capa con 400 entidades tipo 

polilínea que unen todos los puntos de interés posibles entre ellos y cuyos atributos 

tienen la estructura siguiente (Figura 64): 

Figura 64: Listado de facilities e incidents para usuario estándar (origen punto A) 

Name FacilityID IncidentID FacilityRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 2 1 2 30,71874458 

A - C 3 1 3 44,63111445 

A - D 4 1 4 59,91164465 

A - E 5 1 5 59,96424825 

A - F 6 1 6 70,01825883 

A - G 7 1 7 75,08868066 

A - H 8 1 8 75,47930067 

A - I 9 1 9 86,98354013 

A - J 10 1 10 87,83095496 

A - K 11 1 11 88,24572631 

A - L 12 1 12 100,9299486 

A - M 13 1 13 110,2162764 

A - N 14 1 14 120,2805713 

A - O 15 1 15 120,9085702 

A - P 16 1 16 129,0520454 

A - Q 17 1 17 142,6015707 

A - R 18 1 18 173,774891 

A - S 19 1 19 197,8415113 

A - T 20 1 20 220,0989242 

… … … … … 
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Para eliminar los duplicados (consideramos una misma ruta independientemente del 

sentido de circulación) debemos realizar una consulta con la herramienta Selection > 

Select by Attributes. Debemos seleccionar los elementos de la capa de rutas de 

“Centro más cercano (usuario estándar)” que cumplan FacilityID > IncidentID (Figura 

65). 

Figura 65: Rutas duplicadas en la matriz origen-destino (usuario estándar) 

 

Con esta operación eliminaremos los itinerarios duplicados o con origen y destino en el 

mismo punto y nos quedaremos únicamente con un total de 190 rutas (Ecuación 6): 19 

rutas partiendo de A, 18 rutas partiendo de B y así sucesivamente hasta n-1. 

Ecuación 6: Rutas descartando duplicados y origen=destino (usuario estándar) 

                                        

 
 

      

 
     

Finalmente, para generar las rutas se ha utilizado la extensión Zoom and Export 2.322 

de Ken Buja, utilizando las siguientes opciones: 

 Definimos un dataframe limitando su extensión para que todas las imágenes 

aparezcan idénticas en la página web. 

 Seleccionamos la capa que queremos exportar como imagen, en nuestro caso, 

la capa creada anteriormente una vez eliminados los duplicados. 

 Elegimos el campo “Name” como nombre del archivo a crear. 

 Seleccionamos Do not zoom to feature. 

                                                 
22

 Disponible de forma gratuita en http://arcscripts.esri.com/details.asp?dbid=15395 
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 Elegimos la opción Show only zoomed feature. 

 Elegimos el formato de salida (PNG) y la carpeta de destino. 

El resultado es un conjunto de 190 PNG con nombres del tipo “STD_A–T.png” listos 

para ser incorporados a la web23 para su difusión (Figura 66). 

Figura 66: Imagen del itinerario A-T para usuarios estándar exportada para la web 

 

  

                                                 
23

 Véase http://www-cpsv.upc.es/PATRAC/ 
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9.3 Obtención de rutas para usuarios con movilidad reducida 

El análisis de red se realiza sobre el network dataset creado anteriormente 

(Rutas_MR_ND), para el cual se han definido anteriormente todos los parámetros 

necesarios para poder efectuar la evaluación de rutas óptimas (detallado en el 

apartado 8.2, página 90). 

En primer lugar es necesario utilizar la herramienta Network Analyst Tools > Network 

Dataset > Build Network para construir la topología de red. 

Con esta acción la extensión Network Analyst genera una geometría a partir de los 

parámetros establecidos de manera que a cada segmento de red se le asignan valores 

en función de los evaluadores considerados: 

 EV_Distancia: Coste de atravesar el tramo (se ha considerado el mismo coste 

en los dos sentidos) medido en metros 

 RE_Altura: Consideración del tramo como transversable o no transversable (no 

se distinguen los dos sentidos) según su altura 

 RE_Anchura: Consideración del tramo como transversable o no transversable 

(no se distinguen los dos sentidos) según su anchura 

 RE_Escaleras: Consideración del tramo como transversable o no transversable 

(no se distinguen los dos sentidos) en función de la presencia de escaleras 

 RE_Iluminacion: Consideración del tramo como transversable o no 

transversable (no se distinguen los dos sentidos) en función del grado de 

iluminación 
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9.3.1 Ruta entre múltiples puntos para usuarios con movilidad reducida 

Cuando la geometría está generada y sus valores asignados, se ha procedido a cargar 

en ArcMap el network dataset Rutas_MR_ND. 

Con la herramienta Network Analyst Tools > Analysis > Make Route Layer se ha 

creado una capa de análisis de redes de tipo ruta óptima con los siguientes 

parámetros: 

 Nombramos a la capa de análisis “Ruta óptima (usuario con movilidad 

reducida)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras y RE_ 

Iluminacion 

Con esta información se ha creado una capa de análisis que encontrará el recorrido 

con la mínima distancia entre puntos a visitar, evitando las zonas con altura 

insuficiente, anchura insuficiente, presencia de escalones e iluminación insuficiente. 

Adicionalmente obtendremos la longitud total del recorrido óptimo. 

Para añadir paradas a la ruta, se ha utilizado la herramienta Create Network Location 

Tool de la barra de herramientas de Network Analyst para incorporar puntos de interés 

(entidades tipo stop). Estos puntos no deben ser necesariamente los puntos de interés 

prefijados descritos anteriormente. 

También se puede utilizar la misma herramienta para crear barreras (entidades tipo 

barrier) y así incorporar en la evaluación de la ruta información de elementos que 

impidan el paso de manera transitoria, como por ejemplo unas obras en la vía pública. 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

el itinerario óptimo correspondiente, pudiendo modificar los parámetros del análisis en 

la Layer Properties de la capa (por ejemplo el orden de las paradas). 
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9.3.2 Matriz origen-destino para usuarios con movilidad reducida 

Para saber las distancias de las rutas óptimas entre puntos de interés, se ha creado 

una capa de análisis tipo OD Cost Matrix mediante la herramienta Network Analyst 

Tools > Analysis > Make OD Matrix Cost Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Matriz OD (usuario con movilidad reducida)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras y RE_ 

Iluminacion 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario con movilidad reducida)” como Input network 

analysis layer 

 Asignamos Origins como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario con movilidad reducida)” como Input network 

analysis layer 

 Asignamos Destinations como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 
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 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la matriz origen-destino. El resultado es una capa con 88 entidades tipo línea que unen 

todos los puntos de interés posibles entre ellos (Figura 67). Este gráfico permite 

identificar clusters de puntos de interés donde la movilidad es posible. Se evalúan 

negativamente 312 pares (78% de los pares). 

Figura 67: Pares de puntos donde el itinerario para usuario con movilidad reducida es posible 
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Los atributos de estas entidades tienen la estructura siguiente (Figura 68): 

 Figura 68: Listado de orígenes y destinos para usuario con movilidad reducida (origen punto A) 

Name OriginID DestinationID DestinationRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 1 2 2 30,7187445791 

A - H 1 8 3 59,9642482466 

A - L 1 12 4 86,9835401317 

… … … … … 

 

Esta información se puede representar en una matriz cuadrada de dimensiones n x n, 

simétrica y con ceros en la diagonal. Para obtenerla, en primer lugar se ha tenido que 

exportar la información a un archivo DBF mediante la herramienta Conversion Tools > 

To dBASE > Table to dBASE. 

Una vez importada la información en Access con la orden External data > Import > 

More > dBase File hemos obtenido una tabla llamada OD_MR en nuesta base de 

datos. 

Para obtener la matriz debemos crear una nueva consulta (Figura 69) con la orden 

Create > Other > Query Design que seleccionaremos que sea del tipo Crosstab a la 

que llamaremos OD_MR_Crosstab. 

 El primer campo se le ha llamado “Origen_MR” y se le ha asignado la función 

Group By Row Heading y que adquiera el valor de la primera letra de los 

registros del campo “Name”: Left$([OD_MR]![Name];1) 

 El segundo campo se le ha llamado “Destino_MR” y se le ha asignado la 

función Group By Column Heading y que adquiera el valor de la ultima letra de 

los registros del campo “Name”: Right$([OD_MR]![Name];1) 

 El tercer campo es “Total_EV_Distancia” y se le ha asignado la función First 

Value de manera que obtiene el valor del campo “Total_EV_Distancia” (que es 

único) 

Figura 69: Consulta SQL para generar la matriz OD para usuario con movilidad reducida 

TRANSFORM First(OD_MR.Total_EV_D) AS FirstOfTotal_EV_D 

SELECT Left$([OD_MR]![Name],1) AS Origen_MR 

FROM OD_MR 

GROUP BY Left$([OD_MR]![Name],1) 

PIVOT Right$([OD_MR]![Name],1); 
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Con estas operaciones se ha obtenido la matriz de distancias origen-destino para el 

usuario estándar y se le ha dado formato en Excel (Figura 70). Para ello se ha utilizado 

la opción conditional formatting aplicado a los valores de matriz: 

 Cells that contain a blank Gris claro 

 Cell value = 0 Gris oscuro 

 Todo el rango Gradación rojo-amarillo-azul 

Figura 70: Matriz de distancias origen-destino para usuario con movilidad reducida 

  A B C D E F G H I J K L M N O P Q R S T 

A 0 30,72 
     

59,96 
   

86,98 
        

B 30,72 0 
     

29,25 
   

56,26 
        

C 
  

0 
 

35,28 
 

15,28 
  

43,61 
   

69,38 
  

101,77 
   

D 
   

0 
                

E 
  

35,28 
 

0 
 

20,00 
  

48,33 
   

74,10 
  

106,49 
   

F 
     

0 
              

G 
  

15,28 
 

20,00 
 

0 
  

28,33 
   

54,10 
  

86,49 
   

H 59,96 29,25 
     

0 
   

27,02 
        

I 
        

0 
   

25,45 
  

44,80 
    

J 
  

43,61 
 

48,33 
 

28,33 
  

0 
   

25,77 
  

58,15 
   

K 
          

0 
   

28,91 
  

80,07 212,70 126,39 

L 86,98 56,26 
     

27,02 
   

0 
        

M 
        

25,45 
   

0 
  

19,35 
    

N 
  

69,38 
 

74,10 
 

54,10 
  

25,77 
   

0 
  

32,39 
   

O 
          

28,91 
   

0 
  

51,16 183,79 97,48 

P 
        

44,80 
   

19,35 
  

0 
    

Q 
  

101,77 
 

106,49 
 

86,49 
  

58,15 
   

32,39 
  

0 
   

R 
          

80,07 
   

51,16 
  

0 209,43 46,32 

S 
          

212,70 
   

183,79 
  

209,43 0 255,75 

T 
          

126,39 
   

97,48 
  

46,32 255,75 0 

 

Con la información de esta matriz se pueden descartar las distancias excesivas si se 

creyera necesario. 
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9.3.3 Rutas posibles para usuarios con movilidad reducida 

Desafortunadamente, las entidades generadas son líneas rectas entre los puntos y no 

itinerarios reales, por lo que es necesario un paso adicional para poder obtener 

gráficamente todas las rutas posibles para su utilización en la web. 

Para conseguirlo, debemos utilizar una capa de análisis tipo closest facility de una 

manera distinta a como está diseñada para aprovechar que el análisis closest facility 

genera los itinerarios con su geometría real a diferencia del OD Cost Matrix. 

Como conocemos el número de puntos de interés (en este caso 20) se han podido 

obtener las rutas creando en primer lugar una capa de análisis tipo Closest Facility 

mediante la herramienta Network Analyst Tools > Analysis > Make Closest Faclity 

Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Centro más cercano (usuario con  movilidad 

reducida)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como facilities to find introducimos 20 (el número total) 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras y RE_ 

Iluminacion 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario con  movilidad reducida)” como Input 

network analysis layer 

 Asignamos Facilities como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 
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Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario con  movilidad reducida)” como Input 

network analysis layer 

 Asignamos Incidents como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la totalidad de las rutas posibles. El resultado es una capa con 88 entidades tipo 

polilínea que unen todos los puntos de interés posibles entre ellos y cuyos atributos 

tienen la estructura siguiente (Figura 71): 

Figura 71: Listado de facilities e incidents para usuario con movilidad reducida (origen punto A) 

Name FacilityID IncidentID FacilityRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 2 1 2 30,7187445791 

A - H 8 1 3 59,9642482466 

A - L 12 1 4 86,9835401317 

… … … … … 

 

Para eliminar los duplicados (consideramos una misma ruta independientemente del 

sentido de circulación) debemos realizar una consulta con la herramienta Selection > 

Select by Attributes. Debemos seleccionar los elementos de la capa de rutas de 

“Centro más cercano (usuario estándar)” que cumplan FacilityID > IncidentID (Figura 

72). 
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Figura 72: Rutas duplicadas en la matriz origen-destino (usuario con movilidad reducida) 

 

Con esta operación eliminaremos los itinerarios duplicados o con origen y destino en el 

mismo punto y nos quedaremos únicamente con un total de 34 rutas (Ecuación 7). 

Ecuación 7: Rutas descartando duplicados y origen=destino (usuario con movilidad reducida) 

 
                                        

 
 

     

 
    

 

Finalmente, para generar las rutas se ha utilizado la extensión Zoom and Export 2.324 

de Ken Buja, utilizando las siguientes opciones: 

 Definimos un dataframe limitando su extensión para que todas las imágenes 

aparezcan idénticas en la página web. 

 Seleccionamos la capa que queremos exportar como imagen, en nuestro caso, 

la capa creada anteriormente una vez eliminados los duplicados. 

 Elegimos el campo “Name” como nombre del archivo a crear. 

 Seleccionamos Do not zoom to feature. 

 Elegimos la opción Show only zoomed feature. 

 Elegimos el formato de salida (PNG) y la carpeta de destino. 

El resultado es un conjunto de 34 PNG con nombres del tipo “MR_A–L.png” listos para 

ser incorporados a la web25 para su difusión (Figura 73). 

                                                 
24

 Disponible de forma gratuita en http://arcscripts.esri.com/details.asp?dbid=15395 
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Figura 73: Imagen del itinerario A-L para usuarios con movilidad reducida exportada para la web 

 

  

                                                                                                                                            
25

 Véase http://www-cpsv.upc.es/PATRAC/ 
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9.4 Obtención de rutas para usuarios en silla de ruedas 

El análisis de red se realiza sobre el network dataset creado anteriormente 

(Rutas_SR_ND), para el cual se han definido anteriormente todos los parámetros 

necesarios para poder efectuar la evaluación de rutas óptimas (detallado en el 

apartado 8.3, página 94). 

En primer lugar es necesario utilizar la herramienta Network Analyst Tools > Network 

Dataset > Build Network para construir la topología de red. 

Con esta acción la extensión Network Analyst genera una geometría a partir de los 

parámetros establecidos de manera que a cada segmento de red se le asignan valores 

en función de los evaluadores considerados: 

 EV_Distancia: Coste de atravesar el tramo (se ha considerado el mismo coste 

en los dos sentidos) medido en metros 

 EV_Pendiente: Evaluador del coste de atravesar el tramo (se ha considerado el 

mismo coste en los dos sentidos) en función de la pendiente. Se utiliza para 

calcular la restricción de pendiente (RE_Pendiente) 

 RE_Altura: Consideración del tramo como transversable o no transversable (no 

se distinguen los dos sentidos) según su altura 

 RE_Anchura: Consideración del tramo como transversable o no transversable 

(no se distinguen los dos sentidos) según su anchura 

 RE_Escaleras: Consideración del tramo como transversable o no transversable 

(no se distinguen los dos sentidos) en función de la presencia de escaleras 

 RE_Iluminacion: Consideración del tramo como transversable o no 

transversable (no se distinguen los dos sentidos) en función del grado de 

iluminación 

 RE_Pendiente: Consideración del tramo como transversable o no transversable 

(no se distinguen los dos sentidos) en función de la pendiente menor o mayor 

del 12% 
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9.4.1 Ruta entre múltiples puntos para usuarios en silla de ruedas 

Cuando la geometría está generada y sus valores asignados, se ha procedido a cargar 

en ArcMap el network dataset Rutas_SR_ND. 

Con la herramienta Network Analyst Tools > Analysis > Make Route Layer se ha 

creado una capa de análisis de redes de tipo ruta óptima con los siguientes 

parámetros: 

 Nombramos a la capa de análisis “Ruta óptima (usuario en silla de ruedas)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras, RE_ 

Iluminacion y RE_Pendiente 

Con esta información se ha creado una capa de análisis que encontrará el recorrido 

con la mínima distancia entre puntos a visitar, evitando las zonas con altura 

insuficiente, anchura insuficiente, presencia de escalones, iluminación insuficiente y 

pendiente excessiva. Adicionalmente obtendremos la longitud total del recorrido 

óptimo. 

Para añadir paradas a la ruta, se ha utilizado la herramienta Create Network Location 

Tool de la barra de herramientas de Network Analyst para incorporar puntos de interés 

(entidades tipo stop). Estos puntos no deben ser necesariamente los puntos de interés 

prefijados descritos anteriormente. 

También se puede utilizar la misma herramienta para crear barreras (entidades tipo 

barrier) y así incorporar en la evaluación de la ruta información de elementos que 

impidan el paso de manera transitoria, como por ejemplo unas obras en la vía pública. 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

el itinerario óptimo correspondiente, pudiendo modificar los parámetros del análisis en 

la Layer Properties de la capa (por ejemplo el orden de las paradas). 
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9.4.2 Matriz origen-destino para usuarios en silla de ruedas 

Para saber las distancias de las rutas óptimas entre puntos de interés, se ha creado 

una capa de análisis tipo OD Cost Matrix mediante la herramienta Network Analyst 

Tools > Analysis > Make OD Matrix Cost Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Matriz OD (usuario en silla de ruedas)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras, RE_ 

Iluminacion y RE_Pendiente 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario en silla de ruedas)” como Input network analysis 

layer 

 Asignamos Origins como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Matriz OD (usuario en silla de ruedas)” como Input network analysis 

layer 

 Asignamos Destinations como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 
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 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la matriz origen-destino. El resultado es una capa con 19 entidades tipo línea que unen 

todos los puntos de interés posibles entre ellos (Figura 74). Este gráfico permite 

identificar clusters de puntos de interés donde la movilidad es posible. Se evalúan 

negativamente 381 pares (95% de los pares). 

Figura 74: Pares de puntos donde el itinerario para usuario en silla de ruedas es posible 
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Los atributos de estas entidades tienen la estructura siguiente (Figura 75): 

 Figura 75: Listado de orígenes y destinos para usuario en silla de ruedas (origen punto A) 

Name OriginID DestinationID DestinationRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 1 2 2 30,7187445791 

… … … … … 

 

Esta información se puede representar en una matriz cuadrada de dimensiones n x n, 

simétrica y con ceros en la diagonal. Para obtenerla, en primer lugar se ha tenido que 

exportar la información a un archivo DBF mediante la herramienta Conversion Tools > 

To dBASE > Table to dBASE. 

Una vez importada la información en Access con la orden External data > Import > 

More > dBase File hemos obtenido una tabla llamada OD_SR en nuesta base de 

datos. 

Para obtener la matriz debemos crear una nueva consulta (Figura 76) con la orden 

Create > Other > Query Design que seleccionaremos que sea del tipo Crosstab a la 

que llamaremos OD_SR_Crosstab. 

 El primer campo se le ha llamado “Origen_SR” y se le ha asignado la función 

Group By Row Heading y que adquiera el valor de la primera letra de los 

registros del campo “Name”: Left$([OD_SR]![Name];1) 

 El segundo campo se le ha llamado “Destino_SR” y se le ha asignado la 

función Group By Column Heading y que adquiera el valor de la ultima letra de 

los registros del campo “Name”: Right$([OD_SR]![Name];1) 

 El tercer campo es “Total_EV_Distancia” y se le ha asignado la función First 

Value de manera que obtiene el valor del campo “Total_EV_Distancia” (que es 

único) 

Figura 76: Consulta SQL para generar la matriz OD para usuario con movilidad reducida 

TRANSFORM First(OD_SR.Total_EV_D) AS FirstOfTotal_EV_D 

SELECT Left$([OD_SR]![Name],1) AS Origen_SR 

FROM OD_SR 

GROUP BY Left$([OD_SR]![Name],1) 

PIVOT Right$([OD_SR]![Name],1); 
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Con estas operaciones se ha obtenido la matriz de distancias origen-destino para el 

usuario estándar y se le ha dado formato en Excel (Figura 77). Para ello se ha utilizado 

la opción conditional formatting aplicado a los valores de matriz: 

 Cells that contain a blank Gris claro 

 Cell value = 0 Gris oscuro 

 Todo el rango Gradación rojo-amarillo-azul 

Figura 77: Matriz de distancias origen-destino para usuario en silla de ruedas 

  A B C D E F G H I J K L M N O P Q R S T 

A 0 30,72 
                  

B 30,72 0 
                  

C 
  

0 
                 

D 
   

0 
                

E 
    

0 
               

F 
     

0 
              

G 
      

0 
             

H 
       

0 
            

I 
        

0 
           

J 
         

0 
          

K 
          

0 
         

L 
           

0 
        

M 
            

0 
       

N 
             

0 
      

O 
              

0 
  

51,16 
 

97,48 

P 
               

0 
    

Q 
                

0 
   

R 
              

51,16 
  

0 
 

46,32 

S 
                  

0 
 

T 
              

97,48 
  

46,32 
 

0 

 

Con la información de esta matriz se pueden descartar las distancias excesivas si se 

creyera necesario. 
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9.4.3 Rutas posibles para usuarios en silla de ruedas 

Desafortunadamente, las entidades generadas son líneas rectas entre los puntos y no 

itinerarios reales, por lo que es necesario un paso adicional para poder obtener 

gráficamente todas las rutas posibles para su utilización en la web. 

Para conseguirlo, debemos utilizar una capa de análisis tipo closest facility de una 

manera distinta a como está diseñada para aprovechar que el análisis closest facility 

genera los itinerarios con su geometría real a diferencia del OD Cost Matrix. 

Como conocemos el número de puntos de interés (en este caso 20) se han podido 

obtener las rutas creando en primer lugar una capa de análisis tipo Closest Facility 

mediante la herramienta Network Analyst Tools > Analysis > Make Closest Faclity 

Layer con los siguientes parámetros: 

 Nombramos a la capa de análisis “Centro más cercano (usuario en silla de 

ruedas)” 

 Como impedancia (elemento a minimizar) utilizamos EV_Distancia 

 Como facilities to find introducimos 20 (el número total) 

 Como acumuladores elegimos EV_Distancia 

 Permitimos al algoritmo efectuar cambios de sentido 

 Elegimos como restricciones RE_Altura, RE_Anchura, RE_Escaleras, RE_ 

Iluminacion y RE_Pendiente 

Para definir los orígenes debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario en silla de ruedas)” como Input 

network analysis layer 

 Asignamos Facilities como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 
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Para definir los destinos debemos incorporar la información de los puntos de interés a 

la capa de análisis mediante la herramienta  Network Analyst Tools > Analysis > Add 

Locations con los siguientes parámetros: 

 Elegimos “Centro más cercano (usuario en silla de ruedas)” como Input 

network analysis layer 

 Asignamos Incidents como Sub layer de destino 

 Elegimos nuestra capa “Puntos de interés” como Input locations 

 Elegimos que la propiedad Name adquiera el valor del campo “NombrePunto” 

de la capa “Puntos de interés” en Field Mappings 

 Forzamos a importar las entidades en orden seleccionando el campo “Nombre 

Punto” como Sort Field 

Se ha utilizado la herramienta Network Analyst Tools > Analysis > Solve para obtener 

la totalidad de las rutas posibles. El resultado es una capa con 19 entidades tipo 

polilínea que unen todos los puntos de interés posibles entre ellos y cuyos atributos 

tienen la estructura siguiente (Figura 78): 

Figura 78: Listado de facilities e incidents para usuario en silla de ruedas (origen punto A) 

Name FacilityID IncidentID FacilityRank Total_EV_Distancia 

A - A 1 1 1 0 

A - B 2 1 2 30,7187445791 

… … … … … 

 

Para eliminar los duplicados (consideramos una misma ruta independientemente del 

sentido de circulación) debemos realizar una consulta con la herramienta Selection > 

Select by Attributes. Debemos seleccionar los elementos de la capa de rutas de 

“Centro más cercano (usuario estándar)” que cumplan FacilityID > IncidentID (Figura 

79). 
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Figura 79: Rutas duplicadas en la matriz origen-destino (usuario con movilidad reducida) 

 

Con esta operación eliminaremos los itinerarios duplicados o con origen y destino en el 

mismo punto y nos quedaremos únicamente con un total de 4 rutas (Ecuación 8). 

Ecuación 8: Rutas descartando duplicados y origen=destino (usuario en silla de ruedas) 

 

                                        

 
 

     

 
   

Finalmente, para generar las rutas se ha utilizado la extensión Zoom and Export 2.326 

de Ken Buja, utilizando las siguientes opciones: 

 Definimos un dataframe limitando su extensión para que todas las imágenes 

aparezcan idénticas en la página web. 

 Seleccionamos la capa que queremos exportar como imagen, en nuestro caso, 

la capa creada anteriormente una vez eliminados los duplicados. 

 Elegimos el campo “Name” como nombre del archivo a crear. 

 Seleccionamos Do not zoom to feature. 

 Elegimos la opción Show only zoomed feature. 

 Elegimos el formato de salida (PNG) y la carpeta de destino. 

El resultado es un conjunto de 4 PNG con nombres del tipo “SR_A–B.png” listos para 

ser incorporados a la web27 para su difusión (Figura 80). 

                                                 
26

 Disponible de forma gratuita en http://arcscripts.esri.com/details.asp?dbid=15395 
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Figura 80: Imagen del itinerario A-B para usuarios en silla de ruedas exportada para la web 

 

 

 

 

  

                                                                                                                                            
27

 Véase http://www-cpsv.upc.es/PATRAC/ 
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10 Conclusiones 

La evaluación de la accesibilidad en entornos urbanos que aborda esta tesis sólo tiene 

sentido si podemos obtener resultados y si los resultados obtenidos nos permiten 

identificar en qué aspectos debemos incidir para mejorarla. 

El aprovechamiento de las herramientas generalistas disponibles para el estudio de la 

movilidad, adaptándolas para la evaluación de la accesibilidad, aporta la capacidad de 

realizar un análisis más complejo que la evaluación de la accesibilidad en entornos 

urbanos necesita. 

Para la presente tesis se han tenido que hacer algunas simplificaciones, tanto en la 

metodología de evaluación como en el número de aspectos considerados, pero se ha 

desarrollado una metodología extensible que permitirá incorporarlos en el futuro. 

Por otra parte, se han buscado herramientas de análisis y visualización de los 

resultados que permitan ver más allá de la complejidad inherente a todo análisis 

urbano, para permitir la toma de decisiones correctoras adecuadas. Un ejemplo de ello 

es la detección discontinuidades en las redes de movilidad, que pueden solventarse 

con una única intervención. 

También se ha hecho especial hincapié en la máxima difusión de los resultados 

obtenidos, que permite por una parte facilitar los recorridos más accesibles a las 

personas que lo necesitan y por otra la toma de consciencia de los problemas de 

accesibilidad. 

La obtención de datos topográficos y la identificación de ciertos tipos de obstáculos 

como las escaleras es un aspecto esencial en la evaluación de la accesibilidad. 

La utilización de los datos obtenidos mediante la tecnología de escáner láser para la 

generación de la topografía y la caracterización de los obstáculos era el objetivo 

secundario de la presente tesis. Este es un ámbito en el que se están desarrollando 

grandes avances y la generalización del uso de la tecnología LIDAR28 permitiría aplicar 

la metodología grandes extensiones de territorio. También se ha comprobado que los 

                                                 
28

 La nueva versión de AutoCAD 2011 permite trabajar con nubes de puntos 
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datos de la nube de puntos permiten obtener los límites de las edificaciones y la 

identificación de las escaleras. 

Por otra parte, se han desarrollado técnicas para visualizar en plano estas nubes de 

puntos, empleando técnicas de representación arquitectónicas. Filtrando los puntos 

más altos y elaborando un mapa de pendientes conseguimos un plano equivalente a 

una planta arquitectónica dónde aparecen representados por sus límites los muros y 

otros elementos en proyección horizontal. Estas representaciones permiten generar un 

mapa detallado de accesibilidad para su difusión. 

Finalmente, como propuestas de futuro, algunos aspectos de esta investigación 

pueden aplicarse a distintos ámbitos: 

 Incorporación la información 3D a un GPS para su uso en bicicletas y así poder 

evitar pendientes excesivas. 

 Utilización de la caracterización de la topografía para el análisis de cubiertas 

complejas o en paisajismo para una mejor gestión de las escorrentías. 

 Herramientas de soporte para la elaboración de planes de accesibilidad 

municipales y posterior gestión de la accesibilidad. 

 Obtención de las rutas del ámbito en 3D ya sea mediante vuelos virtuales 

generados por la propia aplicación, via web con X3D29, incrustados en archivos 

PDF o mediante Google Earth.  

                                                 
29

 Sucesor de VRML (Virtual Reality Modelling Language) 
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12 Anexos 

12.1 Código VisualBasic del módulo de identificación de candidatos 

' --------------------------------------------------------------

------------- 

' Reclass.vbs 

' Created on: Sun Jun 27 2010 06:32:51 PM 

'   (generated by ArcGIS/ModelBuilder) 

' --------------------------------------------------------------

------------- 

 

' Create the Geoprocessor object 

set gp = WScript.CreateObject("esriGeoprocessing.GPDispatch.1") 

 

' Check out any necessary licenses 

gp.CheckOutExtension "spatial" 

gp.CheckOutExtension "3D" 

 

' Load required toolboxes... 

gp.AddToolbox "C:/Program 

Files/ArcGIS/ArcToolbox/Toolboxes/Spatial Analyst Tools.tbx" 

gp.AddToolbox "C:/Program Files/ArcGIS/ArcToolbox/Toolboxes/3D 

Analyst Tools.tbx" 

 

' Set the Geoprocessing environment... 

gp.scratchWorkspace = "C:\PATRAC\Scratch.gdb" 

gp.extent = "494458.017499131 4618416.86241715 494666.470908555 

4618625.45455789" 

 

 

' Local variables... 

Slope_Result = "C:\PATRAC\Scratch.gdb\Slope Result" 

Points_Interpolated__Natural_Neighbor_ = 

"C:\PATRAC\PATRAC.gdb\Points_Natural" 

Slope_Reclass = "C:\PATRAC\Scratch.gdb\Slope_Reclass" 

Range_Result = "C:\PATRAC\Scratch.gdb\Range_Result" 

Range_Reclass = "C:\PATRAC\Scratch.gdb\Range_Reclass" 

Desv_Result = "C:\PATRAC\Scratch.gdb\Desv_Result" 

Desv_Reclass = "C:\PATRAC\Scratch.gdb\Desv_Reclass" 

Curvature_Result = "C:\PATRAC\Scratch.gdb\Curvature" 

Curvature_Result__Profile_ = 

"C:\PATRAC\Scratch.gdb\Curvature_Profile" 

Curvature_Result__Plan_ = "C:\PATRAC\Scratch.gdb\Curvature_Plan" 

Curvature__Profile__Reclass = 

"C:\PATRAC\Scratch.gdb\Curvature_Profile_Reclass" 

 

' Process: Slope... 

gp.Slope_sa Points_Interpolated__Natural_Neighbor_, 

Slope_Result, "PERCENT_RISE", "1" 
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' Process: Reclassify Slope... 

gp.Reclassify_sa Slope_Result, "Value", "0 50 1;50 99999 2", 

Slope_Reclass, "DATA" 

 

' Process: Range... 

gp.FocalStatistics_sa Points_Interpolated__Natural_Neighbor_, 

Range_Result, "Rectangle 3 3 CELL", "RANGE", "DATA" 

 

' Process: Reclassify Range... 

gp.Reclassify_sa Range_Result, "VALUE", "0 0.20000000000000001 

1;0.20000000000000001 99999 2", Range_Reclass, "DATA" 

 

' Process: Desv... 

gp.FocalStatistics_sa Points_Interpolated__Natural_Neighbor_, 

Desv_Result, "Rectangle 3 3 CELL", "STD", "DATA" 

 

' Process: Reclassify Desv... 

gp.Reclassify_sa Desv_Result, "VALUE", "0 0.10000000000000001 

1;0.10000000000000001 99999 2", Desv_Reclass, "DATA" 

 

' Process: Curvature... 

gp.Curvature_sa Points_Interpolated__Natural_Neighbor_, 

Curvature_Result, "1", Curvature_Result__Profile_, 

Curvature_Result__Plan_ 

 

' Process: Reclassify Curvature (Profile)... 

gp.Reclassify_3d Curvature_Result__Profile_, "Value", "-

999999999999 -200 1;-200 200 2;200 99999999999 1", 

Curvature__Profile__Reclass, "DATA" 
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12.2 Código VisualBasic del módulo de cálculo de pendientes 

' --------------------------------------------------------------

------------- 

' Pendiente.vbs 

' Created on: Mon Jun 28 2010 07:35:36 PM 

'   (generated by ArcGIS/ModelBuilder) 

' Usage: a <Rutas__1m_>  

' --------------------------------------------------------------

------------- 

 

' Create the Geoprocessor object 

set gp = WScript.CreateObject("esriGeoprocessing.GPDispatch.1") 

 

' Load required toolboxes... 

gp.AddToolbox "C:/Program Files/ArcGIS/ArcToolbox/Toolboxes/Data 

Management Tools.tbx" 

 

' Set the Geoprocessing environment... 

gp.scratchWorkspace = "C:\PATRAC\Scratch.gdb" 

gp.workspace = "C:\PATRAC\PATRAC.gdb" 

 

' Script arguments... 

Rutas__1m_ = wscript.arguments.item(0) 

if Rutas__1m_ = "#" then 

 Rutas__1m_ = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" ' provide a 

default value if unspecified 

end if 

 

' Local variables... 

Campo_X_Inicio_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_X_Inicio = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_X_Final_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_X_Final = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Y_Inicio_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Y_Inicio = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Y_Final_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Y_Final = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Z_Inicio_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Z_Inicio = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Z_Final_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Z_Final = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Pendiente_calculada = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campo_Pendiente_creado = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

Campos_limpios = "C:\PATRAC\Tossa.gdb\Rutas_Simple_3D" 

 

' Process: Crear campo X Final... 

gp.AddField_management Rutas__1m_, "Fin_X", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo X Final... 

gp.CalculateField_management Campo_X_Final_creado, "Fin_X", 

"Fin_X", "VB", "dim pcurve as ipolycurve\nset pcurve = 
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[shape]\ndim ppt as ipoint\nset ppt = pcurve.topoint\ndim Fin_X 

as double\nFin_X = ppt.x" 

 

' Process: Crear campo X Inicio... 

gp.AddField_management Rutas__1m_, "Inicio_X", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo X Inicio... 

gp.CalculateField_management Campo_X_Inicio_creado, "Inicio_X", 

"Inicio_X", "VB", "dim pcurve as ipolycurve\nset pcurve = 

[shape]\ndim ppt as ipoint\nset ppt = pcurve.frompoint\ndim 

Inicio_X as double\nInicio_X = ppt.x" 

 

' Process: Crear campo Y Final... 

gp.AddField_management Rutas__1m_, "Fin_Y", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo Y Final... 

gp.CalculateField_management Campo_Y_Final_creado, "Fin_Y", 

"Fin_Y", "VB", "dim pcurve as ipolycurve\nset pcurve = 

[shape]\ndim ppt as ipoint\nset ppt = pcurve.topoint\ndim Fin_Y 

as double\nFin_Y = ppt.y" 

 

' Process: Crear campo Y Inicio... 

gp.AddField_management Rutas__1m_, "Inicio_Y", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo Y Inicio... 

gp.CalculateField_management Campo_Y_Inicio_creado, "Inicio_Y", 

"Inicio_Y", "VB", "dim pcurve as ipolycurve\nset pcurve = 

[shape]\ndim ppt as ipoint\nset ppt = pcurve.frompoint\ndim 

Inicio_Y as double\nInicio_Y = ppt.y" 

 

' Process: Crear campo Z Final... 

gp.AddField_management Rutas__1m_, "Fin_Z", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo Z Final... 

gp.CalculateField_management Campo_Z_Final_creado, "Fin_Z", 

"Fin_Z", "VB", "dim pcurve as ipolycurve\nset pcurve = 

[shape]\ndim ppt as ipoint\nset ppt = pcurve.topoint\ndim Fin_Z 

as double\nFin_Z = ppt.z" 

 

' Process: Crear campo Z Inicio... 

gp.AddField_management Rutas__1m_, "Inicio_Z", "DOUBLE", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular Campo Z Inicio... 

gp.CalculateField_management Campo_Z_Inicio_creado, "Inicio_Z", 

"Inicio_Z", "VB", "dim pcurve as ipolycurve\nset pcurve = 

[shape]\ndim ppt as ipoint\nset ppt = pcurve.frompoint\ndim 

Inicio_Z as double\nInicio_Z = ppt.z" 
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' Process: Crear campo Pendiente... 

gp.AddField_management Rutas__1m_, "Pendiente", "FLOAT", "", "", 

"", "", "NULLABLE", "NON_REQUIRED", "" 

 

' Process: Calcular pendiente... 

gp.CalculateField_management Campo_Pendiente_creado, 

"Pendiente", "Abs((([Fin_Z] - [Inicio_Z]) / (([Fin_X]-

[Inicio_X])^2 + ([Fin_Y]-[Inicio_Y])^2)^0.5)*100)", "VB", "" 

 

' Process: Borrar campos intermedios... 

gp.DeleteField_management Pendiente_calculada, 

"Fin_X;Inicio_X;Fin_Y;Inicio_Y;Fin_Z;Inicio_Z" 
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12.3 Código VisualBasic del módulo de cálculo de obstáculos 

' --------------------------------------------------------------

------------- 

' Obstaculos.vbs 

' Created on: Mon Jun 28 2010 08:05:44 PM 

'   (generated by ArcGIS/ModelBuilder) 

' Usage: Obstaculos <Rutas> <Rutas_con_obstaculos>  

' --------------------------------------------------------------

------------- 

 

' Create the Geoprocessor object 

set gp = WScript.CreateObject("esriGeoprocessing.GPDispatch.1") 

 

' Set the necessary product code 

gp.SetProduct "ArcInfo" 

 

' Load required toolboxes... 

gp.AddToolbox "C:/Program 

Files/ArcGIS/ArcToolbox/Toolboxes/Analysis Tools.tbx" 

 

' Set the Geoprocessing environment... 

gp.scratchWorkspace = "C:\PATRAC\Scratch.gdb" 

 

' Script arguments... 

Rutas = wscript.arguments.item(0) 

if Rutas = "#" then 

 Rutas = "C:\PATRAC\PATRAC.gdb\Rutas_Simple_3D_1m" ' provide a 

default value if unspecified 

end if 

 

Rutas_con_obstaculos = wscript.arguments.item(1) 

if Rutas_con_obstaculos = "#" then 

 Rutas_con_obstaculos = 

"C:\PATRAC\Scratch.gdb\Rutas_Simple_3D_1m_4_Iluminación" ' 

provide a default value if unspecified 

end if 

 

' Local variables... 

Altura_Incorporada = 

"C:\PATRAC\Scratch.gdb\Rutas_Simple_3D_1m_1_Altura" 

Altura__ICC_ = "C:\PATRAC\Tossa.gdb\Obstaculo_Altura_ICC" 

Anchura_Incorporada = 

"C:\PATRAC\Scratch.gdb\Rutas_Simple_3D_1m_2_Anchura" 

Anchura = "C:\PATRAC\Tossa.gdb\Obstaculo_Anchura" 

Escalera_Incorporada = 

"C:\PATRAC\Scratch.gdb\Rutas_Simple_3D_1m_3_Escaleras" 

Escaleras = "C:\PATRAC\Tossa.gdb\Obstaculo_Escaleras_ICC" 

Iluminación = "C:\PATRAC\Tossa.gdb\Obstaculo_Farolas" 

 

' Process: Calculo Altura... 

gp.Identity_analysis Rutas, Altura__ICC_, Altura_Incorporada, 

"NO_FID", "", "NO_RELATIONSHIPS" 
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' Process: Calculo Anchura... 

gp.Identity_analysis Altura_Incorporada, Anchura, 

Anchura_Incorporada, "NO_FID", "", "NO_RELATIONSHIPS" 

 

' Process: Calculo Escalera... 

gp.Identity_analysis Anchura_Incorporada, Escaleras, 

Escalera_Incorporada, "NO_FID", "", "NO_RELATIONSHIPS" 

 

' Process: Calculo Iluminación... 

gp.Identity_analysis Escalera_Incorporada, Iluminación, 

Rutas_con_obstaculos, "NO_FID", "", "NO_RELATIONSHIPS" 
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