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Abstract

IT Asset Management (ITAM) is the process of managing an identified IT asset
throughout its lifecycle of procurement, installation, support, and retirement and disposal.
This paper was prepared to explain the design and development of the ITAM system

which is an internal web application that was completed for BM InfoTech Inc.

The need for an IT Asset Management (ITAM) System, the technology which is enabling
it, IT Asset Management data model, General ITAM tool characteristics are discussed in
detail. The .Net Framework Technology was used in the development. The comparison
between various web technologies' and the reason why the .Net Framework Technology
has been chosen is discussed in detail. The Rapid Application Development Tool Visual
Studio .Net is used for the development of the application. The code generated by the tool

is included in the appendix B.
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1. Introduction

In brief, ITAM (IT Asset Management) is the process for keeping track of technology
assets (hardware, software, etc.)--Knowing where they are, who owns them, and how
they are used and maintained. It is a combination of policies, procedures, and enabling
technology. IT asset classes are composed of categories such as desktops, servers,

network and telephony equipment, mobile phones, pagers, and PDAs".

ITAM is accomplished by centralizing all manually or electronically gathered
information into an IT Asset Management Database (AMDB). The benefits resulting
from a successful ITAM process implementation are significant and can be quantified
for forward savings based on industry data and on the organization’s own experiences
with not having the right information available at the right time.
This report gives an overall view of the business concepts of an IT Asset Management
System. ITAM System is part of a Support Module under any CRM application. The
report carries the entire technical environment on how the project was designed and
implemented.
The report consists of the following sections —

- Necessity of this ITAM System development

- Deliverables



- Project Life Cycle

- Future Work and enhancements

Why IT Asset Management is important
In today’s complex business environment, there is constant pressure on IT
organizations to understand their cost envelope in order to better manage costs and to
justify their expenditures and resulting service pricing. An ITAM program is critical in
helping IT improve sourcing decisions, in positioning the IT organization as a business
enabler rather than a cost center, and in running IT as a business.
The company BM InfoTech, NY has various assets at different locations. They couldn’t
keep track of their assets. So there was a necessity for the development of an IT Asset
Management System.
Technology
The technologies that were used for the IT Asset Management System are:

e Programming Languages: C#, ASP.NET, ADO.NET, XML, Web Services

e Database: SQL Server 2000

e Graphic Tools: Fireworks 5.0

e Web Development Tool: DreamWeaver 4.0

e Web server: IIS 5.0

e Third-Party Tools: Concept Draw 2.0



Development Environment

Microsoft .NET allow programmers to develop applications in language independent
manner. It has been specifically designed with Web Services in mind. Visual Studio.Net is
the IDE (Integrated Development Environment) for .NET based application. The
professional version of Visual Studio.NET contains the .NET Framework SDK (Software
Development Kit) and the main .NET languages VB (Visual Basic), C++, C# and Java script
(Jscript) .NET. All the XML capabilities that were formally available to the programmer
through the Microsoft XML (MSXML) parsers are now encapsulated in the system.xml
namespace of classes. Appendix lists the classes that are used in the project. This project
uses C# as the main language to develop the XML Web Services along with ASP.NET Web
forms.

Deliverables

There is a list of deliverables pertaining to this ITAM project at BM InfoTech, NY.

e A working model of the Asset Management Application.

The company should be able to add, update and delete assets. The application should

list all the details pertaining to a particular asset.

e A good documentation explaining the functionality of the system.

In order to facilitate the description of the model, all the screen shots and the source

code are included in the appendix.



2. Requirements Gathering and Plan of Action

This section discusses about:

e The company and the department for which the project was developed

e Significance of the project work

e Business Requirements and application users
Company
The company BM InfoTech is located at New York. It provides resources for the
Fortune 500 Clients specialized in the areas of Client Server Technologies, System
Administration, and ERP applications. The following sections give a brief introduction
to the significance of the project and the Business Requirements that was devised for
development of the project.
Significance of the project
BM InfoTech (www.bminfotech.com) currently has around 75 consultants working on
various projects for clients like Verizon, Sun Microsystems, and Delta Airlines etc. The
company has offices at various places like New York, Sioux Falls, Sioux City, New
Hampshire. The offices have different assets based on the size, operations and
requirements. The company provides laptops for the consultants and also issues
licensed software (CD’s and product manual’s) for the need of cross training or

updating knowledge of the consults on the current technologies. But keeping track of



those assets has always been a major problem for the Consultancy due to the frequent

updates in this process. Thus the project (IT Asset management System) to keep track

of those million dollar assets is highly significant in order to have a high ROI (Return

on Investment).

Business Requirements and Users of the project

The following listed below are the business requirements which were framed for this

project:

>  The accounts Manager must able to identify the current assets of the company in
a time-efficient manner (Ex: What is the total asset of the entire company at any

point of time? Answer: Total Assets: 5 Million)

»  The Company must able to find the depreciation costs each year (Ex: Say each
year Sioux Falls Location’s current assets depreciates by 5 million to 3.8
million)

>  The Company must be able get the value of the assets in a particular location

(Ex: what is the current total asset in Sioux Falls Location? Answer: 1 million)

»  The Company must be able to add assets as on when needed. (Ex: If accounts
department wants to add 10 computers which they have recently purchased.)

>  The Company must be able to delete assets when they are sold or discarded (Ex:

It might be either sold or was thrown away)



The people who would be using the system are:

1. Accounts Manager

2. IT Systems Engineer (For the system maintenance)

The below listed are the current assets of the Company’s Total Assets on various

Locations (varies frequently™*)

1. Laptops — 25

2. Desktops — 50

3. Landline phones — 10

4. Cell phones - 10

5. Licensed Software’s — 50

6. Printers - 25



Table 2-1: Assets in Specific Locations

Location Current Assets
Laptops | Computers | Land Cell Licensed | Printers
phones | phones | software’s
New York 10 20 5 3 30 15
Iowa 10 20 3 1 10 5
South Dakota 5 10 2 | 10 5
Total 25 50 10 5 50 25

(Note: though close to the real Projections, actually these are the sample figures)
The following would be Database Entities of the system:

According to the requirements, the main possible entities are:

a. Assets (Primary Key # Asset ID)

b. Asset Categories (AssetCategory ID)
c. Depreciation (Depreciation ID)

d. Status (Status ID)

e. Maintenance (Maintenance 1D)

f. Departments (Department ID)

g. Employees (Employee ID)



h. Vendors (Vendor ID)
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Fig 2-1: Based on the Business Requirements, the ER Diagram was created for the IT

Asset Management Application



ShowAssetsTable - Microsoft Internet Explorer provided by Schering-Plough
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Fig 2-2. Shown is the screenshot of the web application developed using this ER
diagram. Front-end web application system of AMS (Asset Management

System)



3. Overall Structure
The following was discussed in this section:
e The overall structure of the web application including the .Net Framework.

o Necessary explanation of the technologies to understand the working of the

application.

The .NET Framework Application

e The application to be presented consists of the following sections:

o Microsoft ASP.NET Hittp handler architecture for processing requests

A company request class for controlling authorization checks and HTML

o

rendering
o XSLT documents for XML to HTML transforms
o XML returning stored procedures

The physical database layer, in addition to the (forms) authentication

o

mechanism.
e Unlike the prior ASP applications, Visual Studio Developer is like a RAD tool
and handles the database connection objects and there isn’t much code on the client
side. Also the .Net Environment’s FCL (Foundation Class Libraries) provides many
system classes that handle the input/output and SQL part of the application. The
challenge was on data transformation through XML and XSLT part, which largely

10



reduces the data transaction speed and thereby reducing the network load on the
server. The below section highlights the necessary steps required for building this

transformation.

UML Diagrams

Use Case Diagram

A use case is initiated by a user with a particular goal in mind, and completes
successfully when the goal is satisfied. It can be further defined as a set of
interactions between external actors and the system under consideration. An actor
may be a class of users, roles users can play, or other systems. A primary actor is
one having a goal requiring the assistance system. A secondary actor is one from

which the system needs assistance.

11
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Fig 3-1: UML Use Case Diagram

Use Case Diagram Description

Primary User: Account Manager

Secondary User: IT System Engineer

System was created for the following usage:
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e The System should help to keep track of the assets and able to include all the other

external data in determining it.

Class Diagram

Step 1: Presentation Layer

The driving force behind the application design was the presentation layer. The premise

of the developed solution was to present, using an HTML interface, the Asset Details

information from the Asset database. This supports two types of users, the

administrative user (System IT Engineer) and generic user (Account Manager).

Table 2-2: Presentation flow

Page Description

Companys for Location

Companys for Asset

Company Detail

Asset Listing

Asset Details

Company Summary

Operation

GetCustomersByCountry

GetCompaniesByUser

GetCompanyByld

GetCompanyAsset

GetCompanyAssetDetails

GetCompanySummByld

XML Stored Procedure
Style Sheet

xml_customer_cty

customerlistcty.xslt

xml_customer_user

customerlistuser.xslt

xml_company_id
companyheader.xslt

xml_company_Assets

companyAssets.xslt

xml_asset_details

companyassetdetails.xslt

xml_company_summary

companysummary.xslt

13



The application creates each HTML page through the use of an XML-returning stored
procedure, which is then transformed into HTML using an XSLT document. Table 1
outlines each page, the name of the operation to support the XML retrieval, the name of
the associated XML returning stored procedures, and finally the corresponding XSLT

document from which the HTML is generated.

Step 2: XML Data Layer

As previously stated, the application makes use of SQL Server 2000 XML
functionality, each operation in Table 1 has a corresponding XML-returning stored
procedure. In designing these stored procedures, the structure of the resultant XML
required consideration. Several techniques could be used, as this application
demonstrates. To retrieve XML results directly from the database, the FOR XML
clause of the SELECT statement is used; with one of either three modes RAW, AUTO,
and EXPLICIT.

RAW mode means each row in the resulting XML has the generic row identifier.
AUTO mode returns query results in a simple nested XML tree. Each table in the
FROM clause, listed in the SELECT statement, is represented as an XML element of
the same name. The SELECT columns are then mapped as attributes of the elements.
The hierarchy is determined based on the order of the tables identified by the columns

of the SELECT statement. To structure the XML identifiers column, alias names

14



should be used.

EXPLICIT mode specifies the shape of the XML tree, the query specifying all the
information to produce what is known as a universal tree. This means that the query
must, in addition to specifying the required data, specify all the meta data. Other
important benefits of EXPLICIT mode are that columns can be individually mapped to
either attributes or sub-elements and one can generate sibling hierarchies.

In writing XML queries, one must remember that the XML identifier names are case
sensitive, important when performing the XSLT transforms. In addition within the
XSLT documents we also has to remember to prefix the XML identifiers with @
symbols for attributes.

Step 3: Modifying XML Hierarchy with Views

The first challenge in formulating the XML came when the XML hierarchy required

flattening; information for a single hierarchal layer is derived from more than a single
table. To achieve this, the XML query can use views rather than underlying tables.
The view, being seen as a single table, flattens the resulting XML hierarchy. This was
a requirement for presenting company asset information. In this case, I have to present
the company information, with each company element containing asset information:
SELECT CMP_DETAILS.CMP_ID Companyld, CMP_DETAILS.CMP_NAME

CompanyName, CMP_DETAILS.CMP_DESC CompanyDescription,

15



CMP_DETAILS.CMP_LOCATION CompanyLocation FROM CMP_DETAILS
Company INNER JOIN dbo.view_assets ASSET_DETAILS ON
CMP_DETAILS.CMP_ID = ASSET_DETAILS.CMP_ID WHERE

CMP_DETAILS.CMP_ID = @CMP_ID

FOR XML AUTO, ELEMENTS

The VIEW in the query is simple INNER JOIN query:

SELECT CMP_DETAILS.*, ASSET_DETAILS.*

FROM CMP_DETAILS

INNER JOIN ON ASSET_DETAILS CMP_DETAILS.CMP_ID =

ASSET_DETAILS.CMP_ID

In the generated XML, the view is treated as a single hierarchy; namely

CMP_DETAILS.

Step 4: FOR XML EXPLICIT Queries

For queries requiring a more complex XML structure, the FOR XML EXPLICIT clause
can be used. EXPLICIT mode is used for the company details and asset summary
pages. As stated, the structure of the XML hierarchy is determined by a generated
universal table, thus the use of views are only relevant for query simplification. One of
the main tasks in using EXPLICT mode is ensuring that the Tag and Parent properties
are correctly set. Hence, in this case a UNION ALL is used to return the required
Company and then Asset information. The final ORDER BY is important to correctly

16



relate the assets with the appropriate company. The CAST function is used to ensure
correct data type is returned from the query: numeric rather than a float. As we see,
EXPLICIT mode, although verbose, offer greater flexibility in the generation of the
resulting universal tree. To get a better understanding of this concept of a universal
table, run the previous query without the FOR XML EXPLICIT clause. The output will

be the universal table.

Step 5: Data Access Layer

As in most applications, access to the database is controlled though a data access layer;
the CompanyAssets class. The purpose of this class is to abstract the stored procedure
calls and present XML back to the Hittp application. The chosen return data type is an
XPathDocument, rather than an XmlDocument. The reasons are twofold: The resultant
XML obtained from SQL Server is a document fragment (may not have a root node)
and hence cannot be loaded directly into an XmlDocument, and secondly an

XpathDocument offers the best performance for performing transforms.

Step 6: Obtaining and Returning XML

The structure of each method call with the class is identical: format a SQLCommand

and its parameters, set its active connection, execute the XML reader, and return the

17



constructed XPath document. As only the SQLCommand settings differentiate the data

access method calls, the XML processing is managed by a private method:

private XPathDocument CommandToXPath(SqlCommand assetCom)

// setup the local objects

SqlConnection assetCon = null;

XmlReader xmlReader = null;

XPathDocument xpathDoc = null;

// set base command options

assetCom.CommandType = CommandType.StoredProcedure;

assetCom.CommandTimeout = 15;

// now execute the command

try

// setup the database connection

18



assetCon = new SqlConnection(dbConnectionString);

assetCon.Open();

assetCom.Connection = assetCon;

// execute the command and place into an Xpath document

xmlReader = assetCom.ExecuteXmlReader();

xpathDoc = new XPathDocument(xmlReader, XmlSpace.Preserve);

catch (Exception ex)

throw new ApplicationException

("Cannot Execute SQL Command: " + ex.Message, eX);

finally

// dispose of open objects

19



if (xmlReader != null) xmlReader.Close();

if (assetCon != null) assetCon.Close();

return xpathDoc;

The ExecuteXmlReader method of the SqlCommand class returns an XmlReader

representing the returned XML. This reader is used to construct the XPath document.

Prior to making this method call, the calling method will create a new SqlCommand,

specify which stored procedure to execute, and define the appropriate parameters

collection.

Step 7: Class Methods

As we can again see from Table 1, the class methods correspond 1-to-1 with an
XML-returning stored procedures and a Web application-presenting function. Figure 2
outlines the public and private methods for the CompanyAssets class. The class
methods are all simple get methods, and return an XPath document representation of

the required XML.

20



Table 3-1 : CompanyAssets Class diagram

CompanyAssets

+GetCompanyAssets(): XpathDocument

+GetCompanyByLocation(in Company: string): XpathDocument
+GetCompanyByName(in CompanyName: string): XpathDocument
+GetCompanyByld(in companyID:string): XpathDocument
+GetCompanyAssets(in companyID:string, in assetld: int): XpathDocument
-GetDbConnection(): SqlConnection

-CommandToXPath(in sqlCommand: SqlCommand): XpathDocument

The only work of the class methods is to define the stored procedure and associated

parameters. No authorization checks are performed, that was done in an earlier step.

Consider the method to return the details of the company asset:

public XPathDocument GetCompanyAssetDetails

(string CMP_ID, int AST_ID)

// the command object to return the XML Document Fragment

SglCommand AssetCom = new SqlCommand("xml_asset_details");

// the stored procedure parameters

SqlParameter companyParam = new SqlParameter

("@p_CMP_ID", SqIDbType.NChar, 5);

21



companyParam.Direction = ParameterDirection.Input;

companyParam.Value = CMP_ID;

assetCom.Parameters.Add(companyParam);

SqlParameter assetParam = new SqlParameter(" @asset", SqIDbType.Int);

assetParam.Direction = ParameterDirection.Input;

assetParam.Value = AST_ID;

assetCom.Parameters.Add(assetParam);

// return the XPath document

return CommandToXPath(assetCom);

As we watch the above code, all the XML work is accomplished in the

CommandToXPath method.

22



4. Project Life Cycle

The project life cycle of the IT Asset Management System includes the sub sections

titled planning, analysis, design and execution.

Asset Management System

Planning & Analysis

The company was having a difficult time in maintaining its assets. Asset Management
System would be useful for the Accounts Department and also the company could
increase the ROI (Return on Investment).

UML Design for IT Asset Management System

A good UML design in the planning and the development phase is the backbone and
success for any software project. In .NET, UML has a special emphasis on the standards
and quality of the code involved in the projects. The Class Diagrams was used to

convert the design ideas to the system code for the planning and development phases.

Class Diagram for AMS

Attributes correspond to the variables declared within a class (but not variables
declared within the body of a function or sub procedure).

Derived Attribute

e Types

23



Attribute with enumerated values

e Location

Asset

- /Types = Fixed Assets + Variable Assets

- Location : enum{Sioux Falls, Sioux city, New York}

Derived Code:

Class Asset

private String Types;
private String Location;

private string Asset_Types

return Fixed Assets + Variable Assets;

Visibility
e Public members (attributes or operations) can be referenced directly by any

class in this or any other model package (more on packages later).

24



e Private members can only be referenced in the same class where they’re
declared.
e Protected members can be referenced in the same class or in any descendants
of that class (more on inheritance later).
e Any classes in the same UML package can reference package scope members
only.
Operations correspond to functions or sub procedures in C#.
For eg: public void walk(CompassBearing direction, float distance) + serialize(inout

pBag : PropertyBag)

Asset

- Total Value
+Location : String = Sioux City

+Asset_Types

+Add(Asset: Single)
-Update(Asset: Single)
-Delete(Asset: Single)

Class Asset

Class Asset

25



Public types;

Private Asset Value;
}
Class Asset
{

Private float value = 0;

Public string Location;

Public string Type;

Public Void AddAsset(String Type)

AddAsset()

private static int numberOfAsset = 0;

private string Type;

private Asset(string Type)

this. Type = Type;

26



numberOfAsset++;

public static Person createAsset(string Type)

return new Asset(Type);

public string getType()

return this.Type;

public static int getNumberOfAsset()

return numberOfAsset;

Dependencies — C#

To show that the 2 classes are related to each other, the DataAccessObject uses the

System.Data.SqlClient.SqlDataReader class.

27



DataAccessObject

AssetDAO

+ find(id : int) : Asset

a

W

System::Data::SqlClient::SglDataReader

public Customer find(int id)

{
SqlConnection ¢n = new SqlConnection(CONNECT_STRING);

cn.Open();

SqlCommand cmd =

new SqlCommand("SELECT * FROM Customers WHERE id = *
+ id.ToString(), cn);

SglDataReader reader = cmd.ExecuteReader();

Customer c;
while (reader.Read())

{

¢ = new Customer(reader.GetInt32(0), reader.GetString(1));

}
cn.Close();

return c; }

The above code conversions are to show how UML is necessary for the deployment of
the System. Other UML diagrams could be used as well to describe the functional

actions in detail.

Implementation

28



The design of the application was based on the business requirements, database design,

technologies used for the application, implementation methodologies used for coding,

Xml-Html transformations. All these different sections were handled during the

implementation phase of the project. The coding was done using the IDE and a RAD

Tool Visual Studio .Net 2003. Unlike ASP, Web controls and the Code behind files of

this VS tool assists the development work a lot. The Web.Config handles the

configurations of the IIS server and other IP settings for the mail server etc. Finally the

company assets could now be maintained in an efficient way. Since the application is

built on the .Net Framework, it could use the future enhancements like the .Net Mobile

application Framework.

5. Future Work and Enhancements
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The application was earlier planned to have a number of additional features. In addition
to storing basic information about each asset, the repository can include data integrated
from a number of sources to provide updated inventory information, purchasing details,
and financial costs, as well as support and maintenance contract details. Also the
application could be enhanced to track the assets in terms of the employee, vendors etc.,
by having a separate project under the solution. So, for example if a consultant borrows
or holds a particular asset and after a certain time frame he would be sent an email
asked to return the asset (say a Laptop) back to the accounts department or to get their
permission. So, future enhancements would be like calculating the depreciation costs
for a particular asset, maintaining of the license agreements and the level of priority
given to that particular asset as well.

Similarly I need to include the date in the employee table to identify when the asset was

taken the employee in order to track efficiently.
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6. Summary and Conclusions
Thus the benefits of the organization with the help of the ITAM system include:

e Accurate hardware, software license, and configuration information for
purchasing decisions, and IT projects.

e Identification and subsequent redeployment, exchange, or credit for software
licenses and hardware.

e Reduced risk of noncompliance with software licensing restrictions.

e Service contract quantities based on hard data can be compared with the vendor’s
estimate and used as the basis for successful vendor negotiations, resulting in
savings.

e Reduction of unplanned expenses, such as lease and rental penalties for the late
return of equipment.

e Availability of IT asset information to the service desk and technical support
organizations.

e Reduction of administrative costs through the adoption of process-based roles and
responsibilities and enabling technology.

This report has shown the application that was developed in BM InfoTech. The report
also includes XML Web Service in general and the building blocks of any XML Web

Service: SOAP, WSDL, and UDDI under Appendix C. Finally it shows how to build
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an XML Web Service in .NET Environment. The Web Service attributes, which is

placed in top of the class, is an optional attributes that can have the service name and

description. The lessons learnt while implementing the system include the Web based

Client which involves more programming than the console based as we are using

ASPNET Web Components. While building the Web based client user friendliness

factor was considered by giving the user better control over the transformed XML

document. Also proper planning and execution of the project according to the plan is

very important ie. Project Management plays an important role. Keeping a good focus

on the sequence of the project would help the completion of project on time. It was a

nice experience trying to enforce the business concepts in the technical environment.
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Appendix A Screen Shots

The below screenshots will walkthrough the application with an example. Also the sample

.screenshots of the application includes the database and the client side interactions.

;m SQL Server Enterprise Manager - [Console Root'Microsoft 501 Servers)

1%

1 Console Root
) icrosoft SQL Servers

24 50 server Growp 05/01/2005 08:38:48 AM

g % (local) (Windows NT) Departments 05/01/2005 08:38:48 AM
] Databases Depreciation dbo User (05/01/2005 08:38:49 AM

i poset 1B deproperties dho System 05012005 09:03:57 AM

3 Diagrars [ enployees tho User 051012005 08:38:50 AM

: B Maintenance dbo User (501/2005 08:38:50 AM

-6 Vews = status dbo User 051012005 08:38:50 AM

Y Stored Procedires Switchboard tems dho User 05/01/2005 08:38:50 AM

ii g:le: ] syscolumns dbo System 08/06/2000 01:29:12 AM

"] Ruls i syscomments dbo System (8/06{2000 01:29:12 AM

L2 Defaults ] sysdepends dbo System (18/06{2000 01:29:12 AM

User Defined Data Types sysfilegroups dbo System (18/06/2000 01:29:12 AM

g'; ser Defined Functions E]sysﬁles dbo System 03J06{2000 01:20:12 AM

4 master (22] sysfilest dbo System 0/06/2000 01:29:12 AM

¢ | sysforeignkeys dbo System 08/06/2000 01:29:12 AM

= sysfultextcatalogs dho System 08/06/2000 01:29:12 AM

sysfulltextnotify dho System (18/06/2000 01:29:12 AM

B sysindexes dbo System (18/06/2000 01:29:12 AM
-4 tempdb = sysindexkeys dho System 08/06/2000 01:29:12 AM
i {1 Data Transformation Services sysmenbers dho System 08/06/2000 01:29:12 AM
(] Managenent Hsysobjects tho System 08J06/2000 01:29:12 AM
Ll Replcaton ) syspernissions do Stem OB06/200001:2%:12 Al
] Securty ) sysproperties dbo System 08/06/2000 01:29:12 AM
5 :qi'i?{;if:;:::zes ] sysprotects dho System OB/06/200001:20:12 AM

(%] sysreferences dho System 08/06/2000 01:29:12 AM

systypes dbo System (18/06/2000 01:29:12 &M

SUSEs dho System (8/06/2000 01:29:12 AM

2] Vendors dbo User (15/01/2005 08:38:51 AM

Fig A-1: Shows the Asset database and its tables.
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# SOL Query Analyzer

~-select * from agsets;

2| dbo Assets
2l dbo.Departments
| dbo Depreciation
+| dho.diproperties
5| dbo Employees
3| dboMaintenance

s dho.syscomments
] dbo.sysdepends
ba.sysfilegroups

4] dbo.sysfiles

5| dho.sysfles! -

=] cho sysforeignkeys : S . ‘ .

%] dho sysfultestcatalogs Personal Computer 2 J 1
3| dbo.sysfulltestnotity Personal Computer 5 2 1 5 2

ﬁ dEosysmjexes Desktop Laser Printer 1 3 il 4 5

o dnnit Desktop Laser Printer 3 3 1 1 2
bho.sysmembes

£ dho.sysabiects
:‘j dba. syspelmissmns

; PR C] Vews
D O Stored Procedures

Fig A-2: Shows the values of the ‘Assets’ Table details
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IT Asset Management System
| @BM Infotech, NY |

malntenance { status 1 vendors

asset categories } assels 1 departments | depreciation ] employens

& Computer
I Pringer

4 Laptop

Copyright @ 2005 AMS, BN Infatech, All rights rezerved,

Fig A-3: Shows all the values of the Asset Categories table.
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. % http:fflocalhostMyApp2}Asset %20Cateqories/AddA:
Type search term(s) here 'v(\ P searh 5 :‘j

IT Asset Management System
@BM Infotech, NY

oassets | departments | depreciation g employees i maintenance {swms i vendors |

asset categories

s

| Asset(atagory ID 16

ksset Category IT Security Application

Save  Cancel

Copyright @ 2005 AMS, BM Infotach, All rights reserved,

Fig A-3: Adding a new asset category ‘IT Security Application’ in the Asset

Categories table
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IT Asset Management

@BM Infotech, NY

§assetcate ories | assels | departments ’ depreciation | emplovess | maintenance | staus | venders
| g i

Search for Go

#sset Lategory 1D 1AI| #;

Asset Category I,,A" B vi

1 Softuare

2

Computar

w3

Printer

4 Lagbop

P

Coplat

& IT Ssourity Application

Copyright @ 2003 AMS, BM Infotech, All rights resered,

53] 317 s el

Fig A-5: Shows the ‘asset categories’ Table values after adding the new asset ‘IT

Security Application’.
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ShowdssetsTable - Microsoft Internet Explorer provided by Schering-Plough

T

Assets/ShowhssetsTable.aspx

o Pwemd )0

IT Asset Management System
| ~ (@BM Infotech, NY

asset categorins E assets I deparinents } deprociation { pmployses I maintenance ] status ] vendars ‘

e ne W P

Search for

Asset ID |2 *:i
Asset Description ]A" *f

2 Parsonal ! 51 6465531

Computar

Copyright © 2005 AMS, 88 Infotech, All rights resarved,

Fig A-6: Can see the value with a particular Asset ID. The value shown is for
Asset ID =2
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b ShowAssetsTable - Microsoft Internet Explorer provided by Schering-Plough

IT Asset Management System
@BM Infotech, NY

asset categories I assets % deparbnents [ depreciation { employess i naintenance I status I yepdors

Search for

All »

Asset 1D

Personal
Computar

2 Parsonal § 2 i 5 2 LPL4geT 6465581
3 1 3 1 4 g 560¢ 454632452-2
4 3 3 i 1 z ALW4 4554544-3

Copyright @ 2005 AMS, BM Infotzch, All rights ressrved,

Fig A-7: Shows the Asset Table values
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3 ShowDepartmentsTable - Micrasoft Internet Euplorer provided by Schering-Plough

@ http:HIuc@hqsthy@ppiqu;_rtmntsiShwnDepartmentsIable.a_sp

Tyﬁe iarcﬁ Eerm(s) Hae @ A5

IT Asset Management System
~ @BM Infotech, NY

asset categorieg i assals E departments % depraciation { sinployees I maintenance ‘ status i gedors |

Search for 3 Go

Department 1D W
Departmant Name i_A” R 'i

Copyright @ 2005 AMS, BM Infatech, All rights resened,

Fig A-8: Shows the Current Values of the ‘Departments’ table
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% AddbepartmentsRecord - Microsoft Internet Explorer provided Iy Schering-Plough

IT Asset Management System
@BM Infotech, NY

depariments | depreciation I amploypes ‘ maistenance

stats | vendors |

: i R ‘W» i ‘. :
Department ID |6 l
|

Department Name ﬂ-"ackaging

- Department Number 4567 T

Copyright @ 2005 AMS, BM Infatech, All rights raserved,

Fig A-9: Shows adding a new department ‘Packaging’
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ShowDepartmentsTable - Microsoft Internet Explorer provided by Schering-Plough

locahostMyApp2{Departments/ShowDe

For | Type search term(

IT Asset Management System
@BM Infotech, NY

assetcategaries | assets | departments § depreciation S smployees | maintenance { status f vendors

Search for

Depariment ID iAII «]
Department Name iAII §§

2 Program Managemant 4000
3 ‘ Developmart 3393
& Sales 5934
§ 8347
3 7

Copyright @ 2005 AMS, BM Infotech, All rights reserved.

Fig A-10: Shows the added department ‘Packaging’
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e @ ht Ubga!_hostiMyAppZIDgpartrnents!anwDepartmentsTable7aspx?rpv=p

\ Tyﬁe ;eargh term{s)here . ‘

IT Asset Management System
@BM Infotech, NY

emplayess i maintenance } status } vendors |

E'asgsz categories | assels { departments | depreciation

v
H

%

Department ID {All 1

Department Name IA" vi

& Packsging 43567

Copyright © 2005 AMS, B8 Infatach, All rights reserved.

Fig A-11: Can search for a particular department ‘Packaging’
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2]t ocehostMypo2 Depre
Search o | Type search term

IT Asset Management System
@BM Infotech, NY

| asset categories ‘ assets E departments t depreciation I enmployees ‘ maintenance [ status l yendors ]

Z 1 2/28f2002 5.4&!30

....... 1 3f31/2002 $40.00
4 - Z 2/289’1.‘1}0?: ‘ £50.00
5 KRR TH Y] $80,00
3 d £7.00
7 §7.00
g 3 $7.60

Copyright @ 2005 AMS, 84 Infatech, All rights resanved.

Fig A-12: Shows all the values of the Depreciation Tables
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IT Asset Management System _
@BM Infotech, NY

departments { depraciation } pmployess F maintenance § statss I yendars

asset pategories i ansels

Employee (D

e o
]
Social Security Number
|
|
|
|
|

£mployae Number

First Name

Last Name

Title

Email Nama

Hioma Phona
Yok Phone
Office Location

fave

Copyright © 2005 AMS, &M Infotech. All rights reserved,

Fig A- 13: Adding a new employee to the Employees Table
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3 AddemployeesRecord - Microsoft Internet Explorer provided by Scheting-Plough

Type search term(s) here

IT Asset Management System
@BM Infotech, NY

asset categories 1 assets ‘ departments 1 depreciation i employess S maintenance l status g vendsrs

o
|
i

o

Erployes 1D |12

Social Security Number 1437899034

Employes Number ES

Fiest Nama fPrabhu

Last Name iSundaram

Tile [Web Developer

Email Name Iprabhu.sundaram@spcorp.com

Home Phone 732 232 2323

Work Phone |67 232 2323

fiffice Location New Jersey|

CSave  Cancel

Copyright © 2005 AMS, BM Infotach, All rights raserved,

POl ER A

Fig A- 14: Adding an employee named ‘Prabhu’
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& SOL Query Analyzer

Biowser

* . " Query - HBLHFLQ .AssetS‘zpsundara-UnﬁitIedl‘
HBLHFLO3HO1(US \psundara) e . : i

elect * from employees where EmployeelD=12f

{ dbo Maintenance
2] dbo Status

dbo Vendors

{173 System Tables

dbo.syscolumns

dbo.syscomments

dbio.sysdepends

dbo.sysfilegroups

dbo.sysfles

dbo.sysfiles!

‘ dho.sysforeigrkeys

- @ doospsfullestcatalogs

53 dbo.syshullestnatiy

= dbo.sysindenes

dbo.sysindeskeys

dho.sysmembers

Sundaram Web Developer prabhu.s

1437899034 Prabhu

dbo.syspermissions
’+7 dbo.syspioperties
: # & dbo.spsprotects

5 ] dbo.sysreferences
; Z dbo.systypes
- dbosysusers
-1 Views
{2 Stored Procedures

Fig A-15: Retrieving the Record from the database for EmployeelD ‘12’
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howMaintenanceTable - Microsoft Internet Explorer provided by Schering-Plough

IT Asset Management System |
. (@BM Infotech, NY

asset categories l assels I departments f depreciation l smployees E maintenance i status 1 yendars

Search for | b0

Maintenance ID lAII v ;
Asset 1D !All v‘f

1i 1 132002 Annual Maintenance Technidian $100.00

21 1222002 Ungxpactad Regair Technizian $125.00

Copyright @ 2005 AMS, B Infotech, All rights reserved.

Fig A- 16: Showing the records of the Maintenance table
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Qs

18t fcshos e

ype search term

IT Asset Management System

@BM Infotech, NY

assel categeries I assels } depariments ! depreciation ] amployass i maintenance i status | vendars

=

Status 1D [Al 3]
status [Al |

Search for

Copytight @ 2005 AMS, BM Infotech, All rights rasened,

Fig A- 17: Showing the records of the Status table
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Show¥endorsTable - Microsoft Internet Explorer pravided by Schering-Plongh

Type search terms) here v

IT Asset Management System
@BM Infotech, NY

emplayess { maintenance 1 status E vendors

asset categories } assats 1 departments E depreciation 1

Searchfor |

Yendor ID IAII vi
Yendor Name IA" g:‘

1 A Daturn | Susan Burk Order

i My Lauisiana
Corporation Adrministrator 6783 Orleans
2 Fabrikam, il o Masray Sales 6135550138 1§
Ing, i Regresentative
3 Sharon pend
4 Trey Adina Hagegs 71
Research

Fig A-18: Showing the records of the Vendors table
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% showvendorsTable - Microsoft Internet Explorer provided by Schering-Plough

Qe

@‘ht_tp; flocaho: UWAppZNendqrsfSlwwVendorsTabIe 3

hifor | Tyee search terms) r

IT Asset Management System
~ (@BM Infotech, NY

asset categaries 1 assets l departments I depreciation i smployess | maintenance l shatus 1 vendors I

£ Fay Number @

8133550149 :

Iurray

America

Copyright @ 2003 AMS, BM Infotech, All rights reserved,

Fig A-19: Showing the records of the Vendors table throhgh ‘Vendor ID’
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IT Asset Management System

@BM Infotech, NY

asset categories I agsels 1 depariments Ldepreciatiea l employess 1 maintenance l status } vendors

Seavch for
Yendor ID Iﬂ” 3*!

Unitad

7475

4 Trey
Research ¢
Agant

Copyright ® 2005 AMS, B Infotech. All rights reserved,

ok

Fig A-20: Showing the records of the Vendors table through ‘Vendor Name’
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Appendix B Program Codes

Program # 1
Name: AddAsset.cs (C# Code for adding assets to the database)

using System;

using System.Collections;

using System.Configuration;

using System.Data;

using System.Drawing;

using System.Web;

using System.Web.UI,;

using System.Web.ULHtmlControls;
using System.Web.UL. WebControls;

namespace MyApp2

{
public AddAssetsRecordGen()

{
base.Init += new System.EventHandler(this.Page_Init);

base.Load += new System.EventHandler(this.Page_ILoad);

private void Page_Load(object sender, System.EventArgs e)
{
if (!this.IsPostBack)

{
this.DataBind();

}

// web control variable properties code
}
}
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Program # 2
Name: AddAssets.aspx (ASP.NET Code for Adding Assets)

<% @ Register Tagprefix="MyApp2" TagName="Button"
Src="../Shared/Button.ascx" %>

<% @ Register Tagprefix="MyApp2" TagName="Menu" Src="../Menu
Panels/Menu.ascx" %>

<% @ Register Tagprefix="MyApp2" TagName="Footer" Src="../Header &
Footer/Footer.ascx" %>

<% @ Register Tagprefix="Panel"
Namespace="MyApp2.PanelControls.AddAssetsRecord" Assembly="MyApp2" %>
<% @ Register Tagprefix="Custom" Namespace="MyApp2" Assembly="MyApp2"
o>

<% @ Page Language="cs" AutoEventWireup="false"
Codebehind="AddAssetsRecord.gen.aspx.cs" Inherits="MyApp2.AddAssetsRecord"
o>

<% @ Register Tagprefix="MyApp2" TagName="Header" Src="../Header &

Footer/Header.ascx" %>

<HTML id="Html1" runat="server">
<HEAD id="Headl" runat="server">
<title>AddAssetsRecord</title>
<meta name='GENERATOR' content="Microsoft Visual Studio.NET 7.0">
<meta name='CODE_LANGUAGE' content='Visual Basic 7.0">
<meta name='"vs_defaultClientScript' content="JavaScript">
<meta name='vs_targetSchema'
content="http://schemas.microsoft.com/intellisense/ie5">
</HEAD>
<body id="Body1" runat="server" bottomMargin='0" leftMargin='0" topMargin='0'
rightMargin='0">
<form id="Form1' method='post' runat="server'>
<BaseClasses:BasePageSettings id="PageSettings" runat="server"
></BaseClasses:BasePageSettings>
<link rel="stylesheet" rev="stylesheet" type="text/css" href="../Styles/Style.css">
<table cellspacing="0" cellpadding="0" border="0" class="pageBackground">
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<tr>
<td class="pageAlignment">
<table cellspacing="0" cellpadding="0" border="0" class="borderTable">
<tr>
<td class="pageBorderTL"><img src="../Images/space.gif" height="1" width="1"
alt=""></td>
<td class="pageBorderT"><img src="../Images/space.gif" height="1" width="1"
alt=""></td>
<td class="pageBorderTR"><img src="../Images/space.gif" height="1"
width="1" alt=""></td>
</tr>
<tr>
<td class="pageBorderL"><img src="../Images/space.gif" height="1" width="1"
alt=""></td>
<td class="pageBorderC">
<table cellspacing="0" cellpadding="0" border="0" class="master_table">

<tr>
<td>
<table cellspacing="0" cellpadding="0" border="0" width="100%">
<tr>
<td>

<MyApp2:Header runat="server" id="V_Header">
</MyApp2:Header>
</td>
</tr>
</table>
<table cellspacing="0" cellpadding="0" border="0" class="master_table">
<tr>
<td>
</td>
<td>
<MyApp2:Menu runat="server" id="V_Menu">
</MyApp2:Menu>
</td>
</tr>
<tr>
<td>
</td>
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<td>
<table cellspacing="0" cellpadding="0" border="0"

class="master_table">

<tr>

<td class="page_yellow">

<Panel:CustomRecordControl runat="server"

id="V_AssetsRecord" TableName="MyApp2.AssetsAccess, MyApp2"
Virtualld="Assets">

<!-- Begin Record Panel.html -->

<%=
SystemUtils.GenerateEnterKeyCaptureBeginTag(FindControl("V_CancelButton:V_B
utton")) %>
<%=
SystemUtils.GenerateEnterKeyCaptureBeginTag(FindControl("V_OKButton:V_Butt
on")) %>
<%o=
SystemUTtils.GenerateEnterKeyCaptureBeginTag(FindControl("V_SaveButton:V_But
ton")) %>
<table class="dialog_view" cellpadding="0" cellspacing="0" border="0">
<tr>
<td class="dialog_header">
<table cellpadding="0" cellspacing="0" width="100%" border="0">
<tr>
<td class="dialogHeaderEdgeL"><img src="../Images/space.gif"></td>
<td class="dialogHeaderlcon"><BaseClasses:Image

ImageUrl="../Images/icon_edit.gif" runat="server" id="V_AssetsDialoglcon">

</BaseClasses:Image></td>
<td class="dialog_header_text" valign="middle">
<BaseClasses:Literal runat="server" id="V_AssetsDialogTitle" Text="Add
Assets" HtmlEncodeWhiteSpace="True">
</BaseClasses:Literal>
</td>
<td class="dialogHeaderEdgeR "><img src="../Images/space.gif"></td>
</tr>
</table>
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</td>
</tr>
<tr>
<td>
<table cellpadding="0" cellspacing="0" border="0" width="100%">
<tr>
<td class="dialog_body">
<table cellpadding="0" cellspacing="3" border="0">

<tr>
<td class="field_label on_side">
<BaseClasses:Literal runat="server" id="V_AssetIDLabel" Text="Asset ID">
</BaseClasses:Literal>
</td>
<td class="dialog_field_value">
<BaseClasses:FieldValueTextBox runat="server" id="V_AssetID"
Field="Assets_.AssetID" Columns="14" CssClass="field_input">

</BaseClasses:FieldValueTextBox>&nbsp;<BaseClasses:RequiredFieldValid
ator runat="server" id="V_AssetIDRequiredField Validator"
ControlToValidate="V_AssetID" Enabled="True" ErrorMessage="AssetID is
required." Text="*"> </BaseClasses:RequiredFieldValidator>
<BaseClasses: TextBoxMaxLengthValidator runat="server"
id="V_AssetIDTextBoxMaxLengthValidator" Visible="False"
ControlToValidate="V_AssetID" ErrorMessage="The Asset ID value is too long.">
</BaseClasses: TextBoxMaxLengthValidator>
<BaseClasses:FieldValueValidator runat="server"
id="V_AssetIDFieldValueValidator" ControlToValidate="V_AssetID"
ErrorMessage="The Asset ID value you entered is invalid. It may be invalid for a
number of reasons. You may have entered a value that is longer than what is allowed,
the value may contain invalid characters or the value might be out of range of allowed
values. Please review the value and correct it and submit the changes again.">
</BaseClasses:FieldValueValidator>
<BaseClasses:RecordControlCustomValidator runat="server"
id="V_AssetIDRecordControlCustomValidator" ControlToValidate="V_AssetID"
Enabled="False" Visible="False" ErrorMessage="The Asset ID value you entered is
invalid. It may be invalid for a number of reasons. You may have entered a value

that is longer than what is allowed, the value may contain invalid characters or the
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value might be out of range of allowed values. Please review the value and correct it
and submit the changes again.">
</BaseClasses:RecordControlCustomValidator>
<BaseClasses:CustomValidator runat="server"
id="V_AssetIDCustomValidator" ControlToValidate="V_AssetID" Enabled="False"
Visible="False" ErrorMessage="The Asset ID value you entered is invalid. It may be
invalid for a number of reasons. You may have entered a value that is longer than
what is allowed, the value may contain invalid characters or the value might be out of
range of allowed values. Please review the value and correct it and submit the
changes again."> </BaseClasses:CustomValidator>
</td>
</tr>
<tr>
<td class="field_label_on_side">
<BaseClasses:Literal runat="server" id="V_AssetDescriptionLabel"
Text="Asset Description">
</BaseClasses:Literal>
</td>
<td class="dialog_field_value">
<BaseClasses:FieldValueTextBox runat="server" id="V_AssetDescription"
Field="Assets_.AssetDescription" Columns="60" CssClass="field_input" Rows="5"
TextMode="MultiLine">
</BaseClasses:FieldValueTextBox>&nbsp;
<BaseClasses:RequiredFieldValidator runat="server"
id="V_AssetDescriptionRequiredFieldValidator"
ControlToValidate="V_AssetDescription" ErrorMessage="A value for Asset
Description is required." Enabled="False">
</BaseClasses:RequiredFieldValidator>
<BaseClasses: TextBoxMaxLengthValidator runat="server"
id="V_AssetDescriptionTextBoxMaxLengthValidator"
ControlToValidate="V_AssetDescription" ErrorMessage="The Asset Description
value is too long."> </BaseClasses: TextBoxMaxLengthValidator>
<BaseClasses:FieldValue Validator runat="server"
id="V_AssetDescriptionFieldValue Validator"
ControlToValidate="V_AssetDescription" ErrorMessage="The Asset Description
value you entered is invalid. It may be invalid for a number of reasons. You may
have entered a value that is longer than what is allowed, the value may contain invalid

characters or the value might be out of range of allowed values. Please review the
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value and correct it and submit the changes again.">
</BaseClasses:FieldValueValidator>
<BaseClasses:RecordControlCustomValidator runat="server"
id="V_AssetDescriptionRecordControlCustomValidator"
ControlToValidate="V_AssetDescription" Enabled="False" Visible="False"
ErrorMessage="The Asset Description value you entered is invalid. It may be invalid
for a number of reasons. You may have entered a value that is longer than what is
allowed, the value may contain invalid characters or the value might be out of range
of allowed values. Please review the value and correct it and submit the changes
again."> </BaseClasses:RecordControlCustomValidator>
<BaseClasses:CustomValidator runat="server"
id="V_AssetDescriptionCustomValidator" ControlToValidate="V_AssetDescription"
Enabled="False" Visible="False" ErrorMessage="The Asset Description value you
entered is invalid. It may be invalid for a number of reasons. You may have entered
a value that is longer than what is allowed, the value may contain invalid characters or
the value might be out of range of allowed values. Please review the value and
correct it and submit the changes again.">
</BaseClasses:CustomValidator>
</td>
</tr>
</table>
<BaseClasses: ValidationSummary id="ValidationSummary1"

runat="server"></BaseClasses: ValidationSummary>

</form>

</body>

</HTML>
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Program #3
Name: Asset.xml (XML Code for generating Assets Table)

<?xml version="1.0" encoding="UTF-8" standalone="no" 7>
- <ComponentDefinition xmlns:xsd="http://www.w3.0org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- <Selt>
<Name>AddAsset_CategoriesRecord</Name>
<Type>Page</Type>
<GenerateDirectory>Asset Categories</GenerateDirectory>
<Layout>Asset Categories\AddAsset_CategoriesRecord.html</Layout>
<DisplayName>AddAsset_CategoriesRecord</DisplayName>
<Description>Standard record panel.</Description>
<CheckSum>659939543-5608</CheckSum>
</Self>
= <ComposedOf>
- <ContainedComponent>
<Name>Asset_CategoriesDialoglcon</Name>
<Type>Image</Type>
<ImageUrl>../Images/icon_edit.gif</ImageUrl>
</ContainedComponent>
- <ContainedComponent>
<Name>Asset_CategoriesDialogTitle</Name>
<Type>Html</Type>
= <PassthroughAttributes>
= <Attribute>
<Name>HtmlEncodeWhiteSpace</Name>
<Value>True</Value>
</Attribute>
= <Attribute>
<Name>Text</Name>
<Value>Add Asset Categories</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>Asset_CategoriesRecord</Name>

<Type>Record</Type>
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<Table>Asset Categories</Table>
- <PassthroughAttributes>
= <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>AddRecord</Value>
</Attribute>
= <Attribute>
<Name>Virtualld</Name>
<Value>0</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>AssetCategory</Name>
<Type>FieldValue</Type>
<Field>AssetCategory</Field>
<FieldValueStyle>TextBox</FieldValueStyle>
<Table>Asset Categories</Table>
- <PassthroughAttributes>
- <Attribute>
<Name>CssClass</Name>
<Value>field_input</Value>
</Attribute>
- <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>Parent</Value>
</Attribute>

- <Attribute>

<Name>V_AssetCategoryRequiredFieldValidator:
Enabled</Name>
<Value>False</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>AssetCategorylD</Name>

<Type>FieldValue</Type>



<Field>AssetCategoryID</Field>
<FieldValueStyle>TextBox</FieldValueStyle>
<Table>Asset Categories</Table>
- <PassthroughAttributes>
- <Attribute>
<Name>CssClass</Name>
<Value>field_input</Value>
</Attribute>
- <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>Parent</Value>
</Attribute>

= <Attribute>

<Name>V_AssetCategorylDRequiredFieldValidato
r:Enabled</Name>
<Value>True</Value>
</Attribute>

= <Attribute>

<Name>V_AssetCategoryIDRequiredFieldValidato
r:ErrorMessage</Name>
<Value>AssetCategorylD is required.</Value>
</Attribute>

= <Attribute>

<Name>V_AssetCategoryIDRequiredField Validato
r:Text</Name>
<Value>*</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>AssetCategorylDLabel</Name>
<Type>Literal</Type>
= <PassthroughAttributes>
= <Attribute>

<Name>InternalUse:Field</Name>
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<Value>AssetCategoryID</Value>
</Attribute>
- <Attribute>
<Name>InternalUse:Table</Name>
<Value>Asset Categories</Value>
</Attribute>
= <Attribute>
<Name>Text</Name>
<Value>%ISD_DEFAULT % Asset
Categories % AssetCategorylD</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>AssetCategoryLabel</Name>
<Type>Literal</Type>
= <PassthroughAttributes>
- <Attribute>
<Name>InternalUse:Field</Name>
<Value>AssetCategory</Value>
</Attribute>
= <Attribute>
<Name>InternalUse:Table</Name>
<Value>Asset Categories</Value>
</Attribute>
- <Attribute>
<Name>Text</Name>
<Value>%ISD_DEFAULT % Asset
Categories % AssetCategory</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>CancelButton</Name>
<Type>Button</Type>
<Layout>..\Shared\Button.html</Layout>
= <PassthroughAttributes>

- <Attribute>



<Name>P_Button-CausesValidation</Name>
<Value>False</Value>
</Attribute>
= <Attribute>
<Name>P_Button-RedirectURL</Name>
<Value>Back</Value>
</Attribute>
- <Attribute>
<Name>P_Button-Text</Name>
<Value>Btn: Cancel</Value>
<Type>ResourceReference</Type>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>Footer</Name>
<Type>Footer</Type>
<Layout>..\Header & Footer\Footer.html</Layout>
</ContainedComponent>
- <ContainedComponent>
<Name>Header</Name>
<Type>Header</Type>
<Layout>..\Header & Footer\Header.html</Layout>
</ContainedComponent>
= <ContainedComponent>
<Name>Menu</Name>
<Type>Menu</Type>
<Layout>..\Menu Panels\Menu.html</Layout>
</ContainedComponent>
= <ContainedComponent>
<Name>SaveButton</Name>
<Type>Button</Type>
<Layout>..\Shared\Button.html</Layout>
- <PassthroughAttributes>
= <Attribute>
<Name>P_Button-CausesValidation</Name>
<Value>True</Value>

</Attribute>
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= <Attribute>
<Name>P_Button-CommandName</Name>
<Value>UpdateData</Value>
</Attribute>
- <Attribute>
<Name>P_Button-Consumers</Name>
<Value>page</Value>
</Attribute>
= <Attribute>
<Name>P_Button-RedirectArgument</Name>
<Value>updatedata</Value>
</Attribute>
- <Attribute>
<Name>P_Button-RedirectURL</Name>
<Value>Back</Value>
</Attribute>
- <Attribute>
<Name>P_Button-Text</Name>
<Value>Btn:Save</Value>
<Type>ResourceReference</Type>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
</ComposedOf>

</ComponentDefinition>
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Program # 4
Name: Departments.xml (XML Data Access for the Departments)

<?xml version="1.0" encoding="UTF-8" standalone="no" 7>
= = <ColumnDefinition>
= <Column InternalName="0" Priority="1" ColumnNum="0">
<columnName>DepartmentID</columnName>
<columnUIName>%ISD_DEFAULT %</columnUIName>
<columnType>Number</columnType>
<columnDBType>int</columnDBType>
<columnLengthSet>10.0</columnLengthSet>
<columnDefault />
<columnDBDefault />
<columnIndex>N</columnIndex>
<columnUnique>N</columnUnique>
<columnFunction />
<columnDBFormat />
<columnPK>N</columnPK>
<columnPermanent>N</columnPermanent>
<columnComputed>N</columnComputed>
<columnldentity>N</columnldentity>
<columnReadOnly>N</columnReadOnly>
<columnRequired>Y</columnRequired>

<columnNotNull>Y</columnNotNull>

<columnVisibleWidth>%ISD _DEFAULT %</columnVisibleW
idth>
<columnTableAliasName />
</Column>
= <Column InternalName="1" Priority="2" ColumnNum="1">
<columnName>DepartmentName</columnName>
<columnUIName>%ISD DEFAULT %</columnUIName>
<columnType>String</columnType>
<columnDBType>nvarchar</columnDBType>
<columnLengthSet>50</columnLengthSet>
<columnDefault />

<columnDBDefault />
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<columnIndex>N</columnIndex>
<columnUnique>N</columnUnique>
<columnFunction />

<columnDBFormat />
<columnPK>N</columnPK>
<columnPermanent>N</columnPermanent>
<columnComputed>N</columnComputed>
<columnldentity>N</columnIdentity>
<columnReadOnly>N</columnReadOnly>
<columnRequired>N</columnRequired>

<columnNotNull>N</columnNotNull>

<columnVisibleWidth>%ISD_DEFAULT %</columnVisibleWidth
<columnTableAliasName />
</Column>
- <Column InternalName="2" Priority="3" ColumnNum="2">
<columnName>DepartmentNumber</columnName>
<columnUIName>%ISD_DEFAULT %</columnUIName>
<columnType>Number</columnType>
<columnDBType>int</columnDBType>
<columnLengthSet>10.0</columnLengthSet>
<columnDefault />
<columnDBDetault />
<columnIndex>N</columnIndex>
<columnUnique>N</columnUnique>
<columnFunction />
<columnDBFormat />
<columnPK>N</columnPK>
<columnPermanent>N</columnPermanent>
<columnComputed>N</columnComputed>
<columnldentity>N</columnldentity>
<columnReadOnly>N</columnReadOnly>
<columnRequired>N</columnRequired>

<columnNotNull>N</columnNotNull>
<columnVisibleWidth>%ISD DEFAULT %</columnVisibleW

idth>

<columnTableAliasName />
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</Column>
</ColumnDefinition>
<TableName>Departments</TableName>
<Version>1</Version>
<Owner />
<TableCodeName>Departments</TableCodeName>
<TableAliasName>Departments_</TableAliasName>
<ConnectionName>DatabaseAsset1</ConnectionName>
<canCreateRecords Source="Database">Y</canCreateRecords>
<canEditRecords Source="Database">N</canEditRecords>
<canDeleteRecords Source="Database">N</canDeleteRecords>
<canViewRecords Source="Database">N</canViewRecords>
<AppShortName>MyApp2</AppShortName>
<TableStoredProcPrefix>pMyApp2Departments</TableStoredProcPrefix>
</XMLDefinition>
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Program # 5

Name: Departments.cs (C# code for adding of Departments Record)

using System;

using System.Collections;

using System.Configuration;

using System.Data;

using System.Drawing;

using System.Web;

using System.Web.UI;

using System.Web.UL. HtmlControls;
using System.Web.UL WebControls;

namespace MyApp2

{

public class AddDepartmentsRecord : AddDepartmentsRecordGen

{

#region Overview: The life cycle of a Page and its Controls

// The Life Cycle of a Page and its Controls
/

// In ASP.NET, when a page is executed, it goes through a number of

// events. You can customize the behavior of the page by handling

// each one of these events. Here is the basic order of events:

1

// 1. Init event - Initialize settings needed during the lifetime

// of the incoming web request. We recommend you use the L.oad

// event preferably.

I

/1 2. Load - Perform actions common to all requests. This is the

// usual event that developers can use to do their processing.

/

// 3. PreRender - Perform any updates before the output is rendered.
// This is another common event that developers can use to do their
// processing. This event is the last one in the sequence of events

// prior to the page being displayed to the end user.

/

// There are some additional events such as SaveViewState, Render,

// Dispose and Unload that occur during the lifecycle of the page.
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#endregion
} // End class AddDepartmentsRecord

} // End namespace MyApp2

namespace MyApp2.PanelControls.AddDepartmentsRecord

{
[System.Web.ULToolboxDataAttribute("<{0}:CustomTableControl

runat=server></{0}:CustomTableControl>")]

[System.ComponentModel.DesignerAttribute("System. Web.UI. Design.Read WriteControlDes
igner, System.Design")]

[System.Web.UIPersistChildrenAttribute(true)]
[System.Web.ULToolboxDataAttribute("<{0}:CustomRecordControl

runat=server></{0}:CustomRecordControl>")]

[System.ComponentModel.DesignerAttribute("System. Web.UIL Design.ReadWriteControlDes
igner, System.Design")]

[System.Web.UIPersistChildrenAttribute(true)]

public class CustomRecordControl

{
public CustomRecordControl()
{

}

} /1 End class CustomRecordControl

} // End namespace MyApp2.PanelControls. AddDepartmentsRecord
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Program # 6
Purpose: Depreciation.xml (XML generated for showing the Depreciation Table)

<?xml version="1.0" encoding="UTF-8" standalone="no" 7>
- <ComponentDefinition xmlns:xsd="http://www.w3.0org/2001/XMLSchema"
xmlins:xsi="http://www.w3.0org/2001/XMLSchema-instance" >
<Name>ShowDepreciationTable</Name>
<Type>Page</Type>
<GenerateDirectory>Depreciation</GenerateDirectory>
<Layout>Depreciation\ShowDepreciationTable.html</Layout>
<DisplayName>ShowDepreciationTable</DisplayName>
<Description>Table view to show or edit multiple
records.</Description>
<CheckSum>-1530362054-9813</CheckSum>
- <EventBindings>
- <BEvent>
<Producer>DepreciationExportButton.V_Button</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationIDFilter</Producer>
<Consumer>DepreciationT able</Consi1mer>
</Event>
- <Event>
<Producer>DepreciationTable</Producer>
<Consumer>DepreciationIDFilter</Consumer>
</Bvent>
- <Event>
<Producer>AssetIDFilter</Producer>
<Consumer>DepreciationTable</Consumer>
</BEvent>
- <Event>
<Producer>DepreciationTable</Producer>
<Consumer>AssetIDFilter</Consumer>
</Event>

- <Event>
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<Producer>DepreciationPagination.V_PageSize</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>

- <Event>

<Producer>DepreciationPagination.V_CurrentPage</Pro
ducer>
<Consumer>DepreciationTable</Consumer>
</BEvent>

- <Event>

<Producer>DepreciationPagination.V_TotalPages</Prod
ucer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationPagination.V_FirstPage</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>

- <Event>

<Producer>DepreciationPagination.V_PreviousPage</Pr
oducer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationPagination.V_NextPage</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationPagination.V_LastPage</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationPagination.V_Firstltem</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>

- <Event>
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<Producer>DepreciationPagination.V_LastItem</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>

- <Event>

<Producer>DepreciationPagination.V_Totalltems</Prod
ucer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_PageSize</Consu
mer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_CurrentPage</C
onsumer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_TotalPages</Con
sumer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_FirstPage</Cons
umer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_PreviousPage</C

onsumer>
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</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_NextPage</Cons
umer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_LastPage</Cons
umer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_FirstItem</Cons
umer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_LastItem</Consu
mer>
</Event>
- <Event>

<Producer>DepreciationTable</Producer>

<Consumer>DepreciationPagination.V_Totalltems</Con
sumer>

</Event>

</EventBindings>
</Self>
- <ComposedOf>
= <ContainedComponent>

<Name>AssetID</Name>

<Type>FieldValue</Type>

<Field>AssetID</Field>
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<FieldValueStyle>Literal</FieldValueStyle>
<Table>Depreciation</Table>
- <PassthroughAttributes>
= <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>Parent</Value>
</Attribute>
- <Attribute>
<Name>NullValueText</Name>
<Value>&nbsp;</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>AssetIDFilter</Name>
<Type>FieldFilter</Type>
<FieldValueStyle>DropDownList</FieldValueStyle>
- <PassthroughAttributes>
= <Attribute>
<Name>Field</Name>
<Value>AssetID</Value>
</Attribute>
= <Attribute>
<Name>InternalUse: Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>
<Name>Operator</Name>
<Value>=</Value>
</Attribute>

= <Attribute>

<Name>V_AssetIDFilterDropDownList: CssClass</
Name>
<Value>Filter_Input</Value>
</Attribute>
</PassthroughAttributes>

</ContainedComponent>
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- <ContainedComponent>
<Name>AssetIDLabel</Name>
<Type>Literal</Type>

- <PassthroughAttributes>
- <Attribute>
<Name>InternalUse:Field</Name>
<Value>AssetID</Value>
</Attribute>
- <Attribute>
<Name>InternalUse: Table</Name>
<Value>Depreciation</Value>
</Attribute>
- <Attribute>

<Name>Text</Name>

<Value>%ISD_DEFAULT %Depreciation % Assetl
D</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>AssetIDLabell</Name>
<Type>FieldSort</Type>
- <PassthroughAttributes>
= <Attribute>
<Name>Field</Name>
<Value>AssetID</Value>
</Attribute>
- <Attribute>
<Name>Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>

<Name>Text</Name>

<Value>%ISD_DEFAULT %Depreciation % Assetl
D</Value>
</Attribute>
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</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>DepreciationAmount</Name>
<Type>FieldValue</Type>
<Field>DepreciationAmount</Field>
<FieldValueStyle>Literal</FieldValueStyle>
<Table>Depreciation</Table>
- <PassthroughAttributes>
- <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>Parent</Value>
</Attribute>
- <Attribute>
<Name>NullValueText</Name>
<Value>&nbsp;</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationAmountLabel</Name>
<Type>FieldSort</Type>
- <PassthroughAttributes>
- <Attribute>
<Name>Field</Name>
<Value>DepreciationAmount</Value>
</Attribute>
- <Attribute>
<Name>Table</Name>
<Value>Depreciation</Value>
</Attribute>
- <Attribute>

<Name>Text</Name>

<Value>%ISD_DEFAULT %Depreciation % Depre
ciationAmount</Value>
</Attribute>

</PassthroughAttributes>

B25



</ContainedComponent>
= <ContainedComponent>
<Name>DepreciationDate</Name>
<Type>FieldValue</Type>

<Field>DepreciationDate</Field>

<FieldValueStyle>Literal</FieldValueStyle>

<Table>Depreciation</Table>
- <PassthroughAttributes>
= <Attribute>

<Name>InternalUse:DataSource</Name>

<Value>Parent</Value>
</Attribute>
- <Attribute>
<Name>NullValueText</Name>
<Value>&nbsp;</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationDateLabel</Name>
<Type>FieldSort</Type>
= <PassthroughAttributes>
= <Attribute>
<Name>Field</Name>
<Value>DepreciationDate</Value>
</Attribute>
- <Attribute>
<Name>Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>

<Name>Text</Name>

<Value>%ISD_DEFAULT %Depreciation % Depre

ciationDate</Value>
</Attribute>
</PassthroughAttributes>

</ContainedComponent>



- <ContainedComponent>
<Name>DepreciationExportButton</Name>
<Type>Button</Type>
<Layout>..\Shared\Button.html</Layout>

= <PassthroughAttributes>
= <Attribute>
<Name>P_Button-CausesValidation</Name>
<Value>False</Value>
</Attribute>
- <Attribute>
<Name>P_Button-CommandName</Name>
<Value>ExportData</Value>
</Attribute>
- <Attribute>
<Name>P_Button-Text</Name>
<Value>Btn:Export</Value>
<Type>ResourceReference</Type>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>

= <ContainedComponent>
<Name>DepreciationID</Name>
<Type>FieldValue</Type>
<Field>DepreciationID</Field>
<FieldValueStyle>Literal</FieldValueStyle>
<Table>Depreciation</Table>

- <PassthroughAttributes>
- <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>Parent</Value>
</Attribute>
= <Attribute>
<Name>NullValueText</Name>
<Value>&nbsp;</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>

- <ContainedComponent>
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<Name>DepreciationIDFilter</Name>
<Type>FieldFilter</Type>
<FieldValueStyle>DropDownList</Field ValueStyle>
- <PassthroughAttributes>
- <Attribute>
<Name>Field</Name>
<Value>DepreciationID</Value>
</Attribute>
= <Attribute>
<Name>InternalUse: Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>
<Name>Operator</Name>
<Value>=</Value>
</Attribute>

= <Attribute>

<Name>V_DepreciationIDFilterDropDownList:Cs
sClass</Name>
<Value>Filter_Input</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>DepreciationIDLabel</Name>
<Type>Literal</Type>
- <PassthroughAttributes>
= <Attribute>
<Name>InternalUse:Field</Name>
<Value>Depreciation]D</Value>
</Attribute>
= <Attribute>
<Name>InternalUse:Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>

<Name>Text</Name>
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<Value>%ISD_DEFAULT %Depreciation % Depre
ciationID</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationIDLabell</Name>
<Type>FieldSort</Type>
- <PassthroughAttributes>
- <Attribute>
<Name>Field</Name>
<Value>DepreciationID</Value>
</Attribute>
- <Attribute>
<Name>Table</Name>
<Value>Depreciation</Value>
</Attribute>
= <Attribute>

<Name>Text</Name>

<Value>%ISD_DEFAULT %Depreciation % Depre
ciationID</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>DepreciationNewButton</Name>
<Type>Button</Type>
<Layout>..\Shared\Button.html</Layout>
- <PassthroughAttributes>
- <Attribute>
<Name>P_Button-CausesValidation</Name>
<Value>False</Value>
</Attribute>
- <Attribute>
<Name>P_Button-CommandName</Name>

<Value>Redirect</Value>
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</Attribute>
- <Attribute>
<Name>P_Button-RedirectArgument</Name>
<Value>ID</Value>
</Attribute>
= <Attribute>
<Name>P_Button-RedirectURL</Name>

<Value>../Depreciation/AddDepreciationRecord.as

px</Value>
</Attribute>
= <Attribute>
<Name>P_Button-Text</Name>
<Value>Btn:New</Value>
<Type>ResourceReference</Type>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
= <ContainedComponent>
<Name>DepreciationPagination</Name>
<Type>Pagination</Type>
<Layout>..\Shared\Pagination.html</Layout>
</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationTable</Name>
<Type>Table</Type>
<Table>Depreciation</Table>
- <EventBindings>
- <Event>
<Producer>DepreciationIDLabell</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationTable</Producer>
<Consumer>DepreciationIDLabel1</Consumer>
</Event>
- <Event>

<Producer>AssetIDLabell</Producer>
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<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationTable</Producer>
<Consumer>AssetIDLabell</Consumer>
</Event>
- <Event>
<Producer>DepreciationDateLabel</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
= <Event>
<Producer>DepreciationTable</Producer>
<Consumer>DepreciationDateLabel</Consumer>
</Event>
- <Event>
<Producer>DepreciationAmountLabel</Producer>
<Consumer>DepreciationTable</Consumer>
</Event>
- <Event>
<Producer>DepreciationTable</Producer>
<Consumer>DepreciationAmountLabel</Consumer>
</Event>
</EventBindings>
- <PassthroughAttributes>
= <Attribute>
<Name>InternalUse:DataSource</Name>
<Value>TableOrQuery</Value>
</Attribute>
- <Attribute>
<Name>PageSize</Name>
<Value>10</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationTableIcon</Name>
<Type>Image</Type>

<ImageUrl>../Images/icon_view.gif</ImageUrl>
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</ContainedComponent>
- <ContainedComponent>
<Name>DepreciationTableTitle</Name>
<Type>Html</Type>
= <PassthroughAttributes>
- <Attribute>
<Name>HtmlEncodeWhiteSpace</Name>
<Value>True</Value>
</Attribute>
= <Attribute>
<Name>Text</Name>
<Value>Depreciation</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
- <ContainedComponent>
<Name>Footer</Name>
<Type>Footer</Type>
<Layout>.\Header & Footer\Footer.html</Layout>
</ContainedComponent>
- <ContainedComponent>
<Name>Header</Name>
<Type>Header</Type>
<Layout>..\Header & Footer\Header.html</Layout>
</ContainedComponent>
- <ContainedComponent>
<Name>Menu</Name>
<Type>Menu</Type>
<Layout>..\Menu Panels\Menu.html</Layout>
- <PassthroughAttributes>
- <Attribute>
<Name>HiliteSettings</Name>
<Value>Menu4Menultem</Value>
</Attribute>
</PassthroughAttributes>
</ContainedComponent>
</ComposedOf>

</ComponentDefinition>
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Program # 7

Name: Header.ascx

<% @ Register Tagprefix="Panel" Namespace="MyApp2.PanelControls.Header"
Assembly="MyApp2" %>

<% @ Control Language="cs" TargetSchema="http://schemas.microsoft.com/intellisense/ie5'
AutoEventWireup="false" CodeBehind="Header.gen.ascx.cs" Inherits="MyApp2.Header"
o>

<% @ Register Tagprefix="Custom" Namespace="MyApp2" Assembly="MyApp2" %>
<table cellspacing="0" cellpadding="0" border="0" class="master_table">

<tr>

<td class="logoBG">

<BaseClasses:Image ImageUrl="../Images/Logo.gif" runat="server" id="V_Logo">
</BaseClasses:Image>

</td>

</tr>

</table>

Program # 8
Name: Header.xml

<?xml version="1.0" encoding="UTF-8" standalone="no" 7>
- <ComponentDefinition xmlns:xsd="http://www.w3.0org/2001/XMILSchema"

xmins:xsi="http://www.w3.0rg/2001/XMLSchema-instance" >

<Version>1.4</Version>

= <Self>
<Name>Header</Name>
<Type>Header</Type>
<GenerateDirectory>Header & Footer</GenerateDirectory>
<Layout>Header & Footer\Header.html</I.ayout>
<DisplayName>Header</DisplayName>
<Description>(Description)</Description>

</Self>

= <ComposedOf>

- <ContainedComponent>
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<Name>Logo</Name>
<Type>Image</Type>
<ImageUrl>../Images/Logo.gif</ImageUrl>
</ContainedComponent>
</ComposedOf>

</ComponentDefinition>
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Stored Procedure # 1
Purpose: To add department record into the Departments Table

if exists (select * from sysobjects where id = object_id('pMyApp2DepartmentsAdd")

and sysstat & Oxf = 4) drop procedure pMyApp2DepartmentsAdd
GO

CREATE PROCEDURE pMyApp2DepartmentsAdd
@p_DepartmentID int,
@p_DepartmentName nvarchar(50),
@p_DepartmentNumber int

AS

BEGIN
INSERT
INTO [Departments]

(
[DepartmentID],
[DepartmentName],
[DepartmentNumber]

)
VALUES

(
@p_DepartmentID,

@p_DepartmentName,
@p_DepartmentNumber

END
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Stored Procedure # 2
Purpose: Exporting the Employees data to a CSV file

if exists (select * from sysobjects where id = object_id('/pMyApp2EmployeesExport')
and sysstat & Oxf = 4) drop procedure pMyApp2EmployeesExport
GO

CREATE PROCEDURE pMyApp2EmployeesExport
@p_title_str nvarchar(4000),
@p_select_str nvarchar(4000),
@p_join_str nvarchar(4000),
@p_where_str nvarchar(4000),
@p_num_exported int output
AS
DECLARE
@]_title_str nvarchar(4000),
@1_select_str nvarchar(4000),
@1_from_str nvarchar(4000),
@] _join_str nvarchar(4000),
@]_where_str nvarchar(4000),
@]_query_select nvarchar(4000),
@]_query_union nvarchar(4000),
@]_query_from nvarchar(4000)
BEGIN
-- Set up the title string from the column names. Excel
-- will complain if the first column value is ID. So wrap
-- the value with "".
SET @I _title_str = @p_title_str + char(13)
IF @p_title_str IS NULL
BEGIN
SET @I_title_str =
N"EmployeelD" + ', +
N'"'SocialSecurityNumber"' + ', +
N'""EmployeeNumber"' + ', +
N"FirstName"' +',' +
N'""LastName"' +',' +
N"Title" +",' +
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N'""EmailName"' + ', +
N'"HomePhone"' + ', +
N""WorkPhone" + ', +
N"'OfficeLocation" +"'";

END

ELSE IF SUBSTRING(@I_title_str, 1, 2) ='ID'

SET @] title str=
"
SUBSTRING(@I_title_str, 1, PATINDEX('%,%', @1_title_str)-1) +
"
SUBSTRING(@I_title_str, PATINDEX('%,%', @]_title_str),

LEN(@]_title_str));

-- Set up the select string
SET @I _select_str = @p_select_str
IF @p_select_str IS NULL
BEGIN
SET @] select_str =

N'IsNULL(Convert(nvarchar, Employees_.[EmployeelD]), ") +"," +

'+

N'N""" + REPLACE(IsNULL(Employees_.[SocialSecurityNumber], "),

NIIHN, NHH"VI) + NH"N + H,H +’ +

N'N""" + REPLACE(IsNULL(Employees_.[EmployeeNumber], "), N""",

Nllllll")+NllHH +II’H +|+

N'N""" + REPLACE(IsNULL(Employees_.[FirstName], "), N""", N"""") +

Nll’l” + U’H +|+

N'N""" + REPLACE(IsNULL(Employees_.[LastName], "), N""", N"""") +

NHNII +||," +|+

N'N""" + REPLACE(IsNULL(Employees_.[Title], "), N""", N"""") + N"""

+’V’|| +|+

N'N""" + REPLACE(IsNULL(Employees_.[EmailName], ""), N""", N"""")

+ NHHH + ll,” +l +

N'N""" + REPLACE(IsNULL(Employees_.[HomePhone], "), N""", N"""")

+ NIIHH + H’ll +’ +

N'N""" + REPLACE(IsNULL(Employees_.[WorkPhone], "), N""", N"""")

+ NH”H + II,H +| +

N'N""" + REPLACE(IsNULL(Employees_.[OfficeLocation], "), N""",

NHHHH) + NHIHI + " lll;
END
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-- Set up the from string (with table alias) and the join string

SET @I_from_str = '[Employees] Employees_";

SET @I_join_str = @p_join_str
if @p_join_str is null
SET @I_join_str=""

-- Set up the where string
SET @] where_str=""
IF @p_where_str IS NOT NULL
SET @I_where_str = @1_where_str + WHERE ' + @p_where_str;

-- Construct the query string. Append the result set with the title.
SET @]_query_select =
'SELECT "
SET @1_query_union =
" UNION ALL '+
'SELECT'
SET @]_query_from =
'"FROM '+ @]_from_str+''+ @I_join_str+"'"' +

@1_where_str;

-- Run the query
EXECUTE (@1_query_select + @I _title_str + @1_query_union +
@]_select_str+ @1_query_from)

-- Return the total number of rows of the query
SELECT @p_num_exported = @ @rowcount
END
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Stored Procedure # 3
Purpose: This stored procedure will return query result based on the passed in select,
search and ORDER BY clauses.

if exists (select * from sysobjects where id = object_id('/pMyApp2AssetsDrillDown")
and sysstat & Oxf = 4) drop procedure pMyApp2AssetsDrillDown
GO

CREATE PROCEDURE pMyApp2AssetsDrillDown

@p_select_str nvarchar(4000),
@p_is_distinct int,
@p_select_str_b nvarchar(4000),
@p_join_str nvarchar(4000),
@p_where_str nvarchar(4000),
@p_sort_str nvarchar(4000),
@p_page_number int,
@p_batch_size int

AS

DECLARE

@] _createtemp_select nvarchar(4000),
@]_createtemp_into nvarchar(4000),
@]_createtemp_from nvarchar(4000),
@]_createtemp_where nvarchar(4000),
@]_temp_insert nvarchar(4000),
@]_temp_select nvarchar(4000),
@]_temp_from nvarchar(4000),
@]1_final_sort nvarchar(4000),
@]_query_select nvarchar(4000),
@]_query_from nvarchar(4000),
@1_query_where nvarchar(4000),
@]1_from_str nvarchar(4000),
@]1_join_str nvarchar(4000),

@] _sort_str nvarchar(4000),
@]_where_str nvarchar(4000),
@]1_count_query nvarchar(4000),
@]_end_gen_row_num integer,

@] _start_gen_row_num integer
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BEGIN
-- Set up the from string as the base table.
SET @1_from_str = '[Assets] Assets_'

-- Set up the join string.
SET @I_join_str = @p_join_str
IF @p_join_str is null

SET @I_join_str=""

-- Set up the where string.
SET @] _where_str=""
IF @p_where_str is not null
SET @]_where_str = " WHERE ' + @p_where_str

-- Get the total count of rows the query will return
IF @p_page_number > 0 and @p_batch_size >=0
BEGIN
IF @p_is_distinct =0
BEGIN
SET @I]_count_query =
'SELECT count(*) FROM ( SELECT ' + @p_select_str +
'FROM ' + @]_from_str+''+ @]_join_str+"'"'+

@]_where_str + ') countAlias'

END

ELSE

BEGIN

SET @I]_count_query =
'SELECT COUNT(*) FROM ( SELECT DISTINCT ' + @p_select_str + ', 1
As __One '+

"FROM '+ @]_from_str +''+ @I_join_str+"' "'+
@]_where_str + ') passl'

END
END
ELSE
BEGIN
SET @I_count_query ="'
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END

-- Get the list.
IF @p_page_number >0 AND @p_batch_size >0
BEGIN
-- If the caller did not pass a sort string, use a default value
IF @p_sort_str IS NULL OR LTRIM(RTRIM(@p_sort_str)) ="
SET @1 _sort_str="ORDER BY 1'

ELSE
SET @I]_sort_str ='ORDER BY ' + @p_sort_str
-- Calculate the rows to be included in the list
-- before geting the list.
SET @]_end_gen_row_num = @p_page_number * @p_batch_size;
SET @I_start_gen_row_num = @]_end_gen_row_num - (@p_batch_size-1);

-- Create a temporary table to keep the numbering
-- of the rows returned. It contains the necessary colums
-- from base table plus an identity field used for numbering

SELECT 1 AS IS_SECONDARY_TEMP_T_GETLIST_COL INTO
#IS_SECONDARY_TEMP_T_GETLIST

SET @I_createtemp_select =
'SELECT Identity(int,1,1) AS IS_ROWNUM_COL, ' +
@p_select_str
SET @I_createtemp_into =
"INTO #IS_TEMP_T_GETLIST'
SET @I_createtemp_from =
'FROM [Assets] AS [Assets_], #1S_SECONDARY_TEMP_T_GETLIST'
SET @I_createtemp_where =
'"WHERE 1=2"
-- Now copy column data into temporary table.
SET @I_temp_insert =
'INSERT INTO #IS_TEMP_T_GETLIST (' +
@p_select_str +

l)l
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IF @p_is_distinct = 0 OR @p_sort_str IS NULL OR
LTRIM(RTRIM(@p_sort_str)) ="
BEGIN
IF @p_is_distinct =0
BEGIN
SET @I_temp_select =
'SELECT'
END
ELSE
BEGIN
SET @1_temp_select =
'SELECT DISTINCT'
END
SET @I_temp_select =
@]_temp_select +
'TOP ' + convert(varchar, @1_end_gen_row_num) + "'+
@p_select_str
END
ELSE
BEGIN
-- Need to construct query differently when sorting by expanded DFKA,
-- So get the TOP DISTINCT values after selecting, joining, and sorting
ALL the values
SET @]_temp_select =
'SELECT __ReturnCol FROM (' +
'SELECT '+
DISTINCT ' +
'TOP ' + convert(varchar, @]_end_gen_row_num) + "'+
@p_select_str +
"As __ ReturnCol, ' +
@p_select_str_b
-- Close and alias the outer FROM clause after the inner ORDER BY clause
SET @I_sort_str =
@]_sort_str +
") passl’
END
SET @]_temp_from =
'"FROM '+ @]_from_str + "'+ @l_join_str
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-- Construct the main query
SET @]_query_select = 'SELECT '
SET @]_query_from =
'FROM #IS_TEMP_T_GETLIST ' +
'AS [Assets_]' +
'WHERE IS_ ROWNUM_COL >= '+ convert(varchar,

@]_start_gen_row_num)

SET @I_final_sort ='ORDER BY IS_ROWNUM_COL Asc'

-- Run all the queries as a batch so the temp tables won't lose scope
EXECUTE (@I_count_query +' '+ @]_createtemp_select +
@]_createtemp_into + @1_createtemp_from + @]_createtemp_where +'

1

+
@]_temp_insert + @]_temp_select + @]_temp_from +'' + @]_where_str +"'"' +
@]_sort_str+"' '+ @I_query_select + @p_select_str + @]_query_from +
@1_query_where + @]_final_sort)

END
ELSE
BEGIN
-- If page number and batch size are not valid numbers
-- return the empty result set
SET @I]_query_select = 'SELECT'
SET @I]_query_from =
' FROM [Assets] Assets_ '+
'WHERE 1=2;'
EXECUTE (@1_query_select + @p_select_str + @1_query_from);
END

END
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Stored Procedure # 4
Purpose: Runs a SQL function against a column and returns the result back giving
the current page number and batch size. SQL functions can include sum, avg, max,

etc.

if exists (select * from sysobjects where id =
object_id('pMyApp2Asset_CategoriesGetStats') and sysstat & Oxf = 4) drop
procedure pMyApp2Asset_CategoriesGetStats

GO

CREATE PROCEDURE pMyApp2Asset_CategoriesGetStats
@p_select_str nvarchar(4000),
@p_join_str nvarchar(4000),
@p_where_str nvarchar(4000),
@p_sort_str nvarchar(4000),
@p_page_number integer,
@p_batch_size integer

AS

DECLARE
@1_query nvarchar(4000),
@]_from_str nvarchar(4000),
@]_join_str nvarchar(4000),
@1_sort_str nvarchar(4000),
@]_where_str nvarchar(4000),
@]_count_query nvarchar(4000),
@]_end_gen_row_num integer,
@]_start_gen_row_num integer,
@]_select_str nvarchar(4000),
@]_stat_col nvarchar(4000),
@]_insert_to_temp nvarchar(4000),
@]_create_temp nvarchar(4000),
@]_stat_col_alias nvarchar(20)

BEGIN

-- Extract the col only that we need to run statistics on.

-- First extract the content in the function call.

B44



SET @I _stat_col = @p_select_str
SET @1 _stat_col = SUBSTRING(@I_stat_col,
PATINDEX('%(%', @1_stat_col) + 1,
PATINDEX('%)%', @1_stat_col) - PATINDEX('%(%', @] _stat_col) - 1)

-- Then extract the column from the distinct clause.
SET @I_stat_col = LTRIM(RTRIM(@]1_stat_col))
IF PATINDEX('%DISTINCT %', UPPER(@]_stat_col)) =1
SET @]_stat_col = SUBSTRING(@I_stat_col, PATINDEX('% %',
@]_stat_col) + 1, LEN(@]_stat_col))

-- Get the select column name without alias.
SET @1 _select_str = SUBSTRING(@1I_stat_col, PATINDEX('%.%',
@]_stat_col) + 1, LEN(@]I_stat_col))

-- Set up the from string.
SET @I_from_str = '[Asset Categories] Asset_Categories_'
-- Set up the join string.
SET @I_join_str = @p_join_str
IF @p_join_str IS NULL
SET @I_join_str=""

-- Set up the search string.
SET @] _where_str=""
IF @p_where_str IS NOT NULL
SET @] _where_str = @]1_where_str + ' WHERE ' + @p_where_str

-- Get the list.
IF @p_page_number >0 AND @p_batch_size >0
BEGIN
-- If the caller did not pass a sort string,
-- use a default value.
IF @p_sort_str IS NOT NULL
SET @]_sort_str ='ORDER BY ' + @p_sort_str;
ELSE
SET @] sort_str=""
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-- Calculate the rows to be included in the list

-- before geting the list.

SET @]_end_gen_row_num = @p_page_number * @p_batch_size

SET @]_start_gen_row_num = @]_end_gen_row_num - (@p_batch_size-1)

-- Creating a temporary table to keep the numbering

-- of the rows returned. It keeps the same primary

-- key columns as the base table besides an identity

-- field which keeps the numbering.

Select 1 As tempCol Into #IS_TEMP_TABLE_SECONDARY;

-- Create the temporary table from the
SET @I|_create_temp =
'SELECT Identity(int, 1, 1) As IS_ROWNUM_COL, ' +
@]_stat_col +
"INTO #IS_TEMP_FROM' +
'"FROM '+ @]_from_str+''+
"CROSS JOIN #IS_TEMP_TABLE_SECONDARY' +
'"WHERE 1=2'
-- Insert records into the temporary table from the
-- base table
SET @I _insert_to_temp =
'INSERT INTO #IS_TEMP_FROM ' +
'("+ @l_select_str + ") "+
'SELECT '+ @I]_stat_col +
'"FROM '+ @I_from_str +"''+ @I_join_str+"' "'+
@] _where_str+"'"'+
@]1_sort_str

-- Construct the query for the current page
SET @]_query =
'SELECT '+ @p_select_str+ "'+
FROM ( '+
'SELECT '+ @]_select_str +', IS_ ROWNUM_COL ' +
'FROM #IS_TEMP_FROM ' +
'WHERE IS_ ROWNUM_COL >="+ convert(varchar,

@]_start_gen_row_num) +
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" AND IS_ ROWNUM_COL <="+ convert(varchar,
@]_end_gen_row_num) +
"'+ 'Asset_Categories_'

-- Run the query and get the result for the current page
EXECUTE (@I_create_temp +' '+ @]_insert_to_temp+' '+ @Il_query
£,

END
ELSE
-- Return the empty result if page number or batch size
-- has invalid number
BEGIN
SET @]_query =
'SELECT 1 from ' + '[Asset Categories] Asset_Categories_ " +
'WHERE 1=2;'
EXECUTE (@]_query)
END
END
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Appendix C Glossary
The Glossary is useful since these below technologies are being used for the project,

which needs a small description.

ASP.NET

The key to .NET technology for developing XML Web Services is ASP.NET.
ASP.NET provides framework for developing Web based applications in which the
user interacts with a service using a browser. Although the main emphasis of
ASP.NET is to build conventional web applications, Microsoft has added support for

building XML Web Services as well.

ASP.NET vs. Traditional ASP

ASP.NET provides a true language neutral execution framework for web application
to use. This means that whether we use C#, VB, Jscript .NET, C++ or Perl the code
will compile to IL (Intermediate Languages) and then executed by .NET Framework.
This also means that ASP.NET will take full advantages of .NET Framework based
classes through and compiled languages. However, compared to the traditional ASP,
the choice of languages is limited with VB script and Java script.

Another major difference between traditional ASP and ASP.NET is that traditional



ASP pages are parsed each time they are requested, which will make the ASP
execution slow. On the other hand, when we execute an ASP.NET page for the first
time it gets compiled into a binary .dll (dynamic library link) and then get executed.

All further requests are served by this compiled code, making execution faster.

ASP.NET and XML
The relation between ASP.NET and XML can be summarized but not limited to the
following points:

e ASP.NET uses XML extensively to represent Web Controls and Configuration
setting. It relies on special XML document web.config for configuration
purposes.

e ASP.NET provides Web Controls that can deal with XML data and display it
as our requirement, which can be either tabular or style sheet-based.

e The creation of XML Web Services in .NET platform is done through
ASP.NET. Since it is a huge process to see how we can create a Web Service
in .NET and a client, I have shown this in the appendix.

=  “XML Web Services are a category of software components that provide

functionality over the network” — a general definition to Web Services.



However, if we define Web Services in terms of functionality, then XML Web

Services let applications share data, and more powerfully invoke capabilities from

other application without regards to how those applications were built, what operating

system or platform they run on, and what device are used to access them. While XML

Web Services remain independent of each other, they can loosely link themselves into

a collaborating group that performs a particular task.

XML Web Services are invoked by means of industry-standard protocols includes

SOAP, WSDL, UDDI and XML. They are defined through public standard

organization namely World Wide Web Consortium (W3C). We will define each of

these underling technologies, which are the building blocks of any XML Web

Services —

= Simple Object Access Protocol (SOAP) is the communication protocol for
XML Web Services, which provides a standard way of packaging messages. A
SOAP message is composed of an envelope that contains the body of the
message and any header information used to describe the message, which is an
XML document that follows specific XML schema. The latest version of
SOAP is 1.1. However, in 2001, a working group draft of SOAP 1.2 was
published (www.w3.0rg/TR/2001/WD-soap12-20010709) by the XML

Protocol Working Group.)



=  Web Service Description Language (WSDL) is an XML-based language
layered on top of the schema that describes a Web Service. It provides the
information necessary for a client to interact with the Web Service. WSDL
specifies what a request message must contain and what the response message
will look like in unambiguous notation. WSDL is extensible and can be used
to describe practically any network service, including SOAP over HTTP and

even protocols that are not XML-based, such as DCOM over UDP.

» Universal Description, Discovery, and Integration (UDDI) provides a
central directory service for publishing technical information about Web
Services. In other words, it is the yellow pages of Web Services. UDDI is the
result of an industry initiative backed by a significant number of technology
companies, including Microsoft, IBM, SAP, and Ariba.

All the above protocols and standards we discussed so far are based on the

Extensible Markup Language. Indeed, XML is the backbone of any Web Service’.

“XML is a vehicle for information that brings usable data to the desktop and is a

universal data format that does for data what HTML does for web content- it

provides the necessary markup”.
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