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I. INTRODUCTION [Kevin Povey] 

The Cal Poly Interdisciplinary Satellite Engineering Project (or CPInterSEP) is a prime 

example of Cal Poly‟s motto of “Learn by Doing”. The project involves students, faculty, and 

industry personnel from various areas of expertise coming together to put a full-size functioning 

satellite into space. Starting with a basic satellite bus structure, students will work together with 

members of industry to plan, design, manufacture, and assemble each of the different spacecraft 

subsystems. In order to accomplish this task, it is essential to have a solid understanding of the 

capabilities and requirements of the base structure and this knowledge comes from stress 

analysis. In order to have an efficient process for stress testing and calculations, it is very helpful 

and essential in today‟s industry to be able to perform finite element analysis (FEA) on the 

primary structure of the spacecraft. Since no 3D CAD models were available for this structure, 

the first step is to create the model and then document the process for performing FEA on this 

model. In this case, the structure of the spacecraft is the BS376 satellite bus.  

The project was able to come to life through the generous donation of two 376 type 

satellite buses by the Boeing Company, similar to the bus structure shown in the completed 

satellite diagram below.  
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The model 376 satellite bus was originally designed and manufactured by Hughes Space 

and Communication Co. until the company was bought by Boeing in 2000, where Boeing 

Satellite Systems continued to manufacture and improve the 376 design. The 376 spacecraft has 

always been used as a communications satellite but it can accommodate a wide variety of 

payloads and multiple configurations. Though the payload configuration and mission capabilities 

are flexible, all 376 spacecraft have a similar chassis design. All models have two telescoping 

cylindrical solar panels with body mounted solar cells where, once in orbit, the outer cylinder 

deploys downward in a „Dixie-cup‟ fashion in order to increase the solar panel area, as shown in 

the figure below. 

 
The spacecraft is spin-stabilized with a de-spun antenna platform and uses a hydrazine 

propulsion system for attitude control. The satellites using the 376 bus usually weighed around 

1200kg (2600lb) with variation from program to program. The 376 bus design has proven to be 

one of the world‟s most-purchased commercial communications satellite models with almost 60 

launches. The first was the SBS 1, which was launched on November 15, 1980 on a Delta 3910 

from Cape Canaveral and the last was E-Bird, which was launched from Kourou on the Ariane 

5G on September 27, 2003. Also of note, in 1983, a 376 spacecraft (Anik C3) was the first 

communication satellite to be launched from the space shuttle. These satellites can be boosted by 

any of the world‟s major launch vehicles and though there have been some failures, most are still 

orbiting today providing TV and radio coverage to 5 continents. 

The most efficient and practical way to make a 3D CAD model of the 376 bus is through 

the use of detailed part and assembly drawings. The acquisition of these drawings, however, 

turned out to be much more difficult than expected. The first hurdle came from the fact that 

though the 376 was a popular model, it is no longer in production and all the documentation had 

been moved to storage. A Boeing employee would need to take time away from the work he or 

she needed to get done and go search through the warehouses for the drawings. This process 

itself took many weeks. The next hurdle came once the drawings were located. Since this 

information is ITAR controlled, it was not permissible to transfer the electronic data via the 

internet nor mail the physical copies through the postal system; the information needed to be 

handed over in person. It was an additional number of weeks before an arrangement was able to 

be made for a meeting. In addition, after the electronic versions of the drawings were acquired, 
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many were unable to be opened due to the need for Boeing in-house software. Finally, after the 

drawings had been obtained in an acceptable format, it was found that more than half of the 

drawings were still missing. As a result, the entire 376 satellite bus was unable to be modeled, 

instead, the available drawings were used to create a model of the majority of the spun portion 

only. In lieu of modeling the de-spun structure, much more effort was put into the task of 

performing the finite element analysis.  

The primary purpose of this project is to provide a basis and groundwork for work to be 

done in the future. There will need to be a large amount of stress analysis done when comparing 

various payload packages or other possible additions to the spacecraft. In addition to creating a 

3D CAD model of the spacecraft for visual purposes and as a base for future modeling, the 

project incorporates two other very important features. The project not only verifies that the FEA 

performed on the Pro/E solid model using Patran is accurate and gives expected results, but also 

provides a detailed, accurate, and user-friendly tutorial for performing FEA on Pro/E models 

using PATRAN and NASTRAN. Appendix A details the names and locations of the relevant 

files used in our project. 

It is important to verify that results are similar to what is expected in order to ensure that 

the solid model is interacting appropriately with the FEA software. Very small incongruencies 

with the way a model is made or incorporated into the simulation can create drastic inaccuracies 

in the results. The FEA software will most usually give these incorrect results, with no message 

or indication that something is invalid. In order to verify that the model and simulation for the 

376 spun structure is accurate, loads were analyzed individually in each of the 6 degrees of 

freedom, three in translation and three in rotation, and then compared to both the logical 

reactions and hand calculations. Due to the nature of the CPInterSEP, many other individuals in 

the future will need to perform similar stress testing and finite element analysis on a more 

complete satellite structure. In order to streamline this process and create a much shorter and less 

discouraging learning curve, the complete process from creating the models to viewing and 

analyzing the results needs to be documented in a format that can be followed by an 

inexperienced individual. 

Overall, this project will be just the first steps in the legacy of CPInterSEP. It creates a 

foundation for the project to build upon and a starting point to go forward from. Each aspect of 

what has been accomplished should be able to help future participants both improve upon and 

expand the spacecraft. The project can be broken down into four main categories; creating the 

3D model in Pro/Engineer based on the detail part drawings, modifying the existing model to be 

suitable for FEA, setting up the simulation model in Patran, and actually running the simulation 

model using Patran/Nastran. 

References 

http://www.selkirkshire.demon.co.uk/analoguesat/boeing376diagram.html  
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http://www.astronautix.com/craft/hs376.htm 

http://www.boeing.com/defense-space/space/bss/factsheets/376/376fleet.html 

II. Best Practice Discussion [Kelly Cheng & Richard Pelham] 

As our task will be to generate 3-D solid models for the primary structure, it would be 

beneficial to lay the groundwork for a set of rules for proper modeling practices. Proceeding in 

this manner would reduce incompatibilities of models between the different modelers and 

efficiently generate parts that would adhere to a unified structure for assembly purposes. 

Part Modeling Practices 

 Choose a Part Modeling Philosophy 

o Top/Down approach – Start with the smallest mass that will encompass the whole 

part and remove material to refine detail on the part 

o Bottom/Up approach – Start with a core shape and add features to refine detail onto 

the part 

 Choose and operate under a standard dimensioning system. SI? English? 

 Always plan out logical sequences in creating a part addressing parent/child relationships. 

This will allow for a set of related features to be suppressed/resumed without also 

suppressing/resuming other unrelated features. 

 Carefully select and think about how you define the sketch plane on which you draw. The 

reference plane for which you choose the desired orientation of view will affect which 

direction a plane or surface faces after the sketch is complete. The chosen reference plane 

must be perpendicular to the sketching plane. 

 Create features individually as this will mitigate problems when suppressing or deleting any 

number of various features. 

o Use the insert mode to modify and add features. This will reduce model regeneration 

time by not requiring regeneration of features that have no real involvement with the 

modification. This will help with the order of feature creation as well as maintaining 

proper parent/child relationships. 

o Do not try to sketch multiple closed sections in sketch mode as each section should be 

a unique feature. 

o Total part features should be minimized by compacting similar features using the 

patterns and groups functions. 

o Cosmetic features operations (such as rounds and chamfers) should be left to be 

performed at the end of the fundamental model tree. They should not be added from 

the sketch feature. 

 Good Sketcher Use 

o Use sketched centerlines and construction circles for proper dimensioning scheme. 
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o Remove any weak dimensions before completing a sketch by adding constraints, 

adding strong dimensions or converting weak dimensions into strong dimensions. 

o Many simple features rule: keep the number of dimensions in a sketch to a maximum 

of eight as a rule of thumb. If more are necessary to properly dimension a feature, 

create separate datum features first and then reference these datum features in the 

sketcher. 

 References 

o Pick references in a 3-D view to avoid errors in choosing exactly what reference 

constrains a feature. The message window should be read after the selection is made 

to validate this reference choice has been correctly selected. 

o Choose only as many references as are necessary for a robust model that can change 

as a design evolves. 

o Good reference selection: datums or planar surfaces are good, edges are bad and may 

disappear when cosmetic features like rounding modify the entity, base features 

would make more stable choices than later features.  

o Use Replace rather than deleting a sketched identity to redefine a sketch while 

maintaining the same entity id number and avoid rerouting all the children features 

from the old identity to the new one. 

o Always use reference curves and surfaces to create complex shapes so that complex 

reference parameters will always be available and no parameters will be lost when a 

function fails or causes aborts. 

o Relations should be created that associate features when direct references are not 

feasible. 

o To change a feature reference, use the Edit References method and roll back the part 

temporarily to when a specific feature was created. This way, no mistakes will be 

made to accidentally choose a new reference that is newer than a feature created after 

it in the model tree. 

 Documentation 

o Descriptive names should be assigned for datum planes to provide detail for reference 

selection. Descriptive names for features should be assigned in the model tree 

whenever possible. 

 Revolving for a feature in a part can be used as long as the sketch drawing is fully enclosed 

during editing of the definition. Not enclosing the drawing should be avoided as it blocks the 

user from using the Hole, Shell and Rib tools later in feature creation on some parts. Blends 

can also be used when these features are planned to be used to modify the feature. Revolve is 

a faster feature creation process when these features are not necessary. 

 Layers for Parts Creation 

o Create and use setup files to predefine name and states for all layers. This is useful for 

multiple parts to be used on the same assembly. 
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o Mapkey can streamline this sequence of processes when performing the same 

command sequences repeatedly. This is especially useful for the set up and 

configuration of the same layers on multiple parts. 

o Layers can be used to efficiently control the display of datum planes when 

assembling a large number of different parts such as in the figure below. 

 

A video tutorial presentation to assist with layering in assembly models is presented at: 

http://www.ptc.com/appserver/wcms/replay/wmvPlayer.jsp?im_dbkey=68301&icg_dbkey=362 
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Assembly Practices 

While building assemblies in Pro/Engineer, we will be using the following techniques to 

ensure each model is well built and constrained correctly. 

 

 General Techniques 

o Use a top-down approach. Define where you are going from the start by looking at 

the project specifications.  Define what you know at each level working from the top 

down. 

o Top assembly is cut into specific envelops. Sub assemblies do not limit top 

assemblies progress. Lead designer not responsible for maintaining volumes for sub 

assemblies, their locations and progress in top assembly. 

o Use skeletons, datums, and curves to define important areas and functions. 

o Use dummy parts as necessary to preserve important spaces. 

o Think about what you will need at each subassembly. Create those levels even if 

nothing is in them at the moment. 

o Do not get into details too early. This will save a lot of time and redefinition. 

o Bottom up design. Sub assemblies are added as they are completed with no area 

reserved for sub assemblies. Lead designer is responsible for maintaining top 

assembly and must insure we have latest data from each designer. 

o Either top-down or bottom-up design will work so long as everyone follows the same 

philosophy. 

o Avoid having the same part intersected by assembly features from different levels. 

o Use layers to group like entities so that the assembly is not too cluttered. 

o Reference base part to global axis. All other parts should be referenced to the part it is 

attached too. 

 Constraints 

o Geometric relation between any two parts has six degrees of freedom: 3 translational 

and 3 rotational. All DOFs must be constrained.  

o Think about how to use these constraints to construct the assembly. 

o Most parts can be assembled using 3 constraints; some can be done in two. Make sure 

pro/e automatic assumptions are turned off to fully constrain a part. 

o The order in which components are brought into the frame is more important than the 

constraints. 

o Constraints lead to hierarchical structure of the assembly. 

 Clearance and Interference 

o Determine if the parts in the assembly have clearance or interference. 

o Use hidden or no hidden lines to check for interference. Interference may or may not 

be desirable. 

o Global interference can check the entire assembly. 

 Scales in Assemblies 
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o Small scale parts in large scale assemblies can be tedious to handle. Focus on the 

small scale part first, provide all the constraints for it, then go to the large scale part 

and place all the constraints for it. Pro/E allows you to fix constraints in different 

orders, and will assume a constraint for each incomplete constraint. 

 

Integration between Pro/Engineer and Patran 

 Geometry generated in Pro/E can be transferred directly to Patran. Save part or assembly as a 

step file in Pro/E. Import into Patran. 

 When importing into Patran, Parasolid is an option to render the model. Parasolid models are 

“dumb” with no features or sketches. This is essentially what we want when dealing with 

FEA. 

 By default Parasolid always uses metric in millimeters not meters. Must convert units upon 

import. 

 Objects created in Pro/Engineer are General Trimmed Surfaces. Importing geometry with 

will require use of the tetmesh option in Patran in order to mesh correctly. 

 

References 

http://www.synthx.com/tom/sy_tips.htm - Library of Pro/Engineer Tips 

http://www.mcaduser.com/ - Library of Pro/Engineer Tips 

http://www.caddigest.com/subjects/pro_engineer/tutorials_proe.htm - Library of Pro/E Tips 

http://www.imakenews.com/ptcexpress/e_article001430549.cfm?x=bfvRfnG,b3jsqcsB,w – 

Geometric Tolerance in Pro/E [see www.engineersedge.com/gdt.htm for a list of Geometric 

Tolerance call-outs] 

http://www.ptc.com/appserver/wcms/standards/textmultitextimg.jsp?im_dbkey=13764&icg_dbk

ey=382&icg_dbkey=382 – Flexible components in Pro/E 

http://www.blbeach.com/proe_tips.html 

http://www.iheartrobotics.com/2009/02/proe-wildfire-tips-and-tricks.html 

2008_CON_3D_Design_Practices_Samuels.ppt  

http://www.sciencedirect.com/science?_ob=ArticleURL&_udi=B6V2D-49M6W42-

2&_user=521828&_coverDate=01%2F31%2F2004&_rdoc=1&_fmt=high&_orig=search&_sort

=d&_docanchor=&view=c&_searchStrId=1248708095&_rerunOrigin=google&_acct=C000059

579&_version=1&_urlVersion=0&_userid=521828&md5=bc45b34ee6a65c53380f67f5dae2b69

a#toc17 -  
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http://www.imakenews.com/ptcexpress/e_article000357760.cfm?x=b4nT7KG,b29hVpfK,w – 

Optimizing Memory Usage for Assemblies 

http://www.imakenews.com/ptcexpress/e_article000404998.cfm?x=b11,0,w – Checking for 

Clearance in an Assembly 

http://www.synthx.com/tom/sy_tip_0506.htm - Handling Scales in Assembly 

http://www.imakenews.com/ptcexpress/e_article000899504.cfm?x=b11,0,w – Decreasing 

Assembly Picks 

http://www.synthx.com/tom/sy_tip_0604.htm 

http://www.imakenews.com/ptcexpress/e_article000357760.cfm?x=b4nT7KG,b29hVpfK,w 

http://www.imakenews.com/ptcexpress/e_article000404998.cfm?x=b11,0,w 

http://www.synthx.com/tom/sy_tip_0506.htm 

PowerPoint 3D Design and Practices 

Pro/Engineer Wildfire ™ 3.0 Tutorial 

http://www-h.eng.cam.ac.uk/help/amb/programs/fe/prepost/patfaq/patranf1.html#Q1.5 

http://people.msoe.edu/~rizza/FAQ_for_MSC.html 

http://www-h.eng.cam.ac.uk/help/amb/programs/fe/prepost/patfaq/patranf6.html#Q6.13 

 

  



12 
 

III. PRO/ENGINEER MODEL [Jeffrey Ma] 

Parts list 
 

 From Boeing we received an indentured parts list. The parts list included the part level, 

part number, organization name and a nomenclature. The part level is to indicate what parts go in 

a subassembly whereas the part number identifies the part for quick reference. The organization 

name is used to identify the part under the organization in which it was manufactured from. The 

nomenclature describes what the part, or subassembly, is. To better manipulate the parts list we 

created our own parts list. Our parts list included the part number, part level and nomenclature 

but we also added an assignment column and a notes section. The assignment listed who the 

specific part was assigned to and whether or not the assignment was completed. A completed 

assignment would be colored green whereas an assignment „still-in-progress‟ would be colored 

orange. The notes section is to write down any notes about the specific drawing. Each group 

member was responsible for updating the parts list. 

 Our parts list proved to be very useful. It allowed us to know who worked on which 

drawing so that no two duplicated parts were generated by different team members. Also, the list 

allowed us to locate the part number easily as well as checking the description which allowed us 

to confirm the matching drawing. Another aspect of the parts list that helped was the part level. 

Instead of looking at many different assembly drawings, the part level allowed us to visualize the 

assembly and put together subassemblies. 

Spun Structure 

 As the project went on, we started to receive drawings for the spun structure only. Once 

we received these drawings we distributed the drawings to each group member. The more 

difficult drawings were assigned to the more experienced modelers. However, everyone had their 

fair share of drawings and difficulties.  

 For this project we have built two different models. One model is for display purposes 

only, whereas the other model is only used for analysis. The display model has every detail 

drawn into it. Every ground strap, shim and thread will appear in the display model. For the 

analysis model there will only be structure that is load bearing.  
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The analysis model will contain the four sections, 1) a cone, 2) a cylinder and two 

honeycomb sections. In addition to the four sections there are five rings that will not be imported 

from Pro/Engineer. These rings are the forward, intermediate, Apogee Kick Motor (AKM), 

Reaction Control System (RCS) and the separation ring.  
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IV. PREPARING MODEL FOR FEA [Richard Pelham] 

Rings 

 

Rings are not actually being used in PATRAN. Instead, bar elements are used to simulate 

each ring. An element in PATRAN is generated and then rotated around the axis of preference. 

These elements must be in the correct location and have the correct material properties and 

moments of inertia associated with the actual structure. From the Pro/E model, the position and 

moment of inertia of each of the rings was determined by taking the initial sketch of each ring 

(the cross sectional area), extruding the sketch on both sides of the sketch plane, and using the x-

section mass properties option. This option is located in the Analysis → Model tab. The radial 

center of gravity (CG) of the ring was used as the center of the bar element in PATRAN. The bar 

elements in the FEA model are located at the radial CG location for the physical ring it replaced. 

Material data sheets were used to find the material properties for each ring. 

 

Skins 

 

All of the skins used in PATRAN were modeled as surfaces at their neutral axis. The 

forward and intermediate skins are homogenous material, which means that the actual material 

thickness is also used for FEA. For the honeycomb skin, an equivalent thickness, density and 

Young‟s Modulus had to be calculated. The following equation was used to determine the 

equivalent core thickness, 

   

where tc is the actual thickness of the honeycomb, and t1 and t2 are the actual thicknesses of the 

face sheets. The following equation was used to determine the equivalent thickness,  

   

where  is the equivalent core thickness, and t1 and t2 are the face sheet thicknesses. The 

equivalent thickness was found to be 0.4364 in. We found the equivalent material volume is 

654.5956 in
3
. This gave us an equivalent density of 0.006379 lb/in

3
.  

The equivalent Young‟s Modulus was found using the following equation,  

   

where E is the actual Young‟s Modulus for the face sheets, and t1 and t2 are the face sheet 

thicknesses. This gave us an equivalent Young‟s Modulus of .60724E6. 
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V. PATRAN/FEA TUTORIAL [Kelly Cheng] 

Background & General User Tips 

In order to perform a finite-element analysis (FEA) on the thrust tube assembly of the 

spacecraft spun-section, the MSC FEA software suite was selected due to on-site availability and 

industry heritage. This section provides a step-by-step instruction guide for importing the 

equivalent thrust cylinder solid model, setting it up for test loads and accessing the results for 

plotting. 

NOTE: Patran version 2008r2 was the latest version of MSC Software’s pre/post-processing 

software available and was utilized for all work completed in this tutorial. Figures used in this 

tutorial represent a Patran interface that may vary for other versions of the software. 

A lot of notes like the one above have been included throughout the tutorial. Though 

these are not necessary to build the FEA model, reading these will help you understand the 

concepts behind why you are setting up the model the way you are. Please read this for a better 

background on the model and the Patran/Nastran software suite. More often than not, an error 

down the line could have been avoided earlier on by understanding why you are doing something 

rather than just blindly following this tutorial and making a minor mistake. 

The following is a brief summary of the 

workflow between Patran and Nastran, both of 

which will be utilized for our thrust tube 

analysis. Each step will be discussed in much 

more detail later in the report. The figure on 

the right details the overall workflow of the 

MSC software suite.
1
 

 The basic geometry created in 

Pro/Engineer and described in the 

previous section will first be imported 

into Patran.  

 Then, a finite-element mesh will be 

developed over the imported model.  

 Several test cases consisting of various 

boundary conditions and test loads will 

be inputted.  

 The proper material characteristics will 

be assigned to the proper shell and bar-

element regions.  
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 The pre-processed model will then be sent into the MD Nastran solver for computation.  

 The post-processed test results document can then be read by Patran and visual plots of 

the test report can be viewed for proper analysis. 

The equivalent geometry to be used for finite-element analysis (FEA) purposes will primarily 

consist of the 2D shell surfaces representing the three skin sections and 1D bar elements 

representing the rings between each skin section.  

The primary structure geometry created in Pro/Engineer will be imported into the MSC 

software suite in the IGES file format, .igs. The .igs neutral file format allows us to deliver 

geometries created in Pro/Engineer into Patran for use. This is necessary as we do not have the 

“ProEngineer Access” license for Patran to directly open model files. 

 

Property variations exist between .igs and other neutral formats such as .step. A whole 

chapter alone could be used to describe the nuances specific to each format. Simply put, .igs files 

operate correctly for our purposes on the type of equivalent geometry (shells, bars) that we have 

chosen for our model.  

Initially, the newer .step file type was used though we did not require the extra product 

information architecture aside from the geometry information.
2
 However, .step files began 

operating erratically when we switch from 3D solid geometry to 2D surface geometry as shown 

in the figure on the next page. When opened in PATRAN, these files would result in exploded 

shapes with strange curves. Thus, we returned to the older, more stable .igs files for the rest of 

this project. 

 



17 
 

There are a few good practices to bear in mind when utilizing the Patran software in order to 

work more efficiently. 

 Whenever an Application form is selected or any panel window is opened up, an Auto 

Execute box may be available for selection. Always ensure that this option is turned off. 

Otherwise, when any point, node, etc. is selected, the function may be applied without the 

user noticing causing confusion as well as unintentional changes to the model. 

 After certain objects are deleted or un-selected, the primary model graphic window may 

not display the change until the graphics are refreshed. This can be accomplished simply 

by rotating and adjusting the view of the model. 

 When possible, give unique IDs to your points and nodes in a method that will be easy 

for you to identify. Take note of this ID or the range of IDs that constitute a specific 

portion of the overall assembly model. This will provide for easier reference to 

appropriately select points, nodes or elements on the screen, when necessary. 

 

Now we have laid down some general rules and guidelines to follow when using this 

software suite. We will begin going into detail regarding the process of setting up and analyzing 

the FEA model specific to our project. 
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FEA Modeling – Starting 

Begin by accessing the MSC Patran 2008 r2 application and opening up a database file.  

1. Opening the Application 

Click Start → All Programs → MSC.Software → Patran 2008 r2 → Patran 2008 r2 

 

Note: Exact Patran application location may vary depending on user setup and directory 

selection during program installation. 

2. Creating a New Database File 

On the Main Menu bar, click File → New 

 

Select a directory location for the new database file and assign a file name. This database 

file will store all the physical model information, FEA mesh information, and any test 

Loads/BCs (boundary conditions) you have set. 
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Set database Tolerance → Default 

Set Analysis Code → MSC.Nastran 

Set Analysis Type → Structural 

Click OK to close the selection box. 

 

3. Importing the Geometry 

Click File → Import 

Set Object → Model 

Set Source → IGES 

 

Note: As previously explained, we will be importing geometry from Pro/Engineer using 

the IGES neutral file format. 

 

Search your local directory until you are in your parts folder. Find the IGES file 

containing the thrust tube assembly model and select it. 

 

 
 

Note: Please check to ensure that this is the equivalent 2D surface model version of the 

thrust tube assembly as detailed in the previous section. 

 

Click Apply. 

 

A successful IGES model import should result with the display of the assembly geometry 

in a green wireframe format. 
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FEA Modeling – Setting up the Analysis Model Parameters 

4. Creating a Cylindrical Coordinate System 

Select the Geometry Application form from the Patran Main form. 

Set Action → Create 

Set Object → Coord 

Set Method → 3Point 

Set Type → Cylindrical 

 

 
 

Note: The use of a cylindrical coordinate system will allow us to more easily define nodes 

and loading conditions relative to the imported spacecraft geometry later in the tutorial. 

 

Set Origin to [0, 0, 0] 

Set Point on Axis 3 to [0, 1, 0] 

Set Point on Plane 1-3 to [1, 0, 0] 

Click Apply. 

 

This will create a new cylindrical coordinate system (r,Θ,z) under the label “Coord 1” 

with the origin located at the true location of the center of the bottom separation ring. 

This will be spatially lower than the equivalent bar element representing the separation 

ring to be created later. We will use this new coordinate system frequently as it will often 

provide an easier frame of reference as we build our model. 
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5. Appending RCS Ring Cut to Imported Model Geometry 

 

The current imported model should have 6 surfaces representing three different sections 

on the spacecraft. In order to model the RCS ring axial location on the spacecraft, we will 

split a section‟s geometry into two to simplify locating and generating the ring elements. 

We will create a plane through the geometry to split the two sections.  

 

This plane will be based on a generated point and vector to be explained here. 

 

Select the Geometry Application form from the Patran Main form. 

Set Action → Create 

Set Object → Point 

Set Method → XYZ 

 

In Reference Coordinate Frame, type Coord 1. The reference coordinate frame for this 

point will be based about the cylindrical coordinate frame we created earlier. 

 

In Point Coordinates List, set parameter to [0 0 19.648]. This will generate a point on 

the axial (Z-axis) location of the structure where the RCS ring will be located. 

 

Click Apply to finalize the point creation. 

 

Set Action → Create 

Set Object → Vector 

Set Method → Magnitude 

 

In Reference Coordinate Frame, type Coord 1. The coordinate frame will once again 

be with respect to the cylindrical coordinate system we created. 

 

For Vector Direction List, set to <0 0 1>. This will set the vector to the axial Z-

direction. 

 

The Vector Magnitude List and Base Point List parameters should be left as their 

default settings, i.e. 1.0 and [0 0 0]. 

 

Click Apply to finalize vector creation. 

 

Now, we will use the point and the vectors to generate the plane with which to cut the 

lowest geometrical piece into two. 
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Set Action → Create 

Set Object → Plane 

Set Method → Point-Vector 

 

In the Point List and Vector List selection boxes, select or type in the last two 

geometries we just created. These should be Point 13 and Vector 1 (if you have been 

following the tutorial in order). 

 

Click Apply to generate the plane. The plane will be located normal to the Z-axial 

direction. Now we will use this plane to cut the bottom-third of the imported model. 

 

Set Action → Edit 

Set Object → Surface 

Set Method → Break 

Set Option → Plane 

 

Ensure that Delete Original Surfaces is selected. 

 

In Surface List, select the two surfaces located on the bottom third of the spacecraft or 

Surface 1 2 (if you have been following the tutorial in order). The two surfaces should be 

mirrored pieces that generate an expanding cylinder. 

 

In Break Plane List, select the recently created plane or Plane 1 (if you have been 

following the tutorial in order). This is the plane that Patran will use to break each of the 

old surfaces into two. 

 

Click Apply. 
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A text prompt will appear asking if you are sure to delete the original surfaces. Select Yes 

For All, so that the newly created surfaces aren‟t overlapped by the old surfaces. 

 

The successful alteration in the geometry should now result in eight total surfaces 

comprising our thrust tube assembly as shown in the image below. 
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6. Creating the Material Properties 

Select the Materials Application form from the Patran Main form. 

 

For each isotropic material to be created, the same basic steps 

will be followed… 

 

Set Action → Create 

Set Object → Isotropic 

Set Method → Manual Input 

 

In the Material Name box, enter the name of the material. 

 

Click Input Properties … 

 

In the Input Options box, set the specific property values.  

 

 
 

Enter relevant values for the Elastic Modulus, Poisson Ratio, Shear Modulus (if 

available), Density, Thermal Expansion Coefficient (if available) and Reference 

Temperature. 

 

Click OK to close the Input Options box. 

 

Click Apply to finalize the material creation. 

 

Three isotropic materials and their properties will be set: AL6061, AL7075, and the 

equivalent Honeycomb material. The Aluminum Alloy properties can be found from 

various online sources and the equivalent Honeycomb material property was extracted 

from calculations made based on the equivalent material properties. They are listed in the 

table below (on the next page) for convenience. 
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Table I – Spacecraft Relevant Material Properties 

 

Note: When creating the Honeycomb material, an error message will appear. Press Yes 

to continue. This message appears due to the fact that the material is not actually 

Isotropic. However, later we will modify the material properties to account for this fact. 

 

Repeat this process until all three Isotropic materials are created. 

 

Next, we will generate the 2D Anisotropic properties for the Honeycomb material. 

 

Set Action → Create 

Set Object → 2D Anisotropic 

Set Method → Manual Input 

In the Material Name box, type in the label Honeycomb_anisotropic. 

 

Click Input Properties to bring up the various parameters to set for the material. 

 

Enter the appropriate values for the material property, Gij, matrix for the Honeycomb 

material.  

 

In Stiffness 11, enter 27000. 

In Stiffness 22, enter 13000. 

 

Click Ok.  

Click Apply to finalize this material creation. 

 

Note: These values were obtained from calculations by Ray Ng, Boeing Space Systems. 

(raymond.w.ng@boeing.com, 310-364-5561)  

E, psi γ G, psi ρ, lb/in
3

CTE,in/in-°F Tref,°F

AL6061 1.00E+07 0.33 3.77E+06 0.0975 1.31E-05 68

AL7075 1.04E+07 0.33 3.90E+06 0.1020 1.31E-05 68

Honeycomb 1.05E+07 0.33 4.00E+06 0.1010 1.31E-05 68
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FEA Modeling – Creating and Setting the Element Properties 

7. Creating the Assembly Rings BAR Elements, Method (A) 

We will need to model five different ring structures that are fixed onto the skin currently 

modeled. These rings are on different Z-axial locations with respect to our cylindrical 

coordinate system.  

 

The rings will be designated as follows (from the forward-direction to the aft): Forward, 

Intermediate, AKM, RCS and Separation. The figure on the below details these 

designations. 

 

 
 

All five rings will be modeled using Bar-elements. However, due to the nature of the 

geometry, two different methods will be utilized to fully model all five rings. Though 

they will behave similarly in the final model, the method in which the Bar-element rings 

will attach to the skins will vary. 

 

First, a Bar-element ring will be overlaid right onto the geometry for three of the rings 

(Forward, RCS, and Separation) and, where appropriate, will have offset node vectors 

to simulate the behavior of the rings from their true location. We will designate this 

Method A. 

 

As the other two rings (Intermediate and AKM) exist at Z-axial locations between skin 

sections, they will have Bar-element rings created in floating space, not touching any 

geometry. These rings will not need any offset node vectors as they already exist on the 

neutral axis of the true ring location. We will designate this Method B. 
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We will generate the three overlaid rings first using Method A. The rings to be created 

are highlighted in the figure below.  

 

 
 

Begin by creating the nodes from the top layer of the Cone. 

 

Select the Elements Application Form from the Patran Main form. 

 

Set Action → Create 

Set Object → Node 

Set Method → Edit 

 

Ensure that Associate with Geometry has been selected. 

 

In Analysis Coordinate Frame and Coordinate Frame, select or enter Coord 1 to set 

the nodes to the cylindrical coordinate system. 

 

In the Node Location List, select or enter one of the point locations on the Z-axial skin 

location appropriate to the ring you are creating. This will be Point 11/Point 12 on the 

top level of the cone for the Forward ring (if you have been following the tutorial in 

order). 

 

Click Apply to finalize the node creation. 

 

To generate our first element, we will need at least two nodes. We have just created the 

first node. The second node will simply be a rotational transformation of the first node. 

 

Set Action → Transform 
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Set Object → Node 

Set Method → Rotate 

 

In Refer. Coordinate Frame, type Coord 1. 

 

In Axis, type Coord 1.2. This will allow for proper Z-axis node rotation based on our 

current coordinate system settings. 

 

Note: By connecting two nodes, we can generate a Bar-type element that will act as the 

rigid connection tying several node couples together. After generating a total of 72 

connected (each spaced five-degrees apart) bar elements, they will act as a rigid 

structure and simulate a structural ring. 

 

In the Rotation Parameters, select Rotation Angle and enter 5. Ensure Offset Angle is 

set to 0 and Repeat Count is set to 1.  

 

In the Node List, select or type in the first node you generated. This should be Node 1 (if 

you have been following the tutorial in order). 

 

Click Apply to generate the second new node. This will result in two nodes separated 

five-degrees apart from the center of rotation of the spacecraft.  

 

The Bar-elements for our first ring, the Forward ring, will now be created using the two 

nodes we have just generated. 

 

Set Action → Create 

Set Object → Element 

Set Method → Edit 

Set Shape → Bar 

Set Topology → Bar2 

Set Pattern → Standard 

 

We will need to generate the properties for the bar elements as they pertain to the 

characteristic of each ring. 

 

Select Create New Property. Ensure that Object has been set to 1D and Type has been 

set to Beam. Select the Property Set Name box and enter a proper title. 

 

Select Input Properties. 
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In order to select the proper Material Name, click the  icon and select the proper 

material type from the list. Refer to Table II below for the material type of each ring. 

 

 
Table II – Spacecraft Ring Method (A) Properties 

 

Scroll down to the Area input box as well as the Inertia matrix inputs (Inertia 1,1 2,2 

and 2,1). Enter the appropriate values based on the table above. 

 

Select the Bar Orientation box and enter <0,0,1> in order to create the Bar elements 

with the proper orientation,. 

 

Set both Offset @ Node 1 and Offset @ Node 2 to the vector value appropriate for the 

ring as shown in the table below. For example, the values <-0.074807,0,0.169395> would 

be inputted in this field for the Forward ring. All coordinate values are in the standard 

Coord 0 rectangular coordinate frame. 

 

 
Table III – Spacecraft Ring Method (A) Offset Locations

3
 

 

The standard skin callouts are shown in the figure below.  

 

 

Method A Material Area, in
2

Inertia 1,1 (Iyy) Inertia 2,2 (Ixx) Inertia 1,2 (Ixy)

Forward Ring AL7075 1.9554403E-01 2.0691743E-02 1.8052725E-02 1.7350595E-02

RCS Ring AL6061 1.0116500E-01 1.2025430E-02 5.6087391E-03 8.2344979E-04

Separation Ring AL7075 7.6807750E-01 6.0103882E-01 8.1954054E-02 -3.3276043E-02

Method A X, in Y, in Z, in Referenced from…

Forward Ring -0.074807 0 0.169395 CONE (Top)

RCS Ring -0.481865 0 0.000000 HONEYCOMB (1) (Bottom), (2) (Top)

Separation Ring 0.037298 0 -1.007419 HONEYCOMB (2) (Bottom)
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Click Ok. Select Apply to finalize your property creation. 

 

For Node 1, select or type in the ID of one of the newly created nodes. 

For Node 2, select or type in the ID of the other newly created node. 

 

Click Apply to create the first Bar element, shown as a yellow curve in the displayed 

figure below. 

 

 
 

Now we will need to replicate this five-degree bar element 72-times in order to get the 

full circular ring. 

 

Set Action → Transform 

Set Object → Element 

Set Method → Rotate 

 

Once again set the Refer. Coordinate Frame to Coord 1 and set the Axis to Coord 1.2 

for proper functionality. 

 

In the Rotation Parameters box, set Rotation Angle to 5 for a five degree rotation 

again. Next, set Repeat Count to 71 as we will need 71 additional five-degree elements 

to generate a complete ring. 
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Click the Element List box and either select or type in the ID of the newly created Bar 

element. 

 

Click Apply to generate the first full ring made up of 72 Bar-elements. An example of a 

successfully generated ring is shown in the figure below. 

 

 
 

Note: You may notice that this will generate several overlapping nodes. However, we can 

take care of all the overlapping nodes and elements later using the equivalence function. 

Thus, we can ignore this issue for now. 

 

Repeat the process for the RCS ring between Honeycomb (1) and Honeycomb (2) and 

again for the Separation ring at the bottom layer of the Honeycomb (2) section.  

 

Although some of the configuration for generating and transforming the points and nodes 

will remain the same, slow down to check/ensure that all coordinate frames and other 

parameters are what they should be. 
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After all three rings structures have been placed on the assembly model, the model look 

similar to the figure below. 

 

 
 

8. Creating the Assembly Rings BAR Elements, Method (B) 

 

We will now generate the two remaining ring elements. The two remaining rings lie 

floating between the three main skin sections of the spacecraft. 

 

 
 

Select the Geometry Application Form from the Patran Main form. 
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First, it is necessary to create floating geometric 

points that will locate the nodes of the ring 

structure. We will do this by transforming points a 

specific distance from the edge of the ring‟s 

closest skin structure. 

 

Set Action → Transform 

Set Object → Point 

Set Method → Translate 

 

In Type of Transformation, set option to 

Curvilinear in Reference Coordinate Frame. 

 

In Reference Coordinate Frame, type Coord 1. 

The reference coordinate frame for this point will 

be based about the cylindrical coordinate frame we 

created earlier. 

 

In Translation Vector, an offset vector should be inserted based on which ring element 

the user is creating. The values for both remaining rings can be found in the following 

table. 

 

 
Table IV – Spacecraft Ring Method (B) Offset Locations [Reference 4.3] 

 

Note: The imported solid model will have 4 points for the each of the three different skin 

layers (this is not exactly true with the honeycomb skin as we have further split that 

surface into multiple pieces). We will split and designate two of these points for the top 

level and two for the bottom level of each skin. You can see this in the figure below as 

each layer of the assembly skin is split into two halves of a cylinder. The corners of these 

geometries are what constitute the two points at the top and bottom of the skin section. As 

long as the correct point for the level is selected, it does not matter which of the two 

points you designate. The honeycomb section is split using one curve and so the two 

honeycomb layers should meet at the same points. 

 

Note: The Patran interfaces often acts strangely and does not allow you to use your 

mouse to select a point even though it is very much there. You will need to find the Point 

ID number using Action → Show and manually input it into the Point List. 

Method B X, in Y, in Z, in Referenced from…

Intermediate Ring -0.163711 0 0.034856 CYLINDER (Top)

AKM Ring 0.014453 0 -0.241312 CYLINDER (Bottom)
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In Point List, we will select the point that the offset point will be generated from as 

shown in the “Referenced from…” column of the table above. The standard skin 

callouts used are once again displayed in the figure below. 

 

 
 

Click Apply to create the floating point which represents a point on the neutral axis of the 

yet-to-be created ring. 

 

 
 

Note: Keep track of the Point ID you have just created. Using Action: Show, Object: 

Point and Info: Location, you can verify that the point you have created is where it 

should be. Note the coordinate location of the point as well as the graphical location on 

the model. 
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Now, we will create the node and bar elements for the ring from the newly created 

geometric point.  

 

Select the Elements Application Form from the Patran Main form. 

 

Set Action → Create 

Set Object → Node 

Set Method → Edit 

 

For both Analysis Coordinate Frame and Coordinate Frame, type Coord 1. Now all 

analysis and coordinate frames will for these rings will automatically be set in the 

cylindrical coordinate system. 

 

In Node Location List, select or type in your newly created point. This should be Point 

16 (if you have been following the tutorial in order). 

 

Click Apply to generate the new node. 

 

To generate our first element, we will once again need to make a rotational 

transformation of the first node. This will generate the second node and give us two 

nodes to make the element with. 

 

Set Action → Transform 

Set Object → Node 

Set Method → Rotate 

 

In Refer. Coordinate Frame, type Coord 1. 

 

In Axis, type Coord 1.2. This will allow for proper Z-

axis node rotation based on our current coordinate 

system settings. 

 

In the Rotation Parameters, select Rotation Angle 

and enter 5. Ensure Offset Angle is set to 0 and 

Repeat Count is set to 1.  

 

In the Node List, select or type in the first node you 

generated. 

 

Click Apply. 
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This will create two nodes separated five-degrees apart from the center of rotation for the 

spacecraft.  

 

Note: By connecting these two nodes, we can generate a Bar-type element that will act as 

the rigid connection tying several node couples together. After generating a total of 72 

connected (each spaced five-degrees apart) bar elements, they will act as a rigid 

structure and simulate a structural ring. 

 

Set Action → Create 

Set Object → Element 

Set Method → Edit 

Set Shape → Bar 

Set Topology → Bar2 

Set Pattern → Standard 

 

We will need to generate the properties for the bar elements as they pertain to the 

characteristic of each ring. 

 

Select Create New Property. Ensure that Object has been set to 1D and Type has been 

set to Beam. Select the Property Set Name box and enter a proper title. 

 

Select Input Properties. 

In order to select the proper Material Name, click the  icon and select the proper 

material type from the list. Refer to Table III below for the material type of each ring. 

 

 
Table V – Spacecraft Ring Method (B) Properties 

 

Scroll down to the Area input box as well as the Inertia matrix inputs (Inertia 1,1 2,2 

and 2,1). Enter the appropriate values based on the table above. 

 

Select the Bar Orientation box and enter <0,0,1> in order to create the Bar elements 

with the proper orientation,. 

 

Set Offset @ Node 1 and Offset @ Node 2 both to <0,0,0>.  

 

Method B Material Area, in
2

Inertia 1,1 (Iyy) Inertia 2,2 (Ixx) Inertia 1,2 (Ixy)

Intermediate Ring AL6061 9.7129774E-02 3.0130727E-03 2.5698090E-02 -7.7238827E-03

AKM Ring AL7075 4.1226461E-01 5.6739987E-02 7.7814579E-02 9.5608966E-03
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Note: Structural analysis pertaining to these two specific rings will be analyzed at the 

neutral axis where they have been already placed from the offset locations given. Thus, 

no offset values from the existing nodes need to be inputted in this field. 

 

Click Ok. Select Apply to finalize your property creation. 

 

For Node 1, select or type in the ID of one of the newly created nodes. 

For Node 2, select or type in the ID of the other newly created node. 

 

Click Apply to create the first Bar element shown as a yellow curve in the displayed 

figure below. 

 

 
 

Similar, to the method used for the previous three rings, we will replicate this five-degree 

bar element 72-times in order to get the full circular ring. 

 

Set Action → Transform 

Set Object → Element 

Set Method → Rotate 
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Once again set the Refer. Coordinate Frame to Coord 1 and set the Axis to Coord 1.2 

for proper functionality. 

 

In the Rotation Parameters box, set Rotation Angle to 5 for a five degree rotation 

again. Next, set Repeat Count to 71 as we will need 71 additional five-degree elements 

to generate a complete ring. 

 

Click the Element List box and either select or type in the ID of the newly created Bar 

element. 

 

Click Apply to generate the first full ring made up of 72 Bar elements. An example of a 

successfully generated floating ring is shown in the figure below. 

 

 
 

Note: You may notice that this will generate several overlapping nodes. However, we can 

take care of all the overlapping nodes and elements later using the equivalence function. 

Thus, we can ignore this issue for now. 

 

Now, you will need to repeat this complete process for the other ring (the AKM ring) 

using its respective values. Although some of the configuration for generating and 

transforming the points and nodes will remain the same, check to ensure that all 

coordinate frames and other parameters are what they should be. 
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After all five rings have been successfully generated, 

the Patran assembly model will look like similar to 

the figure on the right. 

 

Although all five sets of rings have been generated 

physically, using the Transform function to generate 

these elements does not also Transform the 

properties of the original element at each ring. 

However, now that we have generated each of the 

Properties for the five rings, we can re-designate the 

applicable region from one Bar-element to all 72-

elements for each ring structure. 

 

Select the Properties Application Form from the Patran Main form. 

 

Set Action → Modify 

Set Object → 1D 

Set Type → Beam 

 

In the Sets By list, select a specific ring which will open up the Modify Properties 

screen. Although we need to select the specific Property Set Name, we do not need to 

alter any of the previously defined properties. Select Ok to close this screen. 

 

Click the Select Application Region box, to open up the applicable region for the 

selected property.  

 

For each ring entity, there should only be one existing applicable region already inputted. 

We will need to type in and append the Application Region with the other 71-element 

IDs for each ring. For example, the Forward Ring will be modified from Element 1 to 

Element 1:72 (if you have been following the tutorial in order). 

 

Note: In the current version of the software, only Surfaces, not Elements, can be 

selected. Regardless, the Element IDs can be typed in manually. 

 

Click Add to append the newly selected members onto the original single Element ID. 
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Click Ok to confirm the new selection. 

 

Click Apply to confirm modification of all 72-elements with the selected property set. 

 

Repeat this process for all five sets of rings. The table below will assist in entering 

Element IDs for each unique ring structure. 

 

Note: Depending on the order in which you created the rings, the Element IDs may be 

different in your case. These should be the appropriate ID values if you have been 

following this tutorial in order. Regardless each Ring should have exactly 72 Element 

IDs corresponding to it. 

 

 
Table VI – Ring-Specific Element IDs 

 

Note: After modifying the properties of these rings, take the time to use the Action: Show, 

Object: Element, Info: Attributes and select one of the non-original Bar-elements to 

ensure that the ring properties for all five rings have indeed been updated. 

 

  

Element IDs

Forward Ring 1:72

Intermediate Ring 217:288

AKM Ring 289:360

RCS Ring 73:144

Separation Ring 145:216
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9. Creating the Skin Surface Mesh Elements 

Now to create the Quad mesh elements using a mesh seed to line the geometry. This 

mesh seed basically outlines how many interior mesh elements will exist for every curve. 

 

Note: Quad elements were chosen rather than triangular due to the rectangular overall 

shape of our structure. As such, Quad elements would provide for cleaner mesh seeding 

and a simple uniform mesh-element model. 

 

Select the Elements Application Form from the Patran Main form. 

Set Action → Create 

Set Object → Mesh Seed 

Set Type → Uniform 

 

Note: The total number of mesh elements around the edge of every skin layer will need to 

match the total number of bar elements. 72 mesh seeds will allow for a five-degree 

rotational separation similar to the ring nodes we created earlier. As a full revolution of 

each edge of the four spacecraft skins (Cone, Cylinder, Honeycomb(1) and (2)) consists 

of two surfaces, we will create a mesh seed of length 36 for each of these curve-halves. 

 

Ensure that the Number of Elements button is selected.  

 

In the Number entry box, type in 36. 

 

In the Curve List, select or type in the highest Z-axial curve-edge of the Cone skin. This 

should be either Surface 5.3 or Surface 6.3. 

 

Click Apply to generate the 36-element mesh seed. 

 

These seeds should lie right on top of the individual nodes we transformed earlier to 

generate the Bar-elements. 
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Now, we will need to complete the mesh seed around this edge surface. In the Curve List 

box, select the other portion on the same Z-axial plane. Click Apply to generate another 

36-element mesh seed and complete the mesh seed generation on this level. The figure 

below shows a completed mesh seed for the top-portion of the Cone skin. 
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Repeat this process for all remaining horizontal-XY portions, generating 2x 36-mesh 

seeds for every level. Altogether, there will exist 72-mesh seeds on: the top/bottom of the 

Cone, top/bottom of the Cylinder, top of Honeycomb(1) and bottom of Honeycomb(2).  

 

The table below will guide you in correctly selecting the surface edges on each level. For 

every new mesh seed, input the proper surface ID into the Curve List entry box. 

 

 
Table VII – Horizontal Mesh Seed Surface Designations 

 

Note: The surfaces designated by the above table will only be accurate if you have been 

following this tutorial in order. Regardless, as a few of these floating edge surfaces lie 

very close to each other, caution should be taken to ensure the correct edge is inputted. 

 

An image of a fully-seeded assembly is shown in the figure below. 

 

 
 

Next, we will need to create the vertical mesh-seed elements. 

 

In the Number entry box, enter in the appropriate number of vertical mesh seeds based 

on the edge you are applying it to. This will need to be done twice for each of the four 

Mesh Seed 1st Surface-Half 2nd Surface-Half

CONE (Top) Surface 5.3 Surface 6.3

CONE (Bottom) Surface 5.1 Surface 6.1

CYLINDER (Top) Surface 3.3 Surface 4.3

CYLINDER (Bottom) Surface 3.1 Surface 4.1

HONEYCOMB (1) (Top) Surface 8.3 Surface 10.3

HONEYCOMB (2) (Bottom) Surface 7.1 Surface 9.1
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skin layers. The specific surface ID and number of seed elements on each skin is given in 

the table below. 

 

 
Table VIII – Vertical Mesh Seed Surface Designations 

 

Note: As the surfaces overlap at every vertical edge, each vertical edge will have two 

surface designations. Selecting either edge surface ID will work correctly. However, only 

one set of surface IDs has been chosen to be displayed in this table to reduce confusion. 

 

The figure below illustrates the assembly seeded for both vertical and horizontal edges. 

 

 
 

Note: The vertical mesh seeds on our model do not line up as shown in the figure above. 

This will not negatively impact the analysis due to the fact that these vertical mesh seeds 

will eventually generate mesh elements that are still equally spaced. 

 

Now to use the mesh seed outline to generate the actual meshes across the skin. 

 

Set Action → Create 

Set Object → Mesh 

Set Type → Surface 

 

Mesh Seed 1st Surface-Half 2nd Surface-Half # of Elements

CONE Surface 5.2 Surface 5.4 15

CYLINDER Surface 3.2 Surface 3.4 10

HONEYCOMB (1) Surface 8.2 Surface 8.4 7

HONEYCOMB (2) Surface 7.2 Surface 7.4 13
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Set Elem Shape → Quad 

Set Mesher → IsoMesh 

Set Topology → Quad4 

 

Ensure that the Automatic Calculation button has been selected in the Global Edge 

Length parameter box. 

 

Click on the Node Coordinate Frames button. 

Set Analysis Coordinate Frame and Reference Coordinate Frame both to Coord 1 to 

set all created meshes with respect to the cylindrical coordinate frame. 

Click Ok. 

 

Note: Similar to how we previously generated properties for our 1D-Bar elements, we 

will need to generate properties for the 2D-Shell elements we are about to assign onto 

our QUAD4-Mesh elements. 

 

Click Create New Property to bring up the properties interface. 

Enter the appropriate title into the Property Set Name text box. 

Ensure that Object has been set as 2D. Also, ensure that Type has been set to Shell. 

 

We will now create the homogeneous (forward and intermediate) skins, beginning with 

the Forward_Skin_Cylinder section. Under the Options selection boxes, select the 

appropriate option based on the respective properties of the skin being assigned as 

designated in the table below. 

 

 
Table IX – Homogeneous 2D Shell Properties 

 

As shown for the Forward and Intermediate skins, the Options will be set as: Thin, 

Homogeneous and Standard Formulation. 

 

Click Input Properties to open up the 2D-Shells property settings. 

 

For Material Name, click the  icon and select the appropriate material type from the 

list based on the table above. 

 

Thin, Homogeneous, 

Standard Formulation
Material

Material 

Orientation
Thickness, in Plate Offset

Forward_Skin_Cylinder AL7075 0 0.032 0

Intermediate_Skin_Cylinder AL7075 0 0.200 0
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In the Material Orientation field, enter in the appropriate value and click on the Value 

Type dropdown button and select Real Scalar (from CID). 

 

Also, enter in the proper values for Thickness and Plate Offset. 

 

Click Ok to confirm property settings. 

Click Apply to confirm property creation. 

 

Select the Surface List field and use your mouse to 

drag-and-drop over a skin section as illustrated in the 

figure to the right.  

 

For the Forward_Skin_Cylinder section, Surface 5 6 

should be selected or entered into the Surface List box 

designating both of these geometric surfaces. 

 

Click Apply to create the first meshed surface over the 

Forward_Skin_Cylinder. 

 

Repeat the preceding process with the Intermediate_Skin_Cylinder using its respective 

properties and surface IDs, Surface 3 4. 

 

Now, in order to create the surface mesh for the Honeycomb skin we will need to slightly 

adjust the property configuration. 

 

Click the Create New Property box. 

 

In the Options selection, change the second input box to 

Equivalent Section (from Homogeneous) to model an 

equivalent composite section. 

 

Enter a proper title for the Honeycomb panel in the Property Set Name. 

 

Once again, click Input Properties to open up the property settings. 

Fill in the various parameters following the information in the table below. 
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Table X – Equivalent Section 2D Shell Properties 

 

Remember to change the Material Orientation dropdown parameter to Real Scalar 

(from CID) again. 

 

Click Ok to finalize the Honeycomb skin‟s shell Input Properties. 

 

Click Apply to confirm property creation. 

 

In the Surface List field, use your mouse to drag-and-drop 

over both Honeycomb(1) and Honeycomb(2) sections as 

shown in the figure to the right. This should select the four 

honeycomb skin surfaces in the entry field, Surface 7:10 (if 

you have been following the tutorial in order). 

 

Click Apply to create the surface mesh across the Aft 

Honeycomb skin section. 

 

Successfully surface meshing the entire thrust tube assembly should result in a model 

similar to the figure below. 

 

 

Thin, Equivalent Section, 

Standard Formulation

Membrane 

Material

Bending 

Material

Shear 

Material

Material 

Orientation
Thickness, in

Honeycomb

_Panel

Honeycomb_

Panel

Honeycomb

_Anisotropic
0 0.025

Bending 

Stiffness

Thickness 

Ratio
Plate Offset Fiber Dist. 1 Fiber Dist. 2

333.6 10 0 0.141 -0.134

Aft_Cylinder_Honeycomb
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10. Equivalencing the Model (First-Time) 

As indicated earlier, the Bar/Quad elements creation has generated a large number of 

redundant nodes in our model. These accumulated redundancies can be quickly resolved 

by using the Equivalence function in Patran. 

 

Select the Elements Application Form from the Patran Main form. 

Set Action → Equivalence 

Set Object → All 

Set Method → Tolerance Cube 

 

Click Apply to equivalence the entire model. Several hundred nodes should be deleted. 

 

 
 

Note: When you equivalence using these settings, you do not need to select anything on 

the model as the entire model is equivalenced.  
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FEA Modeling – Tying the Model Together Using MPCs 

11. Integrating the Spacecraft Structure using Multi-Point Constraints 

We will now begin utilizing a new type of element in Patran called the multi-point 

constraint or MPC. A wealth of information is publicly available regarding the different 

types of MPCs and their various nuances. However, for the purpose of this project, all 

the user needs to know is that we will be utilizing the RBE2-type of MPC to tie grids 

together for two primary purposes: 

 

a) Tie the furthest forward/aft sections at a point about the center of rotation of 

the spacecraft. This will allow for a single load or boundary-condition to be 

placed at a single point rather than splitting into multiple conditions across the 

outer edges of the cylinder. 

 

b) Assemble and tie the floating Intermediate and AKM rings with their 

neighboring skin sections. This will allow for loads/displacements to be 

transferred across the assembly structure despite the geometry/nodes not being 

physically connected. 

 

Note: RBE2 MPCs have been chosen as they fulfill our requirements. There will be one 

independent grid-node (with all six degrees-of-freedom) and may have one or more 

dependent grid-nodes (with a set number of degrees-of-freedom). The RBE2 allows us to 

rigidly tie, or “weld”, multiple nodes to one other grid point.
4
 

 

12. Applying Multi-Point Constraints (MPCs) to the Model, Part A 

We will begin with the first type: creating a “spider-web” MPC-element that will allow 

us to place a single Load or Boundary-Condition along the axis-of-rotation of the 

spacecraft. To do this, we will create and place two nodes at the center of the actual 

physical location of the Forward Ring and the Separation Ring. 

 

Select the Geometry Application Form from the Patran Main form. 

Set Action → Create 

Set Object → Point 

Set Method → XYZ 

 

In Reference Coordinate Frame, enter or type in Coord 1 to select the cylindrical 

coordinate system. 

 

In Point Coordinates List, enter the central location of a ring. This will be [0 0 Z-

location] where the Z-axial location is with respect to which Ring you are generating, 

based on the table below.  
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Table XI – Cylindrical Z-axis Coordinate Location of Rings 

 

Click Apply to generate the Point. 

 

Select the Elements Application Form from the Patran Main form. 

Set Action → Create 

Set Object → Node 

Set Method → Edit 

 

In Analysis Coordinate Frame and Coordinate Frame, set to Coord 1 to utilize the 

cylindrical coordinate frame for the node we will create. 

 

In the Node Location List, enter or select the Point we just created. 

 

Click Apply to generate the Node. 

 

Note: Now, we will create the MPC tying the newly created floating Ring Node to the 

Nodes surrounding the top or bottom skin structures. 

 

Set Action → Create 

Set Object → MPC 

Set Type → RBE2 

 

Select the Define Terms… button to open up the MPC Node definition box.  

 

Note: For tying the two RBE2 nodes together, the choice of independent and dependent 

node is not relevant. However, for the sake of consistency, the independent node will be 

the floating ring node and the dependent nodes will be the adjacent skin node. 

 

Select the Create Independent button. 

In the Node List selection box, select the Node you have just created (that represents the 

center of the true physical location of the ring). 

Click Apply to add this node onto the Independent Terms list. 

 

Select the Create Dependent button. 

Z-location

Forward Ring 60.272606

Separation Ring 1.1925808
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Ensure that all six degrees-of-freedoms (UX, UY, UZ, RX, RY, RZ) are selected in the 

DOFs selection box. 

 

In the Node List selection box, type in the Node IDs for all the nodes on the skin 

adjacent to the floating node. This will be all 72 nodes surrounding either the [Forward 

Ring Bar-element/Forward Cone] or the [Separation Ring Bar-element/Honeycomb 

(2)]. You may need to use the Action: Show, Object: Node, Info: Location function to 

find the exact IDs of these Nodes. Any node IDs shown in the format x:y:z (i.e. 2:142:2 

in the example on the figure below) is interpreted as the Node IDs from x to y, counted in 

intervals of z.  

 

 
 

Note: At this point, after equivalencing and deleting various nodes, the exact list of Node 

IDs may not be immediately intuitive. By creating the Bar-elements using the Transform 

method, the second point in a bar, n, also has the first point in the next bar, n+1, that 

overlaps its location. This is the reason why, after equivalencing, the Node IDs will no 

longer be in simple sequential order (i.e. Nodes 1:72). Instead, the Node IDs will be in a 

range greater than 72 and in intervals of greater than 1 (the example in the figure above 

shows IDs from 2 to 142 in intervals of 2 or 2,4,6….142). However, you’ll notice Node 

ID 1 and 2:142:2 still come out to exactly 72 Nodes. 

 

Inputting the proper ID list into this parameter is imperative. 

 

Click Apply to add these 72 nodes onto the Dependent Terms list. 
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Click Cancel to close the term definition box. 

 

Click Apply to finalize creation of the MPC.  

 

 
 

Successfully generating this MPC should result in a “Spider-Web” looking, purple-

colored element. 

 

If you have generated the forward-MPC, you will now need to repeat the process for the 

aft-MPC and vice versa. After generating both sets of MPCs, the model should look 

similar to the figure below.  

 

Note: Now the model can have a Load or Boundary-Condition placed at the central 

Independent Node and distribute it over the tied Dependent Nodes on the outer cylinder 

edges of the assembly skin. 
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13. Applying Multi-Point Constraints (MPCs) to the Model, Part B 

Now we will create MPCs that integrate the skin structures together so that a load will be 

seen contiguously through the entire spacecraft assembly. 

 

Select the Elements Application Form from the Patran Main form. 

Set Action → Create 

Set Object → MPC 

Set Type → RBE2 

 

Select the Define Terms… button to open up the MPC Node definition box. For tying 

the floating ring with the two nearby skins, the independent node will be the ring node 

and the dependent nodes will be the two adjacent skin nodes. 

 

Select the Create Independent button. 

In the Node List selection box, select a Node from one of the two floating rings, 

Intermediate and AKM, not tied to any skin nodes. 

Click Apply to add this node onto the Independent Terms list. 

 

Select the Create Dependent button. 

Ensure that all six degrees-of-freedoms (UX, UY, UZ, RX, RY, RZ) are selected in the 

DOFs selection box. 

In the Node List selection box, either type in or select (using Shift+Left-Mouse-Button) 

two adjacent skin Nodes to the Independent Node just selected: one from a skin 

structure above and one from a skin structure below. 

Click Apply to add these two nodes onto the Dependent Terms list. 
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Select Cancel to close the term definition box. 

 

Click Apply to finalize creation of this MPC. 

 

 
 

Note: You will notice that we cannot use the Transform function to rotate-and-clone the 

MPC-elements around the cylinder. However, there is another function in Patran that 

allows us to create a Group out of any type of entity whether that is a Point, a Node, an 

Element, an MPC, etc. Using a created Group, we may Transform and clone this entity 

with all its properties intact. 

 

On the Main Menu bar, click Group → Create… 

In New Group Name, give the MPC an appropriate title. 

Click in the Entity Selection box and select or enter the previously created MPC. This 

should be Mpc 3 for the first MPC created in this section of the tutorial (if you have been 

following this tutorial in order). 

Click Apply to finalize the creation of this Group. 

 

Note: Now to Transform and rotate this single-MPC Group 71 times. 

 

On the Main Menu bar, click Group → Transform… 

Set Action → Transform 

Set Method → Rotate 

 

Ensure that the appropriate ring MPC is selected in Selected Group(s). 

 

We will be copying the MPC every five-degrees, seventy-one times around the 

cylindrical axis to create an MPC at every node on the Ring BAR elements. 
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Select the Copy button as we will be rotating and copying this RBE2 MPC. 

In the number of Time(s) entry box, type in 71. 

 

In Reference Coordinate Frame, type Coord 1 to reference the transformation to the 

cylindrical axis we created earlier. 

In Axis, type Coord 1.2. This will allow for proper Z-axis node rotation based on our 

current coordinate system settings. 

 

In Rotation Parameters, we will transform and copy this MPC every five-degrees. In 

Rotation Angle, set to 5. 

 

Click Apply to finalize the MPC transform process. 

 

 
 

If you have tied the Skin and Ring Elements with the 

MPC for the Intermediate Ring, you will now need to 

do this same procedure for the AKM Ring, or vice-

versa. 

 

Completing this process, should result in a total of 146 

MPCs that tie all the Skin and Ring Elements 

together. A correctly tied thrust tube assembly model is 

shown in the figure to the right.  

 

The RCS Ring is already directly integrated with 

nodes on the skin and so it does not need a tied MPC 

as with the other Ring Elements. 

 

The thrust tube assembly model is now completed and 

ready for analysis. 
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14. Equivalencing the Model (Second-Time) 

Similar to the previous time we used the equivalence function to rid redundant nodes 

after Bar/Quad element creation, we will need to utilize the function again after MPC 

cloning. The Group Transform for creating our MPCs has also generated a large 

number of redundant nodes in our model which will again be eliminated using the 

Equivalence function. 

 

Select the Elements Application Form from the Patran Main form. 

Set Action → Equivalence 

Set Object → All 

Set Method → Tolerance Cube 

 

Click Apply to equivalence the entire model. Several hundred nodes should be deleted. 
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FEA Modeling – Setting up the Analysis Conditions 

15. Setting up the Test Analysis Loads and Boundary Conditions 

We will now create a set of unit-load test cases in order to ensure that the model has been 

created properly. A single force or moment on each axis provides a simple test case to 

ensure that the model is operating appropriately. Any incorrectly floating nodes or 

improperly modeled MPCs will become immediately apparent as the model will twist or 

bend in a strange manner. 

 

We will be creating 6 Load Cases: one unit-load case for each axis for both force and 

moment. Each of these unit-load cases will consist of the same Displacement Boundary 

Condition and six different 1000lb or 1000in-lb Force/Moment Load Conditions.  

 

The procedure for setting this up properly is as follows:   

 

1) Create the individual forces, moments or displacement boundary 

conditions using the Loads/BCs Application Form 

 

2) Create a test case scenario using multiple loads and/or boundary 

conditions using the Load Case Application Form 

 

The six different Force/Moment Load Conditions are shown in the table below. 

 

 
Table XII – Individual Unit-Force Loads and Moments 

 

Select the Loads/BCs Application Form from the Patran Main form list. 

Set Action → Create 

Set Object → Force 

Set Type → Nodal 

 

In the New Set Name, enter an appropriate label for the specific load. (i.e. XForce for the 

1000lb load on the X-axis) 

 

X_Force Y_Force Z_Force X_Moment Y_Moment Z_Moment

Force < 1000, 0, 0 > < 0, 1000, 0 > < 0, 0, 1000 > < 0, 0, 0 > < 0, 0, 0 > < 0, 0, 0 >

Moment < 0, 0, 0 > < 0, 0, 0 > < 0, 0, 0 > < 1000, 0, 0 > < 0, 1000, 0 > < 0, 0, 1000 >

Analysis 

Coord Frame
Coord 0 Coord 0 Coord 0 Coord 0 Coord 0 Coord 0

1000LBS Unit-Force Loads
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Select the Input Data button to enter in the appropriate data from the table above 

specific to the load case you are setting up. Fill in values for Force, Moment and 

Analysis Coordinate Frame. 

 

Click Ok to finalize the inputs. 

 

Click on the Select Application Region to choose where the unit-load will be placed 

relative to the assembly structure.  

 

On the top of the screen, enter the Select scroll-down menu to choose which type of 

property will be allowable for application region selection. Select FEM from the 

selection choices. 

 

ALL loads will be located at the center of the MPC on the Forward Ring. Either select 

this node manually or enter it in to the Select Nodes field. This should be Node 4339 (if 

you have been following this tutorial in order). 

 

Click Add to add the node into the application region list. 

 

 
 

Click Ok. 

 

Click Apply to finalize the first load creation. 
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Repeat this process for the other five loads. Keep in mind that the displayed 

forces/moments on the screen will begin to look strange as soon as you have created two 

Loads/BCs. This is because as you are creating each load into a Default Load Case, 

they will display as a sum of all combined Loads. Don‟t worry about this as we will be 

separating these loads into specific Load Cases so that analysis will be performed one 

load at a time. 

 

The Displacement Boundary Condition will remain the same for all six Load Cases is 

shown in the table below. 

 

 
Table XIII – Displacement Boundary Condition 

 

Select the Loads/BCs Application Form from the Patran Main form list. 

Set Action → Create 

Set Object → Displacement 

Set Type → Nodal 

 

In the New Set Name, enter an appropriate label for the boundary condition we are 

creating. (i.e. UnitLoad_BC) 

 

Select the Input Data button to enter in the appropriate data from the table above for the 

Translations

Rotations

Analysis 

Coord Frame

Displacement BC

< 0, 0, 0 >

< 0, 0, 0 >

Coord 1
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boundary condition we are setting up. Fill in values for Translations, Rotations and 

Analysis Coordinate Frame. 

 

Click Ok to finalize the inputs. 

 

Click on the Select Application Region to choose where the boundary condition will be 

placed relative to the assembly structure.  

 

On the top of the screen, enter the Select scroll-down menu to choose which type of 

property will be allowable for application region selection. Select FEM from the 

selection choices. 

 

The boundary condition will be located at the center of the MPC on the Separation 

Ring. Either select this node manually or enter it in the Select Nodes field. This should 

be Node 4340 (if you have been following this tutorial in order). 

 

Click Add to add the node into the application region list.  

 

Click Ok. 

 

Click Apply to finalize creation of our test boundary condition. 
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16. Creating the Load Cases for Model Analysis 

Note: Now we can begin using the loads and boundary conditions we have just created 

and integrating them together to form a Load Case for NASTRAN analysis. 

 

Select the Load Cases Application Form from the Patran Main form list. 

Set Action → Create 

 

Enter an appropriate for the Load Case Name based on the type and direction of load 

you are about to set. (i.e. XForce_1000lbs). 

 

Click the Input Data button to select which loads and boundary conditions will be 

utilized by the load case. 

 

In the Select Individual Loads/BCs selection area, choose one load and the boundary 

condition for one of the six different unit loads to be tested. After being selected, the load 

or boundary condition will appear on the Assigned Loads/BCs area at the bottom of the 

Input Data screen. 

 

Note: The labels of all loads and boundary conditions will be in the format 

Displ_[YourLabel] for displacement boundary conditions and Force_[YourLabel] for 

loads. For every load case, there should only be two items placed in two rows of the 

spreadsheet. If you accidentally select the wrong load, click that load on the spreadsheet 

and click the button at the bottom titled Remove Selected Rows. 

 

 
 

Click Ok once you have finished load and boundary condition assignments for your first 

Load Case. 
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Click Apply at the bottom to finalize Load Case creation. In the Existing Load Cases 

list at the top, your new Load Case should be appended onto the list following the 

Default case. 

 

Repeat this process for all six unit-load test cases.  

 

This can be done by Chenging the Load Case Name to 

a new and appropriate title. Then, go into Input Data 

and click the only load and Remove the Selected 

Rows. Finally, click on the new load you wish to 

create. Click Ok and then click Apply. 

 

When this is successfully completed, you will have six 

Load Cases corresponding to a unit-load in each axis: 

3 Forces and 3 Moments.  

 

We can now proceed to using these test cases for analysis to physically check the validity 

of our model. 
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FEA Modeling – Running the Analysis and Accessing Results 

17. Running the Analysis using PATRAN and NASTRAN 

Now we will simulate these load cases on our thrust tube assembly model. 

 

Select the Analysis Application Form from the Patran Main form list. 

Set Action → Analyze 

Set Object → Entire Model 

Set Method → Full Run 

 

Click on the Subcase Select… button at the bottom of the selection panel on the right. 

All the different load cases you have just created should be available for selection.  

 

Deselect the Default case from the Subcase 

Selected list on the bottom and select all of 

the six different load cases so that they 

appear in the Subcase Selected list. 

 

Note: Although all the load cases have been 

chosen, Nastran will later interpret these 

loads and boundary conditions individually. 

The forces and moments will not be combined 

into one “case”. Results can be viewed for 

each unit-load separately so do not worry 

that all of these cases have been chosen. 

 

Click OK to finalize the load case selections. 

 

In the Job Name entry box, enter an appropriate title that will be easy for you to keep 

track of.  

 

Click Apply to begin analysis. This will take several seconds to several minutes 

depending on the computer resources available.  
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Do not shut down or disturb the computer until all results are processed the MS-DOS 

prompt box (shown in the figure above) has closed itself. 

 

Note: Several output files using this title name will be created once Patran has sent this 

FEA job to Nastran. These files will be created onto the desktop and contain the bulk 

data file (.bdf), the F06 file (.f06) as well as several 

other files that are not as important. The F06 file 

can also be accessed using the Action → Monitor 

and Object → Job. Access to the file will be then 

listed in the selection buttons at the bottom. 

 

The bulk data file is the completed node, mesh, material properties and load case 

information for all information you have in your Patran model. This is the crux of what 

Nastran takes from the Patran interface to do any FEA analysis. Resources are available 

in Patran reference manuals that explain the contents of the bulk data files in detail. 

These can be obtained through contact with David Esposto (805-756-5136, 

desposto@calpoly.edu).  

 

The F06 file provides a summary of the analysis results and should be a very long text 

file containing analysis separated based on a labeled subcase. This file is useful in that it 

can tell you if something in your model was done incorrectly as a fatal error in Nastran 

will result in a very short F06 file that details what the error entails giving you some idea 

as to where and how to fix it. Always check this file after any analysis is performed to 

make sure all subcases were analyzed to completion. 
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18. Accessing Nastran Results 

After Nastran has finished analyzing all six load cases, we will need to access the results 

file. Though we could directly access the results text file, by using Patran to view the 

results file we can have useful visualizations and animations that will help us understand 

these results. The unit-load tests we have used for this tutorial are merely a simulation to 

assess the validity of our spacecraft assembly model. Checking these results using the 

visualization options we have available from Patran will tell us immediately if the Mesh 

and Bar elements have not been hooked up properly. 

 

Select the Analysis Application Form from the Patran Main form list. 

Set Action → Access Results 

Set Object → Attach XDB 

Set Method → Result Entities 

 

Click on the Select Results File and select the results file (.xdb) generated from Nastran. 

This will be in the format [Your_Job_Name].xdb. 

 

 
 

Click Ok to close this menu.  

 

Then, click Apply on the bottom of the screen to attach the interested results file into 

Patran memory for access. 
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19. FEA Model Results 

Now we will use the various options available in Patran to view the results of the 

different load cases on our model. 

 

Select the Results Application Form from the Patran Main form list. 

Set Action → Create 

Set Object → Quick Plot 

 

In the Select Result Cases, choose a subcase you are interested in viewing the results for.  

 

Then, select any Fringe and/or Deformation result. For example, choose 

Displacements, Translational for both Select Fringe Result and Select Deformation 

Result.  

 

Either de-select or leave the Animate option at the bottom active. 

 

Click Apply to view the result for the unit-load you have selected. 

 

Note: To delete these graphics off your model, Set Action → Create and Object → Quick 

Plot. Select and highlight all items in the Existing Plot Types. Then, click the Apply 

button. 

  



67 
 

Tables 

Table I – Spacecraft Relevant Material Properties 

Table II – Spacecraft Ring Method (A) Properties 

Table III – Spacecraft Ring Method (A) Offset Locations 

Table IV –Spacecraft Ring Method (B) Offset Locations 

Table V – Spacecraft Ring Method (B) Properties 

Table VI – Ring-Specific Element IDs 

Table VII – Horizontal Mesh Seed Surface Designations 

Table VIII – Vertical Mesh Seed Surface Designations 

Table IX – Homogeneous 2D Shell Properties 

Table X – Equivalent Section 2D Shell Properties 

Table XI – Cylindrical Z-axis Coordinate Location of Rings 

Table XII – Individual Unit-Force Loads and Moments 

Table XIII – Displacement Boundary Condition 
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VI. FEA Results & Analysis [Jason Carpenter] 

Test Cases 

In order to validate our FEA Model, six test load cases were implemented. We applied 

three axial loads and three moment loads of 1,000 lbs and 1,000 in-lbs respectively. By running 

these load cases, we are able to check proper connections between the skin sections and verify 

that all of the material and physical properties are modeled correctly.  In order to perform the 

hand calculations, we had to alter the simplifying assumptions some. The rings are removed from 

the structure and it is assumed that the center skin stretches to cover the vertical distance that was 

occupied by the rings. 

Load Case Setup 

For all of the test cases, the loads and constraints were applied at the same locations. The 

figure on the next page, shows the locations for the applied forces and constraints. To be 

congruent with its attachment to the rocket, we constrained the structure at the separation ring. 

The ring is constrained in the radial and y (vertical) directions, denoted by the blue double 

headed arrows in parts a and c of the figure on the next page. The ring is not constrained in the 

theta (rotational) direction since the spacecraft is constrained with a clamp band, which allows 

for rotation about the y-axis. Multi-Point Constraints (MPC), shown in pink, are added to the top 

and separation rings to allow for the constraints/loads to be applied evenly to the entire ring.  The 

constraints were applied to the central hub of the MPC on the separation ring. At the top ring, the 

selected load is applied to the central hub of the MPC as well, shown as the yellow arrow in parts 

a and c of the figure on the next page. 

Results Cases 

In testing the results of the finite element analysis, we performed simplified hand 

calculations to compare the solutions with. Since the two methods require different assumptions 

we do not need answers that are exactly the same to validate the model. We looked for answers 

that are close, i.e. within an order of magnitude. In addition, we looked at the difference in 

results and made sure there are reasonable explanations for the incongruence.  Since we cannot 

calculate the displacements at every point by hand due to the volume of calculations required, we 

examined only a select number of points. 
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 a) Side View b) Bottom View 

 Locations of the applied loads and constraints. 

 b) Top View 
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Y-Axial Case 

The first case that was examined was a 1000 lb axial load in the negative y direction. This 

simulates the weight force of the spun section and other components on the thrust cylinder.  The 

stress at each y location of the structure was calculated using the formula: 

  (1) 

By calculating the cross sectional area for each y location in the cylinder, the stress at each 

location was calculated using MATLAB. Using Hooke‟s law: 

  (2) 

the local strain for each y location was calculated. The displacement was then found by 

multiplying the strain by a differential height and numerically integrating over the entire height 

of the cylinder; the results are shown in the top figure on the next page. The displacement ranges 

from zero at the separation ring and has a maximum displacement of 1.73E-3 inches at the 

uppermost edge of the forward skin. Since the area varies linearly in the two conical sections, the 

stress distribution and subsequently the displacements varies as the inverse of y.  

 When looking at the finite element analysis, we find similar results.   The FEA output is 

shown below in the second figure on the next page. Looking at it we see the same trends for the 

displacement. In the figure, the displacement has been discretized into 12 steps represented by 

the different colors. The non-linear nature of the displacement can be seen by the changing width 

of the color bands on the model itself. As the bands get narrower, the displacement is changing 

more rapidly indicating a change in the slope as seen in the plot. Perhaps the best indicator is the 

maximum displacement. From the FEA result, it can be seen that the maximum displacement 

given by FEA is 1.95E-3 inches, which is only an 11% difference. That shows that these two 

models do correlate very well. 
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X,Z Axial Load Case 
 

The next two load cases applied can actually be combined together due to symmetry for 

the interest of convienience. Since our cylinder is completely symmetrical about the central axis, 

the X and Z axial load cases are simply rotations of each other. As such, the results will be the 

same just shifted about the y axis by 90 degrees. In order to simpify the structure for hand 

calculation analysis, the cylinder was modeled as having a single diameter and thickness, shown 

in the figure below, resulting in a constant I (moment area), A (cross sectional area), and E 

(young‟s modulus). 

 

Engineering Model for Hand Calculations of X and Z Axial Load Cases 

To get the highest fidelity, a weighted average was taken for E and I resulting in the values 

shown in engineering model figure above. By simplifying the model to this case, we can use the 

displacement equation for a simple cantilevered beam. Using the given equation: 

  (3) 

the displacement for each y value was calculated.  The results of these calculations are found 

below in the plot on the top of the next page.  The maximum deflection is found at the tip of the 

beam and is found to be 2.91E-3 inches. This model assumes that the entire beam moves together 

and thus you only get a single value for displacement at each y location. Looking at the FEA 

results, shown below on the next page, we notice that this is not the case. 

1,000 lbs 

 

E = 5.7195e+6 psi 

I = 3.7305e+3 in4 
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The displacement is lower on the negative x/z (left side in the figure) side of the results. The 

higher fidelity causes the compression of the cylinder to be accounted for. The figure also shows 

that the maximum deflection is 6.42E-3 inches. This increase is likely due to that compression 

that is accounted for. There is movement in the x/z direction that is not accounted for in the 

simplified model. Even without that, the solutions are well within an order of magnitude 

difference from each other showing a strong correlation between the models.  

 

Y-Moment Case 
 

The third case we examined was 1000 in-lbs of pure torsion about the y axis. For this 

case we do not expect to see any bending displacement. The only displacement should be the 

twisting of the cylinder as a result of the force. To analyze the structure, we simplified the 

structure into three prismatic sections. Using the equation, 

 

  (4) 

the twist angle was determined for the structure. A weighted average was used for the G and J 

values for each section. Using this equation yields a single solution at the point farthest from the 

constraints. It assumes that there is no internal distortion of the structure, i.e. the cylinder 

remains perfectly circular. Calculating the twist angle using this equation yields a solution of 

2.14E-5 radians or .0012 degrees. From the twist angle we can solve for the displacement by 

calculating the arc length of the circle swept out by the twist angle using the equation: 

  (5) 

Since theta is very small we can use the small angle approximation to assume that the 

displacement is equal to the arc length, therefore: 

  (6) 

yields the final displacement to be 1.14E-4 inches at the forward ring. 

 When we look at the FEA results we find a displacement of 2.86E-4 inches at the forward 

ring. This gives a difference of approximately 60%. Considering the difference in assumptions, 

this shows that the two models do roughly match up. We did expect a difference since the 

simplified assumptions did not include the rings and simplified the values of G and J for each 

skin section as constant. In addition to the similarities, we find that the displacement looks 

constant for a given y location indicated by the concentric color bands on the structure shown in 

the figure below. This is congruent with our understanding of pure torsion cases; since the 

structure is symmetric, the stress and strain around the ring should have no concentrations. It 

should only vary with the geometric radius and material properties. The displacement should also 

be increasing with distance from the constraint location as it clearly does. With these indicators, 

this load case also suggests the appropriateness and correctness of our FEA model. 
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Figure 7. Displacement plot for y moment load case (Left: Top View, Right: Side View) 

 

Z,X Axis Moment Case 
 

 The last cases we examined were the Z and X axis moment cases. As with the axial load 

cases, the z and x moment cases produce identical displacements that are rotated by 90 degrees. 

The stress distribution is found by using the stress equation: 

  (6) 

To simplify the problem, this was only solved at the maximum moment arm, i.e. where 

x=r. This gives the solution for theta=0, furthermore, due to symmetry, the solution for 

theta=180 degrees, the solution is simply the negative of the value. The rest of the theta locations 

can be solved by using trigonometric functions to determine the moment arm for each point 

about the radius. It was not necessary to evaluate every point so this step was skipped. Once the 

stress was determined for each y location at theta, the local strain and displacements were found 

by using equation 2 and integrating over the length of the cylinder. In the analysis, we find that 

the maximum displacement is 2.97E-4 inches. By looking at the displacement as a function of 

the y location, shown in the plot located on the next page below, it is shown that most of the 

displacement, occurs in the upper skin section. This is shown by the lower slop in the upper part 

of the curve. This same trend is noted on the FEA results shown on the bottom of the following 

page. The color bands are much narrower in the upper skin indicating a rapid change in the 

displacement.   In addition we note the maximum displacement. First of all is the magnitude at 

3.93E-4, an increase of only 25% over our calculated levels. The proximity of the solutions 

indicates that the model is yielding an appropriate a solution that is in 
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congruence with our hand calculations.   More importantly, is the location of the maximum 

displacement. It is at theta=0 which is the exact same location as predicted by the hand 

calculations.  

In addition to the values we calculated, we can look at the overall results and check to 

make sure they concur with our general understanding of structures. The theory and equations 

say that the stress should decrease with the normal distance from the point of application. 

Looking at the stress plot yielded by FEA, we note that the values given near the center are much 

lower than those at the extremities.  In addition the displacement decreases as we approach the 

constraint location at the separation ring.   Both of these observations are in congruence with our 

understanding of structures helping to validate the model.  

 

Analysis Results & Conclusion 
 

While we cannot make a perfect FEA model, we can make certain simplifying 

assumptions that allow us to make a fairly accurate model. In order to validate our model, we 

must prove that it stands up to simple cases that we can calculate by hand. The summary of our 

results are shown in the table below. The case showing the most difference is the Y-moment case 

showing a 60% difference between the FEA and the hand calculation results, still less than an 

order of magnitude. By using these 6 test cases, each of which has shown a good correlation 

between FEA and hand calculation results, we have gained confidence that our model is both 

appropriate and correct to our assumptions.  In order to increase our confidence with this model 

we could look at some more complicated or different load cases to ensure that the good 

correlations continue. 

 

Load Case 

Maximum Displacement 

Hand Calculation 

(in) 

FEA Results 

(in) 

Percent 

Difference 

Y-Axial  1.73e-3 1.95e-3 11% 

X,Z Axial 2.91e-3 6.42e-3 55% 

Y-Moment 1.14e-4 2.86e-4 60% 

X,Z Moment 2.97e-4 3.93e-4 25% 
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Matlab Code 
 

clc 

clear all 

close all 

 y=0:.01:57.17; 

deltaL=ones(size(y)); 

%___________________________________________________ 

%% Lower Skin 

ylow = 0:.01:27.53; %in 

tlow = .38835; %in 

rlow = 18.319-.085543.*ylow; %in 

Alow = pi*(2*rlow*tlow+tlow^2); %in^2 

Elow = 6.82e5; %psi 

Glow = Elow/2.66; %psi 

Ilow = pi*(rlow+tlow/2).^3.*tlow; %in^4 

Jlow = 2*Ilow; %in^4 

%___________________________________________________ 

%% Central Skin 

ymid = 27.54:.01:40.95; %in 

tmid= .2; %in 

rmid= 15.928*ones(size(ymid)); %in 

Amid = pi*(2*rmid*tmid+tmid^2); %in^2 

Emid = 10.4e6; %psi 

Gmid = Emid/2.66; %psi 

Imid = pi*(rmid+tmid/2).^3.*tmid; %in^4 

Jmid = 2*Imid; %in^4 

%___________________________________________________ 

%% Upper Skin 

y_up = 40.96:.01:57.17; %in 

t_up = .035833; %in 

r_up = 15.875-.6492*(y_up-40.96); 

A_up = pi*(2*r_up*t_up+t_up^2); %in^2 

E_up = 10.4e6; %psi 

G_up = E_up/2.66; %psi 

I_up = pi*(r_up+t_up/2).^3.*t_up; %in^4 

J_up = 2*I_up; %in^4 

%___________________________________________________ 

%% Total Properties 

A = [Alow,Amid,A_up]; 

r = [rlow,rmid,r_up]; 

E = [Elow*ones(size(Alow)),Emid*ones(size(Amid)),E_up*ones(size(A_up))]; 

I = [Ilow,Imid,I_up]; 

J = [Jlow,Jmid,J_up]; 

G = [Glow,Gmid,G_up]; 
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% plot(A,y) 

% axis([0 60 0 60]) 

%___________________________________________________ 

%% Y Axial Case 

  

P = 1000; %lbs 

sigma = P./A; %psi 

epsilon = sigma./E; 

  

deltaL(1) = .01*epsilon(1); 

for i=2:length(epsilon) 

    deltaL(i) = .01*epsilon(i)+deltaL(i-1); 

end 

  

% plot (deltaL,y) 

% ylabel('Vertical Location (in)','fontsize',14) 

% xlabel('Displacement (in)','fontsize',14) 

 %___________________________________________________ 

%% X,Z Axial Case 

P = 1000; %lbs 

  

deltax = -P.*y.^2/(6*mean(E)*mean(I)).*(y-3*max(y)); 

  

% plot(deltax,y) 

% ylabel('Vertical location (in)','fontsize',14) 

% xlabel('Displacement (in)','fontsize',14) 

  

%% Y Moment Case 

T = 1000; %in-lb 

  

theta=T*(max(y_up)-max(ymid))/(mean(G_up)*mean(J_up))+T*(max(ymid)-

max(ylow))/(mean(Gmid)*mean(Jmid))+T*max(ylow)/(mean(Glow)*mean(Jlow)) 

%___________________________________________________ 

%% X,Z Moment Case 

M = 1000; %in-lb 

sigma = M.*r./I; %psi 

epsilon= sigma./E; 

  

deltaL(1)=.01*epsilon(1); 

for i=2:length(epsilon) 

    deltaL(i)=.01*epsilon(i)+deltaL(i-1); 

end 

  

% plot (deltaL,y) 

% ylabel('Vertical Location (in)','fontsize',14) 

% xlabel('Displacement (in)','fontsize',14) 
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VI. Conclusion [Richard Pelham] 

Requirements for Completion of the Model 

The detailed Pro/E model of the Boeing 376 spun satellite is mostly complete.  This 

model only has the thrust tube and spun shelf of the satellite as you can see from the figure 

below. 

 

The model has a significant amount of detail. However, missing from the model are a 

number of doublers, fasteners, spacers, rivets, brackets and the beryllium supports between the 

spun shelf and the thrust tube. The engineering drawings for these should become available at a 

later date, and the beryllium supports will likely be a project for other students to perform in the 

future.  
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Also missing from the model is the de-spun section of the satellite. None of the drawings 

for this section were included in the package we received. Once these become available, they 

will need to be modeled and added to the spun section of the satellite. 

 

In order to generate detailed drawings of this model at a later date, the dimensions and 

tolerances must be added to each of the parts and components. Most of the dimensions are 

already a part of the model; however, they are not immediately visible unless you access the 

sketches for each individual part. None of the tolerances were included since the model itself 

does not require them to visually reproduce the satellite. These tolerances are essential to 

creating a physical model of the satellite. 

 

A detailed list of all the parts included in this model, and the parts that will need to be 

completed and added to this model at a later date, can be found on the Aerospace Engineering 

server under the space folder in the CPIntersep folder. This folder is only accessible with special 

permission. 

 

Visual Issues 

 First, these are not problems with the model itself; it is just a concern for the visual 

aesthetics of the project. Part of this project required a detailed visual model of the Boeing 376 

satellite. We made an effort to make the model look correct but we had some visual difficulties 

due to the way Pro/E renders the parts. 

  

For an unknown reason, a few of the parts are not rendering correctly. This mainly deals 

with the doublers which are very thin sheets placed on the surfaces of the thrust tube. These 

doublers are placed correctly, but they appear as if they are entering the surface. More than likely 

this is because of the way Pro/E draws the models. As of this time, we cannot find a way to fix 

this. An example of this can be seen in the following figure. 
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Another issue we are having with the rendering of the model can be seen in the figure 

below. The red outline shows the head of a screw, the washer and nut can also be seen. The shaft 

of the screw is missing though. This only occurs on a few times throughout the model. This may 

be an effect from using the pattern feature of Pro/E. 

 

 

 

Possible Problems in the Future 

The main axis of the pro/e model is not to industry standards. In order to correct this, the 

z and y axes must be interchanged. At this time, this is not an issue as all of the numbers used in 

both the detailed model and the FEA model take this into account. Once we start dealing with 

industry this may become a problem. There may be a way to change the axes without completely 

redoing the models; however, changing the axes may result in problems with both of the models. 

The numbers calculated and used in both PATRAN and Pro/E were found using the current axis 

set-up. Therefore, changing the axes may require a recalculation of the inertia matrix, and many 

of the offset values used. 
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A. RELEVANT FILES AND LOCATIONS 

 File Name Description Location 

Parts List 
Parts 

List.xlsx 

File contains indentured parts list for spun 

and de-spun section including color coding 

for drawings received and parts modeled. 

N:\Aero\CPinterSEP\M

odel\Parts List.xlsx 

Drawings Folder Folder Containing all drawing files 
N:\Aero\CPinterSEP\M

odel\Drawings 

FEA Patran 

Database 

TC6D_test.

db 

Patran Database file containing FEA model 

and results of test cases (this is the most up 

to date file) 

NOTE: Must be opened from Patran 

2008r2 

N:\Aero\CPinterSEP\M

odel\FEA\TC6\TC6D_t

est.db 

Spun Structure 

Assembly(Pro/E) 

7943088-

001.asm 
Pro/E Assembly file for spun section 

N:\Aero\CPinterSEP\M

odel\Final Spun 

Assembly\7943088-

001.asm 

Spun Structure 

Assembly FEA 

(Pro/E file) 

7943088-

001_fea2.a

sm 

Pro/E assembly file reduced for export into 

Patran for FEA 

N:\Aero\CPinterSEP\M

odel\Final Spun 

Assembly\7943088-

001_fea2.asm 

Pro/E Parts Folder 
Folder containing all of the latest part and 

assembly files 

N:\Aero\CPinterSEP\M

odel\Final Spun 

Assembly 
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B. ABET CRITERIA PREFACE [Kevin Povey] 

 

The Accreditation Board for Engineering and Technology ensures the quality of 

postsecondary education for students. ABET was established in 1932 and includes 28 

professional and technical Societies including AIAA- The American Institute of Aeronautics and 

Astronautics. Among other minimum curricula specified by ABET, a capstone project or design 

class is required for each student. This project must meet a number of criteria in order to ensure 

graduates have had experience and a minimal skill set for entry into the workforce or future 

education. During the preliminary planning and research phase of our project, a number of 

criteria have been completed with some still in progress and others not yet completed. 

 

At this point in the project we have already shown our ability to function on a 

multidisciplinary team. Each member of the group is an aerospace engineering student, yet we 

have had to interface with members of different professional fields. It has involved working with 

an Industrial-Manufacturing Engineer (IME) to learn the 3-d modeling capabilities and practices 

for Pro/Engineer of an Industrial-Manufacturing Engineer (IME). In addition, each group 

member has different strengths and background, from which they have had to share and 

collaborate with other members. Functioning on a multidisciplinary group will continue to be 

important as the project goes on in order to get IME expertise on properly interpreting part and 

assembly blueprints along with ME knowledge on the process of conversion into finite element 

analysis models. In addition we have already completed the criteria of identifying, formulating 

and solving engineering problems. Members of the group have contacted appropriate industry 

professionals and local faculty in order to provide guidance for proper methods for rendering 3D 

solid models and assembly as well as for the integration for any parts from the Pro/Engineer 

software to PATRAN.  

 

There are also multiple ABET criteria that the group is currently in the progress of 

satisfying. The most significant is designing a system, component, or process to meet desired 

needs. We have been working on developing an organization structure or PDM in order to 

regulate and distribute the different parts and assemblies of the total satellite. The system is being 

created using Microsoft Office access and will function similar to a library checkout system. In 

addition, we are in the process of working on effective communication. So far, communication 

has consisted of planning within the team, contact and discussions with the project advisor, and 

interactions with those leading the CPInterSEP program. At this point we have not had any direct 

communication with the Boeing Company and instead have been getting the information through 

our project advisor. Effective communication will continue to play a very important role in the 

project, both in managing part assignments within the team, and in staying up to date with 

CPInterSEP. We are also in the progress of satisfying the criteria of using modern engineering 

tools, skills and techniques. A large portion of this past quarter has involved getting familiar with 

the Pro/Engineer modeling software and the Patran finite element analysis conversion software. 
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These are both very effective engineering tools and will play a primary role in the completion of 

this project. We are, however, still in the process of learning the most effective ways of using 

these programs. 

 

Finally, there are a number of the ABET criteria that though they have not yet been 

satisfied, we hope to complete before the conclusion of the project. First, we are going to apply 

our knowledge of mathematics, science, and engineering. In order to correctly model the parts, it 

will be necessary to have an understanding of engineering design documents. We will have to 

correctly interpret the drawings and transfer the features into a 3D model. In addition, we will 

need to perform some basic analytical stress analysis on the structure based on projected loads in 

order to have a comparison for the FEA models. Second, we plan to design and conduct 

experiments, as well as analyze and interpret data. If time allows, we are going to import the 

satellite assembly into PATRAN and perform an FEA analysis. The resulting data will show the 

stresses and how the completed assembly will handle the test load environments. Interpreting the 

data will be critical in ensuring that the solid model has been appropriately generated and can be 

correctly imported into the FEA software. Third, we will show that we understand our 

professional and ethical responsibilities. We are going to be receiving proprietary blueprints and 

drawings of the structure and assembly of the Boeing 376 spacecraft which are subject to the 

controls of the International Traffic in Arms Regulation (ITAR). Thus, the blueprints of these 

parts must be handled in a professional manner so as to control the release of these documents to 

authorized individuals or organizations. Also, properly producing a completed assembly model 

and finite element analysis in an honest manner is necessary to mitigate incongruities between 

test results for the model and physical spacecraft structure in assembly efforts for the future. 

Fourth, we hope to show the impact of engineering solution in a global and societal context. The 

project involves setting a model base for future members working on the 376 project. It will 

demonstrate the proper processes necessary for adding parts to the assembly and creating a 

model that is compatible with PATRAN and finite element software. Lastly, our project will 

demonstrate the life-long learning process. The work done on this project will have an impact on 

the possibility of future experimental instrumentation in space. The modeling of the primary 

structure of this spacecraft will be used to analyze the stress implications of adding various 

experiments. This project will set the base for the reality of eventually launching the satellite. 
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C. ABET CRITERIA COMPLIANCE [Kelly Cheng & Kevin Povey] 

 Apply knowledge of mathematics, science, and engineering 

An understanding of engineering design documents will be necessary to correctly model parts in 

the solid modeling software. The material properties pertaining to all satellite parts will be 

researched for proper structural characteristics of the completed assembly. Analytical stress 

analysis will be performed based on projected loads. Numerical stress analysis will be executed 

using finite-element analysis (FEA) tools to validate and support analytical results.  

 Design and conduct experiments, as well as analyze and interpret data 

The satellite structure assembly will be imported into PATRAN and FEA results will display 

computerized stress calculations. The data will reveal how the completed assembly will handle 

the test load environments. Interpreting the data will be critical in ensuring that the solid model 

has been appropriately generated and can be correctly imported into the FEA software. 

 Design a system, component, or process to meet desired needs 

A proper database structure will need to be designed and implemented to organize the various 

part files necessary for the completed satellite assembly. Create a baseline structure that will 

function correctly and have the ability to be modified to include future changes to satellite 

structure. The proper generation of the satellite assembly model will allow for the streamlining 

of a process to import the assembly into the FEA analysis tool. 

 Show ability to function on multi-disciplinary team 

This endeavor will include a team of several engineers operating under multiple disciplines. The 

project will involve the 3-d modeling capabilities of an Industrial-Manufacturing Engineer 

(IME). IME expertise will also be necessary to properly interpret part and assembly blueprints. 

The abilities of an Aerospace/Mechanical Engineer (AERO/ME) will also be necessary in order 

to demonstrate the process of conversion into a finite element analysis model is functioning 

correctly. 

 Identify, formulate and solve engineering problems 

Contact appropriate industry professionals and local faculty in order to provide guidance for 

proper method to render 3-d solid models and assembly as well as for the integration of a 

spacecraft assembly from the Pro/Engineer software to PATRAN. If blueprints for any parts to 

the satellite primary structure are unavailable, measurements of the respective parts, available 

on-site, will need to be taken using measurement tools. 

 Understand your professional and ethical responsibilities 
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The proprietary blueprints available for reference for the completion of this project are subject to 

the controls of the International Traffic in Arms Regulation (ITAR). Thus, the blueprints of these 

parts must be handled in a professional manner so as to control the release of these documents to 

authorized individuals or organizations. The reduction of waste and cost is a responsibility 

belonging to each member of this team. Properly producing a completed assembly model and 

finite element analysis in an honest manner is necessary to mitigate incongruities between test 

results for the model and physical spacecraft structure in assembly efforts for the future. 

 Show effective communication 

When working on a team consisting of five members, effective communication between each 

person will be essential. Each task will require information that will need to be provided another 

member, and it is important to have a constant flow of information. With a vast number of 

individual tasks, it will be important to keep track of who is doing what. In addition, it will be 

necessary to be in contact with industry personnel. We will need to communicate our questions 

and needed information with the Boeing Company in a professional and effective manner. 

 

 Show impact of engineering solution in a global and societal context 

 

The project involves setting a model base for future members working on the 376 project. It will 

demonstrate the proper processes necessary for adding parts to the assembly and creating a 

model that is compatible with Patran and finite element software.  

 

 Demonstrate life-long learning process 

 

The work done on this project will have an impact on the possibility of future experimental 

instrumentation in space. The modeling of the primary structure of this spacecraft will be used to 

analyze the stress implications of adding various experiments. This project will set the base for 

the reality of eventually launching the satellite. 

 

 Use modern engineering tools, skills and techniques 

 

This project relies heavily on modern engineering tools. The main bulk of the project will be 

done on the ProEngineer modeling software. Analytical stress analysis calculations will be 

performed and compared to results gained from finite element analysis software. In addition, 

Patran be used to make finite element analysis possible with the ProE Models. 
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D. PEER EVALUATION CRITERIA & FORM [Jeffrey Ma] 

To evaluate other group member‟s performances we will be grading each other on seven different areas. The seven different 

areas are meeting attendance, meeting participation, work ethics, work timeliness, work contribution, work quality and effective 

communication. To grade each other, in these areas, we will be using a number scale from one to five, one being „Great‟ and five 

being „Greatly Needs Improvement.‟ In addition to these seven areas we will also suggest a grade which each individual deserves and 

comment as to why they deserve these grades. 

Name Attendance Participation Ethics Timeliness Contribution Quality Communication Grade Comments/Reasons 

Jason Carpenter                 

  

Kelley Cheng                 

  

Jeffrey Ma                 

  

Kevin Povey                 

  

Richard Pelham                 

  

*To rate people please use this scale: 1 ~ Great, 2 ~ Good, 3 ~ Average, 4 ~ Needs Minor Improvement, 5 ~ Greatly Needs Improvement 
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E. MANAGEMENT STRUCTURE & CONFIGURATION CONTROL 

[Jason Carpenter] 

The management structure will be broken down by task as seen in the management 

structure outlined below in fig. 2. Jason Carpenter will be serving as project manager and 

configuration control. We will have everybody working on the modeling and assembly. The bulk 

of the modeling will be done by our modeling team which will consist of Kelly Cheng, Jeffrey 

Ma, and Kevin Povey. Their exact tasks will be distributed once we receive the indentured 

drawing list and detail drawings. Richard Pelham will lead up the assembly effort with assistance 

from Jason Carpenter and the modeling team as needed. In addition to assemblies, Richard will 

also be in charge of checking the model for Patran compatibility. 

 

In order to maintain control of the model and make sure that the parts are not redundantly 

created, we will be imposing a configuration control system. Without access to a Product Data 

Management (PDM) system we will be creating our own version using Microsoft Access and a 

configuration manager. Jason will be serving as configuration manager. He will control the 

official model and check out parts to a single user at a time.  The official copy of the model will 

be maintained by Jason on his server partition. To maintain quick access to the model at all 

times, a public copy of the model will be maintained on the CPInterSEP server. The purpose of 

this copy is to allow access to the model at all times. Even though all team members have access 

to the parts, they will not be allowed to make official changes without first checking out the part 

though the configuration manager. Parts will not become official however until returned to the 

configuration manger and accepted as official changes. Once a change is accepted, the revised 

model will be published to the server.  

An Access database will be used to track changes and details for each of the parts. We will be 

using a check-in/check-out system to ensure that parts are not being edited by multiple users at 

one time. We will also be tracking many details of the parts description and history including the 

following: 

 Part ID (unique identifier given by Access) 

 Boeing Part Number (including revision) 

Jason Carpenter

Configuration 

Manager

Kelly Cheng

 Parts Modeler

Parts Modeling Team

Kevin Povey

Parts Modeler

Jeffrey Ma

 Parts Modeler

Richard Pelham

Assemblies/Patran 
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 Part Description – A brief physical description of the part 

 Person Checked out To 

 Check Out Date 

 Expected Return Date 

 Latest Revision Date 

 Model Revision History – Revisions to the drawings 

 Subordinate Parts/Assemblies (for Assemblies) 
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F. GANTT CHARTS [Jason Carpenter] 

Winter Version 
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