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Abstract

We have compared current image analysis software packages in order to find the 

most useful one for assessing microbial adhesion and inhibition of adhesion to tissue 

sections. We have used organisms of different sizes, the bacterium Helicobacter pylori

and the yeast Candida albicans. Adhesion of FITC-labelled H. pylori and C. albicans
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was assessed by confocal microscopy. Four different Image analysis software 

packages, NIH-Image, IP Lab, Image Pro+ and Metamorph, were compared for their 

ability to quantify adhesion of the two organisms and several quantification methods 

were devised for each package. For both organisms the dynamic range that could be 

detected by the software packages was 1 x 106 - 1 x 109 cells/ml. Of the four software 

packages tested, our results showed that Metamorph software, using our ‘Region of 

Interest’ method, with the software’s ‘Standard Area Method’ of counting, was the 

most suitable for quantifying adhesion of both organisms because of its unique ability 

to separate clumps of microbial cells. Moreover, fewer steps were required. By pre-

incubating H. pylori with the glycoconjugate Lewis b-HSA, an inhibition of binding 

of 48.8% was achieved using 250ug/ml Lewis b-HSA. The method we have devised 

using Metamorph software, provides a simple, quick and accurate way of quantifying 

adhesion and inhibition of adhesion of microbial cells to the epithelial surface of 

tissue sections. The method can be applied to organisms ranging in size from small 

bacteria to larger yeast cells.
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1. Introduction

Some superficial mucosal infections may become chronic leading to a persistent 

acute inflammatory reaction and in some cases persistent symptoms for the patient. In 

the case of infection with Helicobacter pylori, the host is unable to eradicate the 

organism, despite a florid neutrophil response. In the case of recurrent Candida

vaginitis, the host is similarly unable to eradicate the organism from the mucosa. In 

both cases, the effectiveness of current anti-microbial therapy is being compromised 

by an increasing level of resistance of both H. pylori and Candida albicans to the 

appropriate agents. It is with this in mind that alternative strategies are being 



investigated and one such strategy is to target adhesion, the primary step in the 

infection process (Basset et al., 2003). Microbes frequently adhere to tissue by 

specific ligand-receptor interactions and once adherent lead to tissue damage and a 

subsequent host response.  

H. pylori colonises the stomach of over half the human population. Although most 

infected people are asymptomatic, in 5-20% of those infected, severe gastroduodenal 

diseases, including ulcers of the stomach and duodenum, gastric lymphomas and 

adenocarcinomas, may occur (Montecucco and Rappuoli, 2001). A number of 

putative adhesin-receptor interactions have been proposed for H. pylori (Evans and 

Evans, 2000). The best described interaction is that between the BabA outer 

membrane protein found on the surface of the bacterium and the Lewis b blood group 

antigen which is expressed by gastric epithelial cells. Borén et al. (1993) used 

fluorescently labelled H. pylori cells and showed localised adherence to the 

epithelium of stomach sections by fluorescence microscopy. They were able to inhibit 

adhesion of H. pylori to stomach expressing the Lewis b antigen (Lewis b stomach) by 

first pre-incubating bacteria with Lewis b neoglycoconjugates (analogues of the 

receptor) before adding the bacteria to the tissue sections. Adhesion and inhibition 

were quantified by manually counting the number of bacteria bound to the epithelial 

surface. Other studies have confirmed this (Borén et al.,   1994; Ilver et al., 1998). 

C. albicans, a  yeast, is responsible for a wide range of diseases including vaginal 

infections. Approximately three-quarters of all women will suffer from vaginal 

candidiasis (VC) at least once in their lifetime and up to 25% of these women will 

experience recurrent disease (recurrent vaginal candidiasis, RVC), which is 

distressing and difficult to treat (Mardh et al., 2002). Adhesins that have been studied 

include Hwp1 (Sundstrom, 2002), mannoproteins, which bind to fucose or N-

acetylglucosamine (GlcNAc) glycosides on human buccal and vaginal epithelial cells 

(Calderone, 1993; Critchley and Douglas, 1987a and b) and secretory aspartyl 

proteinases (Watts et al., 1998). The secretory aspartyl proteinase SAP2 has been 

found to be important in vaginal infection in a rat vaginitis model (De Bernardis et al., 

1999) and  SAPs1-3 have generally been shown to be important in mucosal adherence 

(Monod and Zepelin, 2002).

As microbial adhesion is the primary step in the pathogenic process, it has received 

considerable attention because of the possibility of inhibiting this first interaction and 

thus preventing infection. The process of adhesion, usually occurring in the presence 

of hydrodynamic and shear forces, which tend to limit the deposition of 

microorganisms, has been mathematically analysed in both flow and static systems 

(Sjollema et al., 1989). Several studies have been performed with a parallel plate 

device designed to mimic hydrodynamic forces (van Kooten et al., 1992; Millsap et 

al.,1999; Gomez-Suarez et al., 2001), although much work has been performed in the 

absence of these forces.

Many methods for studying bacterial adhesion have been used (An et al., 1997), 

which include direct microscopic counts after suitable staining, flow cytometry and 

image analysis of fluorescent labelled organisms (Clyne et al., 1997; Grivet et al., 

1999), haemagglutination (Goldhar, 1995), attachment to immobilised molecules on 

thin-layer chromatography plates (Saitoh et al., 1991), radiolabelling (Mackowiak et 

al., 1984), ATP quantification (Robrish et al., 1977), and immunological methods 

(Ofek et al., 1995). Although valuable, these studies are artificial as they do not mimic 

tissue very closely and the cells may not be representative of those occurring in the 

target tissue. A number of studies have investigated adhesion to whole tissue sections 

(Borén et al., 1993;  Falk et al., 1993; Reinhard et al., 2000) and although not ideal 

(due to the processing of the tissue), they are likely to be more representative of the 



natural microbial-host interaction.

A fundamental requirement in determining adhesion and inhibition of adhesion is 

quantification of binding. When studying binding to tissue sections, a common 

method of quantification that has been used is direct microscopic counts of labelled 

(usually fluorescent) organisms, although image analysis methods have also been 

applied, as direct visual counts are time consuming. 

Image analysis methods have a broad application in microbiology and have been 

used to quantify microorganisms in geological material (Tobin et al., 1999), in food 

processing (Hood et al., 1997), in the petrochemical industry (Williamson et al., 

1989), for the enumeration of marine plankton (Pernthaler et al., 2003) and biomass 

determination (Pons et al., 2000) as well as biomedical applications, such as analysis 

of bacterial motility (Gualtieri et al., 1988), morphology, physiological processes in 

bacteria following infection (Goldstein et al., 1988), colony counting (Corkidi et al., 

1998) and adhesion (Sjollema et al., 1990; Reinhard et al., 2000).

Image analysis of adherent microorganisms is usually performed following specific 

stains either for DNA or some antigenic cell wall components using a fluorescent 

labelled antibody. Image analysis comprises three main steps: object delineation, 

signal to background differentiation by setting a threshold value and quantification, 

either by enumeration of objects or intensity of signal- usually fluorescence. Initially a 

comparison of visual counts to output of the image analysis system are performed to 

validate the  image analysis system. In dynamic systems, such a flow chamber, 

differentiation between static adherent organisms and free-flowing organisms have to 

be taken into account, usually by multiple image analysis or extended threshold 

values. 

The image analysis system at its simplest may comprise a microscope with 

attached digital camera or colour-CCD devise, frame grabber, computer and analysis 

software. The microscope may be computer controlled so that it automatically scans 

the required fields and in some systems focussing is also automated. Microscopes 

frequently used are epifluorescent microscopes or confocal laser scanning 

microscopes. 

Various software packages have been utilised e.g. NIH Image (Reinhard et al., 

2000),  Image Pro Plus (Barthelson et al., 1999) Prism (Schonholzer et al., 2002), 

ICONIX (Corkidi et al., 1998) or written in-house (Jansen et al.,1999). When 

analysing adherence of irregular shaped organisms or organisms adherent to turbid 

solids the accuracy of the counts can be increased by using an artificial neural network 

to quantify the organisms (Wit et al., 1998).

Currently, there are a number of image analysis software packages available but no 

analysis of which ones are appropriate to assessing microbial adhesion to tissue 

sections. The aim of this study was therefore to compare current image analysis 

software packages in order to find the most useful one for analysing microbial 

adhesion to tissue sections, in particular a yeast and a bacterium, which are of 

different sizes.

2. Materials and Methods

2.1. Tissue

H. pylori negative biopsies of human stomach were obtained by one of the authors 

(DV) with the consent of the Ethics Committee, St Orsola Hospital, Bologna. Vaginal 

tissue was obtained from oophorectomised rats (Charles Rivers Inc USA) maintained 



in pseudo-oestrus by subcutaneous injections of 50mg oestradiol benzoate given every 

second day. An appropriate Ethical Licence was obtained for the study. 

2.1.1. Stomach sections

Formalin-fixed stomach biopsies, whose epithelial cells expressed the Lewis b 

blood group antigen, were used. Five micrometer sections of stomach were cut using a 

Leica SM2400 rocking microtome. Sections were collected on polished glass slides 

coated with Vectabond (Vector Laboratories, UK). After  preliminary studies,  the 

following antigen-retrieval method was used to expose the antigen. The sections were

deparaffinised (3mins in Xylene then Isopropanol, Sigma, UK), rehydrated in a graded 

series of alcohols and digested in α-Chymotrypsin solution, pH 7.8 (0.1% α-

chymotrypsin/0.1% calcium chloride, Sigma, UK) at 37°C for 10mins, to expose the 

Lewis b antigen. To expose the Lewis a antigen, after deparaffinising, the sections 

were boiled for 5 mins in an 800W microwave in plastic coplin jars containing 15mls 

of Citrate buffer, pH 6.0 (100M sodium citrate tribasic dihydrate, Sigma, UK). The 

Lewis phenotype of the tissue was determined by standard immunohistochemical 

staining using the DAKO EnVision Plus HRP kit (DAKO, UK) with anti-Lewis a (Le 

a) and anti-Lewis b (Le b) antibodies generously donated by Dr J Bara, Hôpital St-

Antoine, Paris, France. Both antibodies were supplied at a concentration between 1-

5ug/ml. For use in Lewis typing experiments, the anti-Le antibodies were diluted 1/10 

and 1/50 for the anti-Le a and anti-Le b, respectively. 

2.1.2. Vaginal sections

Rat vaginal tissue was embedded in OCT (Tissue-Tek, UK) and ‘snap-frozen’. 

Five micrometer sections were cut using a cryostat (Leica CM1900, UK) and 

keratinisation of the epithelial cells was confirmed by modified Papanicolaou staining 

(Elzay and Richmond, 1983). 

2.2. Microbial isolates

H. pylori NCTC 11637 and C. albicans ACTC 90025 were used in the study. H. 

pylori was grown for 2 days on Columbia blood agar at (Oxoid, UK) 37oC under 

microaerobic conditions (Stevenson et al., 2001). C. albicans was grown on Columbia 

blood agar for 24hours at 37oC. The number of bacterial cells was determined by 

obtaining viable counts of serial dilutions and measurement of the optical absorbance 

at 600nm (Ultrospec II, LKB, UK) of a suspension of bacterial cells to prepare a 

standard curve for H. pylori. All studies thereafter used the same concentration of 

organism based upon its absorbance. For C. albicans the number of yeast cells was 

determined for each experiment by a microscopic count using a haemocytometer. 

Fluorescent labelling of microbes

For both organisms suspensions of 1 x 109 cells/ml were made in 1ml carbonate 

buffer (0.15M NaCl/0.1M Na2CO3, pH 9.0). Five microlitres of a 10mg/ml FITC 

(fluorescein isothiocyanate isomer I, Sigma, UK) solution in DMSO (dimethyl 

sulfoxide, Sigma, UK) were added to each bacterial suspension and 20µl of FITC 

were added to each yeast suspension. They were then incubated for 1hour with 

continuous shaking. The suspensions were then washed three times with phosphate 

buffered saline (PBS: NaCl 8.0g/L; K2 HPO4 1.21g/L; KH2 PO4 0.34g/L, pH 7.4) 

containing 0.05% Tween 20 (PBST) (Sigma, UK) and then the pellets were 

resuspended in PBS. Labelling was confirmed by flow cytometry (FACSCalibur, 



Becton Dickinson, UK). All incubation and washing steps were carried out in the dark 

at room temperature. 

2.3. Binding Assay

Tissue sections were incubated for 30mins in a humid atmosphere with 200µl per 

slide of blocking buffer (PBST/2%BSA). Sections were then washed three times by 

placing in a slide rack in 350mls PBST on a rotator for 10 mins. The FITC-labelled 

microbes were decimally diluted in blocking buffer to give concentrations between 

1x1010 to 1x102 cells/ml and 200µl were added to each slide and incubated in a humid 

atmosphere for 1hour. After the incubation, slides were washed in PBST as 

previously. Two hundred microlitres of propidium iodide (PI, 5µg/ml) was added and 

each slide incubated for 3 mins. Slides were then washed twice in PBST, air-dried and 

mounted with Vectashield (V-1000, Vector Laboratories, UK). All incubation and 

washing steps were carried out in the dark at room temperature and two tissue 

sections were used for each concentration of organism.

Binding Inhibition Assay for Helicobacter pylori

To inhibit H. pylori adhesion, Lewis b-HSA (Isosep, Sweden) was diluted in 

suspensions of FITC-H. pylori to give final concentrations of 0, 10, 250, 500 and 1000

µg Lewis b-HSA/ml and 1 x 108 bacteria/ml. This was then incubated with continuous 

shaking for 2hours at room temperature in the dark and washed with blocking buffer. 

The suspension was then incubated with the stomach sections as mentioned before. 

Three tissue sections were used for each concentration. The experiment was 

performed twice.

2.4. Quantification of binding

2.4.1. Image capture

Sections were observed using a Laser Scanning Confocal Microscope (Zeiss: 

Axiovert 100 TV) with a x10 Zeiss Plan-Neofluar objective for observing C. albicans

on vaginal sections and a x20 Zeiss LD-ACHR objective for observing H. pylori on 

stomach sections. The excitation wavelengths were 488 (for FITC) and 568nm (for 

PI). 522nm and 605nm band-pass filters were used to acquire FITC emission and PI 

emission respectively. Digital images (512 x 512 pixels) of the sections were captured 

using a Biorad Lasersharp 2000 Confocal Laser Scanning System. Images were 

converted to TIF files for processing. Two photographs showing adjacent areas of the 

tissue were taken for each tissue section.

2.4.2. Image analysis software 

The following Image Analysis software were compared:

NIH-Image (version 1.62) This is public domain software for the Macintosh, and is 

available as a free download from the internet on the NIH’s website at 

<http://rsb.info.nih.gov/nih-image>. There is also a PC version available at 

http://www.cs.ubc.ca/spider/ladic/executor.html

IP-Lab (version 3.6) Professional image analysis software package produced by 

Scanalytics Inc., USA. An evaluation version is available free on the internet on the 

Scanalytics website at: <http://www.scanalytics.com/download/index.shtml>. The full 

version is available for Macintosh  and Windows operating systems and can be 

purchased from  Scanalytics Inc.



Image Pro+ (version 4.1) Professional Image analysis software, produced by Media 

Cybernetics Inc. USA.

Metamorph (version 4.5r) Professional Image Analysis software, produced by 

Universal imaging Corporation, USA.

2.4.3. Image processing and Analysis

From each digital image taken, a red (PI) image showing only the tissue, a green 

(FITC) image showing only the microbial cells and a combined red and green image 

showing the tissue and microbial cells, were produced. Using these digital images we 

have devised 4 methods for quantifying adherent microbial cells using each of the

Image Analysis software packages.

Method 1: Counts by Merging Images

The number of micro-organisms adhering to the surface of the tissue is determined 

by subtracting the sum of the [background (glass/non-tissue) number of micro-

organisms (B) + micro-organisms adherent to the lamina propria (L)] from the total 

number of micro-organisms (C). This method gives a value for only those organisms 

attached to the epithelial surface. 

Method 2: Counts by Image Dilation

This is similar to the above method except that after carrying out the “Fill” 

command, the tissue image is dilated by a set number of pixels (For C. albicans the 

dilation was set to 10 pixels and for H. pylori, which are smaller cells, the dilation was 

set to 5 pixels). As before by merging the red and green images, counts of cells in the 

whole image, the background and the tissue can be obtained and hence the number of 

adherent microbial cells calculated.

Method 3: Counts by Area

In this method, the area of at least 20 individual organisms is found using the 

“Wand” tool (IP Lab & NIH Image) or by using the "area" measurement (Image Pro+ 

and Metamorph) and the average calculated (A). Both the (red and green) and tissue 

(red) images are filled in with the wand or equivalent tools, so that the area with (B) 

and without (C) the adherent organisms is outlined. The areas of both are found. The 

number of organisms adherent to the epithelial surface is found by subtracting the area 

of the tissue image with (B) and without (C) the adherent organism divided by the 

area of a single organism (A). 

Method 4: Counts by Region of Interest 

In this method a region of interest (ROI) is drawn by hand around the microbial 

cells that are directly adhering to the epithelial surface using the “wand” tool. Using 

the “Count” tool the number of microbial cells is provided in the highlighted region.

Metamorph has an additional “Standard Area” method of obtaining the counts 

which automatically divides clusters of microbial cells into the number of composite 

microbial cells by first calculating the mean size of one organism. 

2.4.4. Comparison of software packages

The number of adherent microbial cells per mm of epithelial surface in the section 

was calculated for each of the software packages so that the results of each package 

could be compared. The length of the epithelial surface of each photo was calculated 

by outlining the tissue in the image and using the software to calculate its length (in 

pixels). In order to convert the units from pixels into millimeters, a digital photo of a 

stage micrometer on the confocal microscope was taken, and using the software 

packages, the number of pixels represented by 1mm was obtained. All values obtained 



for length of epithelial surface were subsequently converted into mm.  

Additionally, other data taken into consideration when comparing the software 

packages were the cost, availability of the package, ease of use in terms of number of 

manipulations, correlation between image manipulation and the number of adherent 

organisms and finally which packages were able to perform the various methods listed 

above. 

2.4.5. Operator Error

In order to determine the amount of error introduced by the operator when 

performing quantification, epithelial length measurements and counts of adherent 

cells for the dynamic range for both H. pylori and C. albicans was carried out three 

times on three separate occasions, using the best software package and method 

(Metamorph with the ROI and Standard area method of counting). The mean of the 

three counts was calculated and standard error determined.

2.4.6 Manual method of counting

From each digital image the number of adherent cells was also counted manually 

using the microscope. This was performed by two independent observers and the 

counts obtained averaged. 

The length of the epithelial surface of each digital image was calculated manually by 

measuring the length of the edge of the tissue in the image (in cm). In order to convert 

the length obtained on the digital image into the actual length of the tissue, the image 

on the stage micrometer was measured manually, and the number of cm represented 

by 1mm of the graticule was obtained. All values obtained manually for length of 

epithelial surface on the digital image were subsequently converted into mm.

3. Results

Of the 4 methods used to quantify adherence, only some software packages were 

able to perform all of them and these are outlined in Table 1. Of those software 

packages that could perform the same method of quantification the commands were 

slightly different. The whole set of sequences for each method of each of the packages 

is given in the Appendix. 

3.1. Dynamic Range

For both organisms the dynamic range that could be detected by the software 

packages was between 1x106 and 1x109 cells/ml (Figures 1 and 2). At concentrations 

less than 1x106 cells/ml there were no adherent cells in either of the different tissue 

sections. Conversely, at 1x1010 cells/ml there were so many organisms on the tissue 

sections that it was difficult to see the epithelial surface.

3.2. Comparison of Software Packages with manual count

The accuracy of the software packages was compared to the manual method of 

counting used as the gold standard. The method that could be performed by all the 

packages was chosen (ROI method) as the comparator. Metamorph was found to give 

the most accurate calculation of epithelial length, compared to the other packages and 

manual method (it included all the small indentations in the epithelial surface). 

Therefore in order to compare the ability of the packages to count the number of 

adherent cells, the epithelial length measurement was kept constant (i.e. the 



measurement obtained by metamorph was used for all methods of counting, manual 

and software). Counts of adherent organisms was performed 3 times. The results for 

this show that Metamorph gives the highest count of cells for both H. pylori and C. 

albicans over the dynamic range (Figures 3 and 4), with a correlation coefficient of 

1.00 and 0.95 (respectively) with the manual count. The other three software packages 

gave correlation coefficients of 0.99 and 0.73 (NIH, for H. pylori and C. albicans

respectively) and 0.89 (Image Pro+ , for C. albicans

3.3. Comparison between the software packages

The advantages and disadvantages of the different software packages were compared 

and are summarised in Table 2.

3.3.1. Helicobacter pylori - quantification of binding

None of the methods employed by NIH-Image to quantify the dynamic range 

resulted in a linear increase in the number of adherent cells with increase in H. pylori

concentration. With IP Lab only Method 3 could be used and this again did not yield a 

linear increase in the number of adherent cells with increase in H. pylori

concentration. Quantification was unable to be performed on the images using Image 

Pro+, because the cells were too small to be counted. Using Metamorph, an increase 

in number of adherent cells with H. pylori concentration was obtained using the ROI 

Normal method. Although the ROI Standard Area method produced a slight decrease 

in adherent cell numbers at 1 x 109 cells/ml, the number was not very different from 

adherent cells at a concentration of 1 x 108. Although the Merging (Normal) and Area 

methods also showed an increase in adherence with concentration of bacteria, the 

absolute numbers of adherent cells were much lower than those obtained with the ROI 

method.

3.3.2. Candida albicans - quantification of binding

As for H. pylori none of the methods employed by NIH-Image to quantify the 

dynamic range showed a linear increase in the number of adherent cells with increase 

in concentration of C. albicans. IP-Lab produced the opposite result, as the 

concentration of C. albicans was increased, the number of adherent cells counted 

decreased. Using Image Pro+, both the dilation and ROI method resulted in an 

increase in number of adherent cells with increase in concentration.  Metamorph, 

using the ROI method with standard area method of counting, was able to effectively 

separate clumps of cells and this was the only method that produced an increase in 

adherent cells with increase in C. albicans concentration for this software package.

3.5. Operator Error

Only a small amount of error is introduced by the operator when quantifying the 

number of adherent organisms using image analysis software (Figures 5 and 6). The 

standard error ranged from 0.1 to 3.4 and all of the three counts at each concentration 

of organism (for both H. pylori and C. albicans) fell within 2 standard deviations from 

the mean. 

3.7. Inhibition of H. pylori adhesion  by Lewis b-HSA

Using Metamorph, ROI and standard area method, the binding of H. pylori to 

Lewis b stomach and its inhibition with soluble Le b-HSA was investigated. The 



mean inhibition of binding from the two experiments was 8.3% with 10µg/ml, 48.6% 

with 250µg/ml, 10.6% with 500µg/ml and 19.6% with 1000µg/ml of the Le-b 

conjugate (Table 3).

4. Discussion

As a consequence of the increasing prevalence of antibiotic resistance, alternative 

therapeutic strategies are being sought for mucosal infections. One such strategy is the 

development of agents that inhibit adhesion, the primary step in the pathogenic 

process. Various image analysis software packages are available to quantify the 

adhesion of micro-organisms to mucosal surfaces, but there is no published 

comparison of which software package is the simplest and most accurate to use. We 

have therefore compared 4 image analysis packages with a manual method of 

counting as a “gold-standard”, using micro-organisms of differing sizes- a bacterium, 

Helicobacter pylori and a yeast, Candida albicans.

Of all the software packages tested, Metamorph (using the ROI method with 

standard area method of counting) was found to be the best for counting microbial 

adherence to epithelial surfaces of tissue sections for the two organisms employed in 

this study. Image Pro+ was the second best software package. Metamorph is able to 

take account of clumps of adherent microbial cells into its final cell count, as is Image 

Pro+ [this package was used in the adhesion studies of Barthelson et al., (1999)], but 

it does so less effectively. Moreover, Image Pro+ is unable to count H. pylori cells, 

because they are too small to be detected, which confirms Metamorph as the software 

package of choice. The error introduced by the investigator when performing 

quantification is small and thus should have very little effect on the accuracy of the 

resulting counts. Using Metamorph software for quantification is also better than 

counting manually because it is faster and more accurate at measuring both the 

epithelial length and the number of adherent cells, especially when they are clustered 

together as it is difficult to manually estimate the number of cells comprising the 

clusters. In none of the cases were the counts over the dynamic range linearly related 

to the concentration of organism added to the section. This is of course what one may 

expect particularly at high concentrations as receptors may be blocked and organisms 

may clump. 

Using confocal microscopy and image analysis we have demonstrated that the 

binding of H. pylori strain NCTC 11637 to the epithelial surface of Lewis b stomach 

sections, can both be inhibited by the soluble glycoconjugate Lewis b-HSA and 

quantified by the image analysis software Metamorph. Maximum inhibition was 

achieved using 250ug/ml and at higher concentrations than this, inhibition was less. It 

may be that large amounts of glycoconjugate has an agglutinating effect on the 

bacteria and thus more bind to the epithelial surface and therefore inhibition is less at 

higher concentrations. In fact, more clumps of bacteria were seen on the epithelial 

surface of the tissue sections from the higher concentrations of Le b-HSA (500 and 

1000ug/ml) compared to the control and lower concentrations of Le b-HSA.

The method we have devised, using Metamorph software (using the ROI method 

and the standard area method of counting) is a simple, quick and accurate way of 

quantifying adhesion and inhibition of adhesion of microbial cells to the epithelial 

surface of tissue sections. It is an improvement on the method developed by Reinhard 

et al., (2000) who used NIH-Image for the same purpose. Unlike NIH-Image, 

Metamorph is able to separate clumps of cells into individual organisms, producing a 

more accurate count. We have also demonstrated that the method can be applied to 



organisms ranging in size from small bacteria to larger yeast cells.

Acknowledgements

We would like to acknowledge the European Union on EC contract QLK2-CT-

2001-01216 (ADRI) for financial support. We wish to thank Mariam Andrawiss 

(Dept. of Immunology and Molecular Pathology) for help and advice with the 

confocal microscope and confocal software and Nalini Singh (Dept. of 

Histopathology) for technical assistance with paraffin sectioning.

References

An, Y.H., Friedman, R.J., 1997. Laboratory methods for studies of bacterial adhesion. 

J. Microbiol. Methods 30, 141-152.

Barthelson, R., Hopkins, C., Mobasseri, A., 1999. Quantitation of bacterial adherence 

by image analysis. J. Microbiol. Methods 38,17-23.

Basset, C., Holton, J., O'Mahony, R., Roitt, I., 2003. Innate immunity and pathogen-

host interaction. Vaccine 21, S12-23.

Borén, T., Falk, P., Roth, K. A., Larson, G., Normark, S., 1993. Attachment of 

Helicobacter pylori to human gastric epithelium mediated by blood group antigens. 

Science 262,1892-1895.

Borén, T., Normark, S., Falk, P., 1994. Helicobacter pylori: molecular basis for host 

recognition and bacterial adherence. Trends Microbiol. 7, 221-228.

Calderone, R.A., 1993. Recognition between Candida albicans and host cells. Trends 

Microbiol. 1, 55-58.

Clyne, M., Thomas, J., Weaver, L., Drumm, B., 1997. In vitro evaluation of the role 

of antibodies against Helicobacter pylori in inhibiting adherence of the organism to 

gastric cells. Gut 40, 731-738.

Corkidi, G., Diaz-Uribe, R., Folch-Mallol, J.L., Nieto-Sotelo, J., 1998. COVASIAM: 

an image analysis method that allows detection of confluent microbial colonies and 

colonies of various sizes for automated counting. Appl. Environ. Microbiol. 64, 1400-

1404.

Critchley, I.A., Douglas, L.J., 1987a. Isolation and partial characterization of an 

adhesin from Candida albicans. J. Gen. Microbiol. 133, 629-36.

Critchley, I.A., Douglas, L.J., 1987b. Role of glycosides as epithelial cell receptors for 

Candida albicans. J. Gen. Microbiol. 133, 637-43.

De Bernardis, F., Arancia, S., Morelli, L., Hube, B., Sanglard, D., Schafer, W., 

Cassone, A., 1999. Evidence that members of the secretory aspartyl proteinase gene 

family, in particular SAP2, are virulence factors for Candida vaginitis. J. Infect. Dis. 

179, 201-208.



Elzay, R. P., 1983. A modification of the Papanicolaou exfoliative cytology stain to

demonstrate keratin in paraffin-block tissue sections. Oral Surg. Oral Med. Oral 

Pathol. 56, 51-53.

Evans, D. J. Jr., Evans, D. G., 2000. Helicobacter pylori Adhesins: Reviews and 

Perspectives. Helicobacter 5, 183-195.

Falk, P., Roth, K. A., Borén, T., Westblom, T. U., Gordon, J. I., Normark, S., 1993. 

An in vitro adherence assay reveals that Helicobacter pylori exhibits cell lineage-

specific  tropism in the human gastric epithelium. Proc. Natl. Acad. Sci. USA 90, 

2035-2039.

Goldhar, J., 1995. Erythrocytes as target cells for testing bacterial adhesins. Methods 

Enzymol. 253, 43-50.

Goldstein, E., Donovan, R.M., Kim, Y., 1988. Applications of computerized 

microscopic image analysis in infectious diseases. Rev. Infect. Dis. 10, 92-102.

Gomez-Suarez, C., Busscher, H.J., van der Mei, H.C., 2001. Analysis of bacterial 

detachment from substratum surfaces by the passage of air-liquid interfaces. Appl. 

Environ. Microbiol. 67, 2531-2537.

Grivet, M., Morrier, J.J., Souchier, C., Barsotti, O., 1999. Automatic enumeration of 

adherent streptococci or actinomyces on dental alloy by fluorescent  image analysis. J 

Microbiol. Methods 38, 33-42. 

Gualtieri, P., Ghetti, F., Passarelli, V., Barsanti, L., 1988. Microorganism track 

reconstruction: an image processing approach. Comput. Biol. Med. 18, 57-63.

Hood, S.K., Zottola, E.A., 1997. Adherence to stainless steel by foodborne 

microorganisms during growth in model food systems. Int. J. Food Microbiol. 37, 

145-153.

Ilver, D., Arnqvist, A., Ogren, J., Frick, I. M., Kersulyte, D., Incecik, E. T., Berg, D. 

E., Covacci, A., Engstrand, L., Borén, T., 1998. Helicobacter pylori adhesin binding 

fucosylated histo-blood group antigens revealed by retagging. Science 279, 373-377.

Jansen, G.J., Wildeboer-Veloo, A.C.M., Tonk, R.H.J., Franks, A.H., Welling, G.W. 

1999. Development and validation of an automated, microscopy based method for 

enumeration of groups of intestinal bacteria. J. Microbiol. Methods 37, 215-221.

Mackowiak, P.A., Marling-Cason, M., 1984. A comparative analysis of in vitro assays 

of bacterial adherence. J. Microbiol. Methods 2, 147-158.

Mardh, P.A., Rodrigues, A.G., Genc, M., Novikova, N., Martinez-de-Oliveira, J., 

Guaschino, S., 2002. Facts and myths on recurrent vulvovaginal candidosis--a review 

on epidemiology, clinical manifestations, diagnosis, pathogenesis and therapy. Int. J. 

STD. AIDS. 13, 522-39.

Millsap, K,W., Bos, R., van der Mei, H.C., Busscher, H.J., 1999. Adhesion and 

surface -aggregation of Candida albicans from saliva on acrylic surfaces with adhering 



bacteria as studied in a parallel plate flow chamber. Antonie Van Leewenhoek. 74, 

351-359.

Monod, M., Borg-von Zepelin, M., 2002. Secreted proteinases and other virulence 

mechanisms of Candida albicans. Chem. Immunol. 81, 114-28.

Montecucco, C., Rappuoli, R., 2001. Living dangerously: How Helicobacter pylori

survives in the human stomach. Nat. Rev. Mol. Cell. Biol. 2, 457-66. 

Ofek, I., 1995. Enzyme linked immunosorbent based adhesion assays. Methods 

Enzymol.  253, 528-536.

Pernthaler, J., Pernthaler, A., Amann, R., 2003. Automated enumeration of groups of 

marine picoplankton by fluorescence in situ hybridization. Appl. Environ. Microbiol. 

69, 2631-2637.

Pons, M.N., Vivier, H., 2000. Biomass quantification by image analysis. Adv. 

Biochem. Eng. Biotechnol. 66, 133-184.

Reinhard, J., Basset, C., Holton, J., Binks, M., Youinou, P., Vaira, D., 2000. Image 

analysis method to assess adhesion of Helicobacter pylori to gastric epithelium using 

Confocal laser scanning microscopy. J. Microbiol. Methods 39:179-187.

Robrish, S.A., Kemp, C.W., Bowen, W.H., 1977. Use of extractable adenosine 

triphosphate to estimate the viable cell mass in dental plaque samples obtained from 

monkeys. Appl. Environ. Microbiol. 35, 743-749.

Saitoh, T., Natomi, H., Zhao, W.L., Okuzumi, K., Sugano. K., Iwamori, M., Nagai, 

Y., 1991. Identification of glycolipid receptors for Helicobacter pylori by TLC-

immunostaining. FEBS Lett. 282, 385-387.

Schonholzer, F., Hahn, D., Zarda, B., Zeyer, J., 2002. Automated image analysis and 

in situ hybridization as tools to study bacterial populations in food resources, gut and 

cast of Lumbricus terrestris L. J. Microbiol. Methods. 48, 53-68.

Sjollema, J., Busscher, H.J., Weerkamp, A.H., 1989. Experimental approaches for 

studying adhesion of microorganisms to solid substrata; applications and mass 

transport. J. Microbiol. Methods 9, 79-90.

Sjollema, J., van der Mei, H.C., Uyen, H.M., Busscher, H.J., 1990. Direct 

observations of cooperative effects in oral streptococcal adhesion to glass by analysis 

of the spatial arrangement of adhering bacteria. FEMS Microbiol. Lett. 57, 263-269.

Stevenson, T.H., Castillo, A., Lucia, L.M., Acuff, C.R., 2001. Growth of Helicobacter

pylori in various liquid and plating media. Lett. App. Microbiol. 30, 192-196.

Sundstrom, P., 2002. Adhesion in Candida spp. Cell Microbiol. 4, 461-469.

Tobin, K.J., Onstott, T.C., De Flaun, M.F., Colwell, F.S., Fredrickson, J., 1999. In situ 

imaging of microorganisms in geological material. J. Microbiol. Methods 37, 201-

213.



van Kooten, T.G., Scakenraad, J.M., vab der Mei, H.C., Busscher, H.J., 1992. 

Development and use of a parallel plate flow chamber for studying cellular adhesion 

to solid surfaces. J. Biomed. Mater. Res.  26,725-738.

Watts, H., Cheah, F.,  Hube, B., Sanglard, D., Gow, N., 1998. Altered adherence in 

strains of Candida albicans harbouring null mutations in secreted aspartic proteinase 

genes. FEMS Microbiol Lett. 159, 129-35.

Williamson, F.A., Palframan, K.R., 1989. An improved method for collecting and 

staining microorganisms for enumeration by fluorescent microscopy. J. Microsc. 154, 

267-272.

Wit, P., Busscher, H.J., 1998. Application of an artificial neural network in the 

enumeration of yeasts and bacteria adhering to solid substrata. J. Microbiol. Methods 

32, 281-290.



Table 1

Methods of Quantification able to be performed by software packages

Method NIH Image IP Lab Image Pro+ Metamorph

Merging - - * *

Dilation * - * *

Area * * * *

ROI * - * *

-: not able to be performed

* :can be performed

Table 2

Comparison of software packages - advantages and disadvantages

SOFTWARE PACKAGE

CRITERIA NIH-Image IP-Lab Image Pro+

Metamorph

Can obtain counts for C. albicans and H. pylori Yes Yes No

Yes

No. of steps required to obtain counts Many Few Few Few

Displays results on screen so can see if counts are correct Yes No

Yes Yes

Can separate clumps of cells No No To some extent

Yes

Counts are accurate No No Fairly

Very

Cost Free Free demo version

Expensive > £1000 Expensive > 

£1000

Table 3

Inhibition of H. pylori adhesion to Le b stomach sections by Le b-HSA. The % 

Inhibition of two experiments is shown.

% Inhibition Leb-HSA Concentration (ug/ml)

0 10 250 500 1000

Experiment 1 0 16.7 27.7 19.7 27.5

Experiment 2 0 0 69.5 1.5 11.6

Mean 0 8.4 48.6 10.6 19.6
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Figure 1: Confocal Images showing dynamic range of adherent C. albicans (cells/ml). 

Concentrations represent the number of organisms added to the tissue sections.

 a) 1 x 106       b) 1 x 107     c) 1 x 108    d) 1 x 109

a) b)



         

c) d)

         

Figure 2: Confocal Images showing dynamic range of adherent H. pylori (cells/ml). 

Concentrations represent the number of organisms added to the tissue sections.

 a) 1 x 106       b) 1 x 107    c) 1 x 108    d) 1 x 109



Figure 3: Comparison of manual method of counting with software packages (ROI 

methods), using epithelial length as calculated by Metamorph for each method. 

Quantification of C. albicans dynamic range. The mean of 3 counts is shown by error 

bars.



Figure 4: Comparison of manual method of counting with software packages (ROI 

methods), using epithelial length as calculated by Metamorph for each method. 

Quantification of H. pylori range. The mean of 3 counts is shown with error bars.



Figure 5: H. pylori dynamic range - Operator error. Quantification was performed 

three times on separate occasions. The mean of the 3 counts is shown with error bars.



Figure 6: C. albicans dynamic range - Operator error. Quantification was performed 

three times on separate occasions. The mean of the 3 counts is shown with error bars.



Appendix

IMAGE ANALYSIS PROTOCOLS -

NIH IMAGE 1.62

B+W = black and white

METHOD 1: SURFACE COUNTS BY DILATION  

(Based on paper by Reinhard et al., 2000). Also needed is the software package Adobe 

Photoshop. There is a free trial download on the internet of Version 6.0, the version 

used in the paper.

A. Process the Green (FITC) image of the microbial cells

 1. Threshold. MENU: Options > Threshold. Adjust so all cells are 

thresholded.

2. Convert to 32-Colour Image.

MENU: Options > Colour Tables > 32 Colours

Save as ‘Green Processed 1’

3. Make Greyscale and Fill background in white. USE ADOBE PHOTOSHOP 

5.0

MENU: Image > Mode > Greyscale

Select ‘Fill’ tool in tool bar, select white and click in background of image which then 

turns white.

Save as ‘Green Processed 2’

4. Open in NIH-Image, Threshold and binarise.

MENU: Options > Threshold (Set to 1.0)

MENU: Process > Binary > Make Binary

Save as ‘Green Processed 3’

B. Process the Red (PI) image of the tissue

1. Threshold. MENU: Options > Threshold. Adjust so all the issue is included in 

threshold.

2. Invert, Sharpen and Binarise image - use closed binary function to fill in 

spaces in the image. MENU: Edit > Invert

MENU: Process > Sharpen

MENU: Process > Binary (Use default count 4, Iterations 1) > Close

Save as ‘Red Processed 1’

3. Fill in tissue in black.

Use paintbrush tool and click on black colour in LUT window.

Save as ‘Red Processed 1b’

4. Dilate Red Image so can count particles on surface of tissue section, particles 

outside dilated edge are regarded as background. Dilate 10 pixels for C. albicans and 

5 pixels for H. pylori (10 pixel dilation used in Reinhard’s paper for H. pylori).

MENU: Process > Binary (Set count to 1, Iterations 5 for H. pylori, or 10 for C. 

albicans) > Dilate.  Save as ‘Red Processed 2’

C. Count all cells in image

1. Open Green Image  (Green Processed 3) and Threshold.

2. Count Cells.

MENU: Analyse > Analyse Particles (Select all options and min. size 



1)

MENU: Analyse > Show Results

D. Count cells in background + surface of tissue

1. Merge the Green Processed Image  of the microbial cells, with the Red  

Processed Image  where the tissue has been filled in. 

Open Green Processed 3 and Red Processed 1b.

MENU: Stacks > Windows to stack (use < and > keys to move between images).

MENU: Stacks > Average (of this stack)

MENU: Options > Threshold (adjust so entire image is b+w).

2. Count cells.

MENU: Analyse > Analyse Particles 

MENU: Measure > Show Results

E. Count cells in background only

1. Open Green processed Image and the Red Processed image which has been 

filled in and dilated.

Open Green Processed 3 and Red Processed 2.

MENU: Stacks > Windows to stack (use < and > keys to move between images).

MENU: Stacks > Average (of this stack)

MENU: Options > Threshold (adjust so entire image is b+w).

2. Count cells.

MENU: Analyse > Analyse Particles 

MENU: Measure > Show Results

F. Calculate the number of adherent cells in the image

 Subtract the value obtained in E (background cell count) from the value obtained in D 

(background + surface cell count). This will give number of cells adhered to the 

surface of the tissue. 

METHOD 2: SURFACE COUNTS BY AREA

A. AREA OF TISSUE PLUS ADHERENT CELLS

1. Open  Combined Red + Green image and make greyscale. 

MENU: Options > Greyscale

2. Threshold so tissue and microbial  cells are white, and background is black.

MENU: Options > Threshold - adjust so particles correct size

3. Make Binary.

MENU: Process > Binary > Make Binary

4. Fill in the tissue completely in white

Use tools in toolbox after having selected ‘white’ in the LUT window with the 

eyedropper tool that appears once the tools for filling have been selected.

5. Invert the Image, because the software only counts cells/areas that are black. 

Must threshold and binarise first.

MENU: Options > Threshold

MENU: Process > Make Binary

MENU: Edit > Invert - The tissue has now turned black.

6. Outline tissue+cells.

Select ‘Wand’ tool and click this on the image in the black tissue. This has now 



become outlined. 

7. Measure area of this tissue.

MENU: Analyse > Options (select ‘Area’ measurement).

MENU: Analyse > Set scale. Choose ‘pixels’ as units.

MENU: Analyse > Measure

MENU: Analyse > Show results.

B. AREA OF TISSUE

Open the Red Image of the tissue that has been filled in (Red Processed 1b). Follow 

steps 5 - 7 as outlined in section A (miss out steps 1 - 4 because the image is already 

filled in).

C. MEAN AREA OF A MICRIOBIAL CELL

1. Open Green Image and make greyscale.

MENU: Options > Greyscale

2. Threshold (to 1.0 so cells are correct size and same size as used in methods to 

obtain other counts so no variation is introduced) and Binarise. 

MENU: Options > Threshold 

MENU:  Process > Binary > Make Binary 

3. Measure area of cells.

Select ‘Wand’ tool and click on individual microbial cells. After clicking on a 

cell, it becomes outlined. Then can measure the area of the cell by MENU: Analyse > 

Options (select ‘Area’ as the measurement).

MENU: Analyse > Measure

MENU: Analyse > Show results

METHOD 3: SURFACE COUNTS BY DRAWING SPECIFIC REGION OF 

INTEREST AROUND ADHERENT CELLS

A. CREATE AN ROI AROUND ADHERENT CELLS ONLY

1. Open green image made b+w (Green processed 3).

2. Open the Red+green image alongside this - so can see which particles are on 

the surface so know which to include in the ROI.

3. On the green image, draw a ROI around the cells that are adherent to tissue 

surface - use ‘Trace region’ ROI tool in toolbox.

4. Threshold and Binarise. May have to threshold again after binarising.

5. Select units of measurement as Pixels. 

MENU: Analyse > Set Scale. Choose ‘pixels’.

6. Count cells.

MENU: Analyse > Analyse Particles

MENU: Analyse > Measure

MENU: Analyse > Show Results

B. MEASURE LENGTH/PERIMETER OF EPITHELIUM - the part on which 

the selected adherent cells were measured.

1. Open the red filled image mad b+w (Red Processed 1b).

2. Open Red+Green Image alongside this as a reference for where the epithelial edge 



is that the cells were counted on.

3. Fill in black (make straight square lines) the parts of the tissue edge not 

needed/used to count cells on.

4. Threshold and binarise - may need to re-threshold after binarising.

5.Outline. Click on ‘Wand’ tool and then click wand on black tissue.

6. Measure. MENU: Analyse > Options - choose length/perimeter.

MENU: Analyse > Measure - Results are displayed in the ‘Info’ box.

7. Use the pointer or wand tool to rest on the image edges to get lengths of borders of 

image/parts of the image that were included in the perimeter measurement but want to 

exclude from the measurement since they were not the parts of the tissue surface that 

were used for the cell count. Subtract these values from the total to give the true 

length of surface across which the adherent cells were counted.

MEASUREMENT OF LENGTH OF EPITHELIAL SURFACE - TO 

CALCULATE NUMBER OF ADHERENT CELLS PER UNIT LENGTH OF 

TISSUE

1. Open Red (PI) Image that has been filled in black (Red Processed 1b)

2. Threshold so can perform measurements.

MENU: Options > Threshold (Adjust so all tissue is filled).

3. Choose measurements. 

MENU: Analyse > Options (select ‘Perimeter/Length’) 

MENU: Analyse >Set scale (select ‘pixels’ as the units)

4. Outline tissue.

Select ‘wand’ tool in toolbox. This is the automatic outlining tool.

Click wand inside the tissue required to be measured. Tissue outline should be 

highlighted.

5. Measure.

MENU: Analyse > Measure

6. Subtract from the total perimeter value given, the length of the lines that are not 

wanted to be included in the measurements (i.e.) the borders of the image window. 

This will then give a value for the length of the tissue surface alone. These lengths to 

subtract can be obtained by moving the mouse pointer to the end of the lines that 

want to exclude. Displayed in the ‘Info’ box are the X-Y co-ordinates of the 

position of the mouse pointer. The X-Y co-ordinates represent the pixel number, 

thus the length (no. of pixels) of the line wanted to be excluded from the total 

perimeter, can be obtained. Use the ‘Zoom’ option (magnifying glass symbol in 

the toolbox) to zoom in on the image so the mouse pointer can be positioned more 

accurately at the edges of the lines. To ‘unzoom’ go to MENU: Edit > Unzoom.

IMAGE ANALYSIS PROTOCOLS -

IP LAB

This software cannot perform counts therefore use the ‘Area Method’ (find area of 

adherent cells and divide by mean size of one cell to obtain a cell count) to overcome 

this.



METHOD: SURFACE COUNTS BY AREA

A. AREA OF TISSUE+ADHERENT CELLS

1. Open the Red + Green (PI and FITC combined) image.

2. Make Greyscale. MENU: Enhance > Colour to Grayscale.

3. Segment Image. MENU: Analyse > Segmentation. Select ‘White’.

4. Fill image in black. Double click on the ‘Square’ tool and select ‘fill’. Select 

‘black’ in the segment colour box. Draw squares in the image and fill inside each with 

black. Must fill even small dots of white with black and even the very edges of the 

Image window (zoom in to do this).

5. Binarise. Choose segment colour ‘White’ on the tool box. MENU: Math > 

Binarise.

6. Binarise and segment again to select the tissue.

MENU: Math > Binarise. Select ‘White’.

MENU: Analyse > Segmentation. Select ‘Black’ tissue fills in black.

7. Outline tissue + adherent cells.

In toolbox: Select ‘Wand’ tool, select ‘Segmentation tools’ and select colour as 

‘Black’. 

Click on black part of image. The cells that were attached to the surface of the 

epithelium have also been included in the outline.

8. Measure area of the tissue + adherent cells (outlined part of image).

MENU: Analyse > Set measurements. Select ‘Area’.

MENU: Analyse > Measure ROI.

B. AREA OF TISSUE

Repeat steps outlined in ‘A’ but use the Red (PI) image.

C. MEAN AREA OF ONE CELL

1. Open the Green (FITC) Image.

2. Make Greyscale. MENU: Enhance > Colour to Grayscale.

3. Segment. MENU: Analyse > Segmentation. Select  colour as ‘Green’.

4. Fill cells in white. Zoom in using magnifying glass tool. 

Choose the ‘Segment Rectangle’ tool. 

Double click on its icon in the tool box and in the dialog box that appears select ‘Pen 

size’ as ‘1’ and tick the ‘fill’ option. Click on ‘ok’. Select ‘White’ as the colour in the 

tool box. Click on each pixel within each cell and they fill with white.

5. Measure area of cells.

Select ‘Wand’ tool in toolbox, select ‘White’ as the colour and select ‘segmentation 

tools’. Click wand on each cell filled in white and measure after selecting each one by 

doing MENU: Analyse > Measure ROI.

6. Calculate the Mean size. Results are displayed in ‘Measurement results’ window. 

D. CALCULATE NUMBER OF ADHERENT CELLS

To calculate the number of adherent cells, subtract the value obtained in ‘B’ (area of 

tissue) from the value obtained in ‘A’ (area of tissue + adherent cells). The value that 

is obtained from this is the total AREA of the adherent cells. In order to obtain the 

NUMBER of adherent cells, divide the TOTAL AREA of adherent cells by the 

MEAN AREA of one cell (value obtained in ‘C’).



E. OBTAIN THE LENGTH OF THE EPITHELIAL SURFACE

1. Outline the tissue of the red image that has been filled in (Use ‘Wand’ tool, after 

selecting black as the ROI colour in the toolbox, and click on the tissue part of the 

image).

2. Measure. MENU: Analyse > Set Measurements. Select ‘Area’ and in ‘Perimeter’. 

select ‘pixel method’.

3. MENU: Analyse > Measure ROI. Measurement results are displayed in a separate 

window.

4. To subtract the lengths of the edges of the image that are not to be included in the 

meaurement, obtain the values by taking the x and y co-oordinates of the edges. These 

are displayed in the window that appears when select MENU: Windows > Show 

Status. Use the pointer to obtain the position of the edges.

IMAGE ANALYSIS PROTOCOLS -

IMAGE PRO PLUS

NOTE: When using processed images that have already been saved, before carrying 

out any functions, first the images may need to be segmented (always set segment 

value to 105).

METHOD 1: SURFACE COUNTS BY MERGING IMAGES

A. PROCESS THE RED IMAGE

1. Open red (PI) image.

2. Enhance contrast so can see red more clearly. 

a) Click on ‘Contrast Enhance’ tool on tool bar and Increase the GAMMA contrast 

channel so red becomes brighter but with little increase in background noise.

b) Press ‘Apply’.

3. Make Image greyscale. MENU: Edit > Convert to > Greyscale 8

4. Increase contrast again as for step 2.

5. Threshold - makes image b+w. MENU: Process > Threshold - set at 1.0 so black 

is at darkest level. Click ‘Apply mask’. Then close dialog box.

6. Fill in Image.

a) Create AOI - select required shape on toolbar and draw on image.

b) MENU: Edit > Fill - in ‘Fill’ dialog box select ‘black’ and press ‘fill’.

c) Click ‘New AOI’ in tool bar, then draw new AOI and fill as before. Repeat 

until whole tissue is filled in black.

d) Outline by hand the parts of the edge need to fill in black - Use ‘Irregular 

AOI’ tool, in the same way filling as before.

e) Fill in background in white - same method as a) - d).

B. PROCESS GREEN IMAGE

1. Increase Gamma contrast of green channel to 5.4.

2. Segment Image. MENU: Process > Segmentation. Set green channel to 105, 

choose ‘Black on White’. 

C. COUNT  OF TOTAL CELLS IN IMAGE

1. Open Green Processed Image.



2. Fill over any dirt. Choose the ‘Autotrace’ tool from tool bar. Draw a ROI with it 

around the dirt and fill in the same colour as the background. MENU: Edit > Fill.

3. Count Cells. MENU: Measure > Count/Size. In the count/size window select the 

following options:

DISPLAY OPTIONS: Outline style: Outline Choose colour ‘Red’.

   Label Style: Object No.

   Label Colour: Blue

OBJECT OPTIONS: Select: 8-Connect, Pre-Filter, Fill Holes,

 Clean Borders: No borders. Click ‘Ok’

4. Select Measurements. In Count/size window:

MENU: Measure > Select Measurements: Area and Count (adjusted). Select 

‘AutoDark objects’ if cells are black, if cells are white, select ‘Autobright 

objects’.

5. Count cells. Click ‘Count’ and counts are displayed.

6. Separate clumps/clusters. In count/size window:

MENU: Edit > Autosplit.

MENU: Edit >Watershed split.

Updated Count is automatically displayed.

D. COUNT OF CELLS IN BACKGROUND

1. Open Red filled image and the green processed image.

2. Merge Images. MENU: Acquire > Sequence tools > Merge

       MENU: Acquire > Sequence tools > Average.

3. Decrease gamma contrast of white channel.  Only the cells in the background 

remain visible.

4. Segment this Image.

5. Fill over any dirt in the background. Fill with the background colour.

6. Count cells. MENU: Measure > Count/size. In the Count/size window select: 

‘Auto bright objects’. 

7. Split clusters of cells. In Count/size window do:

MENU: Edit > Autosplit

MENU: Edit > Watershed split. When ‘Watershed split’ is done, the actual 

tissue becomes divided up into segments. Count the number of segments this has been 

divided up into and subtract this value from the total, so that the value obtained only 

represents the number of cells rather than the tissue as well as cells.

E. COUNTS OF CELLS ON TISSUE

1. Merge Red filled tissue image with Green processed image.

2. Average.

3. Increase gamma contrast. Only cells on tissue remain visible.

4. Count cells. Select ‘Auto dark objects’.

F. CALCULATE THE NUMBER OF ADHERENT CELLS

Subtract the value obtained in ‘D’ and ‘E’ (number of cells in the background and on 

the tissue) from the total number of cells in the image (Method 1, part ‘C’) and this 

will give the number of cells adhering to the tissue surface.



METHOD 2: SURFACE COUNTS BY AREA

A. AREA OF RED FILLED TISSUE

1. Open Red filled image made b+w.

2. Outline tissue. Click on ‘Auto trace’ tool. Click on ‘Wand’. Then click the wand 

inside the black tissue. Tissue becomes outlined.

3. Measure.

MENU: Measure > Count/size. In Count/size window do:

MENU: Measure > Select Measurements. Choose ‘Area’ and click ‘ok’.

Choose 

‘Auto Dark objects’. 

Options: Label style > Measurement.    Clean Borders > None.

Then press ‘Count’. 

4. View measurements.

 MENU: View > Measurement data. Area is displayed.

B. AREA OF RED+GREEN IMAGE

1. Open Red+Green image. Make greyscale.

2. Make b+w. Increase gamma contrast for Red channel fully. Click ‘Apply’.

3. Segment. MENU: Process > Segmentation. Set Green channel to ‘105’. Save 

Image.

4. Outline tissue and fill in black. As described in Method 1. By hand outline any 

parts of tissue edge that have not been filled in, and then do ‘Fill’. (select ‘New AOI’ 

on tool bar then ‘Auto trace’ tool. Select ‘trace’ rather than wand, and draw by hand 

an outline on the parts that have not been outlined, then fill this in).

5. Outline the tissue, now filled in. As described in ‘A’.

6. Measure the area. Also described in ‘A’.

C. AREA (MEAN SIZE) OF ONE MICROBIAL CELL

1. Open Green processed image (made b+w).

2. Draw rectangular ROI around some of the microbial cells in the image.

3. Measure area of these cells. MENU: Measure > Count/size. Choose ‘Area’ as the 

measurement under ‘Options’.

4. Export Data into MS Excel to calculate mean area of cells. On ‘Measurement 

data’ window do MENU: File > DDE to Excel.

5. In MS Excel (automatically opened when did Dynamic Date Exchange, DDE), 

calculate the mean area of these cells. 

Repeat  so obtain mean area for approimately30 cells.

D. CALCULATE NUMBER OF ADHERENT CELLS

Subtract the value obtained in ‘A’ (area of tissue) from the value obtained in ‘B’ (area 

of tissue + adherent cells) and divide this number by the value obtained in ‘C’ (mean 

size of 1 microbial cell). This will give the number of cells adhering to the surface of 

the tissue.

METHOD 3: SURFACE COUNTS BY DILATION

A. TOTAL CELLS IN IMAGE



Follow the steps outlined in method 1. 

B. COUNTS OF CELLS IN BACKGROUND - DILATED IMAGE

1. Open the Red filled in tissue image.

2. Segment. Set to 105. Tissue becomes white - need this because dilate function only 

dilates edges of bright objects.

3. Fill over dirt in background.

4. Dilate. MENU: Process > Filters. Select the following options: In the 

‘Morphological tab’ for H. pylori choose 5 Passes (dilates by 5) and for C. albicans

choose 10 passes (dilates by 10). 

Select for both ‘5x5 circle’.

Use ‘Morphological’ tab and select ‘Dilate’.

5. Merge with Green processed image.

6. Average.

7. Increase Gamma contrast. Only cells in the background remain visible.

8. Count cells. Select ‘Auto dark objects’.

C. COUNTS OF CELLS ON TISSUE

Use tissue count obtained in Method 1.

D. CALCULATING NUMBER OF ADHERENT CELLS

Subtract the values obtained in B (Number of cells in background) and C (Number of 

cells on the tissue) from the value obtained in A (total number of cells in image) and 

this will give the number of adherent cells (cells classed as adherent that lie within the 

region of the image that was dilated).

METHOD 4: SURFACE COUNTS BY DRAWING SPECIFIC REGION OF 

INTEREST AROUND ADHERENT CELLS

A. CREATE A ROI AROUND ADHERENT CELLS ONLY

1. Open green Image and Red+Green Image alongside it  - reasons stated on other 

package protocols.

2. Increase Gamma contrast of Green channel (so can see green clearly) and press 

‘Apply’.

3. Threshold. MENU: Process > Segmentation. Select green channel and set so 

decreases the background noise. Press ‘Apply Mask’ and ‘Close’.

4. Draw AOI around adherent cells - Use ‘Irregular AOI’ tool on the ‘trace’ option. 

Click with Right mouse button to end trace.

5. Count cells. MENU: Measure > Count/size. Choose ‘Auto dark objects’ because 

cells have become black after segmentation. Press ‘Count’.

6. Separate clusters/clumps. On the Count/Size window do MENU: Edit > 

Autosplit. Then MENU: Edit > Watershed split.

                                  

B. MEASURE LENGTH/PERIMETER OF EPITHELIUM - the part on which the 

adherent cells were counted.

1. Outline with the ‘Trace’ tool the tissue part of the Red filled image. 

2. Select ‘perimeter’ on the count/size window MENU: Measure > Select 

Measurements.

3. In the ‘Options’ section select: Borders ‘none’ and fill holes ‘off’. 



4. In the count/size window select View: Measurement data. The perimeter length is 

displayed (in pixels). 

NOTE: The measurement doesn’t include the edge of the window, only the surface of 

the tissue, so don’t need to subtract the lengths of the unwanted areas measured from 

the total. 

IMAGE ANALYSIS PROTOCOLS -

METAMORPH

The software package ‘MS Photoeditor’ is also needed for 3 steps of the image 

processing.

METHOD 1: SURFACE COUNTS BY MERGING IMAGES (NORMAL 

COUNTING METHOD)

A. PROCESS THE RED IMAGE

1. Open MS Photoeditor.

2. Open Red (PI) Image.

3. Make Red brighter. MENU: Image > Balance. Adjust the Gamma channel so red 

is brighter only on the PI stained tissue part of the image (not background as well).

4. Make Greyscale. MENU: File > Properties > Image Type. Select ‘Greyscale 8-

BIT’ from drop-down menu.

5. Sharpen. MENU: Effects > Sharpen (choose strength as 6).

6. Save.

7. Open this Red greyscale image in Metamorph. 

8. Fill tissue in grey. Use threshold tool on side of Image window, do Auto Threshold 

for light objects.

Draw ROI boxes and fill by MENU: Display >Graphics >Paint Region.

Select colour that matches e.g. Grey level 65 and ‘Inside region area’. Press 

‘Paint’.

9. Outline the Tissue. MENU: Regions > Create Regions around objects. Click on 

black (background) part of image  and then the grey tissue part of image is outlined. 

10. Fill this all in. Click on tissue so outline becomes active and Fill as before. Fill 

backgound in black. Then Threshold. MENU: Measure > Threshold Image (adjust so 

all tissue is included).

NOTE: Colour combine (step of merging images used later on) does not work on 

binarised images, so binarise images later on.



B. PROCESS THE GREEN IMAGE

1. Make Greyscale. Open in MS Photoeditor and follow same steps as for Red Image 

but exclude step 4, because the cells are already bright enough. Save Image.

2. Turn cells white so can be counted later on (Software only counts white particles). 

Click on Contrast tool on side of Image window. Select ‘Auto-

enhance’

3. Threshold. Adjust so all the cells are included.

4. Fill in any areas of dirt/noise. Use ‘Irregular AOI’ tool, click on ‘trace/wand’ and 

draw line around part of image to fill in. Double click to finish trace. Then fill in by 

procedure described earlier.

C. COUNT TOTAL CELLS IN IMAGE

1. Open the Green processed Image.

2. Threshold (set to 30) and Binarise.

3. Count cells. MENU: Apps > Count Cells.

4. In ‘Count cells’ dialog box click on ‘configure’ and select the first option…. 

‘counts of single objects….’ Check the ‘display result imsge’ box.

5. In image window, click on the colour of the cells to be counted (click on 1 cell).

6. Press ‘Measure’ in the count cells dialog box.

7. Result is displayed in dialog box and on screen.

D. COUNT CELLS IN BACKGROUND ONLY

1. Open the Red-grey image and threshold.

2. Fill in tissue in red (MENU: Graphics > PAINT REGION. Choose ‘Inside region 

area’ and ‘Inside threshold’) and background in black (MENU: Display > Graphics > 

PAINT REGION. Choose ‘Outside region area’ and ‘Value from Variable’).

3. MENU: Regions > Clear Regions and binarise. Make tissue an active ROI (MENU: 

Regions > Create regions around objects’. Click on the tissue part of the image). Copy 

the image.

4. Open Green-grey image. Make b+w (Auto-enhance contrast, threshold and 

binarise).

5. Paste ROI image of tissue onto the green (binarised) image of the cells.

6. Fill in the transferred image and ‘Clear Regions’. This allows adherent cells to 

merge with the tissue and so a count of cells in the background only is obtained.

7. Count cells.

E. COUNT CELLS IN TISSUE ONLY

1. Use the red-filled image (as above; background black and tissue red).

2. Create an ROI around the tissue (MENU: Regions > Create Regions around 

objects).

3. Fill background in red (MENU: Display > Graphics > PAINT REGION. Choose 

‘Outside region area’ and ‘Inside Threshold’) and the tissue in black (MENU: Display 

> Graphics > PAINT REGION. Choose ‘Inside region area’ and ‘Value from 

Variable’).

4. MENU: Regions > Clear regions. MENU: Regions > Create Region around objects. 

Click on the background (now red).

5. Select the thresholded green-grey image and click on this image. Transfer region. 

MENU: Regions > Transfer region. The region selected on the red image now 

becomes superimposed. 

6. Don’t fill in the transferred image. Make the background black and this will allow a 



count of cells on the tissue only.

7. Clear regions, binarise and Count cells.

F. CALCULATE NUMBER OF ADHERENT CELLS

Take values obtained in ‘D’ (number of cells in the background) and ‘E’ (number of 

cells in the tissue) and subtract these from the value obtained in ‘C’ (Total cells in 

image) to give number of adherent cells on the tissue surface.

METHOD 2: SURFACE COUNTS BY MERGING IMAGES (STANDARD 

AREA COUNTING METHOD)

Follow the procedures outlined in Method 1, except when it comes to counting cells, 

in the Count Cells dialog box click on ‘Configure’ and select the 2nd option, the 

method that counts cells using a standard area (the mean area) of a single cell, in order 

to divide and count the number of cells in clusters/clumps as well as single discrete

cells. Press ‘next’ and enter in the ‘Standard area’ spin box the average size (Standard 

area) of a cell, calculated by the procedure outlined below.

 OBTAINING THE STANDARD AREA OF A CELL   

1. Open the Green Image made greyscale.

2. MENU: Apps > Count Cells > Configure > Set Counting Method as ‘Use Standard 

area to estimate objects in a cluster’  > Next

3. Turn Cells White. Contrast tool > Auto enhance contrast.

4. Threshold. Adjust so that all cells are included (MENU: Measure > Threshold

Image).

5. Binarise.

6. Draw an ROI around lots of single cells using ROI tools. 

7. Measure. MENU: Measure > Integrated Morphometry Anlysis (IMA). Set up the 

parameters for measuring as Area and Pixel area. Click in the ROI on the image so 

that it becomes active so the cells can be measured. Press ‘Measure’ in the IMA 

window. 

8. In the IMA window click on ‘display’ and choose ‘Summary’ from the drop-down 

menu. This gives mean and SD of the area of cells counted. Alternatively look in the 

count cells window (MENU: Apps > Count cells) and the standard area of one cell has 

been added (Look in Configure > Set Counting method > ‘Use standard Area….’ of 

the count cells dialog box)

9. Then when doing the actual counting, enter the Standard Area obtained. (From 

the ‘Measure’ menu, choose ‘Configure object Standards’. In the window that appears 

enter the mean area that was calculated, enter the value in the ‘Standard Area’ box. 

Then choose ‘ok’). All clumps/clusters of cells will now be divided by this number, to 

give the composite number of cells in the cluster.

METHOD 3: SURFACE COUNTS BY DILATION (NORMAL COUNTING 

METHOD)

A. PROCESS THE RED IMAGE - DILATE



1. Open Red Greyscale filled image.

2. Fill over any dirt on the image in black.

3. Threshold and Binarise.

4. Dilate. MENU: Process > Binary. Select ‘Dilate’. Choose ‘Neighbourhood’ as 1 

and ‘Repeat Count’ as 10 for C. albicans and 5 for H. pylori. Press ‘apply’. This 

dilates by 10  pixels and 5 pixels respectively.

B. COUNT TISSUE+ ADHERENT CELLS

1. Invert the Processed Red binarised image, so background fills in white.

2. Create ROI of this background - as before, MENU: Regions > Create Regions 

around objects. Click on this background to activate the ROI.

3. Copy and Paste this background onto the binarised Green greyscale Image. 

MENU: Regions > Transfer region. Fill the ROI in white MENU: Display > Graphics 

> Paint Region. Select Grey Value 1 and Paint within Region Area.

4. Count cells. Use Normal method, for both 5x and 10x pixel dialtion.

C. COUNT CELLS ON TISSUE

Use counts previously generated/obtained by merging filled tissue with the processed 

Green image (Method 1).

D. CALCULATE NUMBER OF ADHERENT CELLS

Subtract values obtained in C from values obtained in B.

METHOD 4: SURFACE COUNTS BY DILATION (STANDARD AREA 

COUNTING METHOD)

As for Method 3 but obtain counts using the Standard area method of counting.

METHOD 5: SURFACE COUNTS BY AREA

A. AREA OF TISSUE

1. Use tissue image that has been filled in with red.

2. Cover up any ‘noise’ in the background with black.

3. Threshold (set to 30) and binarise - so that the tissue becomes white.

4. Outline the tissue. Menu: Regions > Create regions around objects. Click in white 

tissue so the ROI becomes active.

5. Measure. MENU: Measure > Region measurements. Select ‘Area’ on the 

‘configure’ tab. Click on ‘measurements’ tab and the measured results can be viewed. 

If do MENU: Measure > Show Region Statistics, can check that the measurements are 

correct because the height and width of the ROI measured, is displayed.

B. AREA OF TISSUE + ADHERENT CELLS

1. Fill in the Red+Green Image.

2. Open in MS Photoeditor.

Sharpen. Menu: Effects > Sharpen.

Make Red clearer. MENU: Image > Balance. Increase Gamma contrast to 

make the red clearer so can get better outline when come to fill in the image 



later on.

Make Greyscale. MENU: File > Properties > Image Type. Select ‘Greyscale 

8-BIT’ from drop-down menu.

Save.

3. Open this greyscale Image in Metamorph.

4. Threshold (set to 30). Some images,( e.g. 107), can’t see edges very well when 

threshold at 30, so use Threshold tool on side of image window select ‘Autothreshold 

for light objects’. This doesn’t increase the sizes of cells/edges of tissue, so is fine to 

use.

5. Binarise and Fill over any dirt on the image.

6. Create ROI around tissue and adherent cells now filled in.

FOLLOW ALL SAME STEPS AS FOR ‘A’.

Merge the green binarised image with the red filled image by copy and paste (as in 

Method 3, ‘B’). Measure the area of this to get the area of tissue+adherent cells.

C. CALCULATE THE NUMBER OF ADHERENT CELLS

1. Subtract the value obtained in ‘A’ from the value obtained in ‘B’ to give the AREA

of adherent cells.

2. Divide this area by the mean area (or Standard area) of 1x micro-organism (cell), to 

give the NUMBER of adherent cells.

METHOD 6: SURFACE COUNTS BY DRAWING SPECIFIC REGION OF 

INTEREST AROUND ADHERENT CELLS (NORMAL COUNTING 

METHOD)

A. CREATE AN ROI AROUND ADHERENT CELLS ONLY

1. Open the Green greyscale Image - make black and white.

2. Make pixels white so can count - click on contrast tool on side of image window 

and press ‘auto enhance’.

3. Threshold. MENU: Measure > Threshold Image. Adjust so white turns red 

(overlay colour) but size of cells does not get larger, use magnifying glass tool to 

check this.

4. Binarise. MENU: Process > Binary. Select ‘Binarise’ and click ‘Apply’.

5. Draw ROI around adherent cells. Use ‘Trace Region’ tool on tool bar. Refer to 

the Red+Green image to see which are the adherent cells to be included in the ROI.

6. Count cells. MENU: Apps > Count cells. Set up as usual. Click on a cell in the

ROI so the ROI becomes active (flashes).

7. Measure. Click ‘Measure’.

B. MEASURE LENGTH/PERIMETER OF EPITHELIAL SURFACE - the part on 

which the adherent cells were counted.

1. Open red greyscale image filled in.

2. Fill in or over parts of image tissue that don’t want the length of, with boxes -

calculate as for NIH-Image.

3. Outline tissue. MENU: Regions > Create Regions around objects. Click on tissue.

4. Get Measurements. MENU: Measure > Region measurements. Click on tissue to 

activate region.



METHOD 7: SURFACE COUNTS BY DRAWING SPECIFIC REGION OF 

INTEREST AROUND ADHERENT CELLS (STANDARD AREA COUNTING 

AREA METHOD)

As for Method 6, but obtain counts using the Standard area method of counting.

MEASUREMENT OF LENGTH OF EPITHELIAL SURFACE - TO 

CALCULATE NUMBER OF ADHERENT CELLS PER UNIT LENGTH OF 

TISSUE

1. Open Red Image.

2. Threshold (MENU: Measure > Threshold Image).

3. Fill tissue in red.

Draw ROI boxes and fill by MENU: Display >Graphics >Paint Region.

Select colour ‘Red’ and ‘Inside region area’. Press ‘Paint’.

4. Outline the Red Image. MENU: Regions > Create Regions around objects. Click 

on black (background) part of image  and then the red tissue part of image is outlined. 

5. Fill this all in. Click on tissue so outline becomes active and Fill as before.

6. Then Threshold and binarise.

7. Measure. MENU: Measure > Region Measurements. Select ‘Include: Active 

Region’.

Select ‘Area’ and ‘Distance’.

8. Remove from the value obtained, the lengths of the parts of the image not wanted 

to be included in the measurement, i.e. the edges of the image. Do this by placing the 

pointer on the edge of the image and obtaining the X-Y coordinates (i.e. Pixel 

no./length) of the line want to subtract from the total. Zoom in to be more accurate.




